13:00:08 <chaconpiza> #startmeeting monasca
13:00:09 <openstack> Meeting started Tue Nov 10 13:00:08 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:13 <openstack> The meeting name has been set to 'monasca'
13:00:25 <chaconpiza> Hi
13:00:39 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:00:59 <witek> Hi
13:01:13 <chaconpiza> Hello Witek, welcome back.
13:01:22 <bandorf> Hi, all
13:01:28 <chaconpiza> Hello Matthias
13:01:56 <chaconpiza> Before to start with todays topics, we have a couple from last week
13:02:07 <chaconpiza> #topic Set stable branches in DevStack plugin
13:02:33 <chaconpiza> In the PTL we spoke about this change for train https://review.opendev.org/#/c/718622
13:02:52 <chaconpiza> and whether we need similar changes for Ussuri and Victoria
13:03:33 <chaconpiza> Ussuri and Victoria changes are ready and on green
13:03:41 <chaconpiza> Victoria https://review.opendev.org/#/c/760981
13:03:49 <chaconpiza> Ussuri https://review.opendev.org/#/c/761020
13:04:02 <chaconpiza> I think we can merge them
13:04:52 <chaconpiza> please take a look on them.
13:05:26 <chaconpiza> #topic Remove Java part from monasca-api and monasca-persister (and possible monasca-common)
13:05:38 <witek> will do, I see that e.g. kibana plugin does not have stable branch
13:06:12 <witek> the same for grafana datasource
13:06:33 <chaconpiza> Good point, in Monasca-Kibana-Plugin last stable is Train
13:07:13 <chaconpiza> #action I will check why we don't have the branches.
13:08:44 <witek> these repositories follow different release models
13:09:01 <witek> and we haven't created stable branches for them
13:09:53 <witek> https://opendev.org/openstack/releases/src/branch/master/deliverables/_independent
13:11:02 <chaconpiza> At least for monasca-kibana-plugin we needed for the changes of Arseni  upgrading to ELK-7
13:12:19 <witek> we can still create a releases and branches but they are not bound to OpenStack releases
13:12:20 <chaconpiza> When I stack using stable/ussuri, I didn't tried to open neither Grafana nor Kibana
13:12:30 <chaconpiza> ok
13:13:46 <chaconpiza> alright, the next one is whether this is a good release to remove java part from api, persister and possible monasca-common
13:14:23 <chaconpiza> deploying api and persister with java is deprecated for long time.
13:14:24 <witek> in general +1, apart from monasca-common
13:14:49 <chaconpiza> probably in monasca-common we have parts used in Thresh
13:15:05 <witek> right, so at least parts of it would have to remain
13:15:33 <chaconpiza> Then let's start with api and persister, of course only for master branches.
13:15:44 <witek> +1
13:16:03 <chaconpiza> #topic Remove Six library from Monasca modules
13:17:03 <chaconpiza> Recently we received a big effort to remove six from monasca-agent from Likui.
13:17:26 <chaconpiza> https://review.opendev.org/#/c/758006/
13:17:55 <chaconpiza> This change can help as well as a model for the rest of Monasca modules
13:18:02 <chaconpiza> in order to remove six
13:19:09 <witek> good stuff
13:19:22 <witek> the problem with monasca-agent is that it's poorly tested :(
13:20:23 <bandorf> We are currently enhancing our system tests to cover monasca-agent. Not part of monasca, but at least some tests will be executed
13:21:21 <chaconpiza> ideal would be to land them into Tempest-test
13:22:39 <bandorf> Yes, but the test approach is different
13:23:03 <chaconpiza> We have other changes with same topic: six_removed but still incompleted. If I would like to completed them, i.e. take the initial partial work of someone, then it is ok to send a new patchset with: Co-authored-by: <initial-commiter> ???
13:24:18 <witek> the Author field remains unchanged, if you submit a new PS, you'll be added as Committer
13:25:11 <chaconpiza> So, no extra information like Co-authored-by is needed?
13:26:38 <witek> that's my take on it, Co-authored-by is meant for cases when you're using someone's work and submit the initial commit
13:26:58 <witek> but it doesn't hurt to put it anyway
13:27:12 <chaconpiza> I see, thanks for the explanation.
13:27:28 <chaconpiza> #topic Imported Translations from Zanata
13:27:57 <chaconpiza> recently we have received this change https://review.opendev.org/#/c/761291/
13:28:38 <chaconpiza> In this case I am not sure whether it is correct. I see they are removing some messages from several languages.
13:29:25 <witek> hm, good point
13:29:31 <chaconpiza> I added Ian Y. Choi (I think he's the PTL of i18n project) as a reviewer
13:29:59 <chaconpiza> and today I wrote a note in the #openstack-i18n channel
13:30:34 <chaconpiza> So, let's wait for an answer..
13:30:48 <chaconpiza> for now let's keep it open
13:31:17 <chaconpiza> #topic Add chaconpiza into monasca organization in Docker Hub
13:31:24 <chaconpiza> ;-)
13:32:15 <chaconpiza> I am not sure Witek you have the access, if not I will contact Tim Buckley
13:32:57 <witek> I'll look up my DB, but I cannot find any credentials at the first glance
13:33:17 <witek> could you check with Dobek please?
13:33:24 <chaconpiza> Right
13:34:05 <chaconpiza> next topic is related
13:34:15 <chaconpiza> #topic Fix encrypted Docker Hub user/password of monasca-tempest
13:34:26 <chaconpiza> https://zuul.opendev.org/t/openstack/builds?job_name=publish-monasca-tempest-plugin-docker-image
13:35:19 <chaconpiza> The user/password in zuul files are encrypted, unfortunatelly for this repo there is a mistake, so Zuul can't login into Docker Hub
13:35:41 <chaconpiza> I will contact Dobek about it too
13:35:53 <chaconpiza> Each repository as a Public and Private key
13:36:37 <chaconpiza> This is way it would be pointless try to use the encrypted user/password from other monasca zuul configuration file
13:36:53 <witek> makes sense
13:38:09 <chaconpiza> right
13:38:48 <chaconpiza> #topic AOB
13:39:27 <chaconpiza> I am fixing/finishing the docker configuration template for Monasca-Notification https://review.opendev.org/#/c/760081/
13:40:39 <chaconpiza> And deploying the pipeline using the master images, victoria images and ussuri images successfully (tempest test ok)
13:41:17 <chaconpiza> soon I will add stable/ussuri and stable/victoria branches into github.com/monasca/monasca-docker
13:42:11 <witek> the review looks good at the first glance, is it ready to merge?
13:42:26 <chaconpiza> create a branch called "legacy" to keep the current code of monasca-docker (which basically points to queens-rocky)
13:43:01 <chaconpiza> ^^ I wand to check one more time the notification plugins
13:43:10 <chaconpiza> (at least webhook and email)
13:44:02 <chaconpiza> for mail I used Mailhog as a dev. mail server https://hub.docker.com/r/mailhog/mailhog/
13:44:58 <witek> perhaps instead of "legacy" use more explicit name like "stable/queens"
13:45:17 <chaconpiza> mmm... but it is not really uniform
13:46:17 <witek> timestamp with date of last update?
13:46:39 <chaconpiza> yes
13:47:14 <witek> so it could be "legacy-2018_10"
13:47:48 <chaconpiza> it sounds good to me
13:49:13 <chaconpiza> in case of tempest, we still pointing to the tempest-test when it was part of monasca-api repo
13:49:48 <chaconpiza> So, it will be ok to make order there ;-)
13:51:37 <chaconpiza> allright, I think these were all topics for today. Then let's close the meeting.
13:51:53 <witek> thanks
13:51:58 <witek> see you next week
13:52:15 <chaconpiza> Thank you Witek and Matthias, see you next week.
13:52:26 <bandorf> Bye, everybody
13:52:44 <chaconpiza> #endmeeting