13:00:04 <chaconpiza> #startmeeting monasca
13:00:05 <openstack> Meeting started Tue Nov 17 13:00:04 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:09 <openstack> The meeting name has been set to 'monasca'
13:00:13 <chaconpiza> Hi
13:00:16 <witek> hi
13:00:27 <chaconpiza> Hello Witek
13:00:31 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:00:35 <bandorf> Hi there
13:00:41 <chaconpiza> Hello Matthias
13:01:25 <yan0s> Hello!
13:01:39 <chaconpiza> Hi Yanos and welcome
13:01:57 <chaconpiza> Let´s start with the topics from the agenda
13:02:16 <chaconpiza> #topic Fix libvirt configuration (yaml)
13:02:46 <chaconpiza> We have a new contributor, Yanos Angelopoulos, who found an issue in Monasca-Agent
13:03:15 <chaconpiza> https://review.opendev.org/#/c/762221/
13:03:50 <chaconpiza> As I wrote in the ticket: "At first glance it looks like we are using oslo-config [1] to handle the configuration like in the rest of Monasca modules. But you are right, monasca-agent is still using .yaml files instead of oslo-config .conf files."
13:04:19 <chaconpiza> [1] https://opendev.org/openstack/monasca-agent/src/branch/master/monasca_agent/collector/virt/libvirt/inspector.py#L21
13:05:17 <witek> hi yan0s, thanks for the contribution
13:06:00 <chaconpiza> Nevertheless that I misslead at the beginning yan0s found exactly the root cause and fix ;-)
13:06:25 <chaconpiza> Time ago was an Epic to migrate all Monasca modules to Oslo conf. Maybe Monasca-Agent is a left over of this Epic
13:06:45 <chaconpiza> I coudn'd find the Story
13:07:19 <chaconpiza> What is your opinion about to migrate monasca-agent to use oslo conf?
13:08:13 <chaconpiza> Here we have the related change for Monasca-Notification [2] https://storyboard.openstack.org/#!/story/2000959
13:08:17 <witek> +1, but it's more complex than other components
13:08:39 <chaconpiza> That's right, because of multiple config files for the plugins
13:08:48 <bandorf> Yes, there are quite a lot
13:09:14 <chaconpiza> dougsz, how it will impact your deployment?
13:10:55 <chaconpiza> So far Yanos yaml fix is only merged in the master branch. yan0s, do you need it in a stable branch?
13:11:33 <chaconpiza> #topic Migrate configuration of Monasca-Agent from yaml to oslo-config .conf
13:12:01 <yan0s> for now I'm just testing stuff, we are considering switching from ceilometer to monasca
13:12:11 <chaconpiza> I see
13:12:22 <yan0s> if we choose to do so then I would want this to be on stable
13:13:47 <witek> yan0s: if you need, you can use Ceilometer's Monasca publisher to get Ceilometer measurements into Monasca
13:14:13 <chaconpiza> #action I will create a Story to keep track on "Migrate configuration of Monasca-Agent from yaml to oslo-config .conf"
13:14:57 <yan0s> witek, I understand that but we want to keep only one project for this job, if possible
13:15:11 <witek> ack
13:15:29 <yan0s> for less complexity
13:16:01 <chaconpiza> let's continue with next topic
13:16:06 <chaconpiza> #topic [monasca] Transition Stein to EM
13:16:56 <chaconpiza> Stein branch is going to extended maintenance state
13:16:59 <yan0s> is there a decision for the previous topic?
13:18:05 <chaconpiza> yan0s, based on your first contribution I would say that you are on the state to lead the migration to oslo config
13:18:23 <chaconpiza> of course with the support of the team
13:18:35 <yan0s> ok
13:19:08 <witek> if you're ready to work on this, that would be great
13:19:25 <chaconpiza> right
13:19:55 <chaconpiza> after the meeting I will create the story and I will assing to you and send you the link to your email
13:20:18 <yan0s> thanks
13:20:21 <chaconpiza> 👍
13:21:09 <chaconpiza> Alright, coming back to the Stein transition to EM. I checked that all commits hashes are correct
13:22:02 <chaconpiza> those commits are pointing to the last tag  on Stein branch, not necessary to the last commit in the Stein.
13:22:19 <chaconpiza> But the process is designed like that
13:22:30 <chaconpiza> I compare with other OpenStack projects.
13:22:57 <chaconpiza> Of course Monasca-Tempest is an exception with only Master branch
13:23:26 <chaconpiza> Besides of that there is a small problem with libvirt libraries
13:23:42 <chaconpiza> not only in Monasca but in few other projects
13:24:04 <chaconpiza> they want to use Ubuntu Focal for the push into PyPi
13:24:19 <chaconpiza> We had the same issue in Master and stable/victoria
13:24:48 <chaconpiza> solved with this change https://review.opendev.org/#/c/757093
13:25:20 <chaconpiza> Based on bindep
13:26:00 <chaconpiza> However they want to solve this situation on other level: https://review.opendev.org/#/c/762699/
13:26:48 <chaconpiza> The #action I will cherry pick https://review.opendev.org/#/c/757093 into the stable branches backwards until Stein
13:27:04 <chaconpiza> it is and innocuous fix
13:27:15 <witek> lgtm
13:27:38 <chaconpiza> great
13:27:54 <chaconpiza> lets move to the next topic
13:28:04 <bandorf> OK, I'll explain
13:28:36 <chaconpiza> #topic Upgrade storm version used for monasca-thresh
13:28:40 <chaconpiza> Thanks Matthias
13:28:41 <bandorf> Background: In our monasca-based product, we currently use storm 1.0.6 in monasca-thresh.
13:29:01 <bandorf> So, we need to use a newer version since this one isn't maintained any longer.
13:29:35 <bandorf> For results of my check, from agenda:
13:29:40 <bandorf> Versions available: 2.x (latest: 2.2.0), 1.2.3
13:29:58 <bandorf> Versions used:    devstack: 1.2.2    monasca/monasca-docker: 1.1.1
13:30:41 <bandorf> Since we will be executing quite some extensive tests (system test), my idea was to use a new version, if no issues occur - e.g. 2.2.0
13:30:49 <bandorf> My first questions:
13:31:03 <bandorf> Anybody has experience with storm 2.x?
13:31:16 <bandorf> Any pros and cons, trying to use it?
13:31:44 <witek> no experience with new Storm from my side
13:32:21 <bandorf> I was hoping for Doug... :-)
13:32:51 <bandorf> Maybe, he's currently not in.
13:32:56 <chaconpiza> dougsz is the one that upgrade Storm in devstack to 1.2.2 https://github.com/openstack/monasca-api/commit/4f62c1d318ebf1756424b7e308fdd037243f5f5c
13:33:11 <chaconpiza> I assume that they are still using version 1.x.y
13:33:18 <bandorf> Yes, I can ask him later.
13:33:23 <bandorf> My 2nd topic:
13:33:51 <bandorf> We are now using storm image, from which monasca-thresh image is constructed.
13:34:12 <bandorf> In storm - from e.g. 1.2.3, they changed the base image:
13:34:43 <bandorf> We are now using storm image, from which monasca-thresh image is constructed.
13:35:02 <bandorf> storm 1.1.1: Alpine Linux 3.7    storm 1.2.3: Debian GNU/Linux 10 (buster)
13:35:19 <bandorf> Thus, our Dockerfile doesn't fit any longer.
13:36:03 <bandorf> Question 1: Is it acceptable for you, that there will be a Dockerfile for updated monasca-thresh that is not compatible with older Storm versions?
13:36:04 <chaconpiza> This is the Docker file Matthias mentioned https://github.com/openstack/monasca-thresh/blob/master/docker/Dockerfile
13:36:58 <bandorf> Next is not really a topic, but: Many things have to be changed:
13:37:14 <bandorf> package mgr: apk -> apt-get
13:37:18 <chaconpiza> it is possible to handle both? with kind of IF statement?
13:37:19 <dougsz> sorry, meeting clash
13:37:24 <bandorf> shell: ash -> bash
13:38:04 <bandorf> Theoretically of course, it's possible. But it's a different structure, differnet package names, ...
13:38:23 <bandorf> If there's no urgent reason, I'd like to avoid this
13:38:40 <witek> ad Q1, I don't think it's a problem, the old version is not maintained anymore
13:39:22 <bandorf> OK, great - at least some good news.
13:39:42 <bandorf> Migration on its own is really tough, at least for me.
13:40:40 <chaconpiza> if we decided to change the Dockerfile to handle the new Storm versions based on debian, it is ok to cherrypick the change to Ussuri?
13:41:41 <bandorf> Doesn't make a lot of sense to me. This would mean we will introduce new storm version for ussuri
13:42:20 <bandorf> Are you asking because of CMM? Then, let's discuss separately
13:42:27 <chaconpiza> ok
13:42:29 <chaconpiza> sure
13:43:10 <witek> why do we have to move to Debian image? Busybox seems avaialable for Alpine https://pkgs.alpinelinux.org/package/edge/main/x86_64/busybox
13:43:31 <bandorf> storm image is based on Debian image.
13:43:50 <chaconpiza> The official Strom image
13:43:53 <bandorf> Other option: continue with old way, i.e. we build our own image, based on alpine
13:44:04 <dougsz> bandorf: Apologies, no experience with Storm 2.x yet
13:44:14 <bandorf> OK, thanks, Doug
13:44:28 <witek> I see, yes, it makes sense to leverage the official image
13:45:16 <chaconpiza> in the past we build the storm image from Alpine to later use it as a base for Thresh https://github.com/monasca/monasca-docker/blob/master/monasca-thresh/Dockerfile
13:45:28 <bandorf> Well, yes, but the job seems to be tough. I'm not sure if it's the right way. The image is provided as "black box", regarding OS etc.
13:45:43 <bandorf> But we are using the OS, java, ...
13:45:49 <chaconpiza> now we use the official https://github.com/openstack/monasca-thresh/blob/master/docker/Dockerfile#L8
13:46:27 <bandorf> I can investigate a bit longer. Maybe, next week, I will know more. Then, we can discuss again
13:47:29 <chaconpiza> Thanks Matthias
13:48:05 <chaconpiza> lets go to next topic
13:48:09 <chaconpiza> #openstack-discuss threads
13:48:34 <witek> I've collected relevant threads from the mailing list
13:49:31 <witek> the first one is related with the code audit related with the Gerrit outage in Oct
13:49:49 <witek> http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018795.html
13:50:36 <witek> then, there was an inquiry on monasca-analytics
13:50:36 <chaconpiza> the audit means to check the commits/merges in this period for all Monasca repositories?
13:51:12 <witek> no, there is more
13:51:31 <witek> some data could be compromised
13:51:43 <witek> here are all details
13:51:47 <witek> http://lists.opendev.org/pipermail/service-announce/2020-October/000011.html
13:53:08 <chaconpiza> Thanks for the link, #action I will go for this
13:54:03 <witek> then, there was an inquiry on monasca-analytics
13:54:13 <witek> http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018785.html
13:54:48 <witek> just FYI
13:55:28 <witek> finally, Telemetry project plans to meet and discuss next steps
13:55:34 <witek> http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018685.html
13:55:45 <witek> main topic seems to be Gnocchi support
13:55:49 <chaconpiza> I am not sure where to redirect the inquiry about monasca-analytics
13:57:17 <witek> well, I've answered that we didn't have anyone maintaining the project
13:57:56 <chaconpiza> right
13:58:44 <chaconpiza> Ok, thanks for bringing the topics specially the one related about Gerrit outage
13:58:55 <chaconpiza> #topic AOB
13:59:27 <chaconpiza> is there any other topic for today you like to discuss?
14:00:17 <bandorf> not from me
14:00:23 <chaconpiza> Thanks for the meeting today. Again, welcome to the Monasca community Yanos.
14:00:43 <chaconpiza> See you next week same hour same channel.
14:00:52 <chaconpiza> Bye
14:00:54 <witek> thanks everyone
14:01:10 <bandorf> Thanks, everybody, see you next week
14:01:26 <chaconpiza> #endmeeting