15:00:58 <kozhukalov_> #startmeeting Monthly Openstack-Helm meeting
15:00:58 <opendevmeet> Meeting started Tue Mar  7 15:00:58 2023 UTC and is due to finish in 60 minutes.  The chair is kozhukalov_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <opendevmeet> The meeting name has been set to 'monthly_openstack_helm_meeting'
15:01:34 <kozhukalov_> Hi, is anyone around?
15:01:39 <steveftaylor> Yes
15:02:16 <gagehugo> o/
15:02:48 <kozhukalov_> That is nice. More than one person  should be enough to call this event a meeting )
15:03:11 <kozhukalov_> #topic Get rid of old plain provisioners (cephfs and rbd)
15:03:35 <steveftaylor> +1
15:04:09 <kozhukalov_> The first topic for today is to get rid of this particualar thing as old plain provisioners. The details are discussed in the ML thread
15:04:22 <kozhukalov_> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-March/032550.html
15:04:56 <steveftaylor> Those provisioners are outdated and incompatible with Ubuntu and Ceph udpates. They haven't been maintained in a long time, and rather than updating them, we should probably move to CSI and get rid of those.
15:05:20 <kozhukalov_> Totally agree
15:05:22 <gagehugo> +1
15:05:28 <gagehugo> sounds good to me
15:05:31 <kozhukalov_> Even more
15:05:48 <kozhukalov_> for ceph csi provisioners we can also use upstream charts
15:05:56 <kozhukalov_> less code to support
15:06:10 <steveftaylor> I like it
15:06:47 <kozhukalov_> Frankly, I even think that since ceph is not a part of openstack we could potentially use rook instead
15:07:26 <steveftaylor> We could. That's a much bigger change, but it's a good plan long term.
15:07:29 <gagehugo> we've brought up using other upstream charts before in the past and it seemed to be fine, just needed someone to port everything over was the main roadblock
15:07:57 <kozhukalov_> yes, this is long term
15:08:35 <kozhukalov_> at least we agree about getting rid old provisioners (I am currently working on the PS for this)
15:09:04 <steveftaylor> I have some really old notes somewhere documenting some issues with rook that could be problematic for us, but those are really old. It is probably that those issues have been addressed.
15:09:12 <kozhukalov_> #agreed get rid of old plain provisioner in favor of using CSI
15:09:14 <steveftaylor> *probable
15:10:04 <steveftaylor> Maybe focus on the provisioners for now and add rook to the agenda for the next meeting?
15:10:05 <kozhukalov_> #steveftaylor can you please try to find your notes and share somehow?
15:10:44 <steveftaylor> Yes, I can try to dig them up.
15:10:52 <kozhukalov_> yes, good idea to postpone the rook discussion for later
15:11:03 <kozhukalov_> Ok, thanks
15:12:09 <kozhukalov_> #action steveftaylor will try to find notes about potential issues of using rook
15:12:29 <kozhukalov_> Let's then switch to the next topic
15:12:50 <kozhukalov_> #topic New PTL - Vladimir Kozhukalov
15:13:21 <kozhukalov_> I believe, this topic was from gagehugo
15:13:27 <kozhukalov_> First of all
15:13:32 <gagehugo> Just wanted to say thanks kozhukalov_ for stepping up in the role and to announce it here
15:14:02 <steveftaylor> kozhukalov_: Congrats! Glad to have you here.
15:14:14 <kozhukalov_> Let me say thank you to gagehugo for all his efforts during previous years
15:14:26 <kozhukalov_> Thanks
15:14:55 <gagehugo> thank you!
15:15:15 <steveftaylor> gagehugo: Thanks for all of your efforts and well done. It's been a pleasure.
15:15:49 <kozhukalov_> and our focus for the next release is 1) improve documentation 2) support Yoga and probably Zed 3) support Focal, recent Fedora and probably centos stream
15:16:23 <gagehugo> Those sound like good goals
15:17:10 <kozhukalov_> I am not sure I'll be in Vancouver this summer, but at least I am currnetly working to prepare good discussions during virtual PTG in the end of March
15:18:22 <gagehugo> kozhukalov_: there currently isn't a session for OSH at the virtual PTG due to lack of interest, so if you're wanting to host one still you may need to reach out to the organizers
15:18:49 <kozhukalov_> yes, I've already done this
15:19:10 <gagehugo> ok cool
15:19:56 <kozhukalov_> diablo_rojo created a track for us in #openinfra-events
15:20:13 <kozhukalov_> so we can allocate discussion slots
15:20:41 <kozhukalov_> at lease we'll try to attract more people
15:21:09 <kozhukalov_> Ok, then let's switch to another topic
15:21:57 <kozhukalov_> yes, and before we switch, just in case here is the link for the official election results
15:22:05 <kozhukalov_> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032442.html
15:22:23 <kozhukalov_> #topic Do we need IRC meetings?
15:23:15 <steveftaylor> This is the most active one I have ever attended. :-)
15:23:31 <kozhukalov_> The idea here is that in most cases we can discuss things in ML threads and it looks like there is no much sense to have monthly IRC meetings
15:23:41 <kozhukalov_> :-)
15:24:17 <gagehugo> Lately the IRC meetings have been pretty quiet
15:24:25 <kozhukalov_> when you have smth to discuss you usually don't want to wait a month, right?
15:24:42 <gagehugo> It depends, usually no
15:24:56 <steveftaylor> The meetings used to be weekly. It has only been recently that they have been monthly because they have been so quiet.
15:25:00 <gagehugo> but in the past the meeting was when you could usually assume more folks would be available
15:25:55 <kozhukalov_> yes, in projects like neutron and nova it makes sense to have weekly meetings
15:25:57 <gagehugo> and usually it was for longer term goals (like ceph here)
15:26:37 <steveftaylor> I don't see much of a need for these meetings if we want to move these discussions to the ML.
15:26:41 <kozhukalov_> Aha, I see, for long term discussions yes
15:27:13 <gagehugo> if anyone wants to discuss something now, there's always this channel or slack too
15:27:35 <kozhukalov_> personally, I would prefer ML discussions even for long term things
15:28:17 <kozhukalov_> anyway, it does not require much effort to conduct these meetings monthly
15:28:18 <steveftaylor> I agree. It may take longer to hold a discussion that way, but it also doesn't require anyone be available at a specific time.
15:28:30 <gagehugo> I am neutral, I've always done the irc meetings and I think they can be useful for newcomers, but I can see the argument for moving our discussions to the mailing list
15:29:06 <gagehugo> we would need to update the references in the repo and wiki to point folks to reaching out there is my main concern, but that is pretty simple
15:29:30 <gagehugo> and it frees up this timeslot for folks who otherwise are likely busy
15:31:17 <kozhukalov_> Ok, our opinions (but there are only three people here) are from neutral to not having meetings, but there is no strong agreement
15:31:49 <kozhukalov_> so, I'll update links and add comments that ML and slack are preferable ways to communicate
15:31:57 <steveftaylor> sounds good
15:32:11 <kozhukalov_> but at the same time, we'll continue to have meetings
15:32:28 <kozhukalov_> will see if they are active enough
15:32:52 <steveftaylor> Good plan
15:32:56 <gagehugo> works for me
15:33:24 <kozhukalov_> next time if there are only three people I will cancel monthly meetings
15:33:42 <steveftaylor> seems fair
15:33:44 <gagehugo> sure
15:33:52 <kozhukalov_> anyway three people is not enough to have consensus for long term things
15:34:23 <kozhukalov_> #topic Open discussion
15:34:51 <gagehugo> I don't have anything else
15:35:09 <steveftaylor> Me neither
15:35:20 <kozhukalov_> Same for me at this point
15:35:47 <kozhukalov_> Thanks a lot for attending.
15:36:01 <kozhukalov_> Now I am closing the meeting.
15:36:05 <gagehugo> kozhukalov_: thanks!
15:36:20 <kozhukalov_> #endmeeting