08:00:35 <ricolin> #startmeeting multi_arch
08:00:35 <openstack> Meeting started Tue Jan  7 08:00:35 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:38 <openstack> The meeting name has been set to 'multi_arch'
08:00:42 <ricolin> #topic roll call
08:00:46 <hrw> o/
08:00:51 <ricolin> \o/
08:01:12 <Kevin_Zheng> o/
08:01:30 <kevinz> o/
08:01:39 <ricolin> ianw_pto, is on pto so he's not likely join this time
08:01:51 <ricolin> I think tonyb might be as well:)
08:03:17 <ricolin> The SIG propose is landed yesterday
08:03:22 <ricolin> https://governance.openstack.org/sigs/
08:03:29 <ricolin> #link https://governance.openstack.org/sigs/
08:03:35 <ricolin> so we're official now
08:04:10 <ricolin> #topic greeting
08:04:19 <hrw> cool
08:04:39 <hrw> so the simple question: which archs this sig covers? other than arm64
08:05:50 <ricolin> hrw, I put following words in initial goal of SIG
08:05:50 <ricolin> At first stage: We aim to reach better coverage for ARM support in OpenStack.
08:05:50 <ricolin> This includes documents, test jobs, tracking issues, and building ecosystem.
08:05:50 <ricolin> We also welcome other architecture to join and triggering tasks.
08:06:00 <hrw> ok
08:06:35 <ricolin> the scope on sigs page defined as follow
08:06:37 <ricolin> This SIG aim to reach better coverage for multiple architecture support in OpenStack. This includes provide documents, building test jobs, tracking issues, and building ecosystem for multiple architecture.
08:07:18 <ricolin> hrw, do you have any other arch. in your mind that we maybe can get people and resources on it too?
08:07:44 <hrw> ricolin: I would love to see someone with ppc64le resources ;D
08:08:19 <kevinz> I know that jchen from IBM are working with S390x
08:08:26 <kevinz> But he is not here today
08:09:20 <hrw> ok, so to arm64...
08:09:23 <ricolin> hrw, maybe we can ask around with ML to see who whould like to join us and work on ppc64le
08:09:27 <hrw> sure
08:09:37 <hrw> someone other than linaro with resources?
08:10:00 <ricolin> is there any works you know already targeting ppc64le in OpenStack?
08:10:33 <ricolin> hrw, we're also try to ask Huawei too
08:10:43 <hrw> ricolin: other than kolla having some kind of ppc64le support no
08:11:05 <ricolin> Kunluncloud is also checking if they can provide their new resources out
08:11:30 <hrw> would be great as for now there are just 8 nodes
08:12:22 <ricolin> and big thanks to ianw_pto to make a separate pipeline for them:)
08:12:38 <hrw> ricolin: it was quite a discussion on how to handle it ;D
08:13:24 <hrw> I suggested separate queue to not have main jobs blocked and then separate pipeline was suggested
08:13:48 <ricolin> oh, also kevinz is working on provide another group of resources to OpenStack community too
08:14:51 <ricolin> kevinz, how's that working for you?:)
08:15:19 <kevinz> Aha, that resource is almost ready
08:15:34 <ricolin> hrw, is there anywhere I can see the discussion? which I can learn more on the history:)
08:15:38 <kevinz> I'm working on the ssl certificate, and reconfigure
08:15:52 <kevinz> After that Openstack-infra team can use it
08:15:59 <hrw> ricolin: #openstack-infra logs
08:16:11 * ricolin think we should switch topic:)
08:16:14 <ricolin> #topic SIG initial setup
08:16:47 <hrw> ricolin: 2019.12.11 irc log
08:16:53 <ricolin> thanks!
08:17:33 <ricolin> kevinz, that's great news!
08:19:40 <kevinz> Thanks
08:19:59 <kevinz> the cluster will offer about 400 vcpu
08:20:29 <ricolin> that's huge improve to what we have
08:21:09 <hrw> kevinz: 50 8vcpu nodes? :D
08:21:47 <kevinz> 9 * 46 I, but in the first phase will be 8*46
08:22:26 <kevinz> The other 2 nodes, one is as a operation node, they other is served as a router
08:22:35 <hrw> sure
08:22:53 <kevinz> Centriq 2400
08:23:37 <hrw> o. another set of not existing machines ;d
08:24:19 <hrw> nice 46 core machines.
08:24:33 <kevinz> yes sure, hope more and more resources will join
08:25:00 <ricolin> kevinz, Long live Linaro:)
08:25:52 <kevinz> \o/
08:26:10 <ricolin> And back to the SIG setup, I think it will be nice to have a StoryBoard to track all tasks
08:26:22 <mrda> +1
08:26:34 <ricolin> mrda, o/
08:26:38 <mrda> \o
08:26:53 <hrw> +1
08:26:56 <kevinz> +1
08:27:31 <ricolin> #action ricolin will help to set up the environment for our StoryBoard
08:27:54 <ricolin> Do we need any initial documents?
08:28:27 <ricolin> or any documents that we should build in short/long run?
08:29:17 <mrda> ricolin: what did you have in mind?
08:30:18 <ricolin> mrda, a document to point out where people need to change to adopt ARM? but not sure that's required
08:30:40 <ricolin> collecting use cases?
08:31:30 <mrda> Right, so a "how to support archs other than x86" and "these are the use cases that we definitely want to support"?
08:32:00 <ricolin> yep
08:32:20 <hrw> I would like to see something like 'oh, on arm64 you need to do XYZ in other way - here is how and why'
08:32:22 <mrda> I guess the first is known common pitfalls, and the 2nd is things that we think should (alomst) work out of the box
08:32:36 <mrda> hrw: right
08:32:41 <hrw> as we can then work on moving that logic into openstack components to allow to remove that option
08:32:59 <hrw> like 'hw_firmware_type=uefi' which was needed <queens to get anything booted
08:33:01 <ricolin> hrw, good idea
08:33:27 <hrw> how many of you know how to create instance with 20 pcie slots?
08:34:09 <kevinz> hrw, strong agree
08:34:15 <ricolin> We definitely should keep tracking who is using ARM with OpenStack too
08:34:19 <hrw> on x86 with i440fx user has unlimited amount of pci slots. on q35/aarch64 you have 2-3 slots and nothing more
08:34:54 <mrda> ok, cool
08:35:06 <hrw> ricolin: 'who' + 'issues they had'?
08:35:56 <ricolin> hrw, and also 'who'+'helping the community to build env.'
08:36:30 <ricolin> So we can high light the help from Linaro, Red hat, etc
08:36:38 <ricolin> s/help/helps/
08:38:13 <ricolin> feel like we can start to build some doc for `oh, on arm64 you need to do XYZ in other way - here is how and why` and `use cases, who, and issues they had`?
08:38:28 <hrw> sounds good
08:38:44 <ricolin> anyone willing to help writing:)
08:38:47 <mrda> yep
08:39:04 <ricolin> I can help to build the repo ready for docs
08:39:56 <ricolin> #action ricolin help build multi-arch SIG repo
08:41:11 <ricolin> #action we need people to help on documents `oh, on arm64 you need to do XYZ in other way - here is how and why` and `use cases, who, and issues they had`
08:41:48 <ricolin> And now CI jobs:)
08:42:05 <hrw> CI is easy
08:42:22 <mrda> lol
08:42:28 <ricolin> hrw, I assume you will keep working on kolla part?
08:42:42 <hrw> ricolin: kolla(-ansible) is where I am core
08:42:58 <ricolin> hrw, you're now on auto signed up to ci stories!:)
08:43:24 <hrw> mrda: in properly managed project you just duplicate existing job, add -aarch64 to name and define aarch64 nodeset
08:43:53 <mrda> Sure, I'm just not familiar
08:44:14 <hrw> I can help with CI definitions if needed
08:44:36 <ricolin> hrw, do you think it will be easy to set up job for openstack-helm as well?
08:45:38 <hrw> ricolin: never looked at helm but should be
08:45:41 <ricolin> kind of interested to verify on too
08:45:55 <hrw> ricolin: if something does not work then it needs to be fixed in project ;D
08:46:39 <ricolin> agree, I guess to see if everything works or not is one of our initial goal, right:)
08:47:06 <hrw> yep
08:48:04 <ricolin> okay, now chairs
08:48:10 <ricolin> anyone interested:)
08:48:13 <ricolin> ?
08:48:18 <mrda> I vote for tonyb :-P
08:48:41 <ricolin> tonyb+1:)
08:48:59 <hrw> I prefer not to apply myself.
08:49:07 <ricolin> we can have about three(or more)
08:49:38 <mrda> How about you ricolin ?
08:50:21 <ricolin> I'm volunteer too
08:50:56 <ricolin> to help set up stuff
08:51:14 <ricolin> totally fine to have others to replace me:)
08:51:50 <ricolin> maybe ianw_pto will be interested too?:)
08:52:31 <ricolin> I will ask them when they back on works
08:52:57 <mrda> sounds good
08:53:07 <ricolin> mrda, how about you:)
08:53:24 <mrda> It is unfair to suggest tonyb while he's travelling, but he would be excellent.
08:53:51 <ricolin> agree
08:53:59 <mrda> ricolin: I've just come back to the community after a 2 year break, so I should settle in a little more longer
08:54:31 <ricolin> mrda, do you happen to know when tony will back on works?
08:55:49 <mrda> And to be honest, I'm still learning ppc64le.  I don't know if I can learn aarch64 as well
08:56:15 <ricolin> mrda, you're the one hrw looking for!
08:56:39 <mrda> He should be back on deck soon, albeit working from a eu tz for a short while
08:56:51 <ricolin> we ware talk about what elese arch we can find people or resources to work on
08:56:53 <hrw> mrda: ignore aarch64, ppc64le has less devs
08:57:02 <mrda> :)
08:57:03 <ricolin> lol
08:57:47 <mrda> Well, that's what I'm focusing on. I think the SIG coming along is good timing.
08:57:53 <hrw> mrda: if you have ppc64le access and work on openstack there then aarch64 is more like a source to look on how to solve !x86isms
08:58:01 <mrda> yep
08:58:22 <hrw> I remember times of fixing rhel7/aarch64 where my aarch64 fixes were fixing ppc64le and s390x too
08:58:30 <ricolin> mrda, is there any work in progress in community now?
08:58:35 <hrw> as most of them were 'if you are not x86 then'
08:59:40 <mrda> Yes, I'm looking at upstream fixes for ppc64le wherever they come
09:00:20 <ricolin> mrda, if you see something can you update the etherpad too(since our documents repo and storyboard is not yet ready)?
09:00:25 <ricolin> #link https://etherpad.openstack.org/p/Multi-arch
09:01:05 <mrda> ricolin: sure
09:01:38 <hrw> I added some github links there
09:01:54 <ricolin> #action mrda help to collect update ppc64le actions and resources in community if see any
09:02:00 <ricolin> hrw, super!
09:02:13 <ricolin> I think we're out of time
09:02:20 <hrw> ricolin: was easy - just looked into my summary of december work ;D
09:02:25 <mrda> Thanks ricolin (for everything)
09:02:49 <ricolin> hrw, everything feels easy with you around!
09:03:02 <hrw> ricolin: if you say so...
09:03:03 <hrw> ;D
09:03:21 <ricolin> anything else before we end our very first meetup?:D
09:03:45 <hrw> see you in 7h on second meeting?
09:03:46 <mrda> Next week, same time?
09:03:55 <ricolin> hrw, yes:)
09:04:00 <hrw> time slot fits my calendar
09:04:16 <ricolin> mrda, we got another one after 7hours
09:04:22 <mrda> Well, that will be 1:30am for me, so I will see you for 3rd meeting the same time next week
09:04:32 <mrda> :-)
09:04:36 <ricolin> I put the meeting schedule biweekly-even
09:04:54 <ricolin> or anyone think we should do this weekly?
09:05:01 <hrw> will see
09:05:06 <mrda> every second week is ok for now
09:05:07 <ricolin> okay
09:05:18 <ricolin> Thanks all for join:)
09:05:23 <ricolin> see you around!
09:05:27 <mrda> Thanks!
09:05:30 <ricolin> #endmeeting