08:00:28 <ricolin> #startmeeting multi_arch
08:00:30 <openstack> Meeting started Tue Jan 21 08:00:28 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:36 <openstack> The meeting name has been set to 'multi_arch'
08:00:38 <ricolin> #topic roll call
08:00:42 <ianw> o/
08:00:43 <ricolin> o/
08:00:48 <ricolin> ianw, o/
08:02:02 <ricolin> tonyb, is traveling in Europe, so I assume will join our 2nd meeting today
08:02:15 <mrda> o/
08:02:23 <ricolin> hi mrda :)
08:02:26 <mrda> hey!
08:02:55 <ricolin> #topic adding items to agenda
08:03:00 <ricolin> #link https://etherpad.openstack.org/p/Multi-Arch-agenda
08:04:01 <ricolin> what's your current multi-arch WIP task mrda ianw?:)
08:04:21 <ianw> so just today i got credentials for the linaro US cloud
08:04:42 <ianw> #link https://review.opendev.org/#/c/703535/
08:05:02 <ianw> when we get this up, we'll have
08:05:27 <ianw> another 8 nodes at least
08:06:10 <mrda> and I'm just got access to a power9 box which I'm planning on doing some testing on (up until now I've just been using a power 8 box).
08:06:18 <ricolin> ianw, is that the same group of node Kevin Zhao mentioned last time?
08:06:44 <ricolin> (with ~400vcpu)
08:07:32 <ianw> ricolin: yes, i think he said 8*44 == 352 vcpu
08:07:32 <ricolin> mrda, stress test?:)
08:07:45 <mrda> ianw: very cool
08:07:48 <ricolin> ianw, that's awesome!
08:08:21 <ianw> well all thanks to linaro and kevinz :)
08:08:44 <mrda> ricolin: just looking at some tripleo undercloud introspection and trait-based deployment.
08:09:03 <ianw> i know the networking is ipv6 only, that shouldn't be a problem but it is new territory for the arm64 clouds, so may be issues lurking
08:09:08 <mrda> ...making sure it works as expected on both power8 and 9
08:09:39 <ricolin> ianw, is that means only ipv6 for devstack too?
08:10:12 <mrda> huh, v6 only networking.  At what layer is that implemented?
08:10:27 <ricolin> mrda, that sounds like a looooot~ of works!
08:10:47 <ianw> ricolin: we haven't got devstack working on arm64, yet.  but i'd say the nodes can communicate between themselves via ipv4 (for multinode jobs), just no routed public ip
08:10:53 <ianw> ipv4 i mean
08:11:23 <ianw> we have several other clouds like this too
08:11:32 <mrda> ianw: thanks for clarifying.  v6-only should just work :)
08:12:54 <ricolin> #topic Follow on Repo and StoryBoard setup
08:13:06 <ricolin> Our Repo is there, but I haven't add the doc and zuul structure yet. Will do it this week.
08:13:07 <ricolin> #link https://opendev.org/openstack/multi-arch-sig
08:13:25 <ricolin> According to the plan we got from last meeting, documents will first to put in. I think that can started now, and send out once the repo structure is ready.
08:13:54 <ricolin> #action ricolin add doc and zuul structure to https://opendev.org/openstack/multi-arch-sig
08:14:24 <ricolin> Since we have our own repo, we have core reviewer list
08:14:28 <ricolin> #link https://review.opendev.org/#/admin/groups/2079,members
08:14:43 <ricolin> And I would like to suggest we add volunteers as core reviewers.
08:14:57 <ricolin> ianw, mrda interested?:)
08:15:02 <mrda> Sure
08:15:23 <ianw> yes, i can subscribe to the repos and watch for things i might know something about :)
08:16:16 <ricolin> super!
08:16:45 <ricolin> I will add both of you in that list later:)
08:17:19 <ricolin> ianw, How about SIG chair role?:)
08:17:27 <mrda> thanks ricolin, you're pretty organised :)
08:18:19 <kevinz> sorry I just got time to join
08:18:24 <kevinz> ianw: my pleasure
08:18:29 <ricolin> mrda, thx, try to be:)
08:18:39 <ricolin> kevinz, o/
08:18:48 <ianw> umm, i dunno about a chair, probably be better to go to someone who travels to things a bit more
08:18:49 <ricolin> kevinz, thanks for the effort!:)
08:19:26 <kevinz> :D
08:20:38 <ricolin> ianw, NP, we know have tonyb and I volunteered, and we still got room for one more IMO, so feel free to let me know if you would like to take it:)
08:20:44 <ricolin> *now
08:21:05 <ricolin> next
08:21:12 <ricolin> Our StoryBoard is created
08:21:18 <ricolin> #link https://storyboard.openstack.org/#!/project/openstack/multi-arch-sig
08:21:46 <ricolin> We should start added task into it. So if all members can put in their current work in progress task in this story will make others easier to track.
08:22:12 <ricolin> We already have some collected WIP patch recorded in https://etherpad.openstack.org/p/Multi-arch which I think will make sense to move to StoryBoard too.
08:22:29 <ricolin> ianw, kevinz mrda thoughts?
08:23:10 <ianw> sounds good, i can do that for what i get up to
08:23:17 <mrda> yup, works for me
08:23:35 <ianw> i guess if we have bigger tasks, split that out into separate stories?
08:24:01 <ricolin> yeah, I think so
08:24:54 <ricolin> for some small one, can created under a story with general title
08:25:25 <ricolin> #action Everyone please help to put on tasks in Storyboard https://storyboard.openstack.org/#!/project/openstack/multi-arch-sig
08:26:31 <ricolin> The most need to track tasks IMO are tasks that already generated patches
08:27:41 <ricolin> let's start with our storyboard and record all future tasks on it:)
08:28:41 <ricolin> Also we can use storyboard to link and assign tasks to another project team (if they also use storyboard too)
08:28:48 <ianw> ++
08:29:00 <ricolin> pretty handy:)
08:29:05 <mrda> +1
08:29:25 <ricolin> I also create a irc channel #openstack-multi-arch mostly because we need a place to record gerrit update also will be nice if people all join that irc and easier to find each other. So please join:)
08:29:55 <ricolin> #action Everyone please join IRC channel #openstack-multi-arch :)
08:30:09 <mrda> Done
08:30:20 <ricolin> mrda, fast!
08:31:01 <ricolin> I think that's all I got from SIG infra set up
08:31:02 * mrda notes he might otherwise forget
08:31:47 <ricolin> #topic Follow on CI Resources
08:32:21 <ricolin> For what I know mnaser mentioned that there might be some ARM resource Vexxhost can donate to community.
08:32:33 <ricolin> Also Huawei mentioned that they can donate ARM resources too.
08:32:58 <ricolin> I will keep tracking with them and see if anything scheduled.
08:33:44 <ricolin> Also ianw and kevinz already give us even better news already:)
08:34:24 <ricolin> so soon, two group of nodes
08:35:53 <mrda> it's great to have multiple sources of nodes
08:35:54 * ricolin thinking crazy CI job ideas
08:37:39 <ricolin> mrda, yeah, that help us to avoid single group of resource failing issue. Also since ARM performance is totally different between providers, we can even help to testing the general performance:)
08:38:22 <ricolin> ianw, when you mentioned about devstack is not working with arm64, you mean devstack itself? or other component?
08:38:29 <mrda> yeah, great idea...
08:39:31 <ianw> ricolin: i haven't tried, would be things like package installs etc that would need to be sorted out
08:41:10 <ricolin> ianw, we can put on a patch and test that out:)
08:41:53 * mrda is going to have to drop off.
08:41:55 <ianw> certainly, it can all be speculatively done with a new job using arm64 nodes
08:41:57 <mrda> Thanks everyone.
08:42:04 <ricolin> mrda, thanks for join:)
08:42:51 <ricolin> ianw, we can put those job definition in SIG repo if we plan to use it officially
08:43:41 <ricolin> like a general devstack-arm64 job
08:44:36 <ianw> yes, i'll try to find some time at least get a job definition up, so if someone who maybe isn't so familiar with zuul configs wants to really run with it they have a head start
08:45:02 <ricolin> sounds great!
08:45:26 <ricolin> ianw, can I put that on as an action?
08:45:37 <ianw> ok, sure :)
08:46:00 <ricolin> #action ianw help to provide arm base job definition for devstack
08:46:06 <ricolin> super!:)
08:46:56 <ricolin> ianw, kevinz anything you would like to add in CI topic?
08:48:08 <ricolin> Okay, move on:)
08:48:13 <ricolin> #topic Follow on documentation
08:49:02 <ricolin> jeremyfreudberg has take the action to working on docs, but didn't sync that with him yet
08:49:34 * ricolin knows that 2nd meeting is the right time for jeremyfreudberg:)
08:49:52 <ricolin> So I don't have much to update here
08:50:52 <ricolin> I guess that's all from me
08:51:35 <ricolin> Anything you would like to covered in this meeting?
08:51:43 <ricolin> ianw, kevinz
08:51:56 <ianw> no
08:52:09 <ianw> thanks for all your work ricolin driving this along
08:52:10 <kevinz> that's all from my side :)
08:52:23 <kevinz> Thanks ianw ricolin
08:52:30 <ricolin> If we can have the doc, storyboard tasks, zuul job out,  will be a big success of this SIG:)
08:52:54 <ricolin> ianw, kevinz  Anytime!:)
08:53:18 <ricolin> I think we can end this meeting now:)
08:53:39 <ricolin> thanks everyone!:)
08:53:54 <ricolin> see you on storyboard!:)
08:54:03 <ricolin> ...and irc:)
08:54:05 <ricolin> #endmeeting