15:00:21 <ricolin> #startmeeting multi_arch
15:00:22 <openstack> Meeting started Tue Jan 21 15:00:21 2020 UTC and is due to finish in 60 minutes. The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'multi_arch'
15:00:32 <ricolin> #topic roll call
15:00:35 <ricolin> o/
15:00:37 <jeremyfreudberg> o/
15:00:45 <ricolin> jeremyfreudberg, o/
15:01:03 <ricolin> jeremyfreudberg, how's going!
15:01:44 <jeremyfreudberg> ricolin: all good, a little busy
15:01:47 <jeremyfreudberg> but busy can be good
15:02:18 <ricolin> true
15:02:49 <jeremyfreudberg> ricolin: do we expect anyone else at this meeting time? or is everybody attending earlier?
15:03:19 <ricolin> ianw, kevinz, and mrda joined earlier
15:03:25 <rh-jelabarre> what would the earlier time be in EST? I think 3AM?
15:03:33 <ricolin> I assume tonyb might be join this one, but not sure
15:03:44 <jeremyfreudberg> rh-jelabarre: yes, i think 3am
15:04:02 <jeremyfreudberg> ricolin: i did not hear anything specific of tony, but maybe he will join now
15:04:05 <ricolin> rh-jelabarre, Tuesday at 0800 UTC is all I know:)
15:04:24 <jeremyfreudberg> ricolin: rh-jelabarre is in my time zone (and also work with me and tony)
15:04:30 <tonyb> Oh!
15:04:32 <ricolin> appear he is traveling
15:04:37 <jeremyfreudberg> hi tonyb
15:04:42 <ricolin> there you're!
15:04:55 <tonyb> So it look slike the calendar is wrong as this is set to biweekly
15:05:08 <jeremyfreudberg> tonyb: it is biweekely, so what's the problem?
15:05:33 <tonyb> Oh nothing I'm just dense
15:05:44 <ricolin> :)
15:06:06 <ricolin> #chair ricolin tonyb
15:06:06 <openstack> Current chairs: ricolin tonyb
15:06:27 <ricolin> #topic adding items to agenda
15:06:31 <ricolin> #link https://etherpad.openstack.org/p/Multi-Arch-agenda
15:06:38 <rh-jelabarre> tonyb: I resemble that remark...
15:07:15 <ricolin> Also here's logs from earlier meeting http://eavesdrop.openstack.org/meetings/multi_arch/2020/multi_arch.2020-01-21-08.00.html
15:08:59 <ricolin> #topic Follow on Repo and StoryBoard setup
15:09:11 <ricolin> some quick paste info
15:09:12 <ricolin> Our Repo is there, but I haven't add the doc and zuul structure yet. Will do it this week.
15:09:16 <ricolin> #link https://opendev.org/openstack/multi-arch-sig
15:09:40 <ricolin> According to the plan we got from last meeting, documents will first to put in. I think that can started now, and send out once the repo structure is ready.
15:09:53 <ricolin> Also we have core reviewer list
15:09:58 <ricolin> #link https://review.opendev.org/#/admin/groups/2079,members
15:10:03 <ricolin> And I would like to suggest we add volunteers as core reviewers.
15:10:23 <ricolin> Anyone volunteer? rh-jelabarre jeremyfreudberg :)
15:10:28 <tonyb> ricolin: Works for me
15:10:34 <jeremyfreudberg> ricolin: feel free to add me as core
15:11:14 <ricolin> jeremyfreudberg, will add you later, or tonyb can add you too as he is also in the list
15:11:15 <rh-jelabarre> not sure what a core reviewer would be doing
15:11:20 <tonyb> jeremyfreudberg: done
15:11:29 <ricolin> tonyb, that's quick
15:11:37 <tonyb> rh-jelabarre: probably not a good fit then
15:11:51 <tonyb> rh-jelabarre: We can help you learn "the openstack way"
15:12:24 <ricolin> rh-jelabarre, we can definitely help you onboard:)
15:12:55 <ricolin> Our StoryBoard is created,
15:13:06 <tonyb> ricolin: you've been busy!
15:13:16 <ricolin> #link https://storyboard.openstack.org/#!/project/openstack/multi-arch-sig
15:13:31 <ricolin> tonyb, yep!:)
15:13:41 <ricolin> in the good way:)
15:14:15 <tonyb> #thanks ricolin For his awesome and rapid setup of the multi-arch-SIG
15:14:29 <ricolin> We can start add tasks in Storyboard now
15:14:33 <ricolin> tonyb, :)
15:15:01 <ricolin> So if all members can put in their current work in progress task in this story will make others easier to track. We already have some collected WIP patch recorded in https://etherpad.openstack.org/p/Multi-arch which will make sense to move to StoryBoard too.
15:15:25 <ricolin> jeremyfreudberg, also we need to add the document plan as task in Storyboard
15:16:23 <jeremyfreudberg> ricolin: yes
15:16:28 <jeremyfreudberg> i'll try to find some time
15:17:01 <ricolin> can I put an action to have you add in document tasks in storyboard?
15:17:09 <jeremyfreudberg> yup
15:17:31 <ricolin> #action jeremyfreudberg create docs plan as tasks in Storyboard
15:17:34 <ricolin> awesome:)
15:19:08 <ricolin> tonyb, I already added an action to ask everyone to put their current tasks (anything that related to Multi-arch) in storyboard if possible
15:19:38 <tonyb> ricolin: Sounds good
15:19:50 <ricolin> tonyb, cool!
15:20:04 <tonyb> ricolin: It'll be good to get that written down aso we can find ways forward
15:20:58 <ricolin> tonyb, I currently only aware of tasks that list in https://etherpad.openstack.org/p/Multi-arch
15:21:26 <ricolin> tonyb, you mean we can add those in?
15:22:31 <tonyb> ricolin: There are some ppc64le things I'm working on some of which will have arm64 work also so getting that written down and then looking for ways forward
15:23:35 <ricolin> tonyb, can you help to put those in Storyboard
15:23:57 <tonyb> ricolin: For sure
15:24:42 <ricolin> Is ppc64le generally supported in OpenStack services?
15:25:00 <ricolin> I mean core components
15:25:09 <tonyb> ricolin: Yes a lot of the work is in deployment tools
15:26:06 <tonyb> ricolin: It's "reasaonably" easy to build an all in one OpenStack (keystone, glance, swift, nova)
15:26:28 <ricolin> I learn from ianw that devstack, *might* still not working with multi-arch, that's where I wonder ppc64le will need to check as well
15:26:35 <tonyb> ricolin: I'm like 95% certain the same can be said for arm64
15:27:03 <ricolin> tonyb, good to learn that:)
15:27:10 <tonyb> ricolin: Hmm I'll check but it *used* to work, I admit I don't use it (devstack) alot
15:27:20 <tonyb> ricolin: I
15:27:30 <tonyb> ll add it do the Action Items list
15:27:49 <ricolin> ianw also take action to create a general job so we can test with it
15:28:07 <ricolin> tonyb, great to have you can join that action:)
15:28:20 <tonyb> Cool.
15:28:27 <ricolin> you can make the action your self:)
15:28:49 <tonyb> ricolin: Will do
15:29:29 <ricolin> move on:)
15:29:58 <ricolin> I think you all aware of the new irc channel :)
15:30:12 <tonyb> ++
15:30:12 <ricolin> #openstack-multi-arch
15:30:34 <ricolin> for who don't know, please join that channel:)
15:30:37 <rh-jelabarre> I am now...
15:31:06 <ricolin> rh-jelabarre, join!:)
15:31:44 <ricolin> That's all I got for SIG infra setup
15:32:20 <tonyb> ricolin: Thanks again!
15:32:31 <ricolin> tonyb rh-jelabarre jeremyfreudberg , any other infra you think we need to add?
15:33:01 <tonyb> ricolin: I want to see where we're at with arm and zuul etc but I don't know that's "setup"
15:34:26 <ricolin> That's something we need to proper tracking by storyboard task I assume
15:34:47 <ricolin> yeah, it's setup for sure:)
15:35:27 <ricolin> I will working on puting init docs and docs test in repo this week
15:36:06 <ricolin> if we plan for some new zuul job, it can defined under our repo too
15:38:23 <tonyb> ricolin: Okay cool.
15:38:26 <ricolin> tonyb, besides adding to storyboard, do you think it's helpful to have an repo on current arm status?
15:38:41 <ricolin> s/repo/report/
15:39:18 <tonyb> ricolin: Yeah I think a report would be really good
15:39:48 <tonyb> ricolin: we can probably make status.rst or sumilar in the repo to collect that information
15:40:22 <ricolin> do you have anything in you mind that the status.rst might looks like?
15:41:52 <tonyb> ricolin: Just a high level summary of what we have, what's known to work, what's known to break
15:42:06 <tonyb> ricolin: but I don't have a strong idea
15:42:31 <ricolin> tonyb, got it, let's record it with an action so we don't forgot about that idea:)
15:43:11 <tonyb> #action tonyb to create a placeholder "status.rst" for discussion
15:43:28 <ricolin> :)
15:43:58 <ricolin> thanks
15:44:15 <ricolin> move on
15:44:16 <ricolin> #topic Follow on CI Resources
15:44:32 <ricolin> For what I know mnaser mentioned that there might be some ARM resource Vexxhost can donate to community.
15:44:33 <ricolin> Also Huawei mentioned that they can donate ARM resources too. I will keep tracking with them and see if anything scheduled.
15:45:01 <ricolin> ianw mentioned from eariler meeting that the second group of node from Linaro is ready https://review.opendev.org/#/c/703535
15:45:05 <tonyb> Cool
15:45:26 <ricolin> so we now have two groups of node
15:46:51 <ricolin> maybe some other provider can help to donates too
15:47:58 <tonyb> ricolin: ideally yes
15:48:36 <ricolin> will try to contact more provider to see if they're interested
15:48:50 <ricolin> #topic Follow on documentation
15:49:09 <ricolin> jeremyfreudberg, do you have anything to update on the docs?
15:50:25 <jeremyfreudberg> ricolin: i do not have much update today. as you suggested i will make some stories for what kind of docs we want.
15:50:29 * ricolin didn't have any to update for now except will try to build the init doc infra in repo
15:50:42 <ricolin> jeremyfreudberg, thanks!
15:50:54 <ricolin> #topic open discussion
15:51:11 <ricolin> tonyb, jeremyfreudberg rh-jelabarre anything we should discuss today?
15:52:02 <jeremyfreudberg> not from me
15:52:16 <rh-jelabarre> not at present
15:52:35 <tonyb> ricolin: I don't have anything
15:52:52 <ricolin> cool
15:53:26 <ricolin> we already have a very productive starts:)
15:53:53 <ricolin> let's see what we can gather on Storyboard:)
15:54:35 <tonyb> ricolin: Cool beans
15:55:00 <ricolin> let's end this meeting, thanks all for join:)
15:55:05 <ricolin> #endmeeting