08:00:36 <ricolin> #startmeeting multi_arch
08:00:37 <openstack> Meeting started Tue Feb 18 08:00:36 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:40 <openstack> The meeting name has been set to 'multi_arch'
08:00:49 <ricolin> #topic roll call
08:00:53 <ricolin> o/
08:01:11 <ianw> o/
08:01:23 <kevinz> o/
08:01:35 <ricolin> hi ianw kevinz :)
08:02:03 <kevinz> Hi ricolin
08:02:39 <ricolin> how's everything for you guys:)
08:03:34 <ianw> not bad!
08:03:34 <ricolin> #topic adding items to agenda
08:03:39 <ricolin> #link https://etherpad.openstack.org/p/Multi-Arch-agenda
08:03:48 <kevinz> fine! just staying at home, working, could not go outside
08:04:10 <ricolin> kevinz, which city you live in?
08:04:46 <kevinz> Shanghai, we are not "encouraged" to go outside, but not restricted
08:05:04 <ianw> oh dear, stay well!
08:05:46 <ricolin> yeah, stay well!
08:05:48 <kevinz> Thanks :-) just go for supermarket once a week
08:05:51 <ricolin> stay home
08:06:07 <kevinz> 😂
08:06:19 <ricolin> hope it will release before next month
08:06:38 <kevinz> yeah, I hope so
08:07:10 <kevinz> Just a quick update about CI, thx for ianw strong support and help, the nodes there are running
08:07:29 <ricolin> #topic Follow on CI Resources
08:07:39 <ricolin> kevinz, it's yours
08:07:55 <kevinz> next I will talking with Nova team this week in their meeting, to define the jobs that need to run on Arm64
08:08:05 <ricolin> #link https://storyboard.openstack.org/#!/story/2007196
08:08:13 <ricolin> so this is all resolved?
08:08:30 <ricolin> sorry not that one
08:08:48 <ricolin> #link https://storyboard.openstack.org/#!/story/2007195
08:08:51 <ricolin> this
08:09:28 <kevinz> yes, except one network issue, we have a workaround now
08:09:38 <ricolin> "nb03.openstack.org communication to us.linaro.cloud:5000   "
08:09:45 <ricolin> this one?
08:10:05 <kevinz> yes
08:10:17 <ianw> yeah, we moved the builder .. i'm not sure that's resolved as such, but we have worked around it
08:10:18 <kevinz> we don't need to fix it right now
08:11:32 <ricolin> then it is running:)
08:11:59 <kevinz> yeah
08:12:17 <kevinz> one question, what do we need to do with devstack?
08:12:42 <kevinz> I guess it is a dependency for Nova CI?
08:12:45 <ianw> oh, i think i had something to start a job and see what happened with that
08:13:03 <ricolin> ianw, yes
08:13:30 <kevinz> cool, devstack on arm64 I've ran for several times, generally it works
08:13:33 <ricolin> kevinz, for now, it's to start devstack job and see how everything goes
08:14:02 <kevinz> yes, we can see the devstack jobs status on arm64
08:14:15 <ricolin> once we have that job, we can start to think what else teat we can added on
08:14:48 <ricolin> I think it will be nice if we have job for test on core services
08:15:05 <ricolin> periodically maybe
08:15:52 <ricolin> kevinz, you mentioned about Nova CI, what about it?
08:15:58 <ianw> ok, give me a minute and i might have a template up
08:15:58 <kevinz> devstack/nova/neutron/cinder at the begining
08:16:08 <kevinz> ianw: great!
08:16:24 * ricolin is now counting!
08:17:11 <ricolin> kevinz, yeah, also swift, glance, etc
08:17:17 <kevinz> ricolin: talk with Nova team to enable CI for Nova first. Since Nova has many jobs to run, we need to sort out what are the essential jobs should run on arm64
08:17:54 <kevinz> will sync about this with nova team at Nova meeting on this Thursday
08:18:15 <ricolin> do you think it can be a gate job for Nova?
08:18:21 <kevinz> https://review.opendev.org/#/c/708102/ now just run 2
08:18:25 <kevinz> 2 jobs
08:18:48 <ricolin> I wonder if we have enough arm node to run for every patch :/
08:18:59 <kevinz> ricolin: hopefully, but we need to have standby jobs first
08:19:04 <ianw> #link https://review.opendev.org/#/c/708317/
08:19:11 <ianw> ^ that at least defines the job
08:19:25 <ianw> i won't have much time to debug it but anyone feel free to update
08:19:53 <kevinz> ianw: cool, I will check :-)
08:20:02 <ricolin> ianw, FAST!!
08:20:30 <ianw> it's just the job, if it works is another thing all together :)
08:20:33 <kevinz> Not sure the how much resources are needed for nova gating.
08:21:25 <ricolin> the number of patch might be huge, so we need to figure that out from Nova team too I think
08:21:30 <ianw> i think you can probably also point out if they use the check-arm64 queue to start with, they get results but it doesn't hold up their gate
08:21:53 <ianw> after a while they can decide to move it into the main gate if everything is good
08:22:07 <kevinz> yes, we can keep check-arm64 as the first step
08:23:49 <ricolin> ianw, +1
08:24:22 <kevinz> +2
08:25:12 <ricolin> kevinz, so you plan to join Nova meeting for that plan?
08:25:44 <kevinz> yes, this Thursday night
08:26:01 <ricolin> #action kevinz will join Nova meeting for discuss about https://review.opendev.org/#/c/708102/
08:26:07 <ricolin> kevinz, thanks
08:26:16 <kevinz> my pleasure
08:27:35 <ricolin> From my side, I just add new story for OpenStack multi-arch on k8s cloud provider
08:27:37 <ricolin> #link https://storyboard.openstack.org/#!/story/2007303
08:27:52 <ricolin> The patch is already out there waiting review
08:29:05 <kevinz> cool, we are also working on cloud provider validation
08:29:11 <kevinz> ricolin, thx
08:29:28 <ricolin> I assume that's all for CI resource topic
08:29:55 <ricolin> will see how's the devtack job goes and how's feedback from Nova team
08:30:06 <ricolin> Anything we missed?
08:30:22 <kevinz> that's all from my side
08:31:22 <ricolin> #topic Follow on Repo and StoryBoard setup
08:31:40 <ricolin> The init patch is out. (https://storyboard.openstack.org/#!/story/2007257 )
08:31:42 <ricolin> #link https://review.opendev.org/#/c/708057/
08:32:05 <ricolin> sorry to keep it that long:)
08:32:54 <ricolin> I assume that's all we need to build for docs story can start
08:32:59 <ricolin> #link https://storyboard.openstack.org/#!/story/2007253
08:33:38 <ricolin> also we can use this repo to keep multi-arch zuul jobs too
08:34:06 <ricolin> or define any playbook resources
08:34:41 <kevinz> \o/
08:34:41 <ricolin> And speak of repo and review
08:34:55 <ricolin> kevinz, do you like to join the core reviewer list?:)
08:35:03 <ricolin> #link https://review.opendev.org/#/admin/groups/2079,members
08:35:24 <kevinz> ricolin: yes I'm happy to join
08:35:47 <ricolin> kevinz, kevin zhao@linaro.org is this the mail for your gerrit?
08:36:08 <ricolin> kevin.zhao@linaro.org
08:36:14 <kevinz> definitely
08:36:55 <ricolin> done
08:37:05 <kevinz> thanks
08:37:18 <ricolin> now go review that patch!!
08:37:20 <ricolin> lol
08:37:43 <kevinz> np!
08:38:01 <ricolin> Regarding of Storyboard
08:38:28 <ricolin> stories start to put in
08:38:45 <ianw> (devstack job is running @ http://zuul.openstack.org/stream/78f158d215e84ecb9cd2a3f45c773cf0?logfile=console.log)
08:39:15 <ricolin> we still missing some current under working stuff though
08:39:41 <ricolin> ianw, cheers!
08:40:25 <kevinz> cheers!
08:41:33 <ricolin> #topic Open discussion
08:42:29 <ricolin> Anything else?:)
08:42:55 <ianw> not from me, i have to head off now
08:43:07 <kevinz> me too
08:43:09 <ricolin> ianw, thanks!
08:43:36 <ricolin> Okay, thanks for both of you to join:) kevinz ianw
08:43:44 <ricolin> let's end this meeting:)
08:43:51 <ricolin> #endmeeting