08:01:17 <ricolin> #startmeeting multi_arch
08:01:18 <openstack> Meeting started Tue Mar  3 08:01:17 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:21 <openstack> The meeting name has been set to 'multi_arch'
08:01:29 <ricolin> #topic roll call
08:01:33 <ricolin> o/
08:03:23 * ricolin 's schedule is really a mess due to COVID-19 :(
08:03:24 <tonyb> \o
08:03:45 <ricolin> hi tonyb!
08:03:52 <tonyb> ricolin: howdy!
08:04:10 <tonyb> ricolin: I can only imagine what kinda of mess it's make
08:04:56 <ricolin> My honeymoon is scheduled from end of March to April
08:05:05 <tonyb> eeeek
08:05:39 <ricolin> try to see if I can reschedule or get refund of part of the trip:(
08:06:24 <ricolin> tonyb, how's everything for you!
08:06:47 <tonyb> ricolin: All good, pretty normal really busy etc etc
08:07:44 <tonyb> And you?   (apart from COVID-19)
08:08:07 <ricolin> All good!
08:08:15 <tonyb> ricolin: good
08:08:16 <ricolin> (apart from COVID-19)
08:08:18 <ricolin> lol
08:08:22 <tonyb> hehe
08:09:07 <ricolin> tonyb, FYI, I response to the survey for Vancouver summit to ask to reserve a small room
08:09:36 <ricolin> Are you plan to be there this time?
08:09:40 <tonyb> ricolin: good idea
08:09:46 <tonyb> ricolin: That's the plan
08:10:09 <tonyb> ricolin: It'll come down to govt's and travel restrictions
08:11:51 <ricolin> okay, we can count few weeks before summit while we try to figure out what we should discuss/workon during summit:)
08:12:09 <ricolin> *counting who will going
08:12:19 <tonyb> ricolin: Yup
08:12:24 <ricolin> s/going/go/ :)
08:13:19 <ricolin> #topic Follow on CI Resources
08:14:03 * tonyb doesn't really have anything ... I'd be happy to use any that exist ;P
08:14:30 <ricolin> Something on CI tasks worth to be mentioned. like kevinz has been working on Nova support for Armhttps://storyboard.openstack.org/#!/story/2007314
08:14:37 <ricolin> #link https://storyboard.openstack.org/#!/story/2007314
08:15:20 <ricolin> And also ianw and kevinz starts devstack support CI job too
08:15:20 <tonyb> Ahh interesting
08:15:23 <ricolin> #link https://storyboard.openstack.org/#!/story/2007196
08:15:30 <ricolin> both under WIP
08:15:59 <tonyb> obviously it "just works" but we need to "tick the boxes" and do it right
08:16:59 <ricolin> tonyb, yeah, we can use some list for that
08:17:09 <tonyb> ricolin: Yup
08:17:47 <ricolin> right now it's more like we have a fail job, and we start to checking which part of devstack is not supported
08:18:09 <ricolin> tonyb, any idea how to make that list?
08:19:02 <tonyb> ricolin: Not really ... I think you're on the right track
08:19:20 <tonyb> ricolin: we'll probbaly make it harder than it needs to be the first time but it'll get easier
08:20:36 <ricolin> I get what you mean
08:20:40 <ricolin> and +1 for that
08:20:59 <tonyb> ricolin: The first time is alwasy hard ;p
08:21:33 <ricolin> once the base devstack job is done, I assume we can do more crazy idea brainstorm:)
08:21:53 <tonyb> ricolin: Yeah.
08:22:09 <tonyb> ricolin: I assume we have simple tox jobs running in arm64
08:23:30 <ricolin> tonyb, you mean like py37/pep8 check?
08:23:40 <tonyb> ricolin: yeah
08:24:09 <ricolin> we can actually start that part right away, isn't it!?:)
08:25:20 <tonyb> ricolin: yeah I'd think so
08:25:44 <ricolin> that sounds like a good action
08:26:14 <tonyb> ricolin: cool
08:26:39 <tonyb> someone that knows the infra / zuul setup shoudl be able to get it going *reasonably* easily
08:26:50 <ricolin> #action (not assigned yet) working on basic tox support for arm64
08:26:50 <kevinz> o/
08:26:55 <ricolin> hi kevinz
08:27:02 <kevinz> sorry I missed the meeting
08:27:10 <tonyb> and will probbaly need soem requirements and infra stuff to get wheels etc in the AFS mirrors
08:27:24 <tonyb> kevinz: Hey there!
08:27:40 <kevinz> Now I was blocked by some tempest test in Devstack side
08:28:00 <kevinz> hey tonyb
08:28:15 <tonyb> kevinz: Oh cool, that implies we already have the infra side done
08:28:34 <ricolin> kevinz, I can help to check later
08:28:56 <kevinz> I assume some of the test was related with Nova side, may be  some functions are not supported on arm64, such as vm shelves
08:29:02 <kevinz> ricolin: cool, thx
08:29:28 <tonyb> kevinz: Yeah that's probably reasonable
08:29:30 <ricolin> tonyb, I think ianw might be able to help on infra, will ask him:)
08:29:53 <kevinz> http://paste.openstack.org/show/790232/ record all the failing test here
08:30:32 <kevinz> some of them are related with configuration, some of them related with Nova are worthy checking
08:31:43 <tonyb> ricolin: Yeah ianw would be a good choice if he's free, he knows how to reach me if he needs anything from requirements/releases
08:32:18 <ricolin> kevinz, is there anyone working on `provide support matrix for Nova` task?
08:34:06 <kevinz> I remember hrw worked on that before
08:34:35 <kevinz> may be 1 or 2 years ago, after that we don't work on it.
08:35:03 <kevinz> But I think it's time to work on this now
08:35:20 <ricolin> kevinz, yeah, I do saw arm64 on that matrix, just wonder how many of them are still valid
08:35:54 <kevinz> yes, I will co-work with xinliang may be to get this work
08:35:58 <ricolin> tonyb, will ping ianw to see if he got any idea:)
08:36:10 <ricolin> kevinz, that's great!
08:36:33 <tonyb> the matrix *should* be pretty quick to test if you have a test cloud you can run them on
08:36:35 <kevinz> :D, Nova is the first step
08:36:58 <tonyb> lots of items have a (nova) CLI to run/test with
08:37:00 <kevinz> tonyb: yes, we are now using the Linaro-us to test it
08:37:35 <tonyb> ..... oooh I see lots of this wrong with the "ppc64" entry
08:37:56 <tonyb> #action tonyb to update the nova support matrix for ppc64
08:38:03 <tonyb> kevinz: great :)
08:38:10 <ricolin> which might indicate what ever comes out for the Nova tests from the devstack job is what we need to put in to that matrix:)
08:38:17 <ricolin> thx tonyb
08:39:18 <ricolin> besides tox and devstack arm support, I'm working on provide multi-arch for container image too, right now WIP for heat-agent and k8s/openstack-cloud-provider
08:39:44 <tonyb> ricolin: nice
08:40:11 <ricolin> which k8s/openstack-cloud-provider looks pretty promising to land
08:40:12 <tonyb> ricolin: FWIW we're also working with tripleo/RDO to do the same for ppc64le
08:40:21 <ricolin> #link https://github.com/kubernetes/cloud-provider-openstack/pull/910
08:40:41 <ricolin> tonyb, I assume it will be the same process?
08:41:04 <ricolin> just way more complex since it's tripleO :D
08:41:14 <tonyb> ricolin: ;P
08:41:42 <tonyb> similar process yes and very complex to build/ publish and CI multiarch containers
08:42:24 <ricolin> tonyb, so can we assume once ppc64 is supported for tripleO/RDO image, arm should be as well?
08:43:20 <tonyb> ricolin: sadly no , but we'll know how to do it and we can (not spoeaking for the tripleo team) almost certianly make it happen but it will be an additiona effort not "for free"
08:43:58 <tonyb> ricolin: as long as we can run a builder and CI the containers on arm64 it shoudl be doable
08:44:28 <ricolin> tonyb, okay, if there's any docs or links generated for that task, I would like to make some learning from it:)
08:44:57 <tonyb> ricolin: I'll try to find them ... it's been a long process (started in SnopenStack)
08:45:08 <ricolin> wow
08:45:30 <ricolin> just share when you happen to find some:)
08:45:36 <tonyb> ricolin: will do
08:45:46 <ricolin> or link it in multi-arch SIG storyboard:)
08:45:51 <tonyb> :)
08:46:17 <ricolin> I assume those are actions/WIP regarding CIs
08:46:53 <ricolin> #topic open discussion
08:47:12 <ricolin> tonyb, kevinz anything we should discuss today?
08:47:22 <kevinz> all from me
08:47:28 <kevinz> thx tonyb ricolin
08:47:31 <tonyb> Nope I'm good
08:47:47 <tonyb> kevinz, ricolin: Thanks!
08:48:01 <ricolin> okay, let's not take all your time and keep the Earth rolling!
08:48:05 <ricolin> thanks tonyb kevinz
08:48:09 <ricolin> #endmeeting