08:00:17 <ricolin> #startmeeting multi_arch
08:00:17 <openstack> Meeting started Tue Apr 28 08:00:17 2020 UTC and is due to finish in 60 minutes. The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:20 <openstack> The meeting name has been set to 'multi_arch'
08:00:25 <ricolin> #topic roll call
08:00:30 <ricolin> o/
08:01:30 <mrda> o/
08:01:38 <ricolin> hi mrda :)
08:01:54 <mrda> hey ricolin - I've been quite forgetful recently.
08:02:28 <tonyb> \o
08:02:35 <ricolin> mrda, NP
08:02:40 <ricolin> hi tonyb :)
08:02:47 <tonyb> Sorry notifications didn't fire
08:03:03 <tonyb> ricolin: hello there
08:03:36 <ricolin> tonyb, don't worry, that happens to me last time!:)
08:03:50 <tonyb> hehe
08:04:26 <ricolin> #topic VPTG planning
08:04:42 <ricolin> #link https://ethercalc.openstack.org/126u8ek25noy
08:04:57 <ricolin> I put our schedule under room #Mitaka
08:05:16 <ricolin> currently
08:05:18 <ricolin> Tuesday 0600-0800 UTC @ Mitaka
08:05:18 <ricolin> Thursday 0600-0800 UTC @ Mitaka
08:05:25 <ricolin> Will that works?
08:05:56 <tonyb> Works for me (assuming I can math ;P)
08:06:31 <mrda> ricolin: yep, that's good for our side of the world
08:06:35 <ricolin> We can also host another time slide, but I'm not able to run it
08:06:52 <ricolin> I mean 2100-0000 UTC time
08:07:25 <tonyb> Perhaps someon from the "earlier" meeting can host that session?
08:08:06 <ricolin> around 1500 UTC you mean?
08:08:16 * mrda looks for jeremyfreudberg
08:08:55 <tonyb> Yeah jeremyfreudberg would be my pick but I don't want to voluntell him ;P
08:09:00 <tonyb> ricolin: I think that's right
08:09:28 <mrda> Well, just suggestionating
08:09:55 <ricolin> added Tuesday 15-17 UTC
08:10:05 <ricolin> same in room Mitaka
08:10:25 <tonyb> Sounds good
08:11:27 <ricolin> #link https://etherpad.opendev.org/p/Multi-arch-2020-VPTG
08:11:38 <ricolin> Just create etherpad for it
08:12:04 <ricolin> Please start to put in topic so we can do pre-work:)
08:13:01 * tonyb promises to try
08:13:39 <ricolin> tonyb, :)
08:14:28 <ricolin> I assume we should keep dive in current WIP/Planning topics in VPTG
08:14:46 <ricolin> And add BoF/Feedback session
08:14:56 <ricolin> I will put in above topics
08:15:28 <mrda> Sounds good.
08:16:07 <ricolin> #action all members please add topic suggestion for VPTG in https://etherpad.opendev.org/p/Multi-arch-2020-VPTG
08:16:51 <ricolin> #topic CI resources
08:17:12 <ricolin> #link https://review.opendev.org/#/c/708317/
08:17:33 <ricolin> devstack support is still under progress
08:17:50 <ricolin> thx to kevinz and ianw
08:18:39 <ricolin> I only see IPV6 tests failing mostly
08:19:26 <tonyb> That's pretty cool for lost of reasons
08:19:40 <ricolin> tonyb, yeah
08:20:12 <ricolin> can't wait to see it all green:)
08:20:22 <tonyb> \o/
08:20:31 <mrda> It's a great amount of effort put it to get it so far - well done!
08:20:51 <ricolin> yeah, thanks to kevinz and ianw again!:)
08:21:03 <mrda> +1
08:21:22 <ricolin> for what I know, they been also working on adjust the ARM host environment too
08:21:52 <ricolin> so works under the table too
08:22:45 <ricolin> For CI resources, no other company response back about resource donation
08:22:53 <ricolin> I will keep following on that
08:23:12 <ricolin> #action ricolin keep in touch with possible CI resource provider
08:23:25 <mrda> thanks ricolin
08:23:34 <ricolin> That's all I have for CI resources
08:23:58 <ricolin> mrda, tonyb any other things to share:)
08:24:53 <mrda> umm, not directly relevant. Just working on ensuring ppc64le tripleo behaves.
08:24:57 <tonyb> Nope
08:25:23 <ricolin> mrda, how about that part:)
08:25:42 * tonyb is lost in a quagmire of OpenStack and k8s and ppc64le
08:26:21 <ricolin> haha
08:26:36 <mrda> Umm, so testing out a simplified undercloud, using metalsmith instead of Nova/Glance. It's going ok :)
08:26:53 <ricolin> tonyb, any chance using kubernetes/cloud-provider-openstack?
08:27:09 <tonyb> ricolin: Yes but not this month ;P
08:28:12 <ricolin> tonyb, the current kubernetes/cloud-provider-openstack can using make scripts to build multi-arch container
08:28:41 <ricolin> you can test it if happen needs to
08:29:05 <tonyb> ricolin: I will be happy to, and it's on my todo list
08:29:19 <ricolin> tonyb, :)
08:29:55 <ricolin> mrda, I'm also using metalsmith as implementation for Heat Ironic resource types, but that's another story:)
08:30:07 <mrda> oh cool, ricolin
08:30:13 <ianw> o/ sorry late ...
08:30:19 <mrda> hey ianw
08:30:42 <ricolin> ianw, yeah, you just missed all the compliment!!
08:31:14 <ianw> heh all kevinz really
08:32:17 <ricolin> Any clue about what's wrong with IPV6 tests?
08:32:21 <ricolin> ianw, ^^^
08:32:52 <ianw> not at the moment sorry, i haven't looked into it too much
08:33:24 <ricolin> NP, will see if kevinz can provide more WIP information:)
08:33:52 <ricolin> #topic open discussion
08:34:02 <ricolin> tonyb, ^^^
08:34:17 <ricolin> you will like to switch the meeting time?
08:35:11 <tonyb> Yeah so ... 1800 is dinner time in my house
08:35:35 <tonyb> is there any chance we can move the meeting back 60mins
08:35:50 <tonyb> (or forward 60 and make it a 30min meeting) ?
08:35:52 <mrda> earlier or later?
08:36:16 <tonyb> It's currently 0800 UTC
08:36:47 <tonyb> so either move it to 0700 UTC (and make it 30mins) or move it to 0900 UTC
08:37:08 <ricolin> mrda, ianw tonyb what about 0700 UTC?
08:37:18 <ricolin> Wait
08:37:20 <ricolin> sorry
08:37:25 <ricolin> I mean
08:37:28 <ricolin> 0900
08:38:02 <tonyb> 0900 UTC works for me but I really don't want to mess up someone else's family routine ...
08:38:07 <ianw> i think that makes it 7pm here, agree probably then and maybe we can allocate 30 minutes usually
08:38:29 * ricolin is fine either way:)
08:38:29 <mrda> My preference would be 0700., but I'm happy to fit in with others
08:38:43 <ianw> i wouldn't want too much later as infra meeting is 5am next day :)
08:38:52 <ricolin> sounds like 0700 works here
08:39:38 <ricolin> we can do meeting in around 30 mins :)
08:39:51 <ricolin> We don't need a hole hours anyway
08:39:57 <ricolin> *hour
08:40:29 <ricolin> tonyb, can you propose the patch to irc-meeting repo?;)
08:41:01 <tonyb> ricolin: I can .. but then I can't approve it ;P
08:41:08 <tonyb> but I'll do it tomorrow
08:41:13 <ricolin> oh!
08:41:20 <ricolin> I will do the patch:)
08:41:25 <tonyb> ttx is very good about approving them
08:41:45 <ricolin> NP, I can do it:)
08:42:12 <ricolin> #action ricolin propose to move meeting time to 0700 UTC at same place
08:42:16 <mrda> thanks ricolin
08:42:29 <ricolin> I think that's all for today?:)
08:42:44 <mrda> Cool, dinner time :)
08:42:47 <ricolin> ianw, in case you missed it
08:42:48 <ricolin> https://etherpad.opendev.org/p/Multi-arch-2020-VPTG
08:42:50 <ianw> i just wanted to mention that we got centos 8 arm nodes up during the week
08:42:57 <ricolin> V PTG planning
08:43:09 <mrda> nice, ianw!
08:43:17 <ricolin> sweet
08:43:26 <ricolin> how many of them?
08:43:31 <ianw> hrw did the leg work, then testing worked out pretty easy! (surprisingly easy even :)
08:43:36 <ianw> ricolin: as many as you want
08:43:40 <ianw> :)\
08:43:42 <ricolin> :)
08:43:47 <tonyb> \o/
08:43:56 <ianw> also, mordred is working on getting arm64 container builds for zuul/nodepool/etc
08:43:59 * ricolin crazy ideas keep popping out
08:45:06 <ricolin> all the good news:)
08:45:13 <ianw> #link https://review.opendev.org/#/c/722140/
08:45:29 <ianw> there's a couple of other changes floating out there, but that's the idea
08:45:48 <ianw> this will be to replace the builder that builds dib images with a containerised version
08:46:24 <ianw> i think this *will* happen, because it's really driven by updating zookeeper to run TLS across all the zuul/nodepool bits
08:46:55 <ianw> the containers are being updated to do this, and nobody wants to update the old deployment mechanisms as well :)
08:47:09 <ricolin> indeed
08:47:34 <ianw> so there's people motivated to work on it :)
08:47:43 <ricolin> talking about container image support
08:47:58 <ricolin> I'm also working on provide multi-arch container support for heat-agents, but that needs some more discussion I guess https://review.opendev.org/#/c/710482/
08:47:59 <ianw> but, i imagine once infra has that templated out it will fit almost anywhere else that wants arm64 container images
08:48:20 <ricolin> Once it merged, magnum can directly using it
08:48:49 <ricolin> ianw, that sounds like some nice goal for Victoria?
08:49:40 <ianw> ricolin: definitely ping mordred i'd say
08:49:42 <ianw> #link https://review.opendev.org/#/c/722339/
08:49:56 <ianw> was the other one i was thinking of, using docker buildx
08:50:17 <ricolin> yeah, that one was discussed month ago
08:50:37 <ricolin> thanks mordred
08:51:28 <ricolin> ianw, thanks for sharing:)
08:52:43 <ricolin> ianw, mrda tonyb anything else?:)
08:53:02 <tonyb> Not from me
08:53:09 <ianw> that's about it for me. i'll get to focal for arm64 soon in infra as well
08:53:11 * ricolin got to remember to talk with mordred
08:53:14 <tonyb> I'me trying to digest all that zuul container work
08:53:47 <ricolin> thanks tonyb ianw :)
08:53:55 <ianw> tonyb: it's magic but works pretty well; give me a ping tomorrow and i can run you through the 5 minute version if you like
08:54:09 <mrda> Thanks everyone
08:54:21 <ianw> tonyb: actually, 20 minute probably :)
08:54:27 <ianw> cheers, ttyl
08:54:32 <ricolin> thanks mrda tonyb ianw for join this meeting, let's ended it:)
08:54:47 <ricolin> #endmeeting