15:00:24 <ricolin> #startmeeting multi_arch
15:00:25 <openstack> Meeting started Tue Aug  4 15:00:24 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <openstack> The meeting name has been set to 'multi_arch'
15:00:32 <ricolin> #topic roll call
15:00:35 <ricolin> o/
15:00:50 <jeremyfreudberg> o/
15:01:00 <ricolin> hi jeremyfreudberg :)
15:01:41 <jeremyfreudberg> hi ricolin !
15:02:12 <ricolin> btw, can you fix the doc patch so we can land it
15:02:35 <ricolin> just a typo:)
15:03:18 <ricolin> https://review.opendev.org/#/c/733192/1/doc/source/what-is-multiarch.rst
15:03:18 <patchbot> patch 733192 - multi-arch-sig - Make some simple doc enhancements - 1 patch set
15:04:32 <jeremyfreudberg> ricolin: done!
15:04:57 <ricolin> and landing
15:05:25 <ricolin> #topic unit test support
15:05:41 <ricolin> #link https://review.opendev.org/#/q/topic:multi-arch-arm64-unittests+(status:open+OR+status:merged)
15:06:01 <ricolin> I start to put in a job for arm64 UT support
15:06:39 <ricolin> Which currently run a none voting py38 job on ubuntu
15:06:55 <jeremyfreudberg> ricolin:do you know why the unittests are slower on arm? for example https://review.opendev.org/#/c/742096/
15:06:55 <patchbot> patch 742096 - keystone - [TEST][DNM] Validate ARM64 Unittests - 1 patch set
15:07:10 <ricolin> I don't know actually
15:08:08 <jeremyfreudberg> it seems only for some projects arm is slower
15:08:21 <ricolin> I move the timeout to 3600 to avoid that, but will be great if we can find out the root cause
15:08:57 <ricolin> one interesting question I'm trying to find out now is, is current wheels build package for arm64?
15:09:12 <jeremyfreudberg> this error is interesting https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_986/742094/1/check/openstack-tox-py38-arm64/986e442/testr_results.html
15:10:26 <ricolin> I think that one is because the default setting in that test is not support in arm64 env
15:11:00 <ricolin> so the actual result is different between arm and x86 in this case
15:11:07 <jeremyfreudberg> yup
15:11:38 <ricolin> which we should remember to send a update to nova test to fix that :)
15:11:51 <ricolin> jeremyfreudberg, nice catch
15:12:00 <jeremyfreudberg> yeah
15:13:50 <ricolin> any idea how we can keep pushing the UT job forward?
15:16:04 <ricolin> jeremyfreudberg, ^^^
15:16:21 <ricolin> rh-jelabarre, TrevorV ^^^
15:16:57 <jeremyfreudberg> ricolin: what are we stuck on exactly?
15:17:57 <ricolin> I assume that job will land soon, but what will be the next step after that?
15:19:09 <jeremyfreudberg> more projects?
15:19:24 <ricolin> jeremyfreudberg, any suggest scope for that?
15:20:22 <rh-jelabarre> I've been limiting my tests to ones that seemed relevant to Compute on Power (eventually add Controller when we start testing with Power-based controllers)
15:20:50 <rh-jelabarre> right now I have hardware down, so I'm limited on the configurations I can run
15:21:24 <jeremyfreudberg> ricolin: how much arm capacity is available? can we only run unit tests or can we do other tests?
15:23:37 * ricolin try to find out the size of nodes we have for arm64-check
15:24:23 <ricolin> I think we can run unit test
15:25:23 <ricolin> We can also try to run some set of functional test
15:26:35 <ricolin> But I don't think we have the capacity to run all functional test job for each patch set for all core projects
15:28:40 <jeremyfreudberg> i think it would be good to run some functional tests
15:28:45 <jeremyfreudberg> i will think about it some more
15:28:57 <ricolin> jeremyfreudberg, thanks
15:29:19 <ricolin> I will spend time to check on wheels part
15:29:26 <jeremyfreudberg> cool
15:30:40 <ricolin> I also got concerns about the stable for the arm64 UT job
15:31:40 <ricolin> But I assume we can only find out after the non-voting job runs good amount of times
15:31:46 <jeremyfreudberg> yeah
15:35:10 <ricolin> Okay that's all from my part, any other update to share or discuss?:)
15:36:28 <jeremyfreudberg> ricolin: summit?
15:37:40 <ricolin> jeremyfreudberg, right!
15:39:14 <ricolin> the nearest deadline for summit is CFP which will ended within a day
15:39:31 <ricolin> less than 15 hours I think
15:39:36 <jeremyfreudberg> approx 15 hours
15:40:44 <ricolin> I'm thinking to propose a talk to share about multi-arch SIG status and share current status for multi-arch support in OpenStack
15:41:10 <ricolin> It will be great if anyone like to share that talk with me:)
15:42:57 <jeremyfreudberg> i think it is a good idea to propose a talk
15:43:14 <jeremyfreudberg> would we have a forum session also, like in shanghai?
15:43:28 <ricolin> PTG is great, but it somehow not that friendly for SIG which require dev+ops+users
15:44:00 <ricolin> jeremyfreudberg, I didn't get any information about forum yet
15:44:24 <jeremyfreudberg> ricolin:yeah it is too early for forum information
15:44:39 <jeremyfreudberg> but i just wanted to remind that forum is also a possibility
15:45:14 <ricolin> jeremyfreudberg, any specific topic for forum in your mind?
15:45:24 <ricolin> or like BoF still
15:45:31 <ricolin> s/still/style/
15:46:02 <jeremyfreudberg> BoF is okay, maybe we could specifically focus on usecases
15:46:59 <ricolin> good idea
15:49:09 <jeremyfreudberg> ricolin: so will you submit a talk? about sig status?
15:49:21 <ricolin> jeremyfreudberg, yes I think I will
15:49:41 <jeremyfreudberg> that's great
15:49:46 <jeremyfreudberg> thanks for doing that
15:49:54 <ricolin> I think it's a good way to further expose this SIG
15:50:19 <ricolin> And will be even better that if we can have forum too
15:50:30 <jeremyfreudberg> yes
15:51:40 <jeremyfreudberg> ricolin: if you want, you can add me as co-speaker
15:51:49 <ricolin> #action all please help to provide summit idea if you got any
15:52:00 <ricolin> jeremyfreudberg, that's great!:)
15:52:46 <ricolin> I definitely would like that!
15:52:51 <jeremyfreudberg> cool
15:53:57 <ricolin> Will send the talk my tomorrow
15:54:10 <jeremyfreudberg> cool
15:54:19 <jeremyfreudberg> ok, i guess we can close the meeting if there is nothing else
15:54:25 <ricolin> yes
15:54:33 <ricolin> none from me now
15:54:48 <ricolin> Thanks for join!
15:54:52 <jeremyfreudberg> thank you!
15:54:54 <jeremyfreudberg> bye
15:54:54 <ricolin> #endmeeting