17:01:04 <dnosovitsky> #startmeeting Murano
17:01:05 <openstack> Meeting started Mon May 27 17:01:04 2013 UTC. The chair is dnosovitsky. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:08 <openstack> The meeting name has been set to 'murano'
17:01:23 <dnosovitsky> Hello everyone
17:01:38 <dnosovitsky> #topic Agenda
17:01:47 <dnosovitsky> Our today's topics:
17:01:51 <dnosovitsky> 1) Murano release code freeze
17:01:57 <dnosovitsky> 2) Release management
17:02:05 <dnosovitsky> Let's start with the easy one:
17:02:08 <dnosovitsky> #topic Code freeze
17:02:31 <dnosovitsky> As far as I know, all features are ready, and we can make a release branch
17:03:24 <dnosovitsky> #info May 28 is going to be Phase I release feature freeze
17:03:34 <dnosovitsky> Let me clarify:
17:03:58 <dnosovitsky> #info our feature freeze just means creating a release branch.
17:04:46 <dnosovitsky> Our master branch will continue on receiving commits,
17:04:58 <dnosovitsky> but our release branch will be open for no development except bugfixing
17:05:33 <dnosovitsky> When we have tested and have proven it to be stable, we release this frozen branch
17:05:46 <dnosovitsky> Questions?
17:05:57 <dnosovitsky> If no, let me go on
17:06:24 <dnosovitsky> #topic Release management
17:06:48 <dnosovitsky> The important question is our release naming scheme
17:07:26 <dnosovitsky> Let me suggest the the following release naming scheme:
17:07:51 <dnosovitsky> <Phase>.<Iteration>[.<bug-fix>.<build>]
17:08:15 <dnosovitsky> Numbering starts with zero
17:09:37 <dnosovitsky> if everyone is ok with my suggestion, our current release will be be 0.6
17:11:50 <dnosovitsky> Regarding our code branch name, I suggest "Release 0-6"
17:12:00 <dnosovitsky> correspondingly
17:12:02 <gokrokve_> Why not to use just release version?
17:12:32 <gokrokve_> major.minor
17:12:53 <dnosovitsky> you mean in the branch name? To make it clear what this branch is about
17:13:00 <gokrokve_> iteration is something internal. Why it should be in the release version?
17:13:22 <gokrokve_> Release-0.1
17:13:27 <gokrokve_> or just 0.1
17:14:02 <dnosovitsky> yes, it is ok to name it 0.1
17:14:19 <dnosovitsky> Release-0.1, I mean
17:15:31 <dnosovitsky> #agreed Suggested branch name for tomorrow: Release 0.1
17:16:11 <dnosovitsky> #topic Misc
17:16:18 <dnosovitsky> Any questions?
17:16:31 <dnosovitsky> Suggestions?
17:17:12 <dnosovitsky> I think that's all for today
17:17:21 <dnosovitsky> Thanks to everyone
17:17:40 <dnosovitsky> #endmeeting