17:00:20 <sergmelikyan> #startmeeting murano
17:00:21 <openstack> Meeting started Mon Jul  1 17:00:20 2013 UTC.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:24 <openstack> The meeting name has been set to 'murano'
17:00:41 <sergmelikyan> #topic Planning 0.2
17:01:10 <sergmelikyan> We have only one major topic in today's agenda, planning of release 0.2
17:01:32 <Ekaterina_F> Hello all
17:02:11 <dkoryavov> Hi
17:03:15 <sergmelikyan> Some major features for new release already added to blueprints for release-0.2
17:03:45 <sergmelikyan> And available here: https://blueprints.launchpad.net/murano
17:04:39 <sergmelikyan> I had added blueprint about API https://blueprints.launchpad.net/murano/+spec/api-v0.2
17:05:21 <sergmelikyan> We need this in release 0.2  to minimization transition to next release, with extended support for extensability
17:05:28 <sergmelikyan> *to minimize
17:06:16 <stanlagun_> Here are 2 more blueprints:
17:06:29 <stanlagun_> https://blueprints.launchpad.net/murano/+spec/sql-server for MS SQL Server support
17:06:49 <stanlagun_> https://blueprints.launchpad.net/murano/+spec/ssl about SSL encryption in Murano
17:07:20 <Ekaterina_F> Will other blueprints be add to release-0.2 or what we have is the final list?
17:07:28 <tnurlygayanov> lets to assign milestones for those blueprints - what about the API 2.0 milestone?
17:08:00 <dteselkin> There is one more blueprint - https://blueprints.launchpad.net/murano/+spec/external-ad External AD support
17:08:13 <stanlagun_> those blueprints are for 0.2. Just need to create milestone entry to be used in blueprints
17:08:19 <sergmelikyan> Ekaterina, yep, eventually new blueprints going to be added later, also current blueprints going to evolve.
17:08:45 <igor_yozhikov> https://blueprints.launchpad.net/murano/+spec/os-images-support
17:09:18 <sergmelikyan> Timur, all blueprints discussed here going to be assigned to release 0.2, or left to another release. We will start assigning procedure shortly.
17:09:34 <sergmelikyan> *going to
17:09:59 <tnurlygayanov> ok, sounds good )
17:11:08 <stanlagun_> API blueprint is a most interesting here because it reflects the direction to which Murano evolves twords becoming more open and flexible
17:12:26 <dkoryavov> I see 9 blueprints. If it is a final list, we can discuss all of them one by one?
17:13:11 <sergmelikyan> Some of this blueprints already implemented.
17:13:27 <sergmelikyan> Status for them should be updated.
17:13:42 <sergmelikyan> For example naming is delivered in release 0.1
17:13:58 <sergmelikyan> gokrokve, how it's look like (blueprints listed in chat)?
17:15:38 <tnurlygayanov> Sergey, we can share the link on blueprints list
17:15:57 <gokrokve> LEt me check
17:16:01 <sergmelikyan> already shared above :)
17:16:33 <dkoryavov> OK. Then, I see 4 links to new blueprints: SSL, SQL Server, External AD and OS images support. This is the final list?
17:17:04 <sergmelikyan> API?
17:17:20 <dkoryavov> Ahh.
17:17:22 <dkoryavov> Yep.
17:17:22 <gokrokve> We have also multiple AD Domains in the roadmap.
17:17:23 <dkoryavov> 5
17:17:40 <gokrokve> Should it be listed here too?
17:18:05 <gokrokve> I wonder if we can implement it in release 0.2.
17:18:38 <sergmelikyan> Scope of this feature is very unclear, for example i am not sure what it is at all.
17:18:54 <sergmelikyan> DE guys?
17:18:54 <stanlagun_> Gosha, can you be more specific by what do you mean by multiple AD Domains?
17:18:55 <gokrokve> We also have to follow the launchpad process. All blueprints should be reviewed and approved for release 0.2
17:19:16 <gokrokve> Just to have multiple domains within single forest.
17:19:33 <gokrokve> Like acme.com, dev.acme.com, qa.acme.com
17:19:58 <sergmelikyan> I am going to updated status of old blueprints tomorrow, approving for this release we going to start after we will finish with list of blueprints.
17:22:18 <dteselkin> I suggest to leave multiple domain feature to 0.3 release
17:22:51 <sergmelikyan> gokrokve?
17:23:01 <gokrokve> ok.
17:23:04 <dkoryavov> I think we can add a new blueprint for this and discuss it, but I highly doubt that we will have time to do this for v.0.2.
17:23:06 <dkoryavov> Yep.
17:23:20 <sergmelikyan> #info multiple domain feature left to 0.3 release
17:23:57 <sergmelikyan> Some other features for release 0.2? jrcookli?
17:24:40 <gokrokve> Hi Joel. Are you here?
17:24:42 <jrcookli> nothing more at this time..
17:24:51 <jrcookli> Yes.
17:24:59 <gokrokve> Ok.
17:25:25 <gokrokve> Do you want to participate in the development of some of the features?
17:25:45 <jrcookli> yes..
17:25:46 <gokrokve> How much resources and time do you have for that?
17:26:24 <jrcookli> 50% FTE
17:26:26 <gokrokve> Sergey, could you please check that Joel is in murano-dev list.
17:26:45 <gokrokve> Sounds great.
17:27:17 <gokrokve> I will share with you all necessary documents.
17:27:46 <gokrokve> We are using google docs for internal documents review.
17:27:46 <jrcookli> Has the SSL blueprint been implemented?
17:28:22 <sergmelikyan> gokrokve, yes, i will check and add Joel as participant to our murano-dev team
17:28:27 <stanlagun_> most parts of it
17:28:41 <gokrokve> Stan checked what is necessary for SSL. We will enable SSL on API side and we will use new rabbitMQ library with SSL.
17:29:00 <sergmelikyan> We have SSL support for API Endpoint, and added support to RabbitMQ library that we use.
17:29:16 <stanlagun_> we know how to enable SSL in REST API and I made a github pull request for SSL support in puka (RabbitMQ Python library)
17:29:54 <jrcookli> Extending to support salt would be a different blueprint then, correct?
17:30:40 <sergmelikyan> jrcookli, please share with me your launchpad identity after the meeting or via pm
17:31:19 * sergmelikyan cleaned list of blueprints and marked already implemented ones as completed
17:31:25 <gokrokve> Yes. Salt stack requires some agent changes. We will cover that in a separate blueprint.
17:31:33 <stanlagun_> SaltStack would be a different blueprint. Need to evaluate several details before publishing
17:32:38 <dkoryavov> OK, as far as I can see all blueprints for v0.2 have been discussed and approved.
17:32:40 <gokrokve> Stan when do you expect to have SaltStack blueprint?
17:33:15 <gokrokve> No. All of them in New state.
17:33:37 <gokrokve> It means that we have to do final review and approve.
17:33:55 <gokrokve> Each blueprint has to be assigned to an engineer.
17:34:00 <stanlagun_> I beleive it would be ready for next IRC meeting
17:34:08 <sergmelikyan> Should we accept them now, one by one, or on the next week (with new blueprints about SaltStack and more?)
17:35:08 <gokrokve> Lets do review off-line. We can use our murano-all mailing list to keep the history.
17:36:13 <sergmelikyan> ok!
17:36:31 <gokrokve> Do we have anything else to discuss?
17:36:47 <gokrokve> Joel, do you have anything to add?
17:36:50 <sergmelikyan> #info blueprints going to be reviewed and approved offline. Results going to be published in our mailing-list
17:37:23 <sergmelikyan> #action Stan, add new blueprint about SaltStack integration
17:37:56 <gokrokve> Ok. Lets finish for today.
17:38:05 <gokrokve> Thanks everyone.
17:39:06 <sergmelikyan> #endmeeting