15:00:52 <dkoryavov> #startmeeting murano
15:00:53 <openstack> Meeting started Tue Jul 30 15:00:52 2013 UTC and is due to finish in 60 minutes.  The chair is dkoryavov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:57 <openstack> The meeting name has been set to 'murano'
15:01:44 <dkoryavov> Hello folks.
15:02:51 <sergmelikyan> Hi!
15:04:56 <dkoryavov> Today is Jul 30 and it would be very nice to have a meeting for Murano Team. Here is agenda for the our meeting https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:08:35 <Ekaterina_F> Hi everybody!
15:08:56 <dkoryavov> I suggest to discuss the blueprints for v 0.2 https://launchpad.net/murano/+milestone/0.2
15:10:36 <Ekaterina_F> I guess we almost done with MS SQL server, right?
15:12:26 <dkoryavov> dim_ ?
15:13:35 <dim_> We've finished Failover Cluster support, which is required for SQL Cluster and now we are working on SQL Cluster itself. It's almost done.
15:15:37 <dkoryavov> OK, then it would be very nice if you will update this blueprint https://blueprints.launchpad.net/murano/+spec/sql-server-single-instance
15:16:00 <dkoryavov> #info We've finished Failover Cluster support, which is required for SQL Cluster and now we are working on SQL Cluster itself. It's almost done.
15:17:23 <dkoryavov> What we should to do to change state from 'almost done' to 'done'?
15:19:04 <dkoryavov> stanlagun Stan, what about this blueprint? https://blueprints.launchpad.net/murano/+spec/ssl
15:19:31 <dkoryavov> stanlagun ?
15:19:40 <stanlagun> SSL if fully implemented in all components
15:19:54 <stanlagun> Both RabbitMQ and HTTPS
15:20:19 <dkoryavov> So, we have nothing to do here and can close this blueprint?
15:20:20 <stanlagun> At least for encryption
15:21:06 <stanlagun> We still can improve SSL support and add server certificate validation on agent or client-side certificate. But I beleave we should leave it for future
15:21:14 <dim_> What is required to complete the SQL Cluster support is to validate SQL AG scripts and write workflows for conductor service.
15:21:16 <stanlagun> so yes, lets close it
15:21:26 <dkoryavov> #info SSL if fully implemented in all components https://blueprints.launchpad.net/murano/+spec/ssl
15:23:05 <dkoryavov> What about SaltStack. As far as I can recall, we cannot implement support for it right now? https://blueprints.launchpad.net/murano/+spec/saltstack-support
15:24:16 <stanlagun> This blueprint is slightly outdated.
15:24:58 <stanlagun> I beleave we need to rework it. But nothing prevent us from start implementing it
15:25:03 <stanlagun> besides chedule
15:25:20 <dkoryavov> And what we should do with it?
15:26:32 <dkoryavov> Shall we plan it to a some other version of Murano (0.3, 0.4)?
15:27:18 <stanlagun> I think we need to have 2 things: write blueprint that says that we need SaltStack automatic installation as a workflow example and suspend this blueprint till we know exactly how agents in vNext are going to be implemented
15:27:30 <stanlagun> yes
15:27:30 <dkoryavov> #action dim_ to validate SQL AG scripts and write workflows for conductor service.
15:28:06 <dkoryavov> OK :)
15:28:28 <dkoryavov> #action stanlagun rite blueprint that says that we need SaltStack automatic installation as a workflow example and suspend this blueprint till we know exactly how agents in vNext are going to be implemented
15:29:23 <dkoryavov> The last, but not least https://blueprints.launchpad.net/murano/+spec/os-images-support
15:30:32 <tnurlygayanov_> what about SSL for Murano API?
15:31:03 <stanlagun> we are halp way to implementation. We already support selection of images in UI and respect those settings in conductor. What is mising is utility for image importing into Glance and maybe some support for execution plan versioning where there are several versions of the same plan for different OSes
15:31:29 <stanlagun> Besides images we also wupport availability zones and VM flavors
15:32:03 <dkoryavov> As far as I can see, this is different blueprints?
15:32:06 <stanlagun> tnurlygayanov_: SSL for API - HTTPS - is already configurable and can be enabled AFAIK
15:32:11 <dim_> Support for different Windows images is implemented in UI. We also can build them in out image builder. However, Windows 2008 still not fully supported.
15:32:20 <dkoryavov> Can we close this blueprint and open another?
15:32:50 <stanlagun> which one? images?
15:33:05 <dkoryavov> #info Support for different Windows images is implemented in UI. We also can build them in out image builder. However, Windows 2008 still not fully supported.
15:33:12 <dkoryavov> Yes.
15:33:29 <stanlagun> I don't think so
15:33:42 <stanlagun> We are inline with the current blueprint
15:33:44 <dim_> We should update the status of the blueprint for now
15:34:18 <dkoryavov> OK, let's update this blueprint. dim_ stanlagun?
15:34:54 <stanlagun> I've changed its status to "good progress"
15:35:25 <dkoryavov> Do we have plans to do this work for v0.2?
15:37:00 <stanlagun> To some extent. Not sure what it is
15:38:35 <dkoryavov> OK. That is all?
15:38:48 <dkoryavov> Do we have other questions to discuss?
15:39:30 <stanlagun> not from my side
15:40:28 <dkoryavov> Then, let's stop our meeting. The next meeting will be on Monday - 5th Aug
15:40:46 <dkoryavov> #stopmeeting murano
15:41:28 <dkoryavov> #endmeeting murano