15:05:06 <dkoryavov> #startmeeting murano
15:05:07 <openstack> Meeting started Mon Aug 12 15:05:06 2013 UTC and is due to finish in 60 minutes.  The chair is dkoryavov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:10 <openstack> The meeting name has been set to 'murano'
15:06:39 <dkoryavov> We have several action items from the previous meetings.
15:07:37 <dkoryavov> dmyznikov akuzetsova and timur moving critical bugs to launchpad.
15:08:05 <dkoryavov> dmyznikov akuznetsov what about this action item?
15:08:54 <dkoryavov> tnurlygayanov ?
15:09:28 <tnurlygayanov> we moved critical bugs to launchpad today...
15:09:54 <dkoryavov> tnurlygayanov with info tag please :)
15:10:02 <dkoryavov> slagun stanlagun rite blueprint that says that we need SaltStack automatic installation as a workflow example and suspend this blueprint till we know exactly how agents in vNext are going to be implemented
15:10:12 <dkoryavov> slagun what about this action item?
15:10:30 <tnurlygayanov> [info] #info we moved critical bugs to launchpad today...
15:12:53 <dkoryavov> OK, we have only 3 weeks before the release (v0.2).
15:13:33 <dkoryavov> It is time to think about stabilization. :)
15:14:22 <gokrokve> That is exactly threse 3 weeks. We have all features implemented and committed.
15:14:29 <ativelkov> do we have all required 0.2 features ready by now?
15:14:44 <dkoryavov> AFAIK, this blueprint is implemented? https://blueprints.launchpad.net/murano/+spec/ssl
15:15:38 <slagun> yes
15:16:28 <gokrokve> And all others. We need to make sure that our blueprints are procesed correctly. I see that some of them are unassined to the series and have no approved status.
15:18:02 <dteselkin> By the way, we've fully implemented the 'MS SQL 2012 Single instance support' (https://blueprints.launchpad.net/murano/+spec/sql-server-single-instance)
15:18:19 <ativelkov> that's great
15:18:36 <ativelkov> what about cluster? Did Stan's fix to rule Muting help?
15:18:42 <dkoryavov> Well it is nice to see.
15:20:08 <gokrokve> Just updated its status.
15:20:49 <gokrokve> Let's pay attentions to the processes. We need to maintain this at high level.
15:21:09 <dteselkin> We haven't test this fix yet, as we are in process of moving PS scripts to conductor. As soon it is done, we will test it.
15:21:29 <dkoryavov> dteselkin then, give the corresponding status for the blueprint please.
15:22:02 <gokrokve> We have a new contributor Chad Bernick. He wants to participate in powershell scripts development.
15:22:48 <gokrokve> Dmitry, please do a quick sync up with him and describe how it is organized in Murano.
15:22:51 <dkoryavov> #info We've fully implemented all blueprints for v0.2.
15:23:08 <dkoryavov> #info We have a new contributor Chad Bernick. He wants to participate in powershell scripts development.
15:23:45 <dteselkin> Ok, please send us his contact.
15:24:50 <dkoryavov> #action item dteselkin will be a mentor for Chad Bernick.
15:25:25 <dteselkin> For now, all PS scritps and worflows are done to support SQL Cluster. We are testing it.
15:25:36 <dkoryavov> slagun what about blueprint?
15:25:51 <dteselkin> #info For now, all PS scritps and worflows are done to support SQL Cluster. We are testing it.
15:26:40 <slagun> I've updated SaltStack blueprint
15:27:09 <gokrokve> We have to start submitting blueprints for the next release.
15:28:25 <gokrokve> Team, please think what is required to improve Murano and etend its functional. Convert your idea to a blueprint and submit it.
15:28:36 <dkoryavov> It would be very nice if we will have a screencast for Murano v0.2.
15:29:06 <gokrokve> Its mandatory. We need to create it during this week.
15:29:20 <dkoryavov> Shall we submit a blueprint for this? :)
15:29:37 <gokrokve> No. This is a task, not a new feature.
15:29:58 <dkoryavov> ОК.
15:30:21 <ativelkov> gokrokve - this is controversary to what we have heard before
15:30:37 <gokrokve> I think Timur can create meaningfull demo scenario and Alex Tivelkov can narrate a text.
15:30:48 <ativelkov> I mean thinking about improvements and and extending of Murano
15:31:10 <ativelkov> because Improvements and Extending is what we suggested for vNext
15:31:13 <gokrokve> Its not a development, it is just a blueprint submission.
15:31:24 <tnurlygayanov> ок
15:31:48 <ativelkov> so, you want us to submit our vNext ideas as blueprints?
15:31:53 <gokrokve> There is a difference between what should be doen and how should be done.
15:32:15 <gokrokve> Do this in abstract way. Do not enforce exact architecture.
15:32:55 <gokrokve> Like "We need dynamic UI". UI Should be described in plain text....
15:33:09 <ativelkov> ok
15:33:29 <dkoryavov> #idea  "We need dynamic UI". UI Should be described in plain text....
15:34:05 <gokrokve> It was not an idea. It was an example how to write an abstract feature description.
15:34:38 <gokrokve> Without referencing exact implementation.
15:34:51 <dkoryavov> I think it is a good idea. :)
15:34:56 <gokrokve> Implementation may change in a time, but the idea is not.
15:35:34 <gokrokve> Any other questions?
15:35:46 <gokrokve> We run out of time.
15:36:04 <dkoryavov> No, i think not.
15:36:39 <dkoryavov> So, let's stop our meeting? Do we have any questions to discuss?
15:37:28 <dteselkin> The last thing to implement is Windows 2008 support. Our build system supports it, but it is not fully integrated with our workflows.
15:37:51 <dkoryavov> ouch...
15:37:55 <dkoryavov> slagun ?
15:38:31 <slagun> We do support Windows 2008
15:38:43 <dkoryavov> dteselkin what time we need to fully implement this blueprint?
15:38:50 <slagun> At least at conductor
15:39:10 <slagun> But we don't have any Win2008-specific logic
15:40:22 <dteselkin> We need to alter PS scrips because currently we use some functions that are available on 2012.
15:41:06 <dteselkin> I think one month should be enough.
15:41:28 <dkoryavov> #info We need to alter PS scrips because currently we use some functions that are available on 2012.
15:41:37 <dkoryavov> dteselkin we have no time to do this…
15:41:41 <dkoryavov> we have only 3 weeks.
15:43:03 <dkoryavov> then, maybe we should to create an another blueprint and implement current blueprint in minimal form?
15:43:48 <dteselkin> It looks a good idea.
15:44:41 <dkoryavov> dteselkin OK, please do this before the next meeting.
15:45:19 <dkoryavov> Do we need any questions to discuss? ativelkov gokrokve slagun tnurlygayanov sergmelikyan katyafervent ?
15:46:02 <katyafervent> No, everything's clear
15:46:27 <dkoryavov> Then, let's stop our meeting.
15:46:33 <dkoryavov> #endmeeting