15:02:23 <dkoryavov> #startmeeting Murano
15:02:24 <openstack> Meeting started Mon Sep  2 15:02:23 2013 UTC and is due to finish in 60 minutes.  The chair is dkoryavov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:24 <akuznetsova> Hello all
15:02:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:28 <openstack> The meeting name has been set to 'murano'
15:02:30 <tnurlygayanov_> Hi all!
15:03:21 <dkoryavov> Here is summary from previous meeting http://eavesdrop.openstack.org/meetings/murano/2013/murano.2013-08-19-15.04.html
15:03:42 <dkoryavov> We have no action items from the previous meeting. o_O
15:04:01 <tsufiev_> hi!
15:04:43 <tnurlygayanov_> Need to fix it on this meeting )
15:05:30 <tnurlygayanov_> the main action item from the last meeting - preparation for release-0.2
15:06:06 <dkoryavov> OK
15:06:11 <tnurlygayanov_> and today we have new tag on git repositories for all Murano components
15:06:49 <dkoryavov> tnurlygayanov_ please, tell us about the quality of Murano v0.2 RC1
15:06:53 <tnurlygayanov_> with rc1 tag.
15:07:05 <dkoryavov> Yep.
15:07:29 <dkoryavov> tsufiev_ should write an email about this to the openstack-dev@ ML
15:07:47 <tnurlygayanov_> Murano release-0.2 RC1 have many fixed bugs and new services and features.
15:08:43 <tnurlygayanov_> In RC1 we have finished to fix all blocker and critical bugs.
15:10:00 <dkoryavov> Folks, I think we need to create a good 'getting start' guide for our users
15:10:03 <tnurlygayanov_> https://bugs.launchpad.net/murano/+bugs?orderby=-status&start=0
15:10:05 <tsufiev_> btw, here is an email: http://lists.openstack.org/pipermail/openstack-dev/2013-September/014522.html
15:10:42 <dkoryavov> tsufiev_ cool! thanks!
15:10:45 <ativelkov> Nice idea
15:11:05 <ativelkov> Getting started guilde - and probably a "tutorial video" or something
15:11:10 <dteselkin> dkoryavov, we are working on "Getting Started" guide
15:11:23 <ativelkov> deploying Murano is complicated stuff: we need to make it simple
15:11:24 <IgorYozhikov> tutorial video - great
15:12:18 <dkoryavov> dteselkin Good. Should we create a blueprint for this?
15:13:10 <IgorYozhikov> Blueprint for text manual or for video tutorial?
15:13:27 <dteselkin> dkoryavov, I'm not sure if it's a good topic for blueprint.
15:14:03 <dteselkin> But we definitely can :)
15:15:42 <dkoryavov> #info dteselkin and IgorYozhikov are working on Getting Started guide for Murano v 0.2
15:15:49 <IgorYozhikov> May be it nice/must to have, it could make install and understanding of the configuration steps  easier
15:16:32 <akuznetsova> One more blueprint will not be superfluous
15:16:38 <dkoryavov> akuznetsova +1
15:16:56 <dteselkin> Ok, I'll create it
15:18:55 <akuznetsova> ativelkov: did you discuss with igor marnat our screencasts?
15:19:11 <dkoryavov> Btw, we have many new blueprints. https://blueprints.launchpad.net/murano/+spec/security-groups
15:19:16 <dkoryavov> https://blueprints.launchpad.net/murano/+spec/combined-roles
15:19:21 <dkoryavov> https://blueprints.launchpad.net/murano/+spec/custom-workflows
15:19:26 <dkoryavov> https://blueprints.launchpad.net/murano/+spec/linux-agent
15:19:40 <dkoryavov> https://blueprints.launchpad.net/murano/+spec/operations-on-deployed-service-or-environment
15:19:48 <ativelkov> Yes, I did
15:20:07 <ativelkov> as a result, it seems like I have to create a new screencast, a merged version of mine and Timur's
15:20:14 <dkoryavov> Did somebody see them?
15:20:31 * IgorYozhikov saw
15:22:27 <dkoryavov> OK. They are not very informative. So, if someone knows more about them, feel free to update them.
15:23:01 <dmyznikov> ativelkov: and we will have one screencast instead two?
15:23:18 <dkoryavov> OK. I suggest to discuss the date for Murano v 0.2.1 - bug fix release for Murano v 0.2.
15:23:23 <ativelkov> yes, it seems so
15:23:55 <ativelkov> plus the one which was created by IgorYohikov
15:24:00 <tnurlygayanov_> #action need to update https://blueprints.launchpad.net/murano/+spec/linux-agent - need to describe messages format for agent, because now it is shudow logic for everyone who wants to help with this task
15:24:36 <akuznetsova> We haven't got a lot of bugs
15:25:11 <katyafervent> How will you share with ready screencast? Will you add link to launchpad?
15:25:16 <dkoryavov> I suggest to release it 19th September. Folks, what do you think - will it be enough?
15:25:37 <dmyznikov> ativelkov: and yet two screencasts... :)
15:26:05 <dkoryavov> katyafervent ativelkov IgorYozhikov I suggest YouTube.  :)
15:29:12 <dkoryavov> akuznetsova it is normal. :) We will see many other bugs after the release (when users will start to use Murano in production :)
15:29:54 <dkoryavov> OK, what about 19th september?
15:30:05 <dkoryavov> Any other opinions?
15:30:10 <IgorYozhikov> why not
15:30:28 <dmyznikov> dkoryavov: not so much bugs...
15:30:36 <akuznetsova> IgorYozhikov: +1
15:31:19 <dmyznikov> dkoryavov: And I hope, none of critical bugs ^)
15:32:02 <dkoryavov> tnurlygayanov_ tsufiev_ dteselkin ativelkov katyafervent ?
15:32:41 <dmyznikov> I agree
15:33:35 <katyafervent> it's more then enough)
15:34:14 <tnurlygayanov_> I belive that we should wait for users feedback and after that estimate 'bugs-fix' iteration
15:34:19 <ativelkov> Yes, I think so
15:34:36 <akuznetsova> But if we won't have time, we can publish 'known issues'
15:34:42 <tnurlygayanov_> probably we should estimate two weeks for 'the first steps of users'
15:34:48 <dkoryavov> akuznetsova we'll do this anyway
15:35:16 <dkoryavov> tnurlygayanov_ we can create 2.0.2 for this :)
15:35:57 <tnurlygayanov_> ok )
15:36:15 <tnurlygayanov_> what about the our estimates for blueprints?
15:36:24 <dkoryavov> OK, most of all  Muranoers are agreed with me
15:36:33 <tsufiev_> 2 weeks should be enough
15:37:02 <tnurlygayanov_> have we the road map with describing different blueprints ? Lets discus this )
15:37:24 <dkoryavov> #info The release date for 'bug fix' release -  Murano v 2.0.1:  Sep. 19th 2013
15:37:41 <tnurlygayanov_> I think that we can work with bugs in parallel with the main development of new features
15:37:54 <tnurlygayanov_> because new features it is very important
15:38:29 <dkoryavov> tnurlygayanov_ the ROADMAP is here https://wiki.openstack.org/wiki/Murano/Roadmap
15:38:55 <dkoryavov> As you can see I already added 19th sep. as the date for bug fix release :)
15:40:26 <dkoryavov> On the previous meeting I suggested to sync our releases with releases of OpenStack, but this Idea is not very popular as I can see.
15:40:44 <akuznetsova> version 0.2.0.1 ? maybe 0.2.1 because we have strange numbering
15:41:36 <dkoryavov> akuznetsova what release should be after 0.2.9?
15:41:46 <dkoryavov> 0.3 or 0.2.10?
15:42:37 <IgorYozhikov> 0.3
15:42:45 <dmyznikov> without serious new features - 0.2.10
15:43:07 <tsufiev_> 0.3
15:43:10 <tnurlygayanov_> without bugs ) 0.3 )))
15:43:15 <akuznetsova> oooh, 0.3
15:43:29 <dmyznikov> without bugs - this is 1.0 ^)
15:44:08 <tnurlygayanov_> ok, what we also plan to discus today?
15:45:23 <dkoryavov> I suggest the next release strategy: if core components are not significantly changed we should use 0.2XX. 0.2 -epoch, XX- the number of release.
15:45:33 <dkoryavov> tnurlygayanov_ nothing more
15:46:03 <dkoryavov> 0.X.YY.ZZZZ
15:46:21 <dkoryavov> ZZZZ - the number of bug fix release
15:46:51 <dkoryavov> So, 0.2.0.1 should be the first bug fix release for v 0.2
15:46:54 <tsufiev_> omg, is it a linux kernel?
15:47:03 <dkoryavov> tsufiev_ yep! :)
15:47:20 <katyafervent> 0.2.1 will suit
15:47:23 <akuznetsova> What means YY?
15:48:41 <dkoryavov> akuznetsova the number of 'minor' release.
15:49:00 <tsufiev_> i'll suggest using X.Y.Z where X is a major feature release, Y is a minor feature release and Z is a bugfix release
15:50:04 <tsufiev_> it implies that we haven't yet any major feature release...
15:50:12 <dkoryavov> tsufiev_ and this is my proposal too.
15:51:04 <dkoryavov> OK.
15:51:32 <dkoryavov> We have no time. Do we agreed or we need more time to discuss?
15:52:06 <IgorYozhikov> +
15:52:30 <katyafervent> Thanks to all for the discussion
15:52:53 <dkoryavov> heeey!
15:53:01 <dkoryavov> what about my last question?
15:53:32 <dkoryavov> ohh…
15:53:36 <dkoryavov> ok, next time.
15:53:46 <tsufiev_> about number versioning?
15:53:55 <dkoryavov> #info to discuss release strategy on the next meeting.
15:54:02 <dkoryavov> Thanks for all.
15:54:23 <dkoryavov> The next meeting will be Sep. 9ht.
15:54:32 <dkoryavov> #endmeeting Murano