15:04:49 <dkoryavov> #startmeeting Murano
15:04:50 <openstack> Meeting started Mon Sep 16 15:04:49 2013 UTC and is due to finish in 60 minutes.  The chair is dkoryavov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:54 <openstack> The meeting name has been set to 'murano'
15:05:02 <dkoryavov> Agenda: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:05:55 <ativelkov> Gosha, before we begin, could you pleasr share a link to your Heat blueprint (The one which allows to configure autoscaling instance type)?
15:06:03 <ativelkov> I cannot find it
15:06:37 <gokrokve> https://blueprints.launchpad.net/heat/+spec/autoscaling-instancse-typization
15:06:59 <dkoryavov> I suggest to change format of our meeting. First, I suggest to review our last week's actions.
15:07:20 <gokrokve> I already discussed it  with Heat team. They want to create a new implementation of Autoscaling groups, so all this should be available in a new implementation.
15:07:30 <gokrokve> LEgacy AG will not be changed.
15:07:45 <gokrokve> So, for now if we want to use it we have to patch Heat.
15:08:01 <gokrokve> We already doing this for other reasons, so it is not a big deal.
15:08:05 <ativelkov> gokrokve,  - that's great news, new implementation is a good chance for us to propose new changes suitable for us
15:08:19 <sergmelikyan> dkoryavov, there are no AI from previous week
15:08:26 <gokrokve> Yes. We need to participate in their meetings.
15:08:49 <gokrokve> I have a question about BP for Murano.
15:09:06 <gokrokve> We have to approve them if we want to implement them in 0.3 version.
15:09:08 <dkoryavov> gokrokve  They want to create a new implementation of Autoscaling groups, so all this should be available in a new implementation. - is this short-term scope or long term?
15:09:26 <gokrokve> I propose to do review via e-mail list @ openstack.org
15:09:56 <gokrokve> dkoryavov: They plan to implement them during Icehouse release. So it is for 6 months
15:11:09 <dkoryavov> gokrokve I'm correct that you want to do a review for a blueprint before we'll include it into the our SOW?
15:11:09 <ativelkov> this means that we will be able to contribute to that implementation (after Havanna release)
15:12:57 <sergmelikyan> gokrokve, BP review via email for our own BP's assigned for 0.3?
15:13:11 <dkoryavov> gokrokve OK. That is a good news!
15:13:17 <gokrokve> dkoryavov: No. There are BP on launchpad. We nedd to review them, assign to the release and approve.
15:13:41 <gokrokve> dkoryavov: And review via e-mail, yes.
15:14:13 <dkoryavov> sergmelikyan yes, so everyone can say what he was working last week.
15:14:54 <dkoryavov> gokrokve Well, it is sounds good for me.
15:16:30 <sergmelikyan> I had working on implementing support for allowed-address-pairs in Heat and using this feature in Conductor
15:17:26 <dkoryavov> #agreeed We should approve a blueprint (to do a review via e-mail list @ openstack.org) if we want to implement it in a new version.
15:17:31 <sergmelikyan> Currently i had submitted few patches to Heat, and already finished workflow for Conductor. Only quick testing for this workflow is still in progress.
15:18:23 <sergmelikyan> This means, that in next release of Murano we going to support only Havanna release of OpenStack (almost) without patches.
15:19:09 <ativelkov> I was working on sеcurity groups (found an issue with Heat, imlemented a workaround), and HighAvailability issues (fixed the major one, but found two cornercases which still break our HA, they need to be addressed in 0.3). Also did some reaserches with Heat and OpenStack Neutron
15:19:29 <dkoryavov> #info In next release of Murano we will support only Havanna release of OpenStack.
15:21:32 <dkoryavov> katyafervent, stanlagun ?
15:22:22 <stanlagun> I work on Heat patches and our possible contributions
15:22:47 <katyafervent> Currently I'm working on some installation problems
15:23:06 <stanlagun> I've submitted path for SSL in Heat. Still need to fix several unit tests and do some commit refactoring
15:23:28 <dkoryavov> gokrokve Do you know something about this project? https://launchpad.net/taskflow
15:24:10 <gokrokve> Yes. It looks like this ia a python library to simplify the workflow creation.
15:24:23 <stanlagun> Regarding AutoscalingGroups I'm not yet sure if we can implement such plugin
15:24:24 <gokrokve> It is not a Murano workflow engine.
15:24:44 <gokrokve> stanlagun: Why?
15:25:34 <joel_c> taskflow aims to be included in oslo; it is currently being implemented into cinder and they are attempting to get it reused across other projects; it will be a core part of another higher level project convection as I understand.
15:26:52 <stanlagun> There is a problem with cros dependencies. ServiceUnit will have to do the actual deployment of environment so that AutoscalingGroup could insert new instance IP into LB. But for environment to be deployed it has to wait for the Heat stack (that is currently resizing) to be in Ready state and then tri to update it. Seems like deadlock
15:27:10 <dkoryavov> gokrokve I thought, maybe it is a good idea to make Murano Workflow engine independent project?
15:27:45 <stanlagun> dkoryavov: Murano workflows are much more than a task scheduling
15:28:45 <gokrokve> Agree. We have DSL languag, so our workflows are specific.
15:29:47 <gokrokve> dkoryavov: Denis, can you please start BP review process. Send a list of BP planned for release 0.3 to openstack-dev [Murano]
15:30:00 <dkoryavov> gokrokve OK.
15:30:00 <sergmelikyan> And first of all they are declarative and dynamic.
15:30:13 <gokrokve> We need to collect oll feedbacks it there are any.
15:30:48 <stanlagun> Actually Murano Workflows are superset of Tasks proceiing engine to large degree. In theory Taskflows task could be defined in our workflows
15:31:51 <ativelkov> so, may be we can reusу taskflow project in some way or another?
15:32:38 <dkoryavov> Well, I do not think that our workflows are very specific. What is block us to create an independent project based on our workflows?
15:32:55 <ativelkov> we wanted to rewrite our workflow engine anyway: build a new DSL etc
15:33:10 <dkoryavov> I suggest to think about this as minimum.
15:33:40 <stanlagun> Workflow include not just task preconditions but also Murano-sprcific actions to be performed when those conditions match
15:33:51 <ativelkov> I don't see any reasons in creating a new general-porpose workflow engine, if some already exists in the community
15:34:37 <gokrokve> Do not mic them. Taskflow is a library to create tasks and flows as a python objects.
15:34:38 <ativelkov> stanlagun, but any task-based workflow engine should be extensible
15:34:57 <ativelkov> ah, you mean - coded in python?
15:35:00 <gokrokve> It has no any language. All flows are defined inside the code.
15:35:06 <gokrokve> Yes.
15:35:07 <dkoryavov> ativelkov as I can see taskflow is very young project, so murano workflows engine is more powerful.
15:35:35 <ativelkov> if it is python-coded tasks, that it is not an option for us
15:35:37 <gokrokve> We can reuse taskflow inside our engine, if it will simplify our development.
15:35:50 <gokrokve> Just read their wiki page.
15:40:12 <gokrokve> Do we have anything else to discuss?
15:40:40 <dkoryavov> So, if taskflow will be included in oslo, as joel_c said, we will have to use it as far as I understand.
15:40:53 <dkoryavov> gokrokve I think no.
15:42:33 <sergmelikyan> dkoryavov, not 'have to', i suppose
15:42:44 <dkoryavov> #action dkoryavov will start BP review process for Murano v0.3 on the openstack-dev ML.
15:44:33 <dkoryavov> sergmelikyan OK, 'should' :)
15:44:46 <sergmelikyan> what about 'may'? )
15:45:09 <sergmelikyan> We not 'have to' or 'should' use anything from oslo
15:45:38 <ativelkov> dkoryavov, if taskflow just defines workflows as python code, then we have no use of it
15:46:04 <ativelkov> because we need safe yaml-based (or some other declarative markup) definitions
15:46:26 <ativelkov> we may (or may not) convert such definition to pre-build python code
15:46:26 <dkoryavov> ativelkov taskflow is a young project. So everything can be changed.
15:46:41 <ativelkov> bu this may (or may not) look ugly )
15:47:10 <ativelkov> so, let's look at this lib as soon as we know final requirements and specs to the new workflow engine
15:47:48 <ativelkov> for now, we know nothing on this topic, so let's postpone this discussion
15:48:00 <dkoryavov> OK, if we have no other items to discuss, I suggest to end our meeting. Let's speak about this on the next meeting.
15:48:24 <dkoryavov> #endmeeting Murano