15:04:40 <tnurlygayanov> #startmeeting Murano
15:04:41 <openstack> Meeting started Mon Sep 23 15:04:40 2013 UTC and is due to finish in 60 minutes.  The chair is tnurlygayanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:44 <openstack> The meeting name has been set to 'murano'
15:04:57 <gokrokve> Ok. Thanks Timur.
15:05:30 <tnurlygayanov> #topic Linux Agent
15:05:31 <katyafervent> Alex Tivelkov has a specification with metadata features  and we will pick tommorow what we gonna implement first
15:05:55 <gokrokve> Ok.
15:06:01 <gokrokve> Was BP updated?
15:06:10 <tnurlygayanov> yes
15:06:27 <tnurlygayanov> https://blueprints.launchpad.net/murano/+spec/linux-agent
15:06:54 <gokrokve> Great.
15:07:00 <katyafervent> Also documentation has been improved, we have different installation  descibed according type of document
15:07:15 <tnurlygayanov> We have discuss this BP today and now we have the following vision of the implementation
15:07:42 <gokrokve> Did you take into account a feedback from Joel and Munir?
15:07:46 <katyafervent> Also documentation has been improved, we have different installation  described according type of document
15:07:52 <gokrokve> I bet you was in CC>
15:08:51 <gokrokve> Are you guys using mobile version for IRC?
15:09:06 <katyafervent> No)
15:09:06 <gokrokve> Are you on planned activity today?
15:09:12 <tnurlygayanov> This linux agent will contain 3 parts: 1. Agent, which will get messages from conductor and will call executors for each task from conductor; 2. Executors - these several components with one target - to parse JSON from agent and to perform tasks/scripts or recepies
15:09:25 <tnurlygayanov> 3. Execution plans
15:10:13 <gokrokve> Good. Do you plan to add a new "run-command" for linux or use the same with new attributes?
15:10:15 <tnurlygayanov> gokrokve, yes, information about use cases was added to BP details
15:10:29 <gokrokve> How it will affect workflow xml format?
15:10:32 <gokrokve> ok
15:11:13 <tnurlygayanov> it will no affect xml format of workflows, I belive that we can implement it without changes in workflows angine
15:11:31 <tnurlygayanov> or? probably, with some updates
15:12:48 <tsufiev> afair, we talked about 2 versions of workflow
15:13:05 <tnurlygayanov> we plan to create new Python-based agent, which will executes new workflows via different executors for bash/puppet and etc.
15:13:12 <gokrokve> ok. Engine will not be affected. That is good.
15:13:36 <gokrokve> What is a second version of workflow?
15:14:41 <tsufiev> i mean, it is possible for conductor to support old version and new one (if there will some changes due to linux agent)
15:16:23 <tnurlygayanov> tsufiev, I belove that we can add some functionality for new workflows without changes of old workflows
15:16:25 <katyafervent> btw, it's not crystal clear what we gonna execute on agent so this topic is open
15:16:45 <tnurlygayanov> looks like we can implement this without versionig for workflows engine
15:17:59 <tsufiev> katyafervent, yes, the discussion on workflows hasn't finished yet
15:18:16 <tnurlygayanov> today on the IRC meeting  we want to discuss what this linux agent shour run for the first version?
15:19:39 <katyafervent> We can listen joel_c suggestion on that)
15:19:47 <gokrokve> I think we need to support bash and puppet.
15:20:27 <tsufiev> gokrokve, you mean, in addition to python?
15:20:38 <gokrokve> We had an offline conversation with Joel and Munir.
15:20:50 <IgorYozhikov> if set executor as python
15:20:56 <gokrokve> Linux agent should be able to run bash scripts and puppet manifests.
15:21:00 <katyafervent> Will you share it later with us?
15:21:17 <gokrokve> So you have to support at least two executor: bash and puppet.
15:21:25 <tnurlygayanov> Joel, Georgy, Munir, do we have some information what we want to run? Bash scripts or puppet manifests?
15:21:50 <tnurlygayanov> Ok, Thank you )
15:23:17 <tnurlygayanov> and also I have a questino about puppet manifests. Single-agent or agents with puppet server? Should we deploy puppet server?
15:23:29 <tnurlygayanov> *question
15:23:48 <joel_c> tnurlygayanov: I would keep it simple at first (no puppet server)
15:24:24 <joel_c> my preference would be to be able to do a puppet apply
15:24:31 <ogelbukh> as long your agent has ability to coordinate with others and conf db
15:24:37 <ogelbukh> there is no need in puppet server
15:24:50 <ogelbukh> in my understanding, at least
15:24:51 <tnurlygayanov> Ok, Thank you, Joel
15:25:41 <gokrokve> Hi Oleg. Yes we can orchestrate puppet on VMs. Murano conductor has most of abilities of mcollective.
15:25:59 <gokrokve> Hi Joel, thank you for a feedback.
15:26:16 <ogelbukh> so then puppet server just add tons of unnesseccary complexity
15:26:22 <gokrokve> Am I right that you have some kind of automation around MariaDB?
15:26:45 <gokrokve> ogelbukh: Totally agree.
15:27:45 <joel_c> gokrokve: the automation we have for mysql (mariadb) depends on our dynamic nodes classifier
15:28:28 <joel_c> gokrokve: but I can share the module with you as well as a sample nodes.pp
15:28:38 <joel_c> gokrokve: if that helps
15:29:26 <gokrokve> joel_c: ok. Share whatever you can. We will try to reuse it, or at least we will figure out what is your approach on automation.
15:30:09 <gokrokve> Are we done with Linux Agent discussion?
15:30:32 <gokrokve> tnurlygayanov: Timur, could you please update Linux Agent BP accordingly today's discussion?
15:30:53 <tnurlygayanov> yes, I'm in progress )
15:30:57 <gokrokve> I would like to switch to Metadata server part.
15:31:23 <gokrokve> Did we prepare BP for metadata service?
15:31:29 <tnurlygayanov> #topic Metadata server
15:31:51 <gokrokve> How is working on UI part of this feature?
15:32:11 <tnurlygayanov> yes, https://blueprints.launchpad.net/murano/+spec/custom-workflows
15:32:28 <gokrokve> I'd like to see some wireframes for UI before actual work.
15:32:31 <gokrokve> good
15:33:11 <gokrokve> I see a dependency from combined roles.
15:33:28 <gokrokve> Was this feature estimated?
15:33:31 <tnurlygayanov> right now we do not plan new WebUi for workflows
15:33:35 <tsufiev> gokrokve, we haven't yet estimated the amount of work on Metadata Repos UI
15:33:55 <tnurlygayanov> ok, we will send wireframes and will add screenshots to BP on launchpad
15:34:17 <gokrokve> tnurlygayanov: ok. thanks.
15:34:49 <gokrokve> tsufiev: We need to estimate all BPs accepted for the release 0.3
15:35:25 <tnurlygayanov> gokrokve, this BP not approved
15:35:28 <tsufiev> gokrokve, yes, we will continue our planning of Metadata Repos tomorrow
15:36:28 <gokrokve> Ok. Please finish all estimations tomorrow. We need to start implementing them.
15:37:05 <tnurlygayanov> do we plan to move Murano WebUI from single tab to single partition? (like for Heat)
15:37:32 <katyafervent> Actually we do want to improve our UI and make service dependency clearly and easier to use
15:38:20 <tnurlygayanov> looks like new WebUI for workflows will be more user-friendly with sevelar different tabs in WebUI
15:38:27 <tnurlygayanov> *several
15:38:32 <katyafervent> You mean to separate to dashboard not a panael in current Project?
15:39:28 <tsufiev> one of the ideas is to free user of the necessity to remember chain of service dependencies (like in MS SQL Cluster - to create Cluster, you should create AD first)
15:39:41 <gokrokve> We can do this. As I know Savana team adds new panel.
15:39:54 <tnurlygayanov> katyafervent, yes
15:40:07 <katyafervent> if we will have more panels (except environments) we can
15:40:38 <gokrokve> tsufiev: How do you see this feature should look like?
15:41:00 <katyafervent> need to think more about it keeping in mind to make work with UI easier and not "like everybody else" )
15:41:12 <tnurlygayanov> tsufiev, we can implement via pre-deployment https://blueprints.launchpad.net/murano/+spec/pre-deployment-testing
15:42:30 <tnurlygayanov> realy, it will more simple and user-friendly.
15:43:38 <katyafervent> tsufiev, has an idea about service dependency implementation will look like adding new user  during tenant creation in horizon
15:43:41 <tsufiev> gokrokve, this still has to be drawn in wireframes, but creating a tenant and a user (if there is not any) could be used as a starting point
15:44:34 <tsufiev> tnurlygayanov, BP seems to address a different issue - checking services consistency at deploy phase
15:44:34 <gokrokve> Ok. Please estimate everything. We need to plan our releases accordingly ETA.
15:44:49 <katyafervent> Actually we can name our new dashboard " Murano Environments" and list all existing services there so user does not require to click on environments button
15:44:58 <gokrokve> ok.
15:44:59 <ogelbukh> this new panel, would it be a item in the tenant menu
15:45:11 <tsufiev> tnurlygayanov, when I'm speaking about service configuration phase and forms validation
15:45:13 <ogelbukh> or something else?
15:45:53 <gokrokve> ogelbukh: Did you see Savana panel? It appears not in the left menu like Instances, Images...
15:45:53 <tnurlygayanov> tsufiev, ok, cool, now I'm uderstand your idea )
15:46:08 <gokrokve> It appears at the top menu as an additional tab
15:46:29 <ogelbukh> so next to the 'Project' one
15:46:32 <ogelbukh> correct?
15:46:44 <gokrokve> Yes.
15:46:45 <katyafervent> yes)
15:46:57 <ogelbukh> ok, I see now )
15:47:04 <ogelbukh> thanks
15:50:05 <tnurlygayanov> #action update linux-agent BP with new information
15:50:18 <gokrokve> Good.
15:50:28 <tnurlygayanov> #action update workflows-service BP with new information
15:50:31 <gokrokve> Do you have any questions?
15:50:47 <katyafervent> I hope today we'l finish with the planning)
15:51:04 <gokrokve> We have couple minutes for an open discussion.
15:51:56 <tnurlygayanov> Yes, I have a question. Do we plan to implement this https://blueprints.launchpad.net/murano/+spec/ha-for-power-shell-scripts for Murano relese-0.3 ?
15:52:26 <tnurlygayanov> looks like we can do this and this is critical task for HA mode.
15:53:26 <tnurlygayanov> It will implemented by Dmitry Teselkin and Igor Yozhikov
15:55:51 <tnurlygayanov> and also we should discuss plans for the next meeting - I belive that we will have some ideas of linux agent implementation and we can discuss details of this implementation.
15:58:28 <ogelbukh> just as a last minute aside question
15:58:49 <ogelbukh> did you think about project mission statement already?
15:58:56 <ogelbukh> just in case, you know
15:59:05 <gokrokve> It is being redefined.
15:59:17 <gokrokve> We think about misson.
15:59:23 <gokrokve> So lets finish for today.
15:59:35 <gokrokve> tnurlygayanov: please end the meeting
16:00:38 <gokrokve> #endmeeting
16:00:42 <gokrokve> #endmeeting murano
16:00:52 <tnurlygayanov> #endmeeting murano
16:01:03 <tnurlygayanov> #endmeeting Murano
16:01:10 <tnurlygayanov> hm..
16:01:16 <tnurlygayanov> #endmeeting Murano