15:05:09 <ativelkov> #startmeeting murano
15:05:10 <joel_c> hi
15:05:10 <openstack> Meeting started Mon Sep 30 15:05:09 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:13 <openstack> The meeting name has been set to 'murano'
15:05:19 <stanlagun> Hi
15:05:20 <ativelkov> Hi guys
15:05:32 <ativelkov> sorry for a little delay
15:05:43 <ativelkov> let's start our meeting
15:06:13 <ativelkov> The agenda can be found here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:06:46 <tsufiev> hello!
15:08:02 <IgorYozhikov> Hi
15:09:33 <ativelkov> So, let's start with the current progress. tnurlygayanov, can you review our progress on release 0.2.1 for the last week?
15:10:09 <tnurlygayanov> yes
15:11:20 <tnurlygayanov> now we already have verified all bugs, which were targeted to release-0.2.1
15:11:56 <tnurlygayanov> and today we have plans to build RPM and DEB packages with Murano release-0.2.1
15:12:48 <ativelkov> #info all open issues  for r 0.2.1 have been tested and verified
15:12:51 <tnurlygayanov> in Murano release-0.2.1 were fixed a lot of critical bugs: https://launchpad.net/murano/+milestone/0.2.1
15:14:15 <tnurlygayanov> and, also, a lot of bugs in documentation.
15:14:35 <tnurlygayanov> I'm work on new tags for each Murano component now.
15:14:40 <akuznetsova> and we almost finish with documentation. we have only one bug releated with administrator guide. and now this bug is in progress. so we should fished today and close userstore
15:14:52 <ativelkov> Sounds good. What are our expectation on the final delivery date?
15:15:33 <tnurlygayanov> ativelkov, I think, today )
15:16:18 <ativelkov> Great. Will you write a release notes and a message to the email-list?
15:16:45 <ativelkov> #info: r0.2.1 to be delivered today, 09/30
15:18:06 <tnurlygayanov> Yes, I will do this today. Probably, you can help me with message to email-list?
15:18:19 <ativelkov> Yes, sure
15:19:02 <ativelkov> #action tnurlygayanov to write release notes for r0.2.1, ativelkov to write a community announcement
15:19:47 <ativelkov> Do we have any problems or other issues with 0.2.1 which we need to discuss right now?
15:21:07 <ativelkov> I guess the silence means that we don't have anym not that somebody is writing something really long :)
15:21:14 <ativelkov> Ok, let's proceed.
15:22:01 <ativelkov> We have two upcoming features to discuss: the Linux Agent and Metadata Repository
15:22:39 <ativelkov> The blueprints for these features have not been announced to the community as public documents, have they?
15:23:03 <stanlagun> The haven't yet
15:23:07 <stanlagun> *they
15:23:08 <ativelkov> Yes, I see
15:23:15 <gokrokve> Hi
15:23:21 <ativelkov> Hi Gosha
15:23:26 <stanlagun> hi
15:23:54 <ativelkov> That's exactly a question to you - shell we publich and announce Stan's and mine specs for the Linux Agent and Metadata repo?
15:24:02 <katyafervent> Where exactly  we gonna keep detaled blueprints information at Openstack wiki?
15:24:08 <gokrokve> What are you discussing now? I don't see previous messages in this IRC client.
15:24:31 <ativelkov> WE were speacking about spec documents for Linux Agent and Metadata Repo
15:24:48 <ativelkov> But they are provate documents by now, accessible only to the Core team
15:24:56 <gokrokve> I suggest openstack wiki as a publishing place for technical details
15:25:06 <ativelkov> We need to deside if we are ready to publish them on the wiki
15:25:22 <gokrokve> As I see on other projects etherpad is used too.
15:25:53 <gokrokve> So it is fine to have a BP with a brief description and a link to Etherpad or wiki.
15:26:06 <ativelkov> Ok
15:26:15 <ativelkov> So, should we publish them "as is" and continue the discussion when they are made public?
15:28:15 <gokrokve> I think yes. They are already mature anough to provide good deep dive to the technical details.
15:28:20 <ativelkov> Ok
15:29:18 <ativelkov> #action Publish the Spec documents at openstack wiki, create blueprints with short descriptions and references to the wiki articles. ativelkov and stanlagun will work on that
15:29:52 <ativelkov> So, does anybody (from the Core team, for now, as nobody else has seen the documents yet) have any questions about these specs?
15:32:10 <stanlagun> I haven't read Metadata repo spec yet. Going to di it later today
15:32:23 <ativelkov> Ok, I hope that when the documents are made available to the wider audience we will get more feedback and questions
15:32:50 <tsufiev> I have a question considering roadmap for Metadata Repository
15:33:03 <gokrokve> I read it. Looks good for me. I like the references to the future use as a part of service catalog.
15:33:23 <tsufiev> what are the approx. time limits for each version in roadmap
15:33:25 <tsufiev> ?
15:33:48 <sergmelikyan> tsufiev, you talking about releases of Murano?
15:34:11 <tsufiev> sergmelikyan, Yes, that's the second thing I wanted to ask
15:34:20 <sergmelikyan> Next release is assigned to October, 25 - 0.2.2
15:34:22 <ativelkov> tsufiev, well, it depends on the amount of developers who will work on the features
15:34:29 <sergmelikyan> tsufiev, what is first thing?
15:35:08 <ativelkov> The idea is to bring more attention to the development from the community, so not only the core team may work on this features. So we cannot predict time.
15:35:10 <tsufiev> sergmelikyan, I mean, (1) what are the time limits for versions specified in Metadata spec and (2) how do they correllate to Murano roadmap
15:35:28 <akuznetsova> sergmelikyan: what exactly should be in 0.2.2, only  Linux Agent?
15:36:25 <ativelkov> it is planned that release 0.3 will include some functionality of Metadata Repository. May be just the minimum basics.
15:36:50 <sergmelikyan> akuznetsova, also we migrating to Quantum as main engine for networking in Murano (previously we used nova-network)
15:37:53 <sergmelikyan> We need to describe all features as BP and assign them to releases to eliminate uncertainity and questions like "when feature A released"
15:38:52 <ativelkov> Realistically, I would expect first 3 milestones of the MR roadmap to be implemented by the 0.3
15:39:27 <stanlagun> Why do we introduce such big improvement as Agent vNext and Linux support as a minor version change 0.2.2? The difference between 0.2.0 and 0.2.1 is nothing compare to that of 0.2.1 to 0.2.2
15:39:42 <gokrokve> By the way, what is a status for Linux agent?
15:39:54 <gokrokve> Do we have PoC for it?
15:40:20 <ativelkov> We have a windows-PoC of Linux Agent :)
15:41:01 <sergmelikyan> And Stan, AFAIK is working on LA from today
15:41:08 <tsufiev> stanlagun, Considering the LinuxAgent spec, there is no words about converting input script parameters (which are strings) to types in script's native language
15:41:39 <stanlagun> Currently I work on this. Initialy I did such PoC on Windows Agent because it already has most of the needed code and because it potentialy can have more implementation problems considering it is .NET base but need a Python interpreter
15:42:04 <tsufiev> or this shouldn't be specified there?
15:42:10 <stanlagun> Now all problems are solves and I moved to Linux implementation. Need several days to complete alpha version
15:42:40 <stanlagun> tsufiev: Input parameters are not strings
15:42:44 <ekarlso> does murano support win 2012 ?
15:43:06 <stanlagun> Currently Win2012 is the only supported OS :)
15:43:07 <sergmelikyan> Yep
15:43:07 <IgorYozhikov> yes
15:43:59 <ekarlso> thought of doing stuff like Citrix as a Service ?
15:44:55 <gokrokve> Yes. We want to build Service Catalog for OpenStack. It will have similar ideas as Citrix product.
15:45:29 <IgorYozhikov> Citrix has much of services, but most of them working over Windows infractructure
15:45:32 <ekarlso> service catalog what ?
15:45:49 <ekarlso> keystone stuff or ?
15:46:04 <stanlagun> Ain't Citrix is similar to MS remote descktop?
15:46:15 <ativelkov> no, not infrustructure-level services
15:46:17 <ekarlso> stanlagun: xendesktop
15:46:18 <ativelkov> user services
15:46:19 <gokrokve> No. Keystone is a service catalog for APIs. It is essentially a list of API endpoints available in the system.
15:47:01 <gokrokve> We want to build a service which will help publish different 3rd party services on top of OpenStack.
15:47:07 <stanlagun> Well, our goal is to let users create such services without low-level programming.
15:47:20 <gokrokve> Right now we have Windows AD, IIS, MS SQL Cluster available.
15:47:56 <ekarlso> 3rd party meaning ?
15:47:58 <ekarlso> db ?
15:48:36 <gokrokve> DB as a part of it yes. We plan to use Trove via Heat to expose options for DB integration.
15:49:37 <gokrokve> There are many different software which might be used on top of OpenStack.
15:49:45 <stanlagun> 3rd pary meen you can create your own service that would be available to Murano users and upload it to open repo
15:50:14 <ekarlso> how does this diff from stuff like savanna etc ?
15:50:18 <ativelkov> and murano will provide an infrustructure to intgrate them together into a single environment
15:50:22 <gokrokve> Currently it is quite hard to use software components as a self service because lack of automation around it.
15:50:42 <gokrokve> Because savanna concentrates on Hadoop specifics.
15:51:38 <gokrokve> We are exposing generic workflows which allow to manipulate with software components inside VM and do complex orchestration for multi-VM deployment.
15:52:01 <ativelkov> Imagine you have a web service that requires a Hadoop Cluster. You may deploy it in the cluster and teach it how to use savanna's APIs to create such a cluster.
15:52:20 <ativelkov> (or you may manually create such a cluster by using savanna yourself)
15:52:21 <ekarlso> hmm k
15:52:31 <ekarlso> teaching it how ?
15:52:34 <ekarlso> a plugin ?
15:53:15 <gokrokve> No. You will need to create a new workflow which will call Savanna API to deploy cluster.
15:53:25 <stanlagun> BTW you're welcome to join #murano channel cause our meeting time is running out
15:53:38 <gokrokve> Then this workflow will setup web components and bind them with hadoop cluster.
15:54:05 <ekarlso> so, murano is a kind of Heat ish thing ?
15:54:17 <gokrokve> It uses Heat itself.
15:54:44 <gokrokve> It is a next level of orchestration when you need to expose complex deployments in a simple way.
15:54:50 <stanlagun> Heat for services :)
15:54:53 <stanlagun> kind of
15:56:10 <gokrokve> Here is a link to the demo http://www.youtube.com/watch?v=Y_CmrZfKy18
15:57:10 <gokrokve> It is an example of complex deployment for MS SQL CLuster with AlwaysON Availability groups. It requires multiple Windows components to be configured. Like Windows AD, Failover Cluster..
15:58:07 <gokrokve> The idea is to provide flexible approach for self-service, when you don't need to have special knowledge about service internals.
15:58:55 <gokrokve> For example QA team can use Murano for quick deployment of different Windows Environments which its own AD, IIS Clusters and SQL Clusters.
16:00:12 <ativelkov> Guys, we are running of time for Murano meeting. I suugest to continue the discussion in #murano channel
16:00:16 <ativelkov> #endmeeting