15:01:02 <ativelkov> #startmeeting Murano
15:01:03 <openstack> Meeting started Mon Oct 14 15:01:02 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'murano'
15:01:25 <tsufiev> hi!
15:01:29 <IgorYozhikov> Hi
15:01:29 <ativelkov> So, the agenda is here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:02:10 <sergmelikyan> Hi!
15:02:20 <ativelkov> Let's discuss the progress since the last week first
15:02:47 <akuznetsova> Hello
15:03:54 <ativelkov> During the last meeting we planned to work on the two new features : Linux Agent and Metadata Repository
15:04:16 <gokrokve> hi
15:04:21 <katyafervent> Hi
15:04:50 <rakhmerov> ativelkov: could you please briefly tell about the progress on these things?
15:04:52 <ativelkov> I can cover the status of Linux Agent.
15:04:53 <gokrokve> Did we test a Linux Agent prototype?
15:05:17 <ativelkov> Yes, it is tested and currently already checked in as part of release-0.3
15:05:37 <ativelkov> however, we've found some issues when integrated this feature
15:05:38 <gokrokve> Where I can find documents with a description of new commands available in workflow syntax?
15:06:14 <ativelkov> it is not related to Linux Agent itslef, that is rather an issue with Heat, which affect the whole 0.3, both Windows and Linux Deployments
15:07:06 <rakhmerov> ativelkov: what is that issue?
15:07:54 <sergmelikyan> gokrokve, i believe no new commands added
15:08:05 <sergmelikyan> gokrokve, i believe no new commands was added
15:08:06 <ativelkov> Quantum client, which is used by the Heat, gets incorrect credentials for the authentication
15:08:21 <ativelkov> as the result, Heat creates networks in the wrong tenant
15:08:32 <rakhmerov> hah
15:08:49 <gokrokve> Tha is nice. Is there an issue filed for that?
15:08:54 <ativelkov> yes
15:08:56 <gokrokve> That is nice. Is there an issue filed for that?
15:09:08 <gokrokve> What is issue id?
15:09:24 <gokrokve> I will try to ping heat team, or Stan can do this.
15:09:31 <sergmelikyan> issue is fixed in Heat Havanna release,
15:09:36 <ativelkov> Actually, that is a bug in Heat: sergmelikyan has found it
15:09:45 <gokrokve> Can we backport it?
15:09:46 <rakhmerov> great
15:09:58 <sergmelikyan> gokrokve, ativelkov already done it and tested
15:09:59 <ativelkov> yes, it affects only grizzly/stable, newer reviosion does not contain it anymore
15:10:28 <gokrokve> Anyway we have to install Grizzly version with the current installation.
15:10:33 <ativelkov> yes, I am now awaiting for an approval to push this fix to our fork of Heat which we will distribute with release-0.3
15:10:42 <sergmelikyan> ativelkov, Maybe we need to publish backport to Stable/Grizzly
15:10:58 <gokrokve> I think this is mandatory
15:11:14 <gokrokve> Don't forget that we have murano installation on Oct 14th
15:11:21 <sergmelikyan> gokrokve, we don't know are Heat team missed this issue or it was intensional
15:11:27 <ativelkov> Is there a procedure for commits to the older branches?
15:11:42 <sergmelikyan> ativelkov, same as for master
15:11:55 <ativelkov> I think we need to discuss this with the Heat team
15:12:05 <rakhmerov> agree
15:12:50 <ativelkov> #action Discuss backporting of https://review.openstack.org/25876 to Stable/grizzly with the Heat team. ativelkov to do it
15:13:39 <ativelkov> For now, we will use our own custom fork of Heat for customer's deployment of 0.3
15:14:22 <ativelkov> That's all about Linux Agent for now. katyafervent, can you give us a quick status update on the development of Metadata Repository?
15:15:19 <tsufiev> I am not katyafervent, but can say a couple of words too about Metadata Repository
15:15:31 <ativelkov> sure, please do :)
15:16:09 <katyafervent> I also can add some words)
15:16:45 <tsufiev> I've rewritten murano-dashboard to first try fetching UI forms definitions from Metadata Repo endpoint (still in a proto state) + changed dashboard to load any changes in dynamic UI immediately, without restarting web server
15:17:22 <katyafervent> Well api works bit needs improvement. Work on metadata client started
15:17:36 <tsufiev> proto state = it will changed after katyafervent changes some things in client API implementation on Metadata Repo Server
15:18:15 <tsufiev> *it will be changed
15:18:54 <gokrokve> Did you added Murano panel?
15:19:05 <tsufiev> currently I'm preparing wifeframes for Metadata Repository WebUI (not finished yet)
15:19:11 <tsufiev> gokrokve, no, not yet
15:19:25 <gokrokve> I understand that dynamic forms d not require to have a panel.
15:19:26 <gokrokve> Ok.
15:19:33 <ativelkov> Sounds great. We've scheduled an offline meeting for tomorrow to actualize the estimates on the tasks and verify which parts of the MR will make their way to the release 0.4
15:19:40 <katyafervent> Is it plan for  a release 0.4?
15:20:05 <katyafervent> I'm taking abt Murano panel
15:20:38 <gokrokve> I don't think so. We can have it in 0.3 if you confirm that we can do this.
15:21:04 <tsufiev> surely we can, it is quite easy
15:21:26 <gokrokve> We need to have some consistency in Murano UI as soon as it starts to work in production.
15:21:27 <ativelkov> rakhmerov is a release-owner for 0.4, so all questions on the scope of that release should be addressed to him
15:21:35 <rakhmerov> ativelkov, I believe, is just talking about the broader topic
15:21:40 <rakhmerov> yes
15:21:56 <gokrokve> The nearest production installation is on Novemnber 1st
15:22:13 <gokrokve> Oct 14th a rollout in QA for internal testing.
15:22:22 <ativelkov> then it's better have a consistent UI till that time
15:22:34 <gokrokve> ativelkov: Agree.
15:22:48 <ativelkov> should we rise the priority of this task then?
15:23:03 <gokrokve> Who is release manager for 0.3?
15:23:16 <ativelkov> sergmelikyan,
15:23:18 <gokrokve> Who tracks all required features for it?
15:23:20 <gokrokve> Ok.
15:24:06 <gokrokve> So, please make sure that everybody is in sync with Sergey on what we are going to release. Provide ETA and checkpoints dates.
15:24:06 <sergmelikyan> I am tracking all tasks related to 0.3
15:24:06 <ativelkov> I think we had already passed a feature-freeze for 0.3, however its up to Serg to decide:  probably if it's a simple feature, we may add it
15:24:34 <sergmelikyan> We talking about dedicated Dashboard for Murano?
15:24:47 <ativelkov> #action sergmelikyan to sync on tasks for 0.3
15:24:49 <gokrokve> Timur, you as a QA Lead need to make sure that you know what will be released and you need to have a test plan for that including a time line for testing.
15:25:01 <sergmelikyan> If so, it is quite easy to add and we may add it to 0.3
15:25:15 <ativelkov> #action tsufiev and sergmelikyan to decide if Murano-Panle should be implemented and included into 0.3
15:25:59 <katyafervent> Note that we will need to edit our setup files after adding Murano as a separate panel
15:26:01 <gokrokve> Sergey, please define checkpoints when you can decide to include feature or not depending on feature code availability and stability.
15:26:32 <gokrokve> Track all features and work with engineers on feature statuses.
15:26:48 <ativelkov> Do we have Timur N in the chat right now?
15:26:48 <sergmelikyan> katyafervent, thx - this is important
15:26:55 <sergmelikyan> gokrokve, sure
15:27:20 <ativelkov> #info We will need to edit our setup files after adding Murano as a separate panel
15:27:23 <akuznetsova> Timur is coming
15:27:30 <gokrokve> sergmelikyan: Also check with Timur that he is aware about all features included. Sit with him and check test plan and dates.
15:28:12 <gokrokve> We need to have robust test plan and good tipe frame for testing.
15:28:35 <ativelkov> Here come tnurlygayanov :)
15:28:50 <ativelkov> Timur, we've got some action items for you :)
15:29:44 <ativelkov> #action tnurlygayanov to verify the test plan for release-0.3 and align it with sergmelikyan who is the release owner
15:29:51 <tnurlygayanov> ok )
15:30:08 <rakhmerov> 1 min left?
15:30:19 <ativelkov> nope, we've got a full hour
15:30:25 <ativelkov> so, 30 more minutes
15:30:29 <rakhmerov> oh, cool
15:30:47 <ativelkov> Let's follow up on the progress with our convection activity
15:30:58 <ativelkov> rakhmerov, can you provide an update?
15:31:02 <rakhmerov> sure
15:31:49 <rakhmerov> we actively started discussing convection ideas with harlowja
15:32:30 <rakhmerov> since we've come to similar things in murano we thought it would be great to unite our efforts (and with the rest of community)
15:33:19 <rakhmerov> and decided to start a new project https://launchpad.net/mistral
15:33:43 <gokrokve> Regarding launchpad. Please add more description to the project page.
15:33:50 <rakhmerov> it's officially announced yet, all the organizational things are currently in progress (repo and so forth)
15:33:57 <gokrokve> I've added some content to the wiki page.
15:34:04 <rakhmerov> gokrokve: sure
15:34:06 <gokrokve> Please work with Joshua on that.
15:34:09 <ativelkov> > it's officially announced yet
15:34:12 <tsufiev> rakhmerov, you mean 'not announced'
15:34:15 <ativelkov> do you mean NOT announced?
15:34:22 <rakhmerov> it's not
15:34:23 <rakhmerov> sorry
15:34:34 <gokrokve> Add etherpad pages for DSL and implementation.
15:34:35 <rakhmerov> but I'd like belive we're close to that
15:34:44 <gokrokve> We need to discuss them before publishing.
15:34:58 <gokrokve> Add links for etherpad pages to the wiki
15:35:20 <rakhmerov> gokrokve: we started discussing technical details with the folks
15:35:21 <tsufiev> https://etherpad.openstack.org/p/TaskServiceDesign - here is etherpad link
15:35:22 <ativelkov> #info Joining efforts on workflow management with Joshua Harlow, new project (codenamed "Mistral") to be launched soon
15:35:24 <gokrokve> Probably it is good idea to start adding BPs to launchpad
15:35:25 <rakhmerov> yes
15:36:01 <rakhmerov> I'll add links to wiki
15:36:13 <gokrokve> We are waiting input from Joshua and his managers about announcement text. Once it is done we will publish the announcement.
15:36:36 <gokrokve> Check if Boris Pavlovich can follow up the announcement letter.
15:36:43 <rakhmerov> The wiki page is now empty, it's in my plans to start filling it up with all needed
15:36:43 <ativelkov> We have also suggested a meeting slot for the new project. Waiting for the agreement on that
15:36:54 <ativelkov> gokrokve, what do we need from Boris?
15:37:10 <gokrokve> We need to create a good visibility for openstack community for Mistral.
15:37:41 <rakhmerov> we can talk to him
15:37:52 <gokrokve> We need a follow up letter as a reply to announcement. We need his input\feedback about this project and how it can help other projects.
15:38:17 <rakhmerov> good idea
15:38:19 <ativelkov> sure, we may ask him to do that
15:38:23 <gokrokve> Also ask Sergey Lukyanov for a feedback.
15:38:28 <rakhmerov> sure
15:38:36 <gokrokve> I know thay were thinking about taskflow
15:38:53 <ativelkov> #action ativelkov to ask SergeyLukjanov and Boris Pavlovich for the feedback on Mistral announcement
15:39:11 <SergeyLukjanov> ativelkov, howdy
15:40:16 <gokrokve> Think about use cases for Mistral. I see a good value in scheduling part. Backup is still a pain in OpenStack. This is a good step forward if we can schedule a task which can do backup.
15:40:30 <gokrokve> This is just an example of one potential use case.
15:40:43 <ativelkov> sounds a good idea
15:40:46 <rakhmerov> yes
15:41:03 <ativelkov> #info Scheduling a backup may be a good example of Mistral use-case
15:42:54 <ativelkov> So, it seems like we are done with our agenda. Does anybody have anything to discuss?
15:43:53 <rakhmerov> just some more technical details on Mistral
15:44:26 <gokrokve> Metadata repository. Do we have a general view about metadata repo sync between them?
15:44:52 <gokrokve> Is there versioning for workflows?
15:45:23 <rakhmerov> I believe we'll have to look closely at TaskFlow library first and try to use it for Mistral. That's our current vision
15:45:45 <rakhmerov> so we're planning to use the most part of its capabilities
15:46:08 <ativelkov> gokrokve, not yet. That's a first version, it is intended to be as simple as possible. We've designed an "import service" and "export service" operations, they can be used for synchronization
15:47:09 <tsufiev> ativelkov, according to the current spec, each Service Definition has a versioned format of manifest file and a version of Service itself
15:47:39 <ativelkov> tsufiev, that is different
15:48:00 <ativelkov> format version is just a version of the spec itself
15:48:49 <ativelkov> version of the service is a stub: when we store the manifests in the database, we will be able to store multiple versions of the manifests
15:48:55 <tsufiev> ativelkov, ok, guess we should not tie spec version to workflows one
15:49:13 <ativelkov> however, having different versions of workflows is much more complicated
15:49:38 <gokrokve> ok
15:49:41 <ativelkov> we'll need to discuss if we really want that with the current spec of metadata
15:49:46 <gokrokve> Lets keep it simple for now.
15:49:57 <ativelkov> ok
15:50:02 <gokrokve> Will implement this differently in SC.
15:50:10 <ativelkov> sure
15:50:25 <ativelkov> anything else for this meeting?
15:50:27 <rakhmerov> one more thing on Mistral: the current suggested time for community meetings is "Mondays at 16.00 UTC"
15:50:31 <gokrokve> Not from my side.
15:51:32 <rakhmerov> seems like we're done :)
15:51:50 <ativelkov> ok, thanks everybody
15:51:55 <ativelkov> #endmeeting