15:00:43 <ativelkov> #startmeeting Murano
15:00:43 <openstack> Meeting started Mon Oct 21 15:00:43 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <gokrokve> Hi Alex
15:00:46 <openstack> The meeting name has been set to 'murano'
15:00:48 <katyafervent> Hi guys!
15:00:53 <akuznetsova> Hello
15:00:56 <sergmelikyan> Hi!
15:01:03 <tsufiev> hi there
15:01:18 <ativelkov> Cool, lot's of people )
15:01:21 <stanlagun> hi all!
15:01:39 <ativelkov> We have an agenda here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
15:02:00 <ogelbukh> o/
15:02:14 <ativelkov> So, let's start with the review of the previous week's AIs
15:02:21 <ativelkov> #topic AI review
15:02:43 <ativelkov> Here we have this list: http://eavesdrop.openstack.org/meetings/murano/2013/murano.2013-10-14-15.01.html
15:03:49 <ativelkov> So, about backporting of our Heat patches: according to Heat team, these were not bugs, but rather features, so backporting of them to grizzly branch is forbidden
15:04:15 <ativelkov> so, we will not be able to commit our backports to official grizzly branch
15:05:07 <ativelkov> That is why we will have to distribute release 0.3 either without quantum support at all, or include patches to Heat with our distribution
15:06:09 <katyafervent> Does this fix present in havana? Do we fully support it?
15:06:12 <ativelkov> Of course, we may use custom for of Heat repository for this as well, but this is not a good practice and should be avoided for public releases
15:06:31 <ativelkov> katyafervent, Most of them are present, yes
15:06:41 <ogelbukh> eltn
15:06:50 <ogelbukh> oh
15:07:12 <ativelkov> however, there was one fix (made by sergmelikyan) which did not get accepted before the check-in gate was closed, so it will get only to icehouse branch
15:08:14 <gokrokve> Can we offer quantum as optional for release 0.3?
15:08:23 <ativelkov> gokrokve, yes, I think so
15:08:33 <gokrokve> I mean on the code level are there any hard dependencies for Quantum?
15:08:50 <ativelkov> Not on the code level
15:09:08 <ativelkov> And the question is not quantum itself
15:09:20 <ativelkov> question is limited support for quantum in Heat
15:10:04 <tnurlygayanov> so, we will not support nova network in release-0.3....
15:10:11 <ativelkov> for example, grizzly Quantum support security groups on the port level, but grizzly Heat does not fully support this feature
15:10:32 <ativelkov> tnurlygayanov, I would suggest to support it "out-of-the-box"
15:11:23 <ativelkov> I mean, the default templates which we distribute with Murano should be targeting Nova Network
15:11:32 <tnurlygayanov> ativelkov: but we should have prepared patch for this
15:11:40 <ativelkov> but we should include an archive with the quantum-ready templates
15:11:51 <tnurlygayanov> yes
15:12:28 <ativelkov> and include a manual how to a) substitute the NN templates with the Quantum ones b) patch Heat
15:12:53 <ativelkov> by the way, NN templates will work with Quantum as well, but the set of functionality will be different
15:13:21 <tnurlygayanov> it is should be 'one magic command', not complex document )
15:13:43 <gokrokve> Still it should be documented in installation guide.
15:13:54 <ativelkov> #info  The default templates which we distribute with Murano should be targeting Nova Network,  but we will include an archive with the quantum-ready templates and ways to migrate and patch the Heat
15:14:19 <ativelkov> gokrokve, yes, we should provide a detailed explanation
15:14:44 <ativelkov> patching an infrustructure-level component should not be done blindly
15:15:07 <ativelkov> but an easy-to-use authomation script is also a good idea
15:15:20 <akuznetsova> btw I created task in jira that we need to update our documentation before release
15:15:34 <ativelkov> Thanks, akuznetsova
15:16:20 <ativelkov> Two other action items are related to r0.3 task synchronization. sergmelikyan, can you provide an update on the release status and what is going to be included there?
15:17:29 <sergmelikyan> We had synchronized all tasks for 0.3
15:18:38 <ativelkov> what about Murano Panel? Have you decided if it should be part of 0.3 or not?
15:19:21 <sergmelikyan> We have several major features: Support for Managing Linux Instances, Usage of Quantum and ability to mark images in glance via UI
15:19:47 <sergmelikyan> Panel (actually Dashboard in terms of Horizon) not going to be introduced in 0.3
15:20:12 <tsufiev> ativelkov: it is simple to implement on its own, but can potentially break many things in 0.3
15:20:19 <ativelkov> so, we'll have the same UI layout for 0.3?
15:20:32 <tsufiev> ativelkov: yes
15:21:06 <ativelkov> #info new leyout of Murano Dashboard will not be included with the release 0.3 and is postponed till 0.4
15:21:46 <ativelkov> OK, next AI (we have quite a lot of them btw)
15:22:01 <ativelkov> tnurlygayanov, what about the test plan for release-0.3?
15:23:06 <tnurlygayanov> ativelkov: we are working on it...
15:23:36 <ativelkov> any estimations?
15:23:49 <tnurlygayanov> and also on automated testing for all services and new workflows with automated testing inside the workflows.
15:24:17 <tnurlygayanov> yes, I plan to finish for 2 days.
15:24:34 <tnurlygayanov> and it will not only for release-0.3 test plan, also for 0.4 too.
15:24:43 <ativelkov> #info Release 0.3 test plan is in progress, as well as updated automation testing scenarios. The ETA is 2 days
15:24:48 <ativelkov> good, thanks
15:25:54 <ativelkov> Last AI is on me
15:26:20 <ativelkov> I asked Boris to do some follow up on Mistral announcement
15:26:46 <ativelkov> It turns out that he didn't get enough time for this, as he is quite busy with his own releases
15:27:00 <ativelkov> But we still get some community responses to the announcement
15:27:38 <rakhmerov> can we ask him provide some feedback on the tech docs we have?
15:28:05 <ativelkov> I asked, but he said that he is too busy now, probably later
15:28:07 <rakhmerov> his opinion should be valuable due to his specific experience
15:28:33 <ativelkov> As far as I understood he is interested in Taskflow library, so he should probably have some attention to Mistral as well
15:28:33 <rakhmerov> yes, I know but I meant ask him to do that before the next meeting or so
15:28:44 <ativelkov> I'll try
15:28:50 <rakhmerov> ok, thanks
15:29:10 <ativelkov> So, seems like we are done with AIs
15:29:30 <gokrokve> Did we test Linux Agent?
15:29:40 <gokrokve> Is it ready for delivery?
15:29:41 <ativelkov> Yes
15:29:56 <ativelkov> But with quite a simple scenario by now
15:30:06 <gokrokve> Do we have example workflow for it?
15:30:12 <ativelkov> we simply deploy telnet
15:30:23 <ativelkov> #topic Release-0.3
15:31:03 <ativelkov> #info LinuxAgent is ready to be delivered in Release-0.3, with simplest possible deployment workflow
15:31:46 <ativelkov> sergmelikyan, do we have anything important to discuss about 0.3?
15:32:03 <ativelkov> what are the open issues there, etc?
15:33:06 <rakhmerov> sorry, a quick note/question: as for LinuxAgent, should we start calling it PythonAgent meaning it can be used not on Linux only?
15:33:19 <gokrokve> Yes.
15:33:20 <rakhmerov> or it's already been discussed and approved?
15:33:47 <ativelkov> well, we were calling it Unified (vNext) Agent
15:33:52 <gokrokve> LinuxAgent is not an official name. We use it just to highlight that it works on Linux.
15:34:11 <gokrokve> remove vNext. Nobody understands that.
15:34:17 <rakhmerov> right, however it may get people confused
15:34:29 <rakhmerov> who is right here, ha :)
15:35:14 <rakhmerov> Unified Agent seems to be ok
15:35:21 <sergmelikyan> ativelkov, right now we don't have any outstanding issues
15:35:25 <rakhmerov> sorry for interrupting, back to open issues
15:36:13 <ativelkov> sergmelikyan, what are our estimation on release date?
15:36:14 <katyafervent> So we just selected official  name - Unified Agent?
15:36:41 <rakhmerov> I would suggest so
15:36:58 <stanlagun> I guess official name for Murano Agent is Murano Agent :)
15:37:13 <ativelkov> katyafervent, the idea is that we have a unified agent specification (the one which is available at https://wiki.openstack.org/wiki/Murano/UnifiedAgent)
15:38:09 <ativelkov> the name of the exact implementation does not matter much, as we expect that other implementations may appear
15:38:13 <sergmelikyan> ativelkov, end of October, first days of November
15:38:22 <ativelkov> sergmelikyan, thanks
15:38:59 <ativelkov> #info Release0.3 is on its way, no outstanding issues, release planned to end of October-beginning of November
15:39:35 <ativelkov> Ok
15:39:47 <ativelkov> #topic Networking Changes for 0.4
15:40:02 <ativelkov> So, we have an important question to discuss
15:40:25 <ativelkov> It turns oput that we will to introduce a new major feature in Release 0.4
15:40:31 <ativelkov> turns out*
15:41:13 <ativelkov> In quantum-enabled version of 0.3 we have isolated each environment into is own L2-segment
15:42:02 <ativelkov> I.e. each env creates its own network with its own subnet, then creates a router and then plugs this router to some external network
15:42:25 <gokrokve> Did you test that with Quantum VM still able to communicate with RabbitMQ?
15:42:51 <ativelkov> Yes, sure
15:43:00 <ativelkov> the deployments are successfull
15:43:25 <ativelkov> The problem is with the IP range of the external network
15:43:37 <ativelkov> Our approach means one router per environment
15:43:59 <ativelkov> and each router in external network obviously consumes 1 IP address from its range
15:44:13 <ativelkov> And these IP{ addresses are quite a valuable resource
15:44:32 <ativelkov> The proper way of doing these should be different
15:44:41 <ativelkov> we should have a single Router per tenant
15:45:08 <ativelkov> and plug all the Networks of this tenant into this router
15:45:43 <ativelkov> But to do this we will have to define non-overlapping subnets
15:46:03 <tnurlygayanov> probably we can configure some 'murano' router and assign all networks to this router
15:46:24 <ativelkov> tnurlygayanov, the proper solution should be more complex
15:46:31 <tnurlygayanov> and user will select new network range for new environment
15:46:49 <tnurlygayanov> ok) need to describe arch in images
15:47:00 <tnurlygayanov> it will more clear for everyone
15:47:41 <ativelkov> Yes. I am writing a new document on this topic right now
15:47:59 <gokrokve> ok. We need to document this. It is not self obvious about Quantum networking topologies.
15:48:08 <ativelkov> #action ativelkov to complete the "Per Environment Network Management" document
15:48:14 <rakhmerov> so we should have something like subnet booking mechanism?
15:48:23 <ativelkov> rakhmerov, yes
15:48:29 <rakhmerov> gotcha
15:48:45 <ativelkov> Also, we should allow the user to select an existing network for the new environment
15:49:01 <ativelkov> (we had similar blueprint for security groups)
15:49:13 <ativelkov> but this should be an advanced option
15:49:14 <rakhmerov> probably we could provide two options and let the users make a choice
15:49:21 <ativelkov> yup
15:49:28 <rakhmerov> one the options is by default
15:49:35 <ativelkov> but the default should be simple and secure
15:49:41 <rakhmerov> right
15:50:17 <ativelkov> e.g. by default, a new network is created per environment, as subnet is allocated accordign to the existing subnets, and the network is plugged to some default router
15:50:54 <ativelkov> and in advanced scenarios user will be able to override any of these defaults (i.e. choose existing network, or modify the ip range, or choose the router, etc)
15:51:15 <ativelkov> As I said, I will complete the spec and will submit the blueprint
15:51:42 <rakhmerov> ok
15:51:44 <ativelkov> Seems like we are done with this topic, let's move on
15:51:49 <ativelkov> #topic Open Discussion
15:51:54 <ativelkov> :)
15:52:07 <rakhmerov> the most pleasant one :)
15:52:31 <ativelkov> yeah. So, any questions, guys?
15:53:34 <katyafervent> Nope, thanks for making all questions clear
15:54:09 <ativelkov> Alright, so we are probably done
15:54:27 <ativelkov> Just do not forget that we have a Mistral meeting in 6 minutes
15:54:36 <rakhmerov> yes, sure
15:54:44 <ativelkov> It's in different channel, #openstack-meeting
15:54:45 <tnurlygayanov> ok ) got to the next meeting )
15:54:46 <sergmelikyan> And in another channel ;)
15:55:08 <ativelkov> so, thanks for joining and see you soon
15:55:12 <ativelkov> #endmeeting