15:00:10 <sergmelikyan> #startmeeting Murano
15:00:11 <openstack> Meeting started Mon Oct 28 15:00:10 2013 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'murano'
15:00:59 <sergmelikyan> Welcome to Murano Project community meeting!
15:01:03 <ogelbukh> hi sergmelikyan
15:01:03 <rakhmerov> Hi!
15:01:10 <ogelbukh> redthrux: o/
15:01:14 <ogelbukh> oop
15:01:17 <ogelbukh> s
15:01:20 <akuznetsova> hello
15:01:28 <sergmelikyan> Let's start with agenda :)
15:01:38 <ativelkov> hi guys
15:01:42 <sergmelikyan> 1) Action Items's review
15:01:52 <sergmelikyan> 2) Release 0.3 Status
15:02:03 <sergmelikyan> 3) Quantum Integration issues
15:02:12 <sergmelikyan> 4) LoadBalancer issues
15:02:34 <katyafervent> Hi!
15:02:36 <tsufiev> hi there
15:02:36 <sergmelikyan> #topic Review AI's
15:02:54 <sergmelikyan> Last meeting summary is available here: http://eavesdrop.openstack.org/meetings/murano/2013/murano.2013-10-21-15.00.html
15:02:58 <gokrokve> Hi
15:03:05 <ativelkov> I think we have just one AI from last meeting ) And its on me
15:03:20 <sergmelikyan> We have only one AI assigned to Alexander Tivelkov:  complete the "Per Environment Network Management" document
15:03:27 <sergmelikyan> ativelkov, yep )
15:03:28 <sergmelikyan> Status?
15:03:32 <ativelkov> Yap. It's done
15:03:43 <sergmelikyan> link?
15:03:56 <ativelkov> here it is: https://wiki.openstack.org/wiki/Murano/Specifications/Network_Management
15:04:19 <sergmelikyan> #link  https://wiki.openstack.org/wiki/Murano/Specifications/Network_Management "Per Environment Network Management" document
15:04:27 <sergmelikyan> #link https://wiki.openstack.org/wiki/Murano/Specifications/Network_Management "Per Environment Network Management" document
15:04:32 <ativelkov> It may (and will) be improved to reflect our recent findings related to different neutron topology issues
15:04:49 <ativelkov> but the general idea is reflected there
15:04:50 <sergmelikyan> #topic Release 0.3 Status
15:05:21 <sergmelikyan> As release manager for 0.3 i believe it is on me :)
15:05:23 <tnurlygayanov> I suggest to create etherpad to discuss this document
15:05:42 <katyafervent> Thank you, Alex, that's already pretty informative
15:05:48 <sergmelikyan> tnurlygayanov, we need discussion?
15:06:31 <ativelkov> we may want to discuss various changes related to different neutron deployment scenarios
15:06:51 <tnurlygayanov> yes
15:07:11 <tnurlygayanov> because we should support different quantum configurations
15:07:13 <ativelkov> So, I'll create an ether pad to reflect that idea. But if somebody has any questions on the current vision - feel free to create Etherpad yourselves
15:07:22 <sergmelikyan> #action ativelkov, Create collaborative document for "Per Environment Network Management" document
15:07:28 <ativelkov> ok )
15:07:58 <sergmelikyan> Let's return to release 0.3 :)
15:08:53 <tnurlygayanov> ok, what the status of this release? what we should do beforethe release date? )
15:09:13 <sergmelikyan> We finished all features for release 0.3, encountered issue with Heat (load balancer related) that we can't fix in this release.
15:10:03 <tnurlygayanov> ok, feature freeze for this release ) need to test and check on different OpenStack installations...
15:10:33 <tnurlygayanov> we have many fixes for SSL configuration in this release
15:10:35 <sergmelikyan> We going to discuss this issue later, and we only have to finish documentation changes for release-0.3 and prepare custom patches for Heat & Quantum for thus who want to have full features of Murano v0.3
15:12:04 <sergmelikyan> tnurlygayanov, AFAIK we does not have any fixes related to issues from previous release.
15:12:49 <sergmelikyan> All fixes related either to functionality implemented in this release or to Heat
15:13:04 <sergmelikyan> So, release 0.3 is on-track
15:13:10 <sergmelikyan> Questions?
15:13:36 <ativelkov> Estimated release date?
15:13:40 <katyafervent> Nope, we are clear on that
15:13:58 <katyafervent> Yeah, except date
15:14:08 <sergmelikyan> ativelkov, November 15
15:14:22 <ativelkov> OK, so - after summit. I see
15:14:47 <sergmelikyan> If no issues going to arise we may release 0.3 sooner.
15:15:01 <tnurlygayanov> and what date for release-0.4 ?
15:15:29 <sergmelikyan> ativelkov, release 0.3 targets Stable/Grizzly so it is not so important to have release before summit.
15:15:40 <tnurlygayanov> yes
15:16:35 <sergmelikyan> And one of our news for todays meeting is news about Timur Sufiev assigned as release manager for 0.4
15:16:47 <sergmelikyan> So, tsufiev, what about dates?
15:17:34 <tsufiev> tnurlygayanov: it was originally tied to Fuel 4.0 release which is on 11.11.13
15:18:19 <sergmelikyan> I believe we going to have some beta version integrated with Fuel 4.0 beta that is going to shown on summit
15:18:27 <tnurlygayanov> yes, but as I know release of Fule Web 4.0 was moved on 18.11 (or later)
15:18:31 <tsufiev> but i've heard Fuel 4.0 will be shifted a week or so, so we have to reschedule it later once we have more precise release date for Fuel
15:18:58 <sergmelikyan> tnurlygayanov, there are no official dates for now :(
15:19:05 <tnurlygayanov> yes..
15:19:13 <tnurlygayanov> ok)
15:19:14 <akuznetsova> so, Is release 0.4  earlier release 0.3 ?
15:19:25 <igormarnat_> Nope
15:20:00 <sergmelikyan> akuznetsov, certainly no :) But this version going to be released in very close dates
15:20:06 <sergmelikyan> *versions
15:20:11 <igormarnat_> We are going to release 0.3 relatively soon, 0.4 comes after that. What's clear now is that we need to have working alpha version based on Havana by Nov, 11
15:20:32 <tnurlygayanov> yes
15:20:39 <akuznetsova> ok, thanks
15:20:49 <tsufiev> igormarnat_: yes, it is quite possible
15:21:10 <sergmelikyan> moving on :)
15:21:25 <sergmelikyan> Other questions? Or moving to the next topic?
15:21:44 <ativelkov> next topic please ))
15:22:17 <sergmelikyan> #info Release Murano v0.3 on November 15 (or sooner)
15:22:43 <sergmelikyan> #info We going to have working alpha version based on Havanna by Nov, 11
15:23:19 <sergmelikyan> #topic Quantum Integration issues
15:23:57 <sergmelikyan> ativelkov, as topic-starter, could you provide some small hint about what issues exactly this topic? :)
15:24:13 <igormarnat_> Wow, great topic. Any issues with Quantum integration?
15:24:16 <ativelkov> Well, this is about our resent findings with network topologies
15:24:41 <ativelkov> Yeah, igormarnat_ , we've got one )
15:25:21 <ativelkov> Briefly speaking, Quantum/Neutron may be used to deploy different network topologies
15:25:39 <sergmelikyan> Quantum may be deployed/configured as "Mixed Flat and Private Network" not all Murano features may handle this
15:26:11 <ativelkov> like "One flat network for everything", "Dedicated network segments with routers for each environment" and everything in between
15:26:29 <ativelkov> We assumed the last one
15:26:32 <igormarnat_> Does it require evolvement of other components, external to Murano?
15:26:36 <sergmelikyan> And otherwise, when Quantum is configured as " Per-tenant Routers with Private Networks" we have issues with Load Balancer related services (on this topic later)
15:26:54 <ativelkov> Let me answer a single question at a time)
15:27:34 <ativelkov> So, we assumed that we have isolated network segments for each environment, and routers to uplink them to external network
15:27:35 <sergmelikyan> #save
15:28:01 <ativelkov> It turned out that not all the configurations of Quantum/Neutron support this
15:28:27 <ativelkov> In some cases, when Neutron is configured to support only flat networks, they do not have "L3-agent" enabled
15:28:37 <ativelkov> or something like this, don't remember exact details)
15:28:47 <ativelkov> So, e cannot create routers
15:28:55 <ativelkov> or, we create them, but they do not work as expected
15:30:17 <tnurlygayanov> probably we can just suggest user to select already configured network for all instances in the current environment
15:30:32 <ativelkov> not in release-03
15:30:37 <tnurlygayanov> yes
15:30:40 <ativelkov> we'll use it in 0.4
15:30:58 <ativelkov> but in 0.3 we have a simple option: disable all this sophisticated networking stuff
15:31:10 <tnurlygayanov> Can we finish this feature for 11/11?
15:31:21 <ativelkov> and join our instances to all available networks without routers
15:31:28 <ativelkov> tnurlygayanov: I am working on that
15:31:40 <tnurlygayanov> ok
15:31:51 <igormarnat_> but this depends on evolvement of external components, isn't it?
15:32:04 <ativelkov> igormarnat_: no
15:32:13 <ativelkov> this is not a bug in quantum
15:32:20 <ativelkov> this is just a configuration
15:32:29 <tnurlygayanov> ativelkov: we tested this and this is does not work with different network configurations....
15:32:31 <ativelkov> it is perfectly fine for them not to support that
15:33:06 <ativelkov> we just need to be ready to react to different configurations in quantum
15:33:23 <igormarnat_> I've heard something about missing possibility to pass parameters for sophisticated networking configurations to Heat or something, isn't this the case?
15:33:47 <sergmelikyan> igormarnat_, it is about our next issue - Load Balancer
15:34:26 <igormarnat_> Oh, it was _previous_ issue. So we have _two_ issues, aren't we?
15:34:39 <ativelkov> yeah
15:35:45 <sergmelikyan> ativelkov, could you summarize once more about Quantum Integration issue?
15:35:54 <ativelkov> Ok, so, here it is:
15:35:55 <sergmelikyan> And public as info?
15:37:01 <ativelkov> #info: Murano currently only supports "Per-tenant Routers with Private Networks" quantum configuration. In case if quantum is not configured for that, current Murano templates do not work
15:37:58 <ativelkov> #action: For release 0.3 we need to include both sets of templates (quantum- and non-quantum) to the distribution, and modify the manifests to use either version depending on the quantum configuration
15:38:34 <ativelkov> #action: For release 0.4 we will introduce a unified logic to properly choose the right configuration right in the workflow
15:38:54 <ativelkov> that's all )
15:39:01 <sergmelikyan> Any question? :)
15:39:25 <igormarnat_> That's was all for the first issue, right?
15:39:30 <ativelkov> yes
15:39:45 <igormarnat_> Ok, no questions. What about second one?
15:40:06 <sergmelikyan> #topic Load Balancer Issue
15:40:57 <sergmelikyan> I will describe the issue and our options :) Don't rush with questions )
15:42:59 <sergmelikyan> #info Current implementation of services IIS Web Farm and ASP.NET App Web Farm completely is based on Heat AWS::ElasticLoadBalancing::LoadBalancer resource
15:44:07 <sergmelikyan> #info AWS::ElasticLoadBalancing::LoadBalancer resource does not support any network related configuration
15:44:23 <katyafervent> And it changed?
15:44:59 <sergmelikyan> So our * Web Farm services does not work when Quantum is configured as "Per-tenant Routers with Private Networks"
15:45:42 <sergmelikyan> Solution for now (release 0.3): disable all network configuration features
15:45:49 <sergmelikyan> katyafervent, ?
15:46:30 <katyafervent> AWS::ElasticLoadBalancing::LoadBalancer , but now I see, thanks
15:46:45 <sergmelikyan> To fix this issue we need to implement  network related configuration feature in  AWS::ElasticLoadBalancing::LoadBalancer resource
15:47:13 <sergmelikyan> (this means implement feature in Heat)
15:47:28 <ativelkov> another option: implement our own (HAProxy-based) load balancer
15:47:40 <sergmelikyan> ativelkov, right
15:47:54 <sergmelikyan> We need to discuss this issue with Heat team and they plans.
15:48:15 <sergmelikyan> #action Discuss with Heat team future of  AWS::ElasticLoadBalancing::LoadBalancer resource
15:49:20 <ativelkov> I would suggest to first check how it behaves in Havana
15:49:28 <sergmelikyan> And based on the reply from Heat we may implement in either as our own service based on HAProxy, or extend AWS::ElasticLoadBalancing::LoadBalancer resource
15:49:30 <ativelkov> this seems to be changed since grizlly
15:50:27 <sergmelikyan> ativelkov, seems reasonable, next release of Murano is going to target Havanna, and in release 0.3 it is Known Issue in case with "Per-tenant Routers with Private Networks"
15:50:54 <sergmelikyan> #action check AWS::ElasticLoadBalancing::LoadBalancer behaviour in Havanna
15:51:11 <sergmelikyan> Any question about this topic?
15:51:24 <sergmelikyan> #save
15:51:26 <ativelkov> Yes, and our workaround for quantum issue works this out as well
15:52:30 <sergmelikyan> so, moving on...
15:52:40 <sergmelikyan> #topic Open Discussion
15:52:57 <sergmelikyan> We have another 8 minutes before meeting going to finish
15:53:02 <sergmelikyan> :)
15:55:56 <igormarnat_> Are there uncovered topics yet in the agenda?
15:56:12 <sergmelikyan> igormarnat_, no
15:57:40 <sergmelikyan> Then let's finish
15:57:40 <sergmelikyan> #endmeeting