15:01:46 <sergmelikyan> #startmeeting Murano
15:01:46 <openstack> Meeting started Mon Nov 11 15:01:46 2013 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:49 <tnurlygayanov> Hi )
15:01:50 <openstack> The meeting name has been set to 'murano'
15:01:54 <tsufiev> hi!
15:02:01 <sergmelikyan> Hi, guys!
15:02:02 <gokrokve> Hi
15:02:06 <akuznetsova> hi there
15:02:22 <sergmelikyan> Todays agenda, as always, is available on wiki - https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:02:30 <sergmelikyan> Agenda:
15:02:35 <sergmelikyan> Quick News (summit summary)
15:02:41 <sergmelikyan> Action Items review
15:02:52 <sergmelikyan> Status of release 0.3/0.4
15:02:59 <sergmelikyan> LoadBalancer Issue
15:03:04 <sergmelikyan> Solum Integration
15:03:09 <sergmelikyan> OpenDiscussion
15:03:20 <sergmelikyan> #topic Quick News
15:03:40 <sergmelikyan> gokrokve, what about some news related to Murano from the summit? :)
15:03:50 <gokrokve> Yep, sure.
15:04:24 <gokrokve> We did unconference presentation and discussion about Murano course changing to Application Catalog.
15:04:33 <gokrokve> This announcement was well accepted.
15:05:27 <gokrokve> I've got couple feedbacks that Murano now is associated with Windows deployment, so we will have to spread information about new mission of Murano among the community.
15:05:38 <igormarnat> Hi there
15:06:17 <gokrokve> There is a demand for Application Catalog and at least two companies told us that they think or do something in this direction.
15:07:21 <gokrokve> I will continue to work with them in order to join our efforts.
15:07:24 <igormarnat> I've heard of three actually:)
15:07:39 <gokrokve> Probably three :-)
15:08:00 <gokrokve> We had two representative and one rumor :-)
15:08:22 <igormarnat> LGTM
15:08:49 <igormarnat> Gosha, we need to put together and distribute over the mailing list  AIs and agreements achieved in HK
15:09:01 <gokrokve> Sure.
15:09:04 <sergmelikyan> Cool, this proves that we going to the right direction
15:09:36 <igormarnat> gokrokve: will you be doing it or do I take it as an AI?
15:09:39 <gokrokve> Yes, It appeared that this is important direction for the community.
15:10:12 <sergmelikyan> #action: gokrokve, Put together and distribute over the mailing list  AIs and agreements achieved in HK
15:10:17 <gokrokve> Let's do this from both sides. I will prepare my list, and you will prepare your list. Then we will merge them.
15:11:08 <gokrokve> So, what is the current status with Murano development? How is integration with Fuel?
15:11:23 <katyafervent> Yes, I think we need to communicate more with the community
15:11:32 <igormarnat> +1
15:11:56 <igormarnat> Let's figure out the status of integration from Serge, after that from Timur
15:12:19 <katyafervent> It was some heat related problems but sergmelikyan resolved them :)
15:12:24 <sergmelikyan> Let's start with reviewing our AI's from the last meeting )
15:12:30 <tsufiev> gokrokve: Max Mazur has built rpm-packages for the Fuel, we have Murano dashboard working, Service draft is able to be created...
15:12:55 <tsufiev> but it wasn't able to deploy due to heat/keystone problem
15:12:55 <sergmelikyan> Release status is our third topic for today :)
15:13:07 <igormarnat> Let's follow the agenda then
15:13:10 <sergmelikyan> #topic Action Items review
15:13:39 <sergmelikyan> Action items from previous meeting is available here - http://eavesdrop.openstack.org/meetings/murano/2013/murano.2013-10-28-15.00.html
15:13:51 <sergmelikyan> *are
15:14:29 <sergmelikyan> First one is related to the  "Per Environment Network Management" document
15:15:26 <sergmelikyan> Alexander is not available today, and I am not sure that he is created etherpad for this document, but I know that he is finished implementation/
15:16:02 <tsufiev> sergmelikyan: are you talking about advanced networking?
15:16:06 <gokrokve> Cool. When will we have a metadata service?
15:16:11 <sergmelikyan> tsufiev, Yes
15:16:45 <sergmelikyan> gokrokve, it is already available, but implementation going to be finished and released with release 0.4
15:16:59 <sergmelikyan> Most of the work is already done
15:17:12 <tsufiev> sergmelikyan: me and Stan Lagun have reviewed it, it has to be changed a bit
15:17:57 <gokrokve> ok
15:18:06 <sergmelikyan> tsufiev, yes, and I believe that all comment going to be resolved  till the next week
15:18:08 <gokrokve> Do we have UI part for it?
15:18:15 <sergmelikyan> Next AI: For release 0.3 we need to include both sets of templates (quantum- and non-quantum) to the distribution, and modify the manifests to use either version depending on the quantum configuration
15:18:23 <tsufiev> sergmelikyan: yes
15:18:33 <katyafervent> ?? ???? ?? ?? ????????
15:18:34 <gokrokve> I mean, we have to do some review from Joel.
15:18:46 <katyafervent> UI part is in progress
15:18:49 <tsufiev> gokrokve: no, UI for advanced networking is planned for next release
15:18:55 <gokrokve> Ok.
15:19:18 <gokrokve> I was talking about metadata service.
15:19:42 <sergmelikyan> About out AI - We had prepared and committed two sets of workflows designed for two use-cases.
15:19:47 <tsufiev> gokrokve: we're currently working on admin UI, plan to finish it by the end of the week
15:19:59 <gokrokve> cool.
15:20:17 <katyafervent> For metadata UI we'll have some features that is not implemented in horizon so we need to do some things that we need
15:20:38 <gokrokve> We will probably need to move this meeting. It is 7 AM in CA.
15:20:48 <gokrokve> Nobody from west coast will attend it.
15:21:10 <igormarnat> Yeah, this is not good
15:21:21 <tsufiev> there is a Mistral meeting planned on 8pm
15:21:34 <igormarnat> Let's assign the AI to Serge to figure out if there's another timeslot available
15:22:10 <sergmelikyan> AI: Find new available timeslot for Murano meeting that is later then current one.
15:22:28 <sergmelikyan> #action, Serg: Find new available timeslot for Murano meeting that is later then current one.
15:22:31 <katyafervent> I suggest to move meeting to our morning
15:22:48 <katyafervent> so it will be evening there
15:23:04 <tsufiev> Sunday evening, i think :)
15:23:15 <sergmelikyan> :)
15:23:45 <sergmelikyan> Let's move to our next AI ))
15:24:03 <sergmelikyan> Next AI: Discuss with Heat team future of AWS::ElasticLoadBalancing::LoadBalancer resource
15:24:11 <stanlagun> So that nobofy from our side will attend it :)
15:24:55 <igormarnat> [still speaking of meetings] I'd rather consider another day but keeping time about 8-9 AM Pst
15:25:11 <sergmelikyan> We discussed this with Heat, and found that we have three options that we may implement to fix issues with Load Balancer based resource. We going to discuss this issue later today
15:25:47 <sergmelikyan> Next AI: AWS::ElasticLoadBalancing::LoadBalancer behaviour in Havanna
15:26:00 <sergmelikyan> Result: same as in Grizzly
15:26:19 <sergmelikyan> Aaaand we finished with our AI's from previous meeting.
15:26:41 <sergmelikyan> Any questions? And we may move to the most hot topic today - release status.
15:27:17 <tnurlygayanov> do we plan to base server farms on AWS::ElasticLoadBalancing::LoadBalancer?
15:27:39 <sergmelikyan> We going to discuss this today (in this meeting) today :)
15:28:24 <sergmelikyan> So, moving on...
15:28:33 <sergmelikyan> #topic Status of release 0.3/0.4
15:29:08 <sergmelikyan> I am responsible for release 0.3, so status is on me for this release.
15:29:50 <igormarnat> gokrokve became all ears:)
15:30:32 <IgorYozhikov> I suggest that we can try to implement LB through the workflow and Linux agent
15:31:17 <sergmelikyan> Our release in testing, we finished with development and now we are on testing phase. We found issue that preventing to receive big messages from RabbitMQ on Linux with SSL enabled and  Puka/Pika as a client. Stan is working on fix for this issue (currently we verifying already provided fix)
15:31:21 <tnurlygayanov> but why we should implement "one more load balancer"?
15:31:52 <sergmelikyan> guys, we going to return to the "Load Balancer" theme
15:31:59 <tnurlygayanov> ok)
15:32:01 <igormarnat> Folks, let's stick to the agenda and get finished with release status
15:32:02 <sergmelikyan> later, please )
15:32:50 <sergmelikyan> And this is all for release 0.3, I believe. No other issues for now.
15:32:56 <gokrokve> So, are we on track with 0.3 release?
15:33:12 <sergmelikyan> As soon as we finish with testing we going to release our Murano 0.3
15:33:13 <gokrokve> When will we have release candidate available for testing?
15:33:20 <sergmelikyan> gokrokve, Yes, release date is Nov 15
15:33:51 <gokrokve> It means, that RC build should be already in testing phase.
15:34:01 <sergmelikyan> gokrokve, this is right.
15:34:04 <gokrokve> Timur, what is your feedback on the release?
15:34:13 <gokrokve> What is the testing status?
15:35:28 <sergmelikyan> tnurlygayanov,
15:36:02 <tnurlygayanov> ok, so...
15:36:39 <tnurlygayanov> we have the complete testing cycle for all components
15:37:06 <tnurlygayanov> and we already checks all components with integration tests
15:37:37 <tnurlygayanov> we have some issues with ssl
15:38:29 <tnurlygayanov> we have different automated testing jobs in CI system https://murano-ci.mirantis.com/
15:38:43 <tnurlygayanov> and we can monitor the staus on this page
15:39:08 <tnurlygayanov> my feedback that all works fine, but we have some issues:
15:39:32 <tnurlygayanov> 1. SSL with Rabbit MW and linux agents (fix in progress)
15:40:03 <tnurlygayanov> 2. Performance of Murano API service (will be fixed in the next releases)
15:40:25 <tnurlygayanov> and we have only one blocker bug for this release - with SSL for RabbitMQ
15:40:57 <igormarnat> Timur, you might want to take an AI for you to switch the page you sent link to to the full English
15:41:19 <tnurlygayanov> ok
15:41:49 <tnurlygayanov> #action fix Jenkins configuration to full eng
15:42:00 <sergmelikyan> Let's move to the Release 0.4 status, tsufiev?
15:42:03 <tnurlygayanov> Thank you, Igor.
15:42:26 <tsufiev> sergmelikyan: yeah, a few more seconds...
15:43:25 <sergmelikyan> #info Release 0.3 Status: In testing, 1 issue pending
15:44:07 * sergmelikyan not mentioned issue with murano-api performance, since this issue is moved to the next release
15:44:48 <tsufiev> 1. advanced networking is implemented by Alexander Tivelkov in murano-conductor and fixed templates in murano-repository, has been reviewed by my and stanlagun, and is waiting for ativelkov to fix our comments. We're expecting him to do it by the end of the week. Release 0.4 still doesn't include UI for it.
15:45:41 * sergmelikyan thinks that we should speed-up, not so much time remains till the end of the meeting
15:45:55 <igormarnat> +1
15:45:56 <tsufiev> 2. Metadata Repository has fully implemented client part (dashboard and conductor), admin UI is in progress, hope to finish also by the end of the week
15:46:34 <tsufiev> 3. Heat/Havana support - sergmelikyan and dteselkin have fixed one bug with heat/keystone today
15:46:55 <tsufiev> though more bugs can be found, i still don't know
15:47:06 <tnurlygayanov> we should fix several bugs in this (Murano 0.4) release: https://bugs.launchpad.net/murano/+bug/1245836
15:47:34 <tnurlygayanov> https://bugs.launchpad.net/murano/+bug/1211337
15:47:51 <sergmelikyan> Issue with Heat and keystone not related to the Murano itself. Bug was simply Heat misconfiguration.
15:47:55 <gokrokve> Great.
15:48:00 <tsufiev> 4. Linux Agent just works :)
15:48:18 <tsufiev> I think that was the status on all 0.4 deliverables
15:48:24 <sergmelikyan> #topic LoadBalancer Issue
15:49:20 <sergmelikyan> This issue may be resolved in three ways: via extending configuration capabilities of AWS::ElasticLoadBalancing::LoadBalancer, using another implementation of load balancing in Heat - OS::Neutron::LoadBalancer or via implementing own load balancing service, for example based on HAProxy (as all previous ones)
15:50:05 <sergmelikyan> We still exploring this options, and I believe finish we decinding till the next week. For now I don't have clear vision how we should fix this issue.
15:50:57 <igormarnat> Who's the guy responsible for this implementation, you or Alexander?
15:51:24 <sergmelikyan> igormarnat, I am responsible one for the implementation
15:52:31 <igormarnat> Fine, then we don't meed to wait for Alexander to get back to Msk, let's discuss this topic tomorrow and either figure out the proper way or figure out suitable folks to discuss this with
15:52:44 <sergmelikyan> igormarnat, we can later discuss this options in more details. I have done some research on this topic.
15:52:45 <igormarnat> I don't think we can decide on this now, so let's move on
15:52:54 <sergmelikyan> igormarnat, Ok!
15:53:11 <sergmelikyan> #topic Solum Integration
15:54:24 <sergmelikyan> Solum is a new project in OpenStack world, that is essentially PaaS and we need to integrate with this solution. gokrokve can you share some thought after summit?
15:54:52 <igormarnat> From my perspective we need to agree with folks on at least API and env. description
15:55:31 <sergmelikyan> igormarnat, sure, we need to start deep dive into they proposal and integration details. I may be responsible for this
15:56:05 <igormarnat> So what's the output from this meeting in regards with Solumn integration? Are there AIs taken by you? :)
15:58:08 <sergmelikyan> igormarnat, not yet, but I would like to start to getting to know more about Solum, and start interaction we Solum guys regarding integration with Murano. What you think about this?
15:58:21 <sergmelikyan> *do you
15:58:58 <igormarnat> It is a good way to � start:)
15:59:03 <gokrokve> Solum is interesting, it is interesting for Murano as it produces applications, which can be published then in Murano
15:59:28 <gokrokve> There will be a design summit on Nov 19th,20th for Solum. I plan to participate in it.
16:00:05 <sergmelikyan> #action Serg, start discussing with Solum devs API specs and env. descriptions format
16:00:06 <gokrokve> We definetely have to prepare our BP for Solum. For everything, not only for integration part.
16:00:28 <sergmelikyan> gokrokve, it's a massive goal :)
16:00:38 <gokrokve> Yes.
16:00:39 <igormarnat> Is there anything else to discuss? We are over in terms of time
16:01:01 <gokrokve> No. It is time for Mistral :-)
16:01:03 <sergmelikyan> #endmeeting