17:04:36 <ativelkov> #startmeeting murano
17:04:37 <openstack> Meeting started Tue Nov 26 17:04:36 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:41 <openstack> The meeting name has been set to 'murano'
17:04:44 <gokrokve> Hi!
17:05:02 <igormarnat__> Howdy
17:05:24 <briancline> adrian_otto: no doubt, my headspace is still within the existing 21 BPs as there's good foundation there that needs to be brought to life
17:05:27 <briancline> oops
17:06:22 <ativelkov> It turns out we do not have any explicit agenda for today (my fault indeed - was to busy to publish it in advance)
17:06:37 <ativelkov> But let's start with AI review, as usual
17:07:07 <katyafervent> Yes, what's first
17:08:04 <ativelkov> We planned to forward the LoadBalancer email to Neutron and Fuel team,
17:08:05 <ativelkov> asking for feedback
17:08:51 <igormarnat__> Yep. Serge was in charge of this. Serge?
17:10:59 <sergmelikyan> Not done yet :(
17:11:13 <ativelkov> Any estimates?
17:11:19 <sergmelikyan> We have collected feedback from community, but not yet from Fuel team.
17:11:35 <gokrokve> This is a right time to do as they are implementing autoscaling and lb right now.
17:11:37 <sergmelikyan> It going to be done by Thurday
17:11:39 <igormarnat__> Not from Neutron team as well, I guess
17:12:05 <gokrokve> Thursday is a holiday
17:12:24 <gokrokve> even Friday probably will be non working day
17:13:24 <sergmelikyan> I will write e-mail tomorrow, and I expect that we going to collect some feedback before holidays. We already settled with implementation, AFAIK?
17:13:50 <ativelkov> Well, it is settled, but if we get any feedback it may be changed
17:13:59 <igormarnat__> +1
17:14:41 <sergmelikyan> May be then we need to postpone implementation?
17:15:09 <sergmelikyan> I had plans to begin with implementation on this week.
17:15:09 <katyafervent> Let's discuss estimation
17:15:23 <ativelkov> Well, if you expect it to be done soon, let's postpone it then - it should not take long
17:15:26 <sergmelikyan> ETA - 5-7 days with testing and etc...
17:15:44 <sergmelikyan> (1-2 days for actual implementation)
17:16:01 <ativelkov> #agreed postpone autoscaling implementation until we get actual feedback from Neutron and Fuel teams
17:16:28 <gokrokve> Fuel -> Heat ?
17:16:35 <ativelkov> No, fuel
17:16:46 <ativelkov> we needed some feedback from their side
17:17:16 <funzo> just a note, the Neutron guys are currently meeting in #openstack-meeting and discussion data collection via ceilometer
17:17:32 <funzo> assumption is this is the precursor to being able to offer autoscaling
17:17:40 <ativelkov> funzo: thanks
17:17:49 <sergmelikyan> Due to one of the implementation strategies based on Nuutron LBaaS for which Fuel has no support at all
17:19:36 <ativelkov> Probably we'll need separate discussion with them.
17:19:38 <gokrokve> Ok. Sergey you can work with Eugene Nikanorov. He is a part of LBaaS team, so he can probably help.
17:19:51 <igormarnat__> I think it'll require some time for folks to get acquainted with the context, so let's initiate this by email.
17:19:52 <gokrokve> Eugene is in Saratov.
17:19:54 <ativelkov> Ok, let's move on
17:20:32 <ativelkov> next AI: gokrokve to summarise the decisions of Solum design workshop for further discussion of integration paths
17:20:54 <gokrokve> Hm. Right now it is too early.
17:21:02 <tsufiev_> hi there )
17:21:15 <ativelkov> hi Timur
17:21:28 <ativelkov> gokrokve nothing to integrate with yet? )
17:21:33 <tsufiev_> have i missed something important?
17:21:35 <gokrokve> I am participating in mostly all Solum meeting, but right now the main focus of Solum team is to create initial design.
17:22:00 <gokrokve> There are some integration points related to Windows ecosystem.
17:22:14 <gokrokve> Solum will be agnostic to OS.
17:23:06 <gokrokve> And Solum will support both VM and Container as a deployment unit.
17:23:06 <ativelkov> well, building windows-based images is a complicated stuff indeed
17:23:32 <gokrokve> Yes. There was a discussion about that in openstack-dev.
17:24:06 <gokrokve> [openstack-dev] [Solum] Working group on language packs
17:24:12 <ativelkov> #info potential integration points with Solum related to Windows ecosystem
17:24:27 <ativelkov> Yes, this looks interesting
17:25:39 <ativelkov> Ok, then let's continue watching Solum's discussions and email distributions. We don't want to miss anything important there
17:26:02 <gokrokve> I am also trying to bring more use cases for Application Catalog. We have some customers who want it.
17:26:17 <gokrokve> I am working with them to collect all necessary requirements.
17:26:50 <gokrokve> Sure. Keep an eye on Solum. This is very interesting project.
17:27:29 <ativelkov> Yeah. But we need to make sure that our set of use-cases is generic and useful for the whole comunity: customer-specific things should not complicated the overall vision
17:27:40 <gokrokve> I remember that Heat team asked us about specific requirements for HOS software orchestration.
17:27:45 <gokrokve> Do we have some?
17:27:52 <gokrokve> HOS->HOT
17:28:03 <ativelkov> stanlagun has answered to that email
17:28:47 <gokrokve> Yes. But after a week, do we have more details on that. On this phase of implementation we can actually ask for some specific features.
17:29:00 <ativelkov> We don't know anything specific yet
17:29:18 <ativelkov> It completely depends on our implementation of metadata and workflow dsl
17:29:29 <ativelkov> That's actually our last AI from the last meeting
17:29:33 <gokrokve> Then check software components definitions. Thay have an idea of different deployers (chef, puppet).
17:29:40 <ativelkov> "tivelkov stanlagun to formalise the new metadata ideas in the etherpad"
17:30:08 <gokrokve> At least we can use HOT to install our agent.
17:30:21 <ativelkov> This is useful - but we need to settle the higher level first
17:30:27 <gokrokve> sure.
17:30:38 <ativelkov> So, the ether pad is not ready yet
17:31:01 <ativelkov> We are trying to come with some design proposal that would be complete and feature rich
17:31:20 <ativelkov> then we will reduce it to a subset of something easier to implement
17:31:36 <ativelkov> Hovever, the process turned out to be trickier then we expected
17:32:20 <ativelkov> Anyway, we expect it to be finished this week, so we may share the vision to others and start implementing once we get some feedback
17:34:10 <ativelkov> So, tha't all on action items
17:34:32 <ativelkov> Let's cover our other news
17:34:44 <ativelkov> sergmelikyan: what's new on release 0.3?
17:35:43 <sergmelikyan> We successfully released Murano v0.3 :)
17:36:32 <sergmelikyan> We have plans to release screencast-review with new features released with v0.3
17:38:17 <gokrokve> Please work with Nick Chase on that.
17:38:33 <gokrokve> He can help you to do this in a right way.
17:38:59 <sergmelikyan> gokrokve, Ok, but he is on vacation now
17:39:00 <ativelkov> #action sergmelikyan to elaborate with Nick Chase on 0.3 screencast
17:39:57 <ativelkov> More news
17:40:06 <ativelkov> release 0.4  is in progress
17:40:22 <ativelkov> advancedNetwowrking has been merged into master
17:40:41 <ativelkov> excessive testing should begin soon
17:40:57 <tnurlygayanov_> do we have WebUI options for this?
17:41:05 <tsufiev_> no, we don't
17:41:17 <tsufiev_> it is postponed until 0.5
17:41:32 <tnurlygayanov_> ok, we started to test it )
17:41:40 <ativelkov> Also, we've found that there is a problem with nova-network support (https://bugs.launchpad.net/murano/+bug/1255057)
17:41:48 <ativelkov> This has just been fixed
17:43:07 <tnurlygayanov_> so, how we should configure OpenStack to try this feature? How it will work with Nova network?
17:44:13 <ativelkov> There will be a configuration parameter indicating default network topology
17:45:39 <tnurlygayanov_> ok, I will test it )
17:46:21 <ativelkov> ping me if you need more details
17:47:08 <ativelkov> I think that was all for the current status
17:47:21 <ativelkov> Does anybody have something else to discuss?
17:47:39 <tnurlygayanov_> ok, thank you )
17:48:25 <tnurlygayanov_> yes, need to fix roadmap on the murano wiki page, we plan release Murano 0.4 in december
17:49:14 <tnurlygayanov_> ou, it is already writed on wiki, ok )
17:49:16 <ativelkov> Ok, good catch
17:50:15 <ativelkov> other questions?
17:51:17 <ativelkov> Seems like we are done
17:51:48 <ativelkov> lets end the meeting then
17:51:51 <ativelkov> #endmeeting