17:03:56 <ativelkov> #startmeeting murano
17:03:57 <openstack> Meeting started Tue Dec  3 17:03:56 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:01 <openstack> The meeting name has been set to 'murano'
17:05:13 <ativelkov> So, let's follow the agenda at https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:06:19 <ativelkov> The only action item which we had was on sergmelikyan about the screencast for the release 0.3
17:06:53 <ativelkov> Serge, do you have any progress on that? Did you speak to Nick Chase about it?
17:08:00 <ativelkov> sergmelikyan, are you here?
17:08:19 <katyafervent> ativelkov, as far as I know all slides are ready and video also almost done
17:08:49 <katyafervent> so at the end of the week we will have screencast
17:08:52 <ativelkov> Ok, seems like Serge is away, katyafervent thanks for update
17:09:11 <ativelkov> #info slides for 0.3 presentation are ready, video is coming later this week
17:09:52 <ativelkov> The question on elaboration with Nick still remains, but that can be answered only by Serge, probably
17:10:26 <ativelkov> #topic Release 0.4 status
17:10:42 <ativelkov> Let's move on: tsufiev, what are the news on 0.4?
17:11:17 <tsufiev> 1. Considering Metadata Repository, we're currently fixing bugs in Admin WebUI
17:12:00 <tsufiev> 2. Also two problems recently arised in 0.4 due to Advanced Networking implementation
17:12:10 <katyafervent> But all functional for Metadata Repository usage from UI is totally implemented
17:12:43 <ativelkov> #info all the functionality for Metadata Repository usage from UI is implemented
17:12:46 <tsufiev> a. One is related to Security Groups and dynamically generated CIDRs
17:13:22 <tsufiev> b. The second is related to MS SQL Cluster - its IPs validation and, again, dynamically generated CIDRs
17:13:42 <tsufiev> I'm currently implementing fix for (b), planning to finish tomorrow
17:13:57 <tsufiev> ativelkov: I think you can tell us more on (a)
17:14:08 <ativelkov> #info: New major issues in 0.4: security group scopes do not match new generated subnet ciders, MS SQL Cluster IP address does not match is as well
17:14:22 <tsufiev> that's all  yet to be fixed in 0.4
17:14:33 <ativelkov> Yes, this is also in progress, also is likely to be fixed by tomorrow
17:15:02 <ativelkov> The fix itself is ready, I just have to update all he workflows to make use of the new steps which fix the problem
17:15:33 <ativelkov> tsufiev: do we have bug reports on launchpad for these issues?
17:16:14 <tsufiev> ativelkov: I think no, should make new tickets
17:16:25 <ativelkov> Yes, please do that
17:16:33 <tsufiev> ok
17:16:53 <ativelkov> #action tsufiev to create launchpad issues to track bugs with security group cords and MS SQL cluster IP
17:16:59 <katyafervent> And for now we need to fill up documentation with Murano Repository information
17:17:24 <ativelkov> Same should probably go for advanced networking: we need to update the blueprint
17:17:29 <ativelkov> I'll do it
17:17:43 <katyafervent> I am started to work on api specification transtation to docbook
17:17:57 <ativelkov> #action tsufiev to implement the subnet detection routing in the dashboard
17:18:19 <ativelkov> #action ativelkov to fix the security groups cidd assignment
17:18:34 <ativelkov> #action ativelkov to update the blueprint on advanced networking
17:18:58 <ativelkov> #action katyafervent to transfer api spec to docbook
17:19:19 <ativelkov> Anything else on 0.4?
17:20:04 <tsufiev> we should document advanced networking also
17:20:29 <ativelkov> I've just mentioned that, see above
17:20:31 <tsufiev> there are some configuration details which are not obvious
17:20:36 <tsufiev> ok
17:20:58 <ativelkov> Ok, moving to the next topic
17:21:06 <ativelkov> #topic Neutron LBaaS news
17:21:21 <ativelkov> sergmelikyan: are you still away?
17:21:57 <ativelkov> Probably yes. So, I'll give an update myself, as I know some details on the topic
17:22:56 <ativelkov> As far as I know, sergmelikyan has implemented the LoadBalancer Murano Service using the Neutron LBaaS underneath, according to the proposal published earlier
17:23:33 <ativelkov> The pull request can be found here: https://review.openstack.org/#/c/59705/
17:23:50 <ativelkov> There are some -1's there, so this is work in progress
17:24:22 <ativelkov> #info elastic apps transition to OS::Neutron::LoadBalancer is in progress, code is being review
17:25:17 <ativelkov> Also, the new service will require to have LB IP assigned by the user
17:26:15 <ativelkov> And this faces the same problem as earlier mentioned issue with MS SQL cluster IP: we'll need to assign the IP which is located in the proper subnet, while the actual subnet cidd is not know at the time when the environment is being composed
17:27:16 <ativelkov> So, this issue will be fixed by the same approach as we use for MS SQL (i.e. the fix which is being developed by tsufiev)
17:27:48 <ativelkov> #info final implementation of LoadBalancer service depends on the fix by tsufiev
17:28:00 <ativelkov> That's all I know on this topic )
17:28:54 <igormarnat_> What's next? DSL and Metadata description?
17:29:27 <ativelkov> igormarnat_: well, we don't have this in agenda for today ) Probably because we don't have any final vision yet
17:29:56 <ativelkov> The last topic in agenda is "Security Groups issue" but we have actually covered it when discussed current 0.4 status
17:30:13 <ativelkov> so, we can move to the open discussion :)
17:30:20 <ativelkov> #topic Open Discussion
17:30:34 <igormarnat_> Ok, what is the status of DSL and Metadata description? :)
17:30:43 <igormarnat_> Any etherpad?
17:31:50 <ativelkov> There is a first draft of the etherpad (https://etherpad.openstack.org/p/MuranoMetadata) but it is not complete yet, as the workflow definition language is still being discussed
17:32:45 <ativelkov> We have planned an offline design session for the workflow definiiotn on this Thursday
17:33:06 <ativelkov> The results will be reflected in this ether pad and will be suggested for further online discussion
17:33:46 <igormarnat_> Ok. Does it make sense to keep the workflow definition in separated etherpad,, given that this is not a metadata (which current etherpad is actually about)?
17:34:30 <ativelkov> Actually, workflows are part of the metadata
17:34:51 <ativelkov> and eventually they can be even exilicitly included into the metadata manifest file
17:35:17 <ativelkov> We just propose to split them in sake of simplicity and readability, as they most likely will be long
17:35:39 <igormarnat_> Ok, so we have couple of days to complete the exercise and take a look at the draft of the DSL and Metadata proposal?
17:35:46 <ativelkov> but in case of simple workflows, the developer may combine both app definitions and workflows in the same file - altogether with the manifest itself
17:35:55 <ativelkov> Yes
17:38:04 <ativelkov> #info DSL definition and workflow spec to be completed in several days
17:38:10 <ativelkov> Any other questions?
17:38:59 <ativelkov> If not, then seems we are done
17:39:31 <ativelkov> Thanks for joining
17:39:41 <ativelkov> #endmeeting