17:00:34 <ativelkov> #startmeeting murano
17:00:34 <openstack> Meeting started Tue Dec 10 17:00:34 2013 UTC and is due to finish in 60 minutes. The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:37 <openstack> The meeting name has been set to 'murano'
17:01:06 <ativelkov> Hi Muranoers!
17:01:15 <ativelkov> Anybody here today?
17:01:15 <tsufiev> hi!
17:01:37 <dteselkin> Hi !
17:01:54 <sergmelikyan-a> \o
17:02:09 <ativelkov> Let's start then
17:02:15 <stanlagun> hi
17:02:41 <ativelkov> Let's start with AI review, as usual
17:02:48 <ativelkov> #topic AI review
17:03:13 <ativelkov> ativelkov to fix the security groups cidd assignment
17:03:31 <ativelkov> This is done, the fix has been reviewed and merged to master branch already
17:03:50 <ativelkov> ativelkov to update the blueprint on advanced networking
17:04:18 <ativelkov> This is not done yet: too many tasks are pending on other documentation, so I could not find time to do it
17:04:28 <ativelkov> will do next week, I hope
17:04:31 <ativelkov> #action ativelkov to update the blueprint on advanced networking
17:04:44 <ativelkov> Next, katyafervent to transfer api spec to docbook
17:04:47 <gokrokve_> Hi
17:05:25 <tsufiev> currently she is away, but afaik she did it
17:05:43 <ativelkov> Ok, that' good
17:05:55 <ativelkov> The remaining are on you, Timur:
17:06:08 <ativelkov> tsufiev to create launchpad issues to track bugs with security group cords and MS SQL cluster IP
17:07:13 <tsufiev> done
17:07:27 <ativelkov> tsufiev to implement the subnet detection routing in the dashboard
17:07:49 <ativelkov> Is this done as well?
17:07:53 <tsufiev> also done, finally implemented it today
17:07:58 <ativelkov> Good!
17:08:14 <ativelkov> Ok, let's discuss the upcoming 0.4 then
17:08:20 <ativelkov> #topic release 0.4
17:08:42 <ativelkov> tsufiev, please share an update
17:09:00 <tsufiev> we have fixed all bugs in Metadata Repository (that are known)
17:09:21 <tsufiev> we have a code freeze today, also
17:09:45 <ativelkov> Is it already active?
17:09:51 <tsufiev> so right now we trying to ensure that nothing broken in 0.4 remains
17:10:22 <tsufiev> we're currently testing MS SQL Cluster deployment - it seems, that some port were open previously by default
17:10:26 <ativelkov> I mean, is the stable 0.4 branch is created?
17:10:33 <tsufiev> and now we need to specify them manually
17:10:43 <tsufiev> not yet, i'l do it in an hour or so
17:11:07 <ativelkov> Ok
17:11:29 <ativelkov> #info code freeze for 0.4 scheduled for today, will occur in about 10 am PST
17:11:51 <ativelkov> tnurlygayanov_: can you comment on the bugs known in 0.4 by far?
17:12:26 <tnurlygayanov_> so, we hova no critical issues in the release 0.4
17:12:59 <ativelkov> #info No critical issues in 0.4 discovered yet
17:13:00 <tnurlygayanov_> and we plan to fix some major features during the next few days
17:13:26 <ativelkov> what do you mean by major features? Is something not implemented yet - or you mean bugs?
17:13:26 <tsufiev> tnurlygayanov_: are they related to fuel?
17:13:40 <tnurlygayanov_> all automated tests, which we executed on our test lab are passed for this release
17:13:57 <tnurlygayanov_> or? sorry, major bugs )
17:14:31 <ativelkov> Ok. We need to decide if we really want to fix them or document as known issues and proceed.
17:14:36 <tsufiev> tnurlygayanov_: do you mean major bugs in murano itself or fuel integration issues?
17:14:55 <ativelkov> Usually code freeze means that check-ins are allowed only for critical bugs
17:15:06 <ativelkov> So, I would suggest
17:15:12 <tnurlygayanov_> in Murano, yes. Need to fix and merge commti for key pair, for example
17:15:28 <ativelkov> to either escalate the status of the bugs to "critical" - or to postpone the fix till 0.4.1
17:15:32 <tnurlygayanov_> it does not work now )
17:16:20 <tnurlygayanov_> ok, we will review bugs descriptions and will change priorities and mailstones for all bugs
17:16:28 <ativelkov> #info some major bugs remain. Some of them may be escalated and fixed before the release, others will remain as known issue
17:16:40 <tsufiev> afair, key pairs wasn't specified as 0.4 deliverables...
17:17:23 <tsufiev> is it a critical feature?
17:17:38 <ativelkov> yup. Also, the linux images which we use for this Apps usually allow root login via the horizon console
17:17:50 <ativelkov> So, I don't think that they are really crtitical
17:18:06 <ativelkov> But it is up to you to decide, as you are the owner of the release
17:18:38 <tnurlygayanov_> it is small non critical feature, but implementation of linux services without this feature is incomple
17:18:44 <tsufiev> i'd prefer to postpone them until 0.4.1
17:18:57 <ativelkov> Anyway, we need to schedule a service release 0.4.1 which will fix these known issues and will add role-based access control to Simplified Metadata Repository
17:19:04 <tnurlygayanov_> ok, no problem, let's move it to 0.4.1
17:19:23 <tsufiev> good :)
17:19:35 <ativelkov> #agreed to postpone kypair fix till 0.4.1
17:19:48 <joel_c> joel_c: when do we expect 0.4.1 to land? approximately?
17:20:31 <ativelkov> Depends on the feature set. If this is just bug fixes + RBAC, then about mid january
17:21:02 <ativelkov> May be earlier, but long holiday seasons tend to consume time
17:21:13 <joel_c> ativelkov: sounds good.
17:22:23 <ativelkov> Is that all what we have for 0.4, tsufiev?
17:23:12 <tsufiev> ativelkov: almost forgotten. Also all needed heat patches were ported to havana - to make ms sql cluster work
17:23:37 <tsufiev> now i think that's all
17:23:47 <ativelkov> I thought that allowed address pairs is not ported to havanna
17:24:08 <ativelkov> At least yesterday I saw it in their master, but not in stable/havana
17:24:33 <tsufiev> i rebased patches made from master onto stable/havana
17:24:53 <tsufiev> dteselkin applied it today on our lab, it works
17:25:03 <ativelkov> Ah, I see
17:25:30 <ativelkov> but the official Heat does not have it in their Havanna release
17:26:18 <ativelkov> This means that our implementation of MS SQL Cluster will work either on the latest trunk of the Heat - or on patched deployment of Havana
17:26:32 <ativelkov> but not on the out-of-the-box Havana
17:26:46 <tsufiev> yes, exactly
17:26:59 <ativelkov> This is fine, but we need to track such limitations carefully
17:27:15 <ativelkov> tsufiev, this should get into the release notes of 0.4
17:27:47 <tsufiev> ativelkov: ok, will add it
17:27:53 <ativelkov> #action tsufiev to ensure that allowed_ip_addresses limitation gets its way into release notes of 0.4
17:28:08 <ativelkov> Ok, let's move on
17:28:20 <ativelkov> #topic release 0.5 planning
17:29:09 <ativelkov> So, we have completed vision for DSL design
17:29:29 <ativelkov> some of it are summarised in ether pad at https://etherpad.openstack.org/p/MuranoMetadata
17:30:02 <ativelkov> We are going to complete the pad this week and move the final definition to wiki
17:30:25 <ativelkov> And then create a series of blueprint to implement the minimal feature set of this spec in the 0.5
17:31:21 <ativelkov> Afaik, stanlagun is doing some PoC with the engine for the new DSL right now
17:31:30 <ativelkov> stanlagun, can you share some update on this topic
17:31:38 <ativelkov> ?
17:32:14 <stanlagun> Well it is going not so fast as I hoped
17:32:22 <stanlagun> because of many meatings we have
17:32:42 <stanlagun> but I expect it to be completed by next comunity meeting
17:33:12 <ativelkov> What set of functionality may we expect?
17:34:12 <ativelkov> #info new-DSL engine is being prototyped. ETA - next tuesday
17:34:14 <stanlagun> Currently I'm trying to implement some workflow engine prototype that can handle simultenious task execution. The goal is also to implement classes for underlying type system. That is a DOM model for the DSL
17:34:56 <ativelkov> #info prototype will have a DOM model with parser and a simple workflow engine
17:35:16 <ativelkov> stanlagun what about Mistral? Are we going to use it for the workflows?
17:35:18 <stanlagun> As a result it will be possible to declare and implement workflow for some Hello-World class
17:36:26 <stanlagun> No. Mistral is yet far from our minimal requirements. But it is moving fast and I'm present on all of their meetings to be sure it is going in good direction. I expect that we can start using Mistral by 0.6-0.7 timeframe
17:36:47 <ativelkov> Thanks
17:37:11 <ativelkov> #info PoC of the new workflow engine is not going to use Mistral. We will migrate to Mistral at later stages of the product
17:37:51 <ativelkov> Also, there was a long discussion in mailing list about HeatR
17:38:23 <ativelkov> It turned out that there is a strong community demand for a generic unified Metadata Repository
17:38:45 <ativelkov> which will be able to store various kinds of cataloged metadata
17:39:18 <ativelkov> The consensus in the list was reached that Glance should become such a reporsitory
17:39:42 <stanlagun> Is it final?
17:39:50 <ativelkov> Of course not
17:40:14 <ativelkov> But we should expect that it may come true
17:41:03 <ativelkov> So, Murano should 1) be prepared for such changes and make a good use of the new repository if it emerges, 2) contribute our own ideas and experience
17:41:29 <ativelkov> In general, this would be really beneficial for all the projects in the community
17:42:19 <ativelkov> Anyway, until the final solution is made, we should demonstrate our own achievements in this area to the community
17:42:43 <ativelkov> It is suggested to present our simplified metadata repository
17:43:09 <ativelkov> tsufiev has recorded a short video demo, gokrokve_ will send it to a mailing list
17:45:09 <ativelkov> Ok, that's all we have for 0.5 for now
17:45:20 <ativelkov> #topic Open Questions
17:45:33 <ativelkov> Does anybody have any questions?
17:46:38 <ativelkov> Ok, then I have a proposal
17:47:14 <ativelkov> As release 0.4 is moving to the delivery, I'd like to clean up the remaining bugs which we have at launchpad
17:47:31 <ativelkov> Some of them are outdated, some need to be re-estimated
17:47:44 <ativelkov> So, I suggest to have a standard bug-scrub procedure
17:49:14 <ativelkov> I suggest to send an invitation to a mailing list - so all may participate in this procedure
17:50:01 <ativelkov> We will then schedule a convenient timeslot and all do a bug scrub in #murano channel
17:50:16 <igormarnat> Sounds good
17:50:57 <ativelkov> currently we have 69 open bugs, so it should not take too long
17:51:38 <ativelkov> lots of them are in "fix committed" state, so they are likely to be closed with the release of 0.4
17:51:53 <ativelkov> Any objections?
17:52:23 <ativelkov> #agreed have a bug-scrub procedure to clean-up the launchpad issues after the release 0.4 goes public
17:52:41 <ativelkov> #action ativelkov to send a bug-scrub invitation
17:52:54 <ativelkov> Ok, that's all I had. Any other questions?
17:54:10 <ativelkov> Then let's finish the meeting
17:54:15 <ativelkov> #endmeeting