17:07:39 <tnurlygayanov_> #startmeeting Murano
17:07:40 <openstack> Meeting started Tue Dec 24 17:07:39 2013 UTC and is due to finish in 60 minutes.  The chair is tnurlygayanov_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:43 <openstack> The meeting name has been set to 'murano'
17:07:44 <openstack> tsufiev: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
17:08:26 <igormarnat_> Let's figure out which meeting is in progress
17:08:29 <igormarnat_> #info
17:08:38 <igormarnat_> #action
17:08:41 <tsufiev> #info
17:09:05 <igormarnat_> You can skip trying #action:)
17:09:08 <tsufiev> ok, i think it's the right, tnurlygayanov was a little faster than me :)
17:09:26 <tsufiev> let's start with the agenda from previous meeting
17:10:46 <tsufiev> afaik there are no AIs to be reviewed, so let's go directly to the release statuses - 0.4, 0.4.1, 0.5
17:11:02 <tsufiev> #topic Status of release 0.4
17:11:54 <tsufiev> being the release 0.4 owner I'm glad to say it has been released on 20th December :)
17:12:42 <tsufiev> release notes are available here: https://wiki.openstack.org/wiki/Murano/ReleaseNotes_v0.4
17:13:11 <tsufiev> and here is the LP page (in case you don't know) https://launchpad.net/murano/1.0/0.4
17:14:04 <tsufiev> we have successfully implemented Simplified Metadata Repository it this release, supported Havana&Neutron and fixed numerous bugs
17:14:33 <tsufiev> hey, does anybody see me :)?
17:14:44 <igormarnat_> Listening carefully
17:14:44 <tnurlygayanov_> yes
17:14:57 <igormarnat_> Though the audience looks smaller than usual:)
17:15:06 <tsufiev> yes, indeed
17:16:04 <tsufiev> in addition to 2 known issues of 0.4 I spoke of on the previous meeting (web farms are not deployed for sure and a large number of ports should be opened for MS SQL cluster) there is another one
17:16:23 <igormarnat_> Namely?
17:16:26 <tsufiev> Namely, if hostname template for a service is longer than 15 symbols (there is validation of field maximum length), Heat Stack creation will fail (because it appends another 47 symbols to the final instance name)
17:16:48 <tsufiev> * there is no validation
17:17:19 <tsufiev> so, 0.4 was released with 3 known issues
17:17:29 <igormarnat_> BTW, Timur, we didn't update public wiki yet, aren't' we?
17:17:44 <tsufiev> nope, we did
17:17:56 <tsufiev> i mean this one https://wiki.openstack.org/wiki/Murano/ReleaseNotes_v0.4
17:18:30 <igormarnat_> Still we missed to update roadmap: https://wiki.openstack.org/wiki/Murano/Roadmap
17:18:45 <igormarnat_> Not only the 4.0 release, but 3.0 as well needs to be updated
17:19:20 <tsufiev> yes, it is slightly outdated
17:19:29 <tsufiev> will fix it right after the meeting
17:19:41 <igormarnat_> #action update https://wiki.openstack.org/wiki/Murano/Roadmap for 3.0 and 4.0
17:20:36 <tsufiev> so, speaking of these 3 known issues - we plan to fix them in the upcoming 0.4.1 bugfix release
17:20:56 <tsufiev> i've nothing more to say about 0.4, shall we proceed next? if you don't have any questions, of course
17:21:30 <igormarnat_> Just one question whether we marked know bugs appropriately (with release tags, I mean)
17:22:50 <tsufiev> here is the LP page for 0.4.1 bugs https://launchpad.net/murano/+milestone/0.4.1
17:23:24 <igormarnat_> Ok
17:23:32 <tsufiev> it seems that known issues I spoke of, should be added to LP
17:24:01 <tsufiev> i don't see all of them there - either milestone for them is not set, or they did not get to the LP
17:24:05 <tsufiev> will fix it
17:24:38 <tsufiev> #action tsufiev make sure that 0.4 known issues are marked with 0.4.1 milestone
17:25:41 <tsufiev> ok, let's proceed then
17:25:53 <tsufiev> #topic Plans for 0.4.1
17:26:40 <tsufiev> nothing changed here much, the approximate date is still the same - the end of 2014 January
17:27:40 <Guest36589> and the primary feature in 4.1 will be rbac, correct?
17:28:16 <tsufiev> igormarnat: am I right about the date of 0.4.1?
17:28:26 <tsufiev> Guest36589: yes
17:28:48 <tsufiev> Guest36589: but we call it now 'per-tenant isolation' :)
17:29:13 <igormarnat> Wiki says "Jan, 30" which is more or less right
17:29:58 <tsufiev> we've recently agreed on how it should be implemented... searching for link
17:30:39 <tsufiev> so here it is https://wiki.openstack.org/wiki/Murano/Specifications/Per_Tenant_Isolation
17:31:03 <Guest36589> thanks
17:31:25 <tsufiev> we decided that there should be 'Common' Services&Metadata objects + per-tenant Services and objects
17:31:58 <tsufiev> Common one should be read-only via WebUI, but can be changed via file-system
17:32:24 <tsufiev> per-tenant ones are modifiable by any user of that tenant
17:33:24 <Guest36589> this is instead of enabling ownership of the object by a tenant with a sharing attribute?
17:33:29 <igormarnat> tsufiev: So 0.4.1 is basically maintenance release for 0.4 with addition of per-tenant isolation, right?
17:33:44 <tsufiev> igormarnat: yes, exactly
17:34:23 <tsufiev> Guest36589: yes, as I recall we decided to not use sharing ownership
17:35:35 <tsufiev> that's all that I wanted to tell about 0.4.1
17:36:05 <tsufiev> now, if you don't have questions let's proceed to the 0.5
17:36:41 <Guest36589> post .6 i hope this can be reconsidered.  We have many BUs that will innovate and want to share with related BUs with having to have the provider IT involved.
17:37:28 <Guest36589> s/with/without/
17:38:53 <tsufiev> Guest36589: we're still in the process of design
17:39:07 <igormarnat> Guest36589: so the idea is to give users the possibility to share the info without involving user with admin privileges?
17:39:20 <tsufiev> the link I've provided and the brief description of how it should work are still in draft state
17:40:31 <tsufiev> so we are open for discussion :)
17:40:34 <igormarnat> tsufiev let's consider this, perhaps this is not a big deal.
17:41:14 <igormarnat> Guest36589 do you have already several descriptions of Murano environments which are used by users?
17:41:27 <tsufiev> igormarnat: yes, should discuss it with the team
17:42:02 <Guest36589> working on it early adopters
17:42:03 <igormarnat> #action consider possibility to provide the way to share environments across BUs without involving admins
17:42:51 <Guest36589> we are looking to go prod with something post the .5 release
17:43:12 <tsufiev> ok, let's proceed to the 0.5 then
17:43:34 <tsufiev> #topic Release 0.5 plans
17:44:17 <igormarnat> Any design docs?
17:44:22 <igormarnat> Any dates planned?
17:44:52 <tsufiev> https://wiki.openstack.org/wiki/Murano/Roadmap#Version_0.5_.28February.2C_2014.29 here is the roadmap for 0.5
17:45:06 <tsufiev> so the initial date is February, 2014
17:45:58 <igormarnat> What are the blueprints/major features to be implemented?
17:46:00 <tsufiev> there are 3 blueprints targeted for that release:
17:46:09 <tsufiev> https://blueprints.launchpad.net/murano/+spec/new-metadata-dsl
17:46:17 <tsufiev> https://blueprints.launchpad.net/murano/+spec/new-web-ui-prototype
17:46:41 <tsufiev> https://blueprints.launchpad.net/murano/+spec/rbac-implementation
17:48:11 <tsufiev> there is pretty much written about new Metadata DSL on this etherpad https://etherpad.openstack.org/p/MuranoMetadata
17:48:13 <igormarnat> Wow, looking at this list, I'd say the initial date is probable _end_of_ February:)
17:48:34 <tsufiev> i also think February is very optimistic date :)
17:49:27 <tsufiev> i would say much more about new Metadata DSL if I were Stan Lagun or Alexander Tivelkov :)
17:49:54 <igormarnat> It's ok, I guess blueprints are pretty much self-explanatory
17:51:10 <igormarnat> Any news in regards with Glance? I remember there were discussions of using it as a general purpose metadata repository
17:52:11 <tsufiev> i heard on Glance meeting that it was decided to make a prototype of 2.0 version
17:52:37 <igormarnat> Ok, cool, let's see how it goes then.
17:52:42 <igormarnat> What else is there in the agenda?
17:53:25 <tsufiev> i think we're done
17:53:43 <igormarnat> Ok, are there any questions from our broad audience?
17:53:46 <tnurlygayanov_> Guest36589, can you please add some information about your use cases for RBAC to https://blueprints.launchpad.net/murano/+spec/rbac-implementation?
17:54:29 <Guest36589> tnurlygayanov_: sure thing
17:54:37 <igormarnat> tnurlygayanov_, Guest36589 any feedback about existing description would also welcome
17:55:42 <igormarnat> tsufiev, I think we're really done, let's close the meeting then
17:56:05 <tsufiev> #endmeeting
17:56:25 <tsufiev> tnurlygayanov: could you end the meeting?
17:57:26 <tsufiev> it seems that it must be the same person who starts it
17:57:52 <tnurlygayanov_> ok )
17:57:57 <tnurlygayanov_> #endmeeting