17:03:34 <ativelkov> #startmeeting Murano
17:03:35 <openstack> Meeting started Tue Jan 14 17:03:34 2014 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:38 <openstack> The meeting name has been set to 'murano'
17:03:46 <tsufiev_> hi there
17:03:48 <ativelkov> Hi Muranoers!
17:03:59 <tnurlygayanov_> Hi ))
17:04:16 <IgorYozhikov> Hi
17:04:28 <ativelkov> Seems like this is our first meeting ater NY holidays
17:04:47 <ativelkov> I hope you all had a good vacation
17:05:06 <ativelkov> This is our agenda for today: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Next_meetings
17:05:43 <ativelkov> Let's start with the AI review
17:06:00 <ativelkov> #topic AI review
17:06:24 <ativelkov> First item was "update https://wiki.openstack.org/wiki/Murano/Roadmap for 3.0 and 4.0"
17:06:55 <ativelkov> Do I understand correctly that this was done?
17:07:00 <tsufiev_> this was on me, done
17:07:10 <ativelkov> Good, thanks
17:07:24 <ativelkov> #info roadmap for 0.3 and 0.4 was updated
17:07:54 <ativelkov> next one, tsufiev make sure that 0.4 known issues are marked with 0.4.1 milestone
17:08:25 <tsufiev_> again, done, but not all the known issues of 0.4 are planned for 0.4.1
17:08:29 <katyafervent> I guess wee did it ob our bug triage
17:08:39 <katyafervent> * we
17:08:47 <ativelkov> tsufiev_: why are not they?
17:09:09 <ativelkov> Some has to be fixed only in 0.5?
17:09:32 <tsufiev_> because as tnurlygayanov said, we don't have time to setup lab for Neutron in 0.4.1
17:09:35 <tnurlygayanov_> or 0.5+
17:10:09 <tnurlygayanov_> yes, I will try to do this on this week.
17:10:21 <ativelkov> This is important
17:10:36 <ativelkov> 0.5 is not a proper release for bugfixing
17:10:51 <katyafervent> Do we have list of known issues in our openstack wiki page?
17:10:55 <ativelkov> it will introduce completely new functionality, and even some of the features will be missing
17:11:25 <ativelkov> so all the fixes for 0.4.* have to be done in 0.4.*
17:11:45 <tsufiev_> katyafervent: yes, we have
17:11:47 <ativelkov> if if don't do somthing important in 0.4.1 it means that we will have to do 0.4.2
17:11:59 <tnurlygayanov_> https://wiki.openstack.org/wiki/Murano/ReleaseNotes_v0.4#Known issues
17:12:18 <ativelkov> or - as another option - we may postpone 0.4.1 a bit, to have more time for neutron testing
17:13:29 <ativelkov> tnurlygayanov_: what are your estimates: how much time may we need to setup lab and fix them?
17:13:35 <tnurlygayanov_> I belive that we will have time for testing with Neutron load balancer before the end of Jun
17:13:50 <katyafervent> and why do we need fuel for that?
17:13:58 <ativelkov> Jun??
17:13:58 <tsufiev_> tnurlygayanov_: June :)?
17:14:19 <tnurlygayanov_> it is one-two days
17:14:20 <ativelkov> Jan, I hope )
17:14:30 <tnurlygayanov_> yes, sorry, Jan )
17:15:05 <ativelkov> Is this Neutron LB a separate module, which does not come installed with MOS?
17:15:20 <tnurlygayanov_> katyafervent, we do not need fuel for it
17:15:30 <katyafervent> tnurlygayanov, ok)
17:15:32 <tnurlygayanov_> yes
17:16:11 <tnurlygayanov_> we can install and configure it with devstack and I plan to do this in our QA lab
17:16:25 <sergmelikyan> ativelkov, Neutron LB may be installed separatly and joined with MOS installed via Fuel
17:16:43 <ativelkov> Ok, but for distribution we will need to either add its support to Fuel or to have a separate deploymnet routine for it
17:17:00 <ativelkov> I see
17:17:09 <tnurlygayanov_> today we finished murano installation script, which allow to install Murano using the devstack - I plan to test Neutron LB and this script in parallel.
17:17:31 <katyafervent> but we are working on devstack integration, right? could it helped with this issue?
17:17:44 <katyafervent> Oh, cool
17:17:56 <ativelkov> So, let's then plan to add Neutron LB support into the 0.4.1 - postponing the release if nessesary
17:18:06 <tnurlygayanov_> yes, need to add this LB in Fuel installation
17:18:20 <ativelkov> Any objections on this?
17:18:24 <katyafervent> ok, I'll add it to 0.4.1 deliverables
17:18:27 <tnurlygayanov_> ativelkov, ok
17:18:43 <sergmelikyan> What integration we are talking about?
17:19:05 <ativelkov> #agreed add Neutron LB support into the 0.4.1 - postponing the release if necessary
17:19:33 <sergmelikyan> Integration Neutron LBaaS to MOS? How it is related to Murano?
17:19:51 <ativelkov> It is a different topic indeed
17:20:11 <tnurlygayanov_> sergmelikyan, it is for another meeting )
17:20:23 <ativelkov> let's continues with the AIs
17:20:34 <ativelkov> "consider possibility to provide the way to share environments across BUs without involving admins"
17:21:05 <ativelkov> I guess this is irrelevant now, as we have changed the suggested implementation for per-tenant isolation, right?
17:21:28 <tsufiev_> it was the thing that our unidentified guest on the previous meeting wanted
17:22:03 <ativelkov> Was that about environments or about service definitions?
17:22:33 <tsufiev_> wait a minute....
17:22:52 <tsufiev_> i don't remember, need to see logs
17:23:27 <tnurlygayanov_> yes, in 0.4.11 we can just make per tenant isolation, but for 0.5 need to support RBAC.
17:23:37 <tnurlygayanov_> *0.4.1
17:24:28 <katyafervent> do we have time for it in 0.5?
17:24:50 <tsufiev_> <tsufiev> we decided that there should be 'Common' Services&Metadata objects + per-tenant Services and objects
17:24:52 <tsufiev_> <tsufiev> Common one should be read-only via WebUI, but can be changed via file-system
17:24:52 <ativelkov> It depends on how do we implement metadata storagde
17:24:53 <tsufiev_> <tsufiev> per-tenant ones are modifiable by any user of that tenant
17:24:55 <tsufiev_> <Guest36589> this is instead of enabling ownership of the object by a tenant with a sharing attribute?
17:25:10 <tsufiev_> <Guest36589> post .6 i hope this can be reconsidered.  We have many BUs that will innovate and want to share with related BUs with having to have the provider IT involved.
17:25:23 <ativelkov> Ah, I see
17:25:27 <ativelkov> We have plans for this
17:25:57 <ativelkov> If we use Glance for storing artifact, we may use the same system for sharing artifacts which is currently present for sharing images
17:26:09 <ativelkov> but for 0.4.1 this will not be possible
17:26:47 <ativelkov> implementation for 0.5 is tentative - depends on the glance arttifacts repo implementation and our adoption of it
17:26:57 <ativelkov> But this is planned anyway
17:27:33 <ativelkov> Are we done with AIs?
17:27:51 <katyafervent> ativelkov, I guess so
17:27:57 <ativelkov> Then lets move on
17:28:02 <ativelkov> #topic Status for release 0.4.1 features
17:28:17 <katyafervent> Release 0.4.1 is on it's way, wiki page is up to date with information about it
17:28:54 <ativelkov> Will 0.4.1 contain the devstack integration which we have discussed above?
17:29:03 <katyafervent> So we do have two main features: per-tenant isolation and managing key-pairs
17:29:23 <katyafervent> Also we'll improve dynamic UI - it should be work faster
17:30:17 <tsufiev_> (but if we use OS Lab on the opposite side of the world, you won't notice that)
17:30:19 <tsufiev_> :)
17:30:33 <katyafervent> Yes, and it's almost done afaik
17:30:36 <ativelkov> I see
17:30:42 <ativelkov> good, thanks
17:31:16 <ativelkov> moving on
17:31:18 <ativelkov> #topic Changes in per-tenant isolation
17:31:56 <ativelkov> So, since out last meeting there it was decided to change the proposed implementation of per-tenant isolation
17:32:18 <tsufiev_> yes, and it simplifies an implementation very much
17:32:45 <ativelkov> There will be no managable "common" repository, instead, commons will be "forked" at the moment when the tenant uses Murano for the first time
17:33:02 <ativelkov> katyafervent - is the new approach documented on wiki somewhere?
17:33:43 <katyafervent> ativelkov, Yes, the specification was updated
17:33:58 <katyafervent> https://wiki.openstack.org/wiki/Murano/Specifications/Per_Tenant_Isolation
17:34:03 <ativelkov> Thanks
17:34:20 <ativelkov> #info new approach to per-tenant isolation is documented at https://wiki.openstack.org/wiki/Murano/Specifications/Per_Tenant_Isolation
17:35:10 <ativelkov> #topic New DSL engine
17:35:46 <ativelkov> So, speaking about new DSL engine - stanlagun, can you share the update?
17:37:25 <ativelkov> stanlagun, are you here?
17:37:34 <stanlagun> there is a prototype that has nearly everything that is required for 0.5 with exclusion of correct YAQL function registration. I'm going to make if complete today and commit to custom repository so that it can be used as a code base
17:37:50 <ativelkov> ah, thanks
17:38:01 <stanlagun> I also expect to have demo service (AD) on new DSL
17:38:06 <stanlagun> by tomorrow
17:38:14 <ativelkov> #info new DSL proptotype is almost ready, will include an engine PoS and a demo service
17:38:29 <ativelkov> #action stanlagun to submit the sources to a custom repo
17:38:34 <ativelkov> Thanks
17:38:37 <rakhmerov> guys, sorry if that's a dummy question.. Do you have this new DSL documented somewhere?
17:38:46 <rakhmerov> I'm curious to take a look
17:38:56 <ativelkov> rakhmerov: yes, there is a blueprint and etherpad
17:39:06 <stanlagun> it is slightly outdated
17:39:15 <rakhmerov> could you please provide links?
17:39:48 <stanlagun> I'm going to write more detailed and up-to-date description as soon as I finish with PoC
17:40:01 <rakhmerov> ok
17:40:04 <stanlagun> https://etherpad.openstack.org/p/MuranoMetadata
17:40:21 <rakhmerov> ok, thanks
17:41:01 <ativelkov> so, the spec will be updated during this week, right?
17:41:41 <ativelkov> #action stanlagun to update the DSL description according to the implemented PoC
17:42:21 <ativelkov> And then we will have a meeting with Dmitry Meytin to demostrate the proptotype to him and discuss the contribution possibilities
17:42:34 <ativelkov> #action ativelkov to schedule a meeting with Dmitry
17:43:07 <ativelkov> That is all on DSL
17:43:47 <ativelkov> #topic Open Discussion
17:44:10 <ativelkov> Does anybody has something unplanned to discuss?
17:44:33 <katyafervent> I have not
17:45:02 <IgorYozhikov> nope
17:45:10 <ativelkov> Well, then I think we are done
17:45:17 <ativelkov> Thanks for joining
17:45:19 <katyafervent> Thanks everyone!
17:45:24 <ativelkov> #endmeeting