17:00:43 <tsufiev_> #startmeeting murano
17:00:44 <openstack> Meeting started Tue Jan 28 17:00:43 2014 UTC and is due to finish in 60 minutes.  The chair is tsufiev_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <openstack> The meeting name has been set to 'murano'
17:01:14 <tsufiev_> So, as always let's begin with AI review
17:01:28 <tsufiev_> it seems to me, that remain the same from the previous meeting
17:02:05 <tsufiev_> 1. stanlagun to update the DSL description according to the implemented PoC
17:02:21 <tsufiev_> stanlagun: how is it going?
17:03:03 <stanlagun> actually i said that code would be ready by now, not documentation
17:03:22 <stanlagun> Well the DSL code is 95% complete
17:03:40 <tsufiev_> yes, i know it because i'm working with the rest 5% :)
17:04:13 <tsufiev_> stanlagun: should we postpone this one until the next meeting?
17:04:33 <katyafervent> postpone what?
17:04:47 <tsufiev_> katyafervent: postpone AI
17:04:53 <stanlagun> docs? yes
17:05:03 <joel_c> hi
17:05:07 <stanlagun> hi
17:05:11 <tsufiev_> hi
17:05:16 <tnurlygayanov_> Hi Joel
17:05:23 <katyafervent> Yes,let's make it to creating service with new engine
17:05:44 <tsufiev_> ok, with the code ready in 1-2 days there should be some time until next week for writing docs
17:06:13 <tsufiev_> katyafervent: right now there is an ActiveDirectory service served by new Dsl Engine
17:06:14 <katyafervent> Let's move on thrn
17:06:17 <katyafervent> *then
17:06:24 <tsufiev_> #action stanlagun to update the DSL description according to the implemented PoC
17:06:44 <katyafervent> tsufiev_, That's a good news, mark it with #info
17:07:23 <tsufiev_> next 2 AI is assigned to ativelkov
17:07:33 <tsufiev_> as he won't be there today, let's skip them
17:08:19 <katyafervent> And please update openstack wiki with DSL specification
17:08:33 <tnurlygayanov_> ok, let's move it to the next meeting too.
17:08:37 <tsufiev_> so let's move to the next item in our agenda
17:08:43 <tsufiev_> #topic Status for release 0.4.1
17:09:21 <tsufiev_> katyafervent: i think you're the most competent person on this topic now ;)
17:09:58 <katyafervent> We postpone 0.4.1 for the 6th of February
17:10:00 <tsufiev_> katyafervent: speaking of ActiveDirectory topic - a bit later
17:10:17 <katyafervent> Due to delay with floating ip feature implementation
17:10:19 <tsufiev_> katyafervent: are there some major bugs left?
17:10:58 <katyafervent> tsufiev_, not major but there are couple that would be better to fix in 0.4.1
17:11:18 <tnurlygayanov_> tsufiev, yes, we have several not fixed bugs which are targeted to 0.4.1 release
17:11:21 <katyafervent> Plus we need to update documentation
17:11:42 <katyafervent> That's why the release was postponed
17:11:57 <akuznetsova_> don't forget to fix bugs with installation scripts
17:12:13 <katyafervent> Please provide a link)
17:12:21 <tsufiev_> akuznetsova_: aren't they in master branch?
17:12:33 <tsufiev_> we are speaking now about release-0.4 branch
17:12:34 <tnurlygayanov_> yes, it is bug with High priority for release
17:12:55 <akuznetsova_> yes, this is actual for release-0.4 https://bugs.launchpad.net/murano/+bug/1267420
17:13:13 <katyafervent> How is testing going?)
17:14:00 <katyafervent> Did you test all implemented features?
17:14:14 <akuznetsova_> good, today i worked with this one https://blueprints.launchpad.net/murano/+spec/per-tenant-isolation
17:14:35 <tnurlygayanov_> not bad ) it is in progress now and we found several bugs in new features
17:14:37 <tsufiev_> akuznetsova_: ah, yes, it seems like the pip version issue
17:15:12 <tnurlygayanov_> tsufiev, yes, and we have workaround for this issue.
17:15:33 <tsufiev_> tnurlygayanov_: speaking of new bugs, should they be fixed in 0.4.1?
17:15:34 <katyafervent> #info We will have feature freeze this Friday
17:15:37 <akuznetsova_> tnurlygayanov_: do you speak about it feature https://blueprints.launchpad.net/murano/+spec/per-tenant-isolation ?
17:16:09 <akuznetsova_> tnurlygayanov_: oops, wrong link https://blueprints.launchpad.net/murano/+spec/key-pair-for-linux-services
17:16:21 <tnurlygayanov_> tsufiev_, yes, we have bugs which sohlud be fixed in 0.4.1, like issue with empty key pair
17:17:02 <tnurlygayanov_> looks like this feature (per tenant isolation) works good
17:17:32 <tnurlygayanov_> we have several problems with keypais and devstack scripts
17:17:52 <tsufiev_> katyafervent: do these additional fixes fit into our new release date estimate?
17:17:57 <tnurlygayanov_> it is the most important issues which should be fixed in 0.4.1
17:18:45 <katyafervent> Yes, we do have in our deliverables
17:19:09 <tsufiev_> ok
17:19:28 <tsufiev_> if nothing left on 0.4.1 topic, let's move to the next one
17:19:35 <katyafervent> Here is the link https://bugs.launchpad.net/murano/+bug/1273596
17:19:49 <katyafervent> stanlagun, Could you please take it?
17:20:05 <stanlagun> np
17:20:15 <katyafervent> What's next in our agenda?
17:20:20 <katyafervent> stanlagun, thanks!
17:20:36 <tsufiev_> #topic New DSL engine
17:21:39 <tsufiev_> as said before the code is 95%-ready
17:22:24 <tsufiev_> right now i'm helping stanlagun with the conditional deploy implementation
17:22:35 <tnurlygayanov_> and what about the rest 5 % ?  )
17:23:13 <stanlagun> 95% of my part :)
17:23:35 <tsufiev_> it is a bit more general than deploy-only - it should allow to decide whether to invoke or not to invoke specific methods based on deployment history
17:23:45 <tsufiev_> so it's the 5% i'm working on
17:24:14 <tsufiev_> problem is interesting and not quite trivial :)
17:24:33 <tnurlygayanov_> can we try to use not finished DSL engine now, before the release?
17:24:41 <tsufiev_> i'm going to think a bit more about it today and have a brainstorm with stanlagun tomorrow
17:25:01 <stanlagun> There were huge improvements in DSL since last CM. Nearly all the problems we had are solved or at least a solution is know
17:25:33 <tnurlygayanov_> ok
17:26:32 <tnurlygayanov_> do we plan to rewrite more services using new DSL?
17:26:43 <tnurlygayanov_> for release 0.5
17:26:45 <tsufiev_> ActiveDirectory DSL definitions are still being reworked - to use the conditional system
17:27:14 <stanlagun> yes. But not before the DSL syntax etc. are approved
17:27:20 <tsufiev_> once we have 100%-ready engine, it would be much faster
17:28:11 <tsufiev_> anything else on the DSL engine?
17:28:15 <katyafervent> That's cool!
17:28:33 <tnurlygayanov_> ok, cool. And do we have anly plan to merge this new DSL with Mistral DSL/engine?
17:29:14 <tnurlygayanov_> or it is only internal Murano DSL?
17:29:30 <tsufiev_> right now they're doing same things quite differently
17:31:14 <tnurlygayanov_> *butt we should remember about this project and plan to use it, if it will be possible and usefull
17:31:18 <tsufiev_> tnurlygayanov_: idk. haven't been on a Mistral meetings for a while
17:31:24 <stanlagun> tnurlygayanov_: not in 0.5. Mistral integration in not clear at this moment
17:31:33 <tnurlygayanov_> ok
17:31:53 <tnurlygayanov_> yes, not for release 0.5
17:32:30 <stanlagun> There can be 2 strategies for this: rewrite DSL engine (very very very not trivial) or just contribute Murano DSL to Mistral in some way
17:32:47 <tsufiev_> stanlagun: also, what about unit tests for new DSL?
17:33:13 <joel_c> +1 for potential merge of murano DSL with mistral
17:33:13 <tsufiev_> i understand that it's still a POC, but the sooner we start writing them, the better
17:34:17 <stanlagun> Unit-testing of YAML workflows is something we need to invent. Currently there is nothing done for this, but this definitely possible. Probably someone may start thinking on it
17:35:19 <stanlagun> Unit tests of DSL engine is also yet to be done. I hope someone will help me with it
17:36:08 <tsufiev_> i'd be glad to think about it, but i have 2-weeks vacation starting next week
17:36:45 <tnurlygayanov_> ok, I can help with it on the next week
17:37:19 <tsufiev_> #action tnurlygayanov to help stanlagun with DSL Engine & YAML workflow unit tests
17:37:28 <stanlagun> I know alex is writing unit tests for YAQL 0.3
17:37:29 <tnurlygayanov_> but I want to review code before it )
17:37:48 <tnurlygayanov_> yes, Alex can help too )
17:38:30 <tsufiev_> tnurlygayanov_: it's going to be very interesting activity :)
17:38:42 <tnurlygayanov_> I will discuss it with him, probably he will share some examples.
17:39:09 <tnurlygayanov_> yes ))
17:39:35 <tsufiev_> ok, is there some other DSL-related questions we want to discuss?
17:39:36 <tnurlygayanov_> and it will help to fast uderstand new DSL to me and Alex.
17:40:21 <tsufiev_> tnurlygayanov_: the best way to understand new DSL (for me) is reading it's code and trying to implement some functionality
17:41:08 <tnurlygayanov_> *to write the tests in my case )
17:41:14 <tsufiev_> yes )
17:42:12 <tsufiev_> so it seems that we finished with DSL engine
17:42:40 <akuznetsova_> do we have any other AI?
17:43:07 <tsufiev_> ativelkov asked to drop the Repository reorganization topic from today agenda, because he wants to discuss it on the next meeting
17:43:35 <tsufiev_> #action ativelkov to write to ML about repository re-organization
17:43:48 <tsufiev_> #action ativelkov to schedule a meeting with Dmitry
17:44:23 <tsufiev_> akuznetsova_: no, we haven't specific topics left
17:44:36 <tsufiev_> #topic Open discussion
17:47:13 <tsufiev_> the question that bothers me most is 'When this cold winter ends?' :)
17:47:37 <tsufiev_> but if you have more Murano-specific questions, you're welcome :))
17:48:03 <katyafervent2> When you vacation starts)
17:48:16 <katyafervent2> *your
17:49:09 <tsufiev_> it is 03.02.14-16.02.14
17:49:30 <katyafervent2> I guess we are done for today
17:50:02 <tsufiev_> agree
17:50:09 <tsufiev_> #endmeeting