17:02:08 <ruhe> #startmeeting murano
17:02:08 <openstack> Meeting started Tue Apr  8 17:02:08 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:12 <openstack> The meeting name has been set to 'murano'
17:02:41 <ruhe> murano folks, rise your hands in the air
17:02:53 <gokrokve> \o
17:02:55 <katyafervent> Hi there
17:03:01 <tsufiev> o|
17:03:40 <ruhe> as usual here is our agenda
17:03:40 <sergmelikyan> =^_____^=
17:03:45 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:03:46 <stanlagun> Oo/
17:04:14 <ruhe> #topic AI review
17:04:32 <ruhe> there were no action items from the last meeting
17:04:53 <ruhe> we have only one common goal - release Murano 0.5 :)
17:05:06 <ruhe> #topic Release status
17:05:27 <ruhe> ok. there are a lot of moving parts at this moment
17:05:33 <ruhe> let's check on at a time
17:05:44 <xwizard_> hi :)
17:05:56 <ruhe> let's start from UI/Dashboard
17:06:07 <ruhe> tsufiev: your turn. is it ready?
17:06:21 <tsufiev> ruhe: yes
17:06:34 <tsufiev> admin ui for AppPackages is working
17:06:46 <tsufiev> and AppCatalog (userland) is working too
17:06:54 <ruhe> tsufiev: awesome!
17:06:55 <ruhe> tsufiev: did you mark all related BPs as "Implemented" ?
17:07:21 <tsufiev> there are some bugs still - e.g. Topology View doesn't work now, but we should fix them soon enough
17:07:50 <tsufiev> ruhe: not yet
17:08:08 <ruhe> #action tsufiev mark all UI-related BPs targeted on 0.5 as complete
17:08:10 <tsufiev> i'm waiting for our designer to say the final word
17:08:30 <ruhe> #info UI/Dashboard is 99% ready
17:08:57 <ruhe> ok. good news about dashboard. what about API? katyafervent your turn
17:09:31 <katyafervent> All API calls are implemented, including search by custom words
17:09:35 <katyafervent> need to be tested
17:09:59 <katyafervent> QA-guys, have you start API testing?
17:10:28 <ruhe> xwizard_: what about QA for API?
17:10:45 <xwizard_> all automated tests already updated
17:10:56 <xwizard_> yes ))
17:11:12 <xwizard_> and we plan to add more test cases
17:11:18 <ruhe> there are still some patches on review
17:11:28 <ruhe> for catalog testing in the gate
17:11:34 <xwizard_> for new API for services metadata
17:11:49 <ruhe> #info API part is finished, need moar tests
17:11:49 <katyafervent> Do you have tests on package search?
17:12:08 <xwizard_> yes, we should wrie more tests for catalog part, now we have only possitive tests
17:12:42 <xwizard_> katyafervent: moment, I will check
17:12:55 <ruhe> #action xwizard_ add more tests for catalog API
17:13:15 <xwizard_> all tests foc catalog, which we have now https://github.com/stackforge/murano-api/blob/master/functionaltests/api/v1/test_repository.py
17:13:20 <katyafervent> May be we will need some more calls, such as adding categories but not for now
17:13:48 <xwizard_> katyafervent: we have no tests for search action, we will add these tests
17:13:57 <ruhe> katyafervent: maybe we should compose priority-sorted list of tests for xwizard_ to implement?
17:14:45 <xwizard_> we will implement all tests :) on this week we will implement first part of tests for new API
17:14:53 <katyafervent> probably, we need, There are lot of use cases on packages search
17:15:05 <katyafervent> cool)
17:15:37 <xwizard_> ok, let's discuss new API, what the most important tests we should automate on this week?
17:15:48 <katyafervent> what's next in our agenda?
17:16:10 <ruhe> xwizard_: let's discuss and compose a list of tests for API in #murano
17:16:22 <xwizard_> ok
17:16:23 <katyafervent> well there are  just several api calls, all of them need to be tested
17:16:35 <ruhe> next and most interesting part is the Murano Engine
17:16:46 <ruhe> sergmelikyan: stanlagun ^^
17:16:53 <xwizard_> katyafervent: ok, we will add you to code review for new API tests
17:17:17 <katyafervent> xwizard_, thanks
17:17:49 <stanlagun> engine is working. During last several days we've added support for object deletion and billing statistics tracking
17:17:58 <sergmelikyan> Two major peaces of code are landed to repository, but during integration session we found several bugs from typos to some design flaws.
17:18:09 <stanlagun> also integration between engine and deployment API was rewritten
17:18:16 <tsufiev> stanlagun: speaking of UI for billing...
17:18:28 * sergmelikyan talked about package loader and object deletion
17:18:39 <tsufiev> afair, gokrokve wanted to implement it?
17:19:02 <ruhe> tsufiev: we can discuss that in the next topic
17:19:09 <sergmelikyan> We expect to finish integration in a few days
17:19:09 <tsufiev> ruhe: ok
17:19:10 <ruhe> let's finish with the engine first
17:19:27 <ruhe> update from my side: patch for 'package import' is on review, i have couple of problems with SQLA, but they're solvable
17:20:22 <ruhe> summary: most of the parts are finsihed, but they're not integrated with each other yet
17:20:37 <ruhe> should take 1-2 more days
17:20:50 <ruhe> katyafervent: tsufiev: stanlagun; sergmelikyan: agree?
17:20:57 <sergmelikyan> ruhe, yep
17:21:02 <stanlagun> lets hope
17:21:10 <tsufiev> ruhe: yes
17:21:10 <katyafervent> hope so
17:21:19 <ruhe> :)
17:21:39 <ruhe> #info summary: most of the parts are finsihed, but they're not integrated with each other yet. optimistic estimate - should take 1-2 more days
17:22:02 <ruhe> anything else on the release status?
17:22:41 <ruhe> ok. let's move on
17:22:55 <ruhe> #topic Review blueprints
17:23:29 <ruhe> tsufiev: you can discuss UI/billing with gokrokve now and related blueprints
17:23:42 <tsufiev> gokrokve: are you here?
17:23:56 <gokrokve> yes
17:24:16 <tsufiev> the first question is about UI for billing
17:24:19 <gokrokve> I plan to make a draft today.
17:24:43 <gokrokve> I have a page for API stats and I will add a new tab
17:24:56 <tsufiev> nice )
17:25:20 <gokrokve> then during my night you can polish it -)
17:25:36 <gokrokve> again it will not have a nice css as Steve will work on it later
17:25:54 <tsufiev> gokrokve: that was the second question :)
17:26:11 <tsufiev> when Steve will be able to do it?
17:26:17 <gokrokve> I will ask Steve to take a look today on existing pages
17:26:35 <tsufiev> also, I have a little concern about usability of Current Environment selector
17:26:44 <gokrokve> during this week he will finish, I think
17:27:15 <gokrokve> Env selector is fine. W ecan remove it if necessary
17:27:17 <tsufiev> the problem is that it is needed to open it to see what environment will the Application land in
17:27:18 <ruhe> gokrokve: tsufiev: should we file a BP for this activity?
17:27:52 <gokrokve> I am more concerned about full flow as when I tried to deploy app with quick deploy it has errors
17:28:11 <tsufiev> gokrokve: what errors?
17:28:39 <gokrokve> good question. I did not dug into the depth
17:28:50 <gokrokve> Just saw error message in UI
17:29:01 <tsufiev> ruhe: it was said that billing UI is too small and very simple to implement
17:29:02 <sergmelikyan> gokrokve, we are working on this right now, we are debugging in realtime starting from 5 PM
17:29:07 <ruhe> tsufiev: ok
17:29:18 <gokrokve> ok
17:29:34 <ruhe> anything else on billing UI?
17:29:51 <tsufiev> btw, team, what do you think about Current Env selection?
17:29:55 <tsufiev> *selector
17:29:56 <ruhe> #info gokrokve is working on billing UI
17:30:02 <tsufiev> does it seem ok to you?
17:30:18 <gokrokve> ok
17:33:24 <ruhe> let's review our "Not started" blueprints
17:33:35 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/app-total-uptime
17:33:45 <ruhe> stanlagun: should we drop it out of 0.5?
17:34:38 <stanlagun> yes, I think we should
17:34:59 <sergmelikyan> ruhe, guys this BP is superseeded
17:35:13 <stanlagun> sorry, it is already implemented :)
17:35:30 <stanlagun> I've joined several blueprints into one
17:35:46 <ruhe> good
17:35:56 <ruhe> now we also have three BPs related to app events
17:36:06 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/dsl-register-event
17:36:11 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/external-events
17:36:19 <ruhe> #https://blueprints.launchpad.net/murano/+spec/api-list-events
17:36:23 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/api-list-events
17:36:38 <ruhe> i would prefer to postpone these BPs to the next release
17:36:52 <ruhe> we don't have time and we don't resources to finish them
17:37:01 <katyafervent> Will murano still be MVP without them?
17:37:07 <ruhe> gokrokve: any objections?
17:37:28 <gokrokve> no
17:37:32 <sergmelikyan> katyafervent, AFAIK they are don't included to MVP list
17:37:36 <sergmelikyan> *no
17:37:37 <sergmelikyan> *not
17:37:38 <stanlagun> I was refering to those BPs when I said we should them from 0.5
17:38:00 <gokrokve> we can add them in 0.5.1
17:38:12 <gokrokve> in a month after 0.5 release
17:38:28 <ruhe> #action ruhe to move events BPs to the next release
17:39:00 <ruhe> next one
17:39:03 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/app-catalog-billing
17:39:25 <ruhe> stanlagun: this BP is in "Started" state. will you be able to finish it in time?
17:40:19 <stanlagun> it is finished from enigene's POV. gokrokve was going to finish UI part and then we close BP
17:40:29 <ruhe> stanlagun: ok
17:40:45 <ruhe> gokrokve: you should mention this BP in your commit message
17:41:06 <gokrokve> ok
17:41:06 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/api-request-stats
17:41:25 <ruhe> gokrokve: this BP is in "Started" state. will you have time to finish it?
17:41:35 <stanlagun> probably the same as above
17:42:03 <ruhe> gokrokve: maybe you should status to "Good progress" or "Beta avaialble" to avoid confusion?
17:42:11 <ruhe> * change status
17:43:20 <ruhe> gokrokve: please confirm
17:43:41 <gokrokve> good progress is ok
17:43:59 <ruhe> #action gokrokve update status on https://blueprints.launchpad.net/murano/+spec/api-request-stats
17:44:15 <ruhe> ok. we covered all the BPs from the "red zone"
17:44:25 <ruhe> anything else on this topic?
17:44:45 <ruhe> btw, once we have something working, we might want to run short bug scrub
17:45:12 <ruhe> maybe find log-hanging-fruits for newcomers
17:45:18 <ruhe> *low-hanging
17:45:27 <sergmelikyan> ruhe, it will be great!
17:45:52 <ruhe> #action sergmelikyan don't forget about and schedule a bug scrub day
17:45:53 <ruhe> ;)
17:46:20 <ruhe> let's move to the next topic
17:46:25 <ruhe> #topic Open Discussion
17:46:53 <ruhe> folks, please step up if you have anything to discuss
17:47:42 <ruhe> i'll give 2 minutes for ideas to come up
17:50:46 <ruhe> i guess, folks are pretty tired already. we can finish the meeting and prepare for the next day :)
17:50:51 <ruhe> #endmeeting