17:03:39 <ruhe> #startmeeting murano
17:03:39 <openstack> Meeting started Tue Apr 15 17:03:39 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:42 <openstack> The meeting name has been set to 'murano'
17:03:59 <tsufiev> hi there
17:04:07 <ruhe> i'll copy the first topic from Solum meeting :)
17:04:09 <ruhe> #topic Roll Call
17:04:19 <sjmc7> hi guys
17:04:33 * ruhe is ruslan kamaldinov
17:04:42 <btully> howdy
17:04:53 * btully is NOT a cowboy ;)
17:05:06 <katyafervent2> Hi!
17:05:10 <akuznetsova_> hello)
17:05:18 <tsufiev> i see a lot of new people this time :)
17:05:46 <ruhe> all right. i hope the rest of murano folk will join soon
17:05:52 <ruhe> #topic Action Items Review
17:06:29 <ruhe> #link http://eavesdrop.openstack.org/meetings/murano/2014/murano.2014-04-08-17.02.txt
17:06:42 <ruhe> first AI is: gokrokve update status on https://blueprints.launchpad.net/murano/+spec/api-request-stats
17:07:05 <gokrokve> Heh. I did not do this.
17:07:21 <ruhe> gokrokve: it's a good time to do it right now ;)
17:07:30 <gokrokve> Will do this. Sure.
17:07:40 <ruhe> gokrokve: thanks
17:07:44 <ruhe> the next AI is: ruhe to move events BPs to the next release
17:07:53 <ruhe> and i did that
17:08:04 <ruhe> #info moved events BPs to the next release
17:08:17 <ruhe> the next one is:  sergmelikyan don't forget about and schedule a bug scrub day
17:08:40 <ruhe> looks like sergmelikyan and me didn't do it. but we really wanted to
17:08:57 <ruhe> it's the release time and a lot of work, you know
17:09:02 <ruhe> sergmelikyan: you here?
17:09:53 <ruhe> ok. i promise we will run bug scrub ASAP
17:10:03 <ruhe> #action sergmelikyan don't forget about and schedule a bug scrub day
17:10:17 <ruhe> the next AI is: tsufiev mark all UI-related BPs targeted on 0.5 as complete
17:10:31 <ruhe> tsufiev: some of your BPs are still "good progress"
17:10:36 <tsufiev> hm...
17:10:51 <ruhe> tsufiev: i would expect them to be "beta available" or "implemented"
17:10:58 <ruhe> #link https://launchpad.net/murano/+milestone/0.5
17:11:16 <tsufiev> we still have categories in 2 places - can it be considered completed?
17:11:28 <tsufiev> marking them as beta...
17:11:38 <akuznetsova_> btw, i started to work with our bugs today, but there are a lot of bugs those are unassaigned and don't have a milestone
17:11:59 <ruhe> tsufiev: yes, beta is more appropriate for the current status of Murano UI
17:12:00 <tsufiev> ruhe: done
17:12:05 <ruhe> tsufiev: thank you
17:12:09 <tsufiev> all is 'Implemented' or 'Beta...'
17:12:44 <katyafervent2> because I have no rights to assign milestones anymore. Is it ok?) who should do it?
17:13:02 <ruhe> akuznetsova_: i guess it relates to our plan to run bug scrub day. but meanwhile you can process the bug list and use #murano to collect feedback on the bugs, wether they should be targeted for 0.5 or not
17:13:12 <dteselkin> Hi
17:13:35 <ruhe> katyafervent2: core team should manage milestones
17:13:36 <akuznetsova_> ruhe: ok, i'll do it tomorrow
17:13:59 <ruhe> katyafervent2: you can always force them to take care of important bugs and BPs
17:14:01 <ruhe> :)
17:14:09 <ruhe> ok
17:14:14 <ruhe> next AI is: xwizard_ add more tests for catalog API
17:14:31 <ruhe> akuznetsova_: i guess you can give us an update on tests for catalog API
17:14:41 <ruhe> btw
17:15:05 <katyafervent2> Sergey M did extend tests but I'm not sure if his commit was merged or no
17:15:10 <ruhe> #info all UI-related BPs targeted on 0.5 are in "implemented" or "beta available" state
17:15:23 <katyafervent2> let's say we did that for a smoke tests
17:15:32 <ruhe> katyafervent2: do we need more test coverage in tempest?
17:15:35 <tsufiev> katyafervent2: Me or Mu :)?
17:15:50 <katyafervent2> Mu :)
17:16:28 <akuznetsova_> yes, Sergey Mu wrote more tests for application catalog ang work with package
17:16:51 <ruhe> #info sergey murashov added smoke tests for catalog API. we expect more tests to arrive
17:17:05 <ruhe> that's all about action items
17:17:10 <tsufiev> akuznetsova_: what's about writing more tests for CentOS & Django 1.4?
17:17:37 <akuznetsova_> tsufiev: do we need more special tests for that?
17:17:53 <ruhe> before we jump to the next topic "Release Status" i'd like folks to give a chance to propose additional topics
17:18:29 <tsufiev> akuznetsova_: we need to run the same tests as for ubuntu & django 1.5 - because they can behave differently
17:19:10 <tsufiev> ruhe: i'd like to ask gokrokve about UI... is it right time now?
17:19:30 <gokrokve> What is the question?
17:19:40 <ruhe> tsufiev: go ahead
17:20:01 <akuznetsova_> tsufiev: ok, we will create new Jenkins Jobs with Centos as soon as our 'new' murano-ci will be done
17:20:33 <ruhe> sjmc7: btully: JFYI you can propose a topic for the weekly meeting if you have something major to discuss. there are two options - update https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda before the meeting or propose topic when the meeting starts
17:20:38 <tsufiev> gokrokve: current UI have 2 category selectors: first as drop-down list, second in right sliding side-bar. will it remain in release?
17:20:50 <tsufiev> i found this a bit confusing
17:20:51 <sjmc7> thanks ruhe - just lurking for now
17:23:19 <tsufiev> gokrokve: are you with us?
17:24:08 <ruhe> tsufiev: i suggest to move on and continue your discussion when gokrokve gets back online
17:24:09 <gokrokve> I think we can keep both. We can extend later the right panel.
17:24:17 <ruhe> oh, here is the man :)
17:24:57 <tsufiev> gokrokve: ok, if our UI man thinks it's ok, then it's ok :)
17:25:50 <ruhe> tsufiev: gokrokve: can we move the next topic?
17:26:00 <ruhe> * to the next topic
17:26:27 <tsufiev> ruhe: yes
17:26:39 <ruhe> #topic Release status
17:26:58 <ruhe> in previous meetings we discussed each component in detail
17:27:32 <ruhe> today i'd like to have an open discussion about items we think are important for this release, but not yet merged or implemented
17:28:39 <ruhe> gokrokve: you're the one who always cares about features :) what's missing from your point of view?
17:28:58 <tsufiev> ruhe: advanced networking, of course :)
17:29:23 <gokrokve> Yes. Networking part should be in 0.5 as it was suported on 0.4 version.
17:29:39 <gokrokve> other stuff can be added later in 0.5.1 release
17:29:41 <ruhe> #info advanced networking is a must have for 0.5
17:30:29 <ruhe> i don't see stan_lagun here. correct me if i'm wrong, but i think that he's working on this feature
17:31:28 <ruhe> tsufiev: do we have a bug for it?
17:31:35 <ruhe> or BP
17:32:02 <tsufiev> ruhe: don't know of any
17:32:17 <tsufiev> ruhe: fortunately you can ask slagun himself :)
17:32:24 <ruhe> slagun: ping
17:32:32 <slagun> hi
17:32:46 <slagun> sorry for being late. What is the question?
17:32:51 <ruhe> slagun: are you working on advanced networking?
17:33:01 <slagun> not yet
17:33:22 <ruhe> slagun: but you will, right?
17:33:31 <slagun> hopefully
17:33:48 <ruhe> slagun: can i ask you to file a bug related to this missing feature?
17:33:59 <slagun> np
17:34:13 <slagun> sure
17:34:16 <ruhe> #action slagun file a bug about missing "advanced networking"
17:34:32 <ruhe> #action slagun implement "advanced networking" in 0.5
17:35:08 <ruhe> anything else critical we would like to land in 0.5?
17:35:34 <ruhe> katyafervent2: is our API in a good shape now?
17:35:43 <gokrokve> I think we need to convert all existing apps to new DSL.
17:35:50 <katyafervent2> I think so)
17:36:05 <ruhe> gokrokve: agree
17:36:20 <ruhe> katyafervent2: good to hear
17:36:20 <katyafervent2> But need more investigation
17:36:47 <ruhe> gokrokve: i suggest to file a BP to track each existing app conversion to the new DSL
17:37:23 <ruhe> #action ruhe file a BP to track conversion of existing apps to the new DSL
17:37:54 <ruhe> katyafervent2: btw, what's your progress with the telnet service?
17:38:25 <katyafervent2> I can't check the deploy due to blocking issues
17:38:46 <katyafervent2> Hope tomorrow I'll do it, because telnet package is ready
17:39:20 <sergmelikyan> I will publish fixes for all found bugs tomorrow, I was able today finish deployemnt of Tomcat - Postgresql
17:39:33 <ruhe> sergmelikyan: woohoo!
17:40:17 <ruhe> #info sergmelikyan successfully ran deployment of Tomcat/Postgres example
17:40:56 <ruhe> so far we identified three critical items for 0.5:
17:41:03 <ruhe> 1. advanced networking
17:41:27 <ruhe> 2. convert existing apps the new DSL
17:41:48 <ruhe> 3. i need to work on my math
17:42:02 <tsufiev> :)
17:42:06 <ruhe> anything else?
17:42:41 <ruhe> all right, we're open for open discussion
17:42:45 <ruhe> #topic Open Discussion
17:43:29 <ruhe> i can give an update on the config generation/checking
17:43:39 <ruhe> here is the patch:
17:43:41 <ruhe> #link https://review.openstack.org/#/c/85855/
17:43:57 <ruhe> it'll allow us to generate sample config from the code
17:44:17 <ruhe> and always make sure that the sample config is synced with configs declared in the code
17:44:35 <tsufiev> speaking of the reviews...
17:44:58 <ruhe> and i'd like to remove SSL configs from heat,keystone,neutron block and keep is in a single [ssl] block
17:44:59 <tsufiev> guys, don't forget to review regularly, patches are not going to merge themselves :)
17:45:06 <sjmc7> i can help with reviews for 0.5. our team is getting up to speed, should be starting to look at low hanging fruit bugs end of this week or beginning of next
17:45:54 <ruhe> sjmc7: thank you. we're constantly behind desired pace in dashboard reviews
17:45:59 <tsufiev> sjmc7: it would be great! btw, we already have plenty of low-hanging-fruits for dashboard
17:46:22 <sjmc7> tsufiev - splendid. if they're tagged, we'll pick them up
17:46:26 <ruhe> sergmelikyan: what do you think about moving all the SSL-related configs to a single block [ssl] ?
17:46:39 <sergmelikyan> ruhe, negative
17:46:44 <ruhe> sergmelikyan: you can find it in the bottom of https://review.openstack.org/#/c/85855/6/etc/murano/murano-api.conf.sample
17:46:52 <tsufiev> sjmc7: https://bugs.launchpad.net/murano/+bugs?field.tag=low-hanging-fruit
17:47:09 <sergmelikyan> ruhe they are different settings for different services, I don't quite get how do you plan to combine them
17:47:35 <sjmc7> tsufiev - yep. still getting dev environments set up, but we'll start on them asap
17:47:57 <ruhe> sergmelikyan: i would expect all the openstack services to use the same SSL keys within the same installation
17:48:18 <sergmelikyan> O.o
17:48:37 <tsufiev> sjmc7: do you have any difficulties with setting dev envs up? we could help
17:49:14 <sjmc7> tsufiev - a couple, but we've worked around/filed bugs. we'll ask if we need help. people are still learning the language and environment, taking some time
17:49:41 <tsufiev> sjmc7: ok, feel free to ask :)
17:49:57 <ruhe> tsufiev: that's something i'd like to improve before the relase. we don't have much developer docs atm. i'd like to add as much as possible and publish them to http://murano-api.readthedocs.org/en/latest/
17:50:23 <ruhe> sergmelikyan: seems i said something stupid, let's discuss in #murano :)
17:50:24 <sergmelikyan> ruhe, I am not sure that this is right thing to do, since different services may have been accessible from different endpoint types with different configurations. Why are trying to restrict them to use only same settings? This will mean that cloud where each service has own certificated will not be supported (murano would not work)
17:50:49 <sergmelikyan> ok :)
17:51:24 <tsufiev> sjmc7: yes, we're working on that. katyafervent2 is currently adding some docs to wiki: https://wiki.openstack.org/wiki/Murano/Documentation/How_to_create_application_package
17:51:27 <sjmc7> ruhe - +1 for developer docs, there're lots of bits out of date
17:51:38 <ruhe> sergmelikyan: i guess we need to speak with folks who run production clouds
17:51:40 <sjmc7> ok, great. i'll keep an eye out
17:51:57 <sjmc7> ruhe - i can ask our public cloud folks?
17:52:14 <tsufiev> ruhe: oops, i confused your message with sjmc7's one :)
17:52:45 <tsufiev> ruhe: anyway, we should move docs from wiki to readthedocs asap
17:53:00 <katyafervent2> and from docbook too?
17:53:08 <ruhe> katyafervent2: docbook is for user docs
17:53:29 <katyafervent2> ok, so user guide will live there
17:53:30 <ruhe> sjmc7: that would be great
17:54:06 <sjmc7> ruhe - maybe let me know after this exactly what the question is
17:54:13 <ruhe> sjmc7: sure
17:54:19 <sergmelikyan> ruhe, we had same settings for all services for one of the customers, but not on public cloud, since on public cloud they planned to not have wildcard certificates and disable insecure option
17:54:26 <ruhe> katyafervent2: right. i'd like to move user docs from murano-docs to murano-api (which will be renamed to murano). but i need to convince sergmelikyan first :)
17:54:36 <akuznetsova_> katyafervent2: i can help with user giude updating
17:55:21 <katyafervent2> akuznetsova_: it would be great
17:55:53 <slagun> sjmc7,you can take Heat's approach to clients' setting configuration as a reference
17:55:56 <sergmelikyan> ruhe, you don't need to convince me :) I think developers docs should be for developers (in murano-api repo in ReST), but manuals and guides in docbook and in different repo. Just as Openstack itself does.
17:56:35 <sergmelikyan> We don't want to rewrite them to docbook once we integrated, are we? )
17:56:47 <ruhe> sergmelikyan: i want to keep user docs in docbook, but move them under murano-api to simplify the release process
17:57:17 <ruhe> the same way we're moving tests and deployment scripts under murano-api
17:58:19 <sergmelikyan> ruhe, no objections here, but I don't think that moving all staff to single repo, where root of the python package is located is a good thing to do. We need to make sure that murano-api will not turn to mess.
17:58:28 <akuznetsova_> ruhe: do you want to move all tests to murano-api repo?
17:58:41 <ruhe> akuznetsova_: yes
17:58:59 <tsufiev> one repo to rule them all :)
17:59:02 <ruhe> speaking of the developer docs, i will take an action item to setup everything necessary for  docs: a job to build them and to push to to readthedocs
17:59:26 <ruhe> #action ruhe setup infrastructure for dev-docs building and publishing
17:59:37 <ruhe> last minute
17:59:44 <ruhe> anything worth mentioning?
18:00:27 <ruhe> thanks everyone!
18:00:40 <ruhe> #endmeeting