17:03:11 <ruhe> #startmeeting murano
17:03:13 <openstack> Meeting started Tue Jun 24 17:03:11 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:16 <ativelkov> o/
17:03:17 <openstack> The meeting name has been set to 'murano'
17:03:19 <sergmelikyan> o/
17:03:33 <tsufiev> hi there
17:03:39 <katyafervent> o/
17:03:53 <ruhe> ativelkov, sergmelikyan: i see you were sitting on the edge of the chair waiting for the meeting to start :)
17:03:57 <iyozhikov> o/
17:04:01 <sjmc7> hi
17:04:04 <ankurrr> hello
17:04:09 <sergmelikyan> :)
17:04:10 <dteselkin_> Hi
17:04:17 <ruhe> hi everyone!
17:04:18 <akuznetsova_> Hi
17:04:22 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:04:23 <ativelkov> ruhe: that's called just-in-time driving )
17:04:40 <ruhe> #topic action items review
17:04:52 <ruhe> katyafervent to investigate how unit testing is done in Django (and perhaps use that approach for muranodashboard unit testing); consult with drupalmonkey if needed
17:05:07 <katyafervent> Hi guys
17:05:28 <ruhe> and according to discussion we had yesterday with sjmc7 investigation already started
17:05:30 <stanlagun> hi
17:05:55 <katyafervent> there are a lot of tools to test Django applications
17:06:22 <sjmc7> ruhe - the openstack_dashboard helpers give a lot of functionality
17:06:27 <sjmc7> i don't think we should reinvent the wheel
17:06:31 <drupalmonkey> @ruhe @katyafervent yes, i'm about to commit some test code for muranodashboard that sjmc7 and i worked on
17:06:34 <katyafervent> such as https://docs.djangoproject.com/en/1.7/topics/testing/tools/ and http://effectivedjango.com/forms.html
17:06:46 <ruhe> sjmc7: agree
17:07:03 <ruhe> katyafervent: seems like drupalmonkey outperformed you here ;)
17:07:19 <katyafervent> we just need to create a test plan or smth like that to define what areas should be tested
17:07:36 <drupalmonkey> test ALL the things!
17:07:59 <tsufiev> drupalmonkey,  should we split muranodashboard into 2 parts, as horizon :)?
17:08:15 <ruhe> ok. drupalmonkey it would be nice a have a blueprint with a brief description of your plan
17:08:55 <sjmc7> we're not planning to write exhaustive tests for existing functionality  - this was just to make a start
17:09:02 <katyafervent> we should cover views, forms and probably templates
17:09:59 <katyafervent> Does anybody have something to add on that topic?
17:10:03 <ruhe> sjmc7: ok. if it's just a start
17:10:09 <igormarnat> ruhe: there was a nice plan - test ALL:)
17:10:36 <sjmc7> retroactively writing tests is not usually very helpful; it makes more sense to add them as new code is written
17:10:44 <sjmc7> i want to get some examples in place
17:10:47 <sjmc7> to make that easier
17:10:59 <ruhe> sjmc7, drupalmonkey: thanks for starting this!
17:11:25 <ruhe> next AI: akuznetsova_ create a document explaining how to run, debug and fix selenium tests
17:11:33 <ruhe> akuznetsova_: ping
17:11:38 <akuznetsova_> Yes
17:11:54 <ruhe> akuznetsova_: did you create that document?
17:12:01 <akuznetsova_> I did, I update articles in wiki
17:12:15 <sergmelikyan> can you share the link?
17:12:19 <ruhe> akuznetsova_: will you port this document to developer documentation?
17:12:27 <akuznetsova_> Not yet
17:13:22 <ruhe> akuznetsova_: can you share link to the document?
17:13:23 <akuznetsova_> where it has to be? In murano.readthedocs?
17:14:14 <ruhe> yes. you'll need to send a patch to stackforge/murano. we keep developer docs here http://git.openstack.org/cgit/stackforge/murano/tree/doc/source
17:15:52 <ruhe> #link https://wiki.openstack.org/wiki/Murano/TestsDocumentation
17:16:09 <akuznetsova_> Yes, that' s it
17:16:12 <ruhe> that's where documentation for running selenium tests is published for now ^^
17:16:35 <ruhe> #action port instructions to run selenium tests to murano developer docs
17:16:42 <ruhe> let's move to the next topic
17:17:02 <ruhe> #topic state of "improve testing"
17:17:24 <ruhe> i kept this item in the agenda to discuss how everyone feels about our current progress
17:18:24 <ruhe> for instance, one of the most important items - "run real deployment tests in CI" is not finished yet
17:18:52 <sergmelikyan> for me is hard to say, had no chance to spent much time writing tests - buy I support our decision to bundle any change with tests
17:18:53 <ruhe> sergey murashov promised that it should work starting from tomorrow :)
17:18:59 <sergmelikyan> *but
17:19:49 <gokrokve> sjmc7: Hi. I have a small demo around CF integration.
17:19:55 <ruhe> sergmelikyan: right. and since we already have a base for API tests and for DB migration, we need to enforce every patch affecting those components to have corresponding tests
17:19:59 <gokrokve> sjmc7: Are you interested to see it?
17:20:12 <sjmc7> gokrokve - yes, but probably not today
17:20:29 <gokrokve> sjmc7: Cool. Ping me once you are ready.
17:21:04 <ruhe> sjmc7: since you started this initiative (improve testing), what do you think about our current state in testing?
17:21:15 <sjmc7> i keep finding broken things :)
17:21:31 <sjmc7> i think if we start making sure there are tests with new code, that's a good direction
17:22:01 <btully> +!
17:22:03 <btully> +1
17:24:25 <ruhe> i hope everyone said "+1" in their mind. finding broken things is dissapointing
17:25:04 <ruhe> let's move to the next topic
17:25:07 <ruhe> #topic post-deploy information
17:25:14 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/post-deployment-information
17:25:16 <sjmc7> i only added this today, so apologies
17:25:48 <sjmc7> this can be a short discussion if anyone has initial questions or problems, but otherwise can talk about it later
17:26:18 <ruhe> this one looks like a very good addition from user experience perspective
17:26:57 <sjmc7> yeah.. i think we have to do something to make it a bit more user-friendly
17:27:06 <ruhe> stanlagun: did you have a chance to look at this BP?
17:27:24 <gokrokve> +1 ащк щгезгеы
17:27:31 <katyafervent> now we deployment history, may be it should be extended somehow
17:27:31 <gokrokve> +1 for outputs
17:27:34 <gokrokve> Sorry
17:27:36 <stanlagun> ruhe, not yet. Thanks for pointing out
17:27:43 <sergmelikyan> gokrokve, I don
17:27:52 <gokrokve> We have something like that in Tomcat app
17:27:56 <sergmelikyan> 't think that we need something so explicit
17:28:20 <gokrokve> Via reporter Tomcat shows somethig like app available http://ip:port/folder
17:28:25 <sergmelikyan> We can map template + data model + yaql expressions
17:28:34 <gokrokve> I agree that we need something more explicit
17:28:51 <sjmc7> i don't really mind how we do it. i would prefer it to be more than just a brief message in the reporter
17:29:03 <gokrokve> Agree
17:29:20 <tsufiev> sjmc7, your bp and that one https://blueprints.launchpad.net/murano/+spec/dynamic-fields-on-service-details might target the same Component page
17:29:22 <sergmelikyan> Most ambigious and hard part is how to show this to the user
17:29:30 <sjmc7> i'll put some more detail in the BP then we can argue about it
17:29:33 <sergmelikyan> What to do in multi-app envs
17:29:57 <sjmc7> display all of the information, sergmelikyan
17:30:04 <sjmc7> tsufiev - i hadn't seen that
17:30:12 <sjmc7> but yeah, maybe some crossver
17:30:14 <gokrokve> We can also add HOT output auto render in Murano app which consist of only HOT.
17:30:41 <sjmc7> i'll put some more detail in the BP, then we can argue about it
17:31:04 <tsufiev> sjmc7, but it's ok to have think about it from the over side
17:31:11 <sjmc7> ?
17:31:39 <sergmelikyan> sjmc7, sure!
17:32:00 <stanlagun> just pit my comments in https://blueprints.launchpad.net/murano/+spec/post-deployment-information
17:32:05 <stanlagun> *put
17:32:22 <tsufiev> sjmc7, the BP I mentioned is more about how that info is shown (in terms of code), while yours is more about UX
17:33:35 <sjmc7> we've been asked to provide the behavior
17:33:49 <ruhe> so, it seems that everyone agrees on direction (i'm going to set direction=approved) and we need more time to agree on definition (specfication)
17:34:08 <ruhe> sjmc7: do you need this to be done in juno?
17:34:27 <sjmc7> ruhe - probably, yes. we'll do it if we need to do it
17:34:35 <ruhe> sjmc7: i'll rephrase. to what milestone would you like to target this BP?
17:34:55 <sjmc7> probably j3 for now
17:34:59 <ruhe> ok
17:35:27 <ruhe> anything else on this topic?
17:36:16 <ruhe> #topic current state of error handling for engine
17:36:46 <ruhe> this one is proposed by sjmc7
17:37:24 <sjmc7> yeah... there are still some cases where exceptions are not clear from deoployments. i wasnt's ure if stanlagun is still working on this or if i should file individual bugs
17:37:43 <sergmelikyan> I think it is ok to create specific bugs, Stan is working on exceptions while covering MuranoPL and Engine with tests, but all found places may be fixed right know
17:37:54 <sjmc7> k
17:38:02 <stanlagun> I'm working on it. Most of exceptoins in DSL code will be improved alongside commits with tests
17:38:04 <sergmelikyan> *now
17:38:29 <sergmelikyan> But we can't be sure that you will not miss something - so opening bugs is okey
17:38:50 <sergmelikyan> i think )
17:38:54 <ruhe> i agree, it'll be helpful to track those problems in bugs
17:39:06 <stanlagun> I suggest wait several days and then start creating bugs for what is missing
17:39:51 <ruhe> stanlagun: how much is "several"? :)
17:40:28 <stanlagun> till this weekend
17:41:26 <ruhe> ok, sound like a good plan
17:42:30 <ruhe> #agreed start filing bugs for engine errors starting from the next week
17:42:45 <ruhe> anything else on this topic?
17:43:37 <ruhe> #topic open discussion
17:43:43 <ankurrr> I wanted to discuss https://bugs.launchpad.net/murano/+bug/1319404     I was hoping to get consensus on "services" vs "applications"  vs "components"
17:43:44 <uvirtbot> Launchpad bug 1319404 in murano "Use 'applications' instead of 'services' in the environment description" [Medium,Confirmed]
17:45:07 <ruhe> ankurrr: by the way. i wanted to reply on your question from yesterday. i've included DB sync instructions in the commit message. to populate DB you'll need to run "murano-db-manage upgrade"
17:45:47 <ankurrr> ruhe: ah, yes.  I ended up in the docs yesterday and was able to run murano-db-manage. thanks
17:46:00 <sergmelikyan> ankurrr, we decided to leave services in env description to reduce amount of changes that going to break backward compatibility. I think we need to start working on specification for v2 API and freeze changes in current one.
17:46:17 <tsufiev> ankurrr, afaik, 'services' was dropped because it reminded of windows
17:46:42 <sergmelikyan> I think we can finish specification in J cycle and start implementing in K
17:47:03 <ankurrr> sergmelikyan tsufiev: ok, but should we keep services, or should we change to "applications" or "components"?
17:47:07 <tsufiev> sergmelikyan, agree, easier to start from scratch than to redo a lot of things in current api
17:47:15 <sergmelikyan> tsufiev, yep, 'services' is part of terminology from previous era :)
17:47:24 <sjmc7> is this no longer a bug then?
17:47:51 <ankurrr> and maybe just change it in v2?
17:47:55 <tsufiev> sjmc7, maybe change milestone to K?
17:48:04 <stanlagun> for me services reminds on SOA applications, web-services etc, not Windows
17:48:21 <sergmelikyan> tsufiev, I think we don't have an issue with changing many things by itself, current API is public one, we can't just change it
17:49:18 <sergmelikyan> Even with v2 API implemented we are going to have 2 cycles deprecation period
17:49:42 <sergmelikyan> And ideally support v1 even further
17:49:43 <stanlagun> in V2 there will be no predefined name in API because it must match that in MuranoPL (currently "applications")
17:50:00 <ankurrr> so that means we'd need to maintain some sort of backward compatibility even if we did change it
17:50:01 <tsufiev> sergmelikyan, agree, 'you can not just rename it' :)
17:50:06 <katyafervent> I guess we can rename everything at least in dashboard from servicies to applications
17:50:15 <stanlagun> V1 and V2 can work in parallel. Like in Heat
17:50:28 <sergmelikyan> stanlagun, +1
17:50:37 <sergmelikyan> So let's refocus on original question :)
17:50:39 <tsufiev> katyafervent, wasn't that already done?
17:50:50 <sergmelikyan> ruhe, what is your suggestion? )
17:51:02 <sergmelikyan> *to original question
17:51:53 <ruhe> sorry, i  was distracted by a very dramatic game, Urugway - Italy
17:51:54 * sergmelikyan did not practiced English enough since summit :(
17:52:10 <sergmelikyan> ruhe, they going to loose
17:52:35 <igormarnat> both of them?
17:52:52 <sergmelikyan> No, one of the team ) But I don't know which one
17:53:00 <sjmc7> ok. this ticket should be marked as not a bug
17:53:04 <sjmc7> and it can get reworked in v2
17:53:13 <sjmc7> or wont fix or something
17:53:18 <ankurrr> ok, sounds good
17:53:31 <ruhe> sjmc7: thanks for summarizing it :)
17:54:12 <katyafervent> tsufiev, not everywhere, inside code we still have services
17:54:25 <ruhe> #agreed close 1319404 as won't fix and work on it in v2 api
17:54:38 <ruhe> anything else for today?
17:56:12 <ruhe> one more minute to close the meeting
17:57:18 <ruhe> thanks everyone for attending this meeting
17:57:41 <ruhe> #endmeeting