17:01:03 <ruhe> #startmeeting murano
17:01:04 <openstack> Meeting started Tue Aug 12 17:01:03 2014 UTC and is due to finish in 60 minutes. The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:07 <openstack> The meeting name has been set to 'murano'
17:01:23 <ruhe> hi murano team!
17:01:28 <sjmc7> hi
17:01:34 <sergmelikyan> o/
17:02:14 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:02:22 <ruhe> i guess we can keep our meeting short today
17:02:44 <ruhe> #topic next steps with python-muranoclient 0.5.3
17:02:59 <katyafervent> 0/
17:03:19 <sjmc7> yeah, this was my bad.. i think kate's commits fix the issues
17:03:44 <ruhe> no worries sjmc7. it's a useful patch anyway
17:04:06 <ruhe> katyafervent: sjmc7: do you think we should release new version? is it working ok now?
17:04:25 <ruhe> katyafervent: did our dashboard tests pass on client with your patch applied?
17:04:32 <katyafervent> yes
17:04:44 <katyafervent> dashboard is fine
17:04:59 <ruhe> any objections towards a new release of python-muranoclient?
17:05:06 <sjmc7> no. thanks kate!
17:05:36 <ruhe> #action ruhe to release python-muranoclient 0.5.4
17:05:45 <sjmc7> on that note
17:05:51 <katyafervent> ruhe, someday you told us that we can release the client as many times as we want :)
17:05:58 <sjmc7> is there a reason the dashboard is >= version ?
17:06:05 <sjmc7> rather than tied to one version?
17:06:16 <ruhe> that's a good point sjmc7
17:06:36 <ruhe> i don't see any reasons not to do so
17:07:05 <sergmelikyan> It helps to fix issues in python-muranoclient without re-releasing murano-dashboard
17:07:15 <sjmc7> yes, that's true
17:07:27 <ruhe> another good point from sergmelikyan
17:08:01 <sergmelikyan> Projects in OpenStack usually assumes that client is backward compatible
17:08:06 <ruhe> and a new release of dashboard is a more complicated thing, because we need to keep dashboard versions in sync with murano versions
17:08:23 <sergmelikyan> and in sync of OpenStack versions...
17:08:38 <sjmc7> ok. in this case, it is my fault for not testing well enough, but with silent version upgrades it's often hard to diagnose problems
17:08:56 <sjmc7> esp if you just check out the dashboard and don't realize there's a version bump
17:08:58 <ruhe> we're going to run dashboard tests on changes in python-muranoclient. that should help to catch compatibility issues before we release a new version of client
17:09:35 <sergmelikyan> sjmc7, I know :( I have hit same issue with silent client version upgrades just yesterday
17:10:03 <ruhe> also, there is a patch to run integration tests (on murano-ci) with murano client instead of custom client. initially it was written with custom client to replicate common practices from Tempest
17:10:05 <sjmc7> the novaclient one was an example, too
17:10:38 <ruhe> ok. it seems that we should stay with >=
17:10:43 <sergmelikyan> sjmc7, you mean when all gates were broken due to bug in client?
17:10:52 <sjmc7> yeah. because they all have novaclient >=
17:11:00 <sjmc7> and it silently upgraded everything to the new version
17:11:13 <sjmc7> but at least it caught the bug, i guess. ok, i'm fine leaving it >=
17:11:21 <sergmelikyan> Was there some discussion about this issue in ml?
17:11:43 <katyafervent> right now the only way to follow the compatibility between client and dashboard in in dashboard requirements.txt
17:11:46 <ruhe> sergmelikyan: we were affected by this issue for 2 or 3 days
17:11:54 <sergmelikyan> ruhe, I know
17:12:05 <ruhe> sergmelikyan: i mean upgrade of novaclient
17:12:40 <ruhe> and i don't recollect any followup discussion on that issue
17:12:58 <sjmc7> no. they fixed novaclient i think. it's happened before
17:14:10 <ruhe> #agreed stay with >= for dependency on python-muranoclient
17:14:25 <ruhe> i promised to keep the meeting short. so, next topic :)
17:14:42 <ruhe> #topic review blueprints for J3
17:14:51 <ruhe> #link https://launchpad.net/murano/+milestone/juno-3
17:15:17 <ruhe> i don't want to go through all the blueprints of course (because i promised to keep the meeting short)
17:15:33 <sjmc7> our team is currently working on pre-release stuff so we're not doing much BP work at the moment
17:15:39 <sjmc7> the trusts stuff i do want to get done in j3
17:16:27 <sjmc7> that's the only one that's really not started
17:16:40 <ruhe> sjmc7: yep. trusts are needed in j3
17:16:48 <sjmc7> stanlagun - did you have any luck with reducing the number of requests the engine makes tothe API?
17:17:35 <sergmelikyan> sjmc7, I am not sure that stanlagun is here... I think this issue not started yet :(
17:17:53 <sjmc7> ok. i consider that one pretty important. it puts a massive load on the server
17:18:00 <ruhe> tsufiev: i think we should remove https://blueprints.launchpad.net/murano/+spec/dynamic-fields-on-service-details from j3
17:18:19 <sergmelikyan> I hope that on the next week Stan or me will have time to finish this :( Issue with requests require not so much efforts to be done :(
17:18:36 <tsufiev> ruhe, agree. It depends on serious dynamic UI redesign, which has not yet started
17:18:59 <ruhe> tsufiev: ok. i'm removing it from j3
17:20:13 <ruhe> sjmc7: what about keystone v3?
17:20:39 <sjmc7> there's a commit in review. but the uptake of v3 seems very slow
17:20:53 <sjmc7> heat had a change that got reverted, many others are not reviewed
17:21:20 <ruhe> sjmc7: ok. let's keep it targeted for j3 and see how it goes in other projects
17:21:35 <sjmc7> and all the clients are different, which worries me. i did test the patch i committed, but it will need some more testing
17:21:43 <sjmc7> ideally there'd be a shared client
17:21:47 <sjmc7> it's stupid each project doing this
17:22:03 <ruhe> agree
17:22:17 <ruhe> it's a shame that commom client library is almost abandoned
17:23:42 <ruhe> https://blueprints.launchpad.net/murano/+spec/murano-api-exception-handling please drive this one further
17:23:47 <ruhe> katyafervent: ^^
17:24:05 <sjmc7> error reporting is still something i'd really like to improve
17:25:01 <ruhe> and there are a lot of places it needs to be improved. not just by introducing specific exception classes. it's just a tiny part of work that needs to be done
17:25:03 <katyafervent> ruhe, have it in my list
17:25:16 <sergmelikyan> sjmc7, had a chance to work with our 0.5 version (released just before summit in Atlanta)... It's almost unbelievable how many things we fixed and improved %)
17:25:31 <sjmc7> i know, things have come a long way
17:25:31 <ruhe> katyafervent: ok. thanks. i think it should be driven by multiple people since it's a complex field
17:25:44 <sjmc7> ruhe, katyafervent - i am happy to help with it
17:25:56 <ruhe> great!
17:25:56 <sjmc7> we need a better design/discussion before more coding i think
17:26:02 <ruhe> sure
17:26:11 <sjmc7> to make sure it makes sense. particularly, look at how other projects handle errors
17:26:12 <sergmelikyan> sjmc7 +1000050000000
17:26:30 <katyafervent> sjmc7, If you have an ideas of the list of possible murano exceptions, you can create an etherpad and we will discuss it and extend it
17:27:14 <sjmc7> it's not about specific exceptions, more what categories there are (whether it's a faulty package, or a server error the user can't control) and how we report it in the logs and to the user
17:27:15 <ruhe> let's start with an etherpad to as a place where we dump our ides
17:27:19 <sjmc7> ok
17:27:24 <sjmc7> i'll try and put some ideas down today
17:27:30 <ruhe> thanks sjmc7
17:27:38 <sjmc7> i'm juggling a lot of stuff the next few weeks though
17:27:46 <ruhe> any other blueprints we should discuss today?
17:28:33 <sergmelikyan> About design/discussion we had an idea about out own mini-design summit in middle of cycle... Maybe in K
17:28:38 <ruhe> #topic open discussion
17:29:34 <ruhe> i personally don't have anything for open discussion today
17:30:04 <sjmc7> me neither, except that since we're preparing for a release we'll be doing less upstream stuff for a few weeks
17:30:59 <ruhe> sjmc7: no worries. we're getting close to j3 release. the rest of the time will be dedicated for bug fixes, and design planning for K
17:31:40 <sjmc7> oh.. we will be doing a lot of documentation work in september
17:31:50 <sjmc7> i'll make sure that's all upstreamed and reviewed
17:32:16 <ruhe> sjmc7: awesome! we need more docs written by native speakers :)
17:32:37 <sjmc7> we'll focus on usage documentation first, then package creation
17:33:39 <ruhe> sergmelikyan: katyafervent: do you have anything to discuss today?
17:33:47 <katyafervent> nope
17:33:55 <sergmelikyan> nope
17:34:12 <ruhe> ok. let's wrap the meeting and get back to work
17:34:19 <ruhe> katyafervent: sreshetnyak: it was a joke :)
17:34:21 <sjmc7> no jokes? :(
17:34:31 <ruhe> ah. sjmc7 please go ahead
17:34:49 <sjmc7> "My dog's got no nose!"
17:35:13 <sjmc7> the punchline can wait til paris
17:35:48 <ruhe> and the drum roll
17:36:04 <ruhe> i'll need some time in google to understand the meaning of it :)
17:36:14 <sjmc7> :) you've got 3 months
17:36:16 <sjmc7> later guys
17:36:48 <ruhe> #endmeeting