17:01:45 <ruhe> #startmeeting murano
17:01:46 <openstack> Meeting started Tue Aug 19 17:01:45 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:50 <openstack> The meeting name has been set to 'murano'
17:01:51 <serg_melikyan> o/
17:02:28 <gokrokve_> o/
17:02:43 <gokrokve_> Can we add to agenda two items?
17:02:52 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:02:55 <ruhe> gokrokve_: sure
17:02:56 <gokrokve_> 1) Discuss Murano participation in programms
17:03:18 <gokrokve_> 2) Discuss what we miss to fully support image based applications
17:03:48 <ruhe> gokrokve_: ack. these topics will go right after the action items review
17:04:05 <ruhe> #topic action items review
17:04:19 <ruhe> there was only one action item - ruhe to release python-muranoclient 0.5.4
17:04:25 <ruhe> and i've released it last week
17:04:40 <sjmc7> yay!
17:05:02 <ruhe> just to make sure everybody's aware. we have a separate launchpad project for python-muranoclient
17:05:12 <stanlagun> o/
17:05:24 <ruhe> #link https://launchpad.net/python-muranoclient
17:05:47 <ruhe> so, please file client related bugs and blueprints in this project
17:06:03 <gokrokve_> ok
17:06:14 <ruhe> we need this because clients have their own versioning schedule
17:06:27 <ruhe> ok. moving to next topic
17:06:34 <ruhe> suggested by gokrokve_
17:06:41 <ruhe> #topic Discuss Murano participation in programms
17:06:46 <ruhe> gokrokve_: your turn
17:06:52 <gokrokve_> https://docs.google.com/a/mirantis.com/document/d/1kYvERC49bJ_qkHL2-RjyRh9JRnZGN1SAaqGRpogIC_I/edit#heading=h.nvnyp0onyt0
17:07:06 <gokrokve_> Here is a document with high level description of what we want to do
17:07:33 <sjmc7> can you summarize for those of us without acces?
17:07:34 <gokrokve_> In the current situation in OPenStack the best way to proceed with any official sttaus is to join some existing program
17:07:45 <gokrokve_> Murano has some overlaps with other programs
17:07:56 <gokrokve_> sjmc7: You should have an access
17:08:01 <serg_melikyan> sjmc7: http://paste.openstack.org/show/97395/
17:08:11 <sjmc7> thanks
17:08:13 <gokrokve_> sjmc7: At least I added your e-mail to list of editor
17:08:53 <gokrokve_> So, we have identified three programs where we can put Murano by parts
17:09:11 <gokrokve_> Ctalog {glance} program for Murano API and Murano repo
17:09:23 <gokrokve_> Orchestration {heat} for Murano engine
17:09:35 <gokrokve_> Dashbard {horizon} for Murano UI
17:09:56 <gokrokve_> We spoke with PTLs of Glance and Heat. They overall accept this idea
17:10:14 <ruhe> here is what i think about this: last week it was the only possible way to proceed. but after thursday TC meeting and latest discussions in ML, I think that we have a good chance to go with our own program
17:10:14 <gokrokve_> we still need to convince the whole teams of Glance and Heat to really approve this
17:11:03 <gokrokve_> ruhe: Discussions are good but there is no any decision after that. We don't know what TC as a tC really thinks. Right now we heard different opinions of various TC members
17:11:55 <gokrokve_> And that is the real problem. TC can't clearly articulate what they really want and what a the game rules. Right now we are in the game where rules changed without notice
17:12:46 <gokrokve_> So the best conservative way is to show actual collaboration between teams rather then trying to blindly push for a new program
17:13:06 <ruhe> gokrokve_: we need to weight both options. splitting across two programs will bring a few major issues. going with our own program - is more risk
17:13:10 <gokrokve_> At least that is what I think and Jay confirms
17:13:31 <gokrokve_> Sure. that is why I brought it here
17:13:43 <ruhe> * going with our program is more risk in terms of our chances to be accepted
17:13:44 <gokrokve_> We need as a team understand what we want and what are the options
17:14:02 <gokrokve_> ruhe: I would sya there chances close to zero
17:14:07 <sjmc7> the fact taht we're split across two areas is part of the problem, i think
17:14:23 <gokrokve_> TC really coniders to reduce number of programs because governance problems
17:14:35 <sjmc7> if it was just extra glance functionality and UI, then it'd be an easier sell
17:15:08 <gokrokve_> sjmc7: Sure. That the root of th problem for any high level service. It has to do more then one thing.
17:15:30 <gokrokve_> We can add API and Artifacts to Glance - thats for sure.
17:15:39 <sjmc7> yes. so does openstack even WANT high level services in openstack?
17:15:46 <gokrokve_> But we have engine which does not belong to Glance at all
17:16:19 <ruhe> sjmc7: i've read all the conversations on this topic. and i don't know. i don't think there is a general agreement
17:16:35 <gokrokve_> sjmc7: TC is biased about that. They see that this really adds value but they struggle to understand how it fits to current OpenSTack model simle service for one task.
17:16:40 <sjmc7> i think there IS general agreement, which is: Yes, but not in my project
17:17:18 <sjmc7> if openstackk is aimed at being a set of services to use, maybe it makes sense not to incubate higher level services
17:17:26 <gokrokve_> sjmc7: True, but we did a good job talking with other teams. Glance is quite accepting this idea of having Murano API under their program.
17:18:14 <gokrokve_> sjmc7: There are debates what is incubation. We do not apply for incubation right now. What we are looking for is to join some program and put our code under their umbrella.
17:18:36 <gokrokve_> Its not an incubation. It just official statement that we want OpenStack governance
17:18:41 <stanlagun> gokrokve_: I can hardly see how API for managing environments is drastically different from engine so that it can be in Glance while engine cannot
17:18:53 <ruhe> gokrokve_: this brings another concern i have about this idea - API and engine are not usable on their own. they're supposed to work *together*
17:19:07 <gokrokve_> And the change will be done in OpenStack governance document
17:19:15 <sjmc7> yeah - to do this, the API would just need to be using heat (+mistral
17:19:20 <sjmc7> +whetever) on its own
17:19:22 <gokrokve_> ruhe: They can work together and still be in different programs
17:19:35 <gokrokve_> ike we use Heat and we can't live without it
17:19:50 <sjmc7> the api and engine is an implementation detail
17:19:58 <gokrokve_> sjmc7: +1
17:20:18 <sjmc7> what you're saying is splitting te artifact repo stuff from the envioronment management stuff
17:20:26 <sjmc7> NOT splitting the api and engine
17:20:32 <gokrokve_> Murano engine is still valuable as it adds some additional paradigms to Heat Orchestration
17:20:47 <gokrokve_> It can help to solve problems where imperative part is crutial
17:21:08 <gokrokve_> Lice DR deployments and cross clouds deployments with sofisticated error handling
17:21:23 <stanlagun> gokrokve_: with a price of switching to MuranoPL. So this is not exactly a help for Heat users
17:21:30 <sjmc7> yeah. but those parts are the hardest to sell
17:22:27 <gokrokve_> stanlagun: We can find out integration path together with Heat team
17:22:43 <gokrokve_> That is why we want to be a part of program
17:22:57 <gokrokve_> to be able to talk and make a decisions together as a team
17:23:01 <ruhe> maybe we should brainstorm pros and cons right here. or take it offline to an etherpad document?
17:23:11 <gokrokve_> Sure. Lets do this.
17:23:28 <stanlagun> I'd like to see Zane using MuranoPL :)
17:23:30 <gokrokve_> I just want to make sure that everybody knows what is going on.
17:23:36 <sjmc7> offline would be good. i hope to get more guidance from our needs later today or tomrrow
17:24:02 <ruhe> gokrokve_: yeah. thanks for driving this. we get a lot of pressure on incubation dates
17:24:15 <ruhe> i'd also like like to take it offline
17:24:18 <gokrokve_> sjmc7: Cool. And please involve other HP guys like Monty to understand how it could be done and what are their perspective on this
17:24:37 <gokrokve_> Again, there is no incubation
17:24:50 <gokrokve_> It is just announcement of joining the program.
17:24:56 <sjmc7> i have very little access to our TC
17:25:07 <ruhe> gokrokve_: but that's a path we take to become incubated some day. right?
17:25:09 <gokrokve_> Like TripleO which is a part of program but never incubated as a project
17:25:20 <gokrokve_> ruhe: Yes. It will be incubated
17:25:52 <gokrokve_> So we need to understand
17:26:01 <gokrokve_> a) how we feel about splitting
17:26:25 <gokrokve_> b) how to present this to TC and explain the way how we collaborate with other projects
17:26:36 <gokrokve_> c) explain this to whole community
17:26:42 <katyafervent2> it would be bithing to incubate if we splitted
17:27:01 <gokrokve_> This is a first precedent when project joins program
17:27:16 <gokrokve_> katyafervent2: That a good question and probably it belongs to tC
17:27:27 <ruhe> honestly, i'd prefer to go with our own program to avoid the complexity of splitting the project and organisational issues being a part of 2 programs. but if there is NO WAY to have our own program, then that's the only option
17:27:28 <gokrokve_> I don't know and we need to seek a TC guidance here
17:27:47 <gokrokve_> ruhe: It is an option which we need to explore
17:27:56 <gokrokve_> ruhe: and discuss with TC
17:28:21 <gokrokve_> Ok
17:28:28 <gokrokve_> Lets move on to the next item
17:28:28 <ruhe> gokrokve_: will you please create an etherpad and send it across the team to continue thinking about pros and cons offline?
17:28:33 <gokrokve_> ruhe: yes
17:28:40 <ruhe> gokrokve_: thanks
17:28:54 <gokrokve_> I want to make sure that we fully support image based applications
17:29:10 <sjmc7> what do you mean by that? because i thnk we're planning to deploy that way
17:29:37 <gokrokve_> https://blueprints.launchpad.net/murano/+spec/docker-registry-in-murano
17:29:43 <ruhe> #action gokrokve_ to create an etherpad for team to fill pros and cons of becoming a part of two programs vs having our own program
17:29:56 <gokrokve_> sjmc7: We need to support all kinds of deployment including image based
17:30:04 <sjmc7> don't we already support that?
17:30:07 <gokrokve_> for both Glance images with apps and containers
17:30:11 <ruhe> #topic support image based deployment
17:30:20 <gokrokve_> sjmc7: We do support something
17:30:34 <gokrokve_> But, I want to be 100% sure that we did not anything critical
17:30:51 <gokrokve_> The first this I see is an ability to filter proper images in UI
17:31:03 <gokrokve_> Right now I can't select Ubuntu only images
17:31:07 <gokrokve_> Or Oracle
17:31:13 <gokrokve_> Or my custom App image
17:31:14 <sjmc7> yeah, the image fliterig def needs work. but maybe not much more complicated than now, just more flexible
17:31:23 <sjmc7> you _can_ do that
17:31:31 <sjmc7> e.g. we just tag via the glance api rather than the UI
17:31:37 <sjmc7> there's a BP about this already
17:31:50 <gokrokve_> sjmc7: Sure. Just add some filtering to make sure that Murano App can find its own image probably without User interfierence
17:32:13 <gokrokve_> sjmc7: Cool. Is it scheduled for Juno
17:32:28 <gokrokve_> sjmc7: Do you need it to be implemented in Juno?
17:33:08 <gokrokve_> Everythin we do for Glance images will work for Docker too
17:33:25 <sjmc7> i have to pay attention to a meeting here now, sorry
17:33:40 <gokrokve_> So it is better to think about it now
17:33:41 <gokrokve_> Ok
17:34:45 <gokrokve_> ruhe: can you please create a dicument summarizing waht we have for Images support in Murano
17:35:01 <gokrokve_> And some image based app example will be good
17:36:20 <ruhe> gokrokve_: i'm not sure about the document. i'll need your input on what items you need to be described. image based examples are on our roadmap for juno
17:37:05 <gokrokve_> ruhe: Cool. We can talk offline. Some etherpad with use cases and input from Steve
17:37:25 <gokrokve_> I want to make sure that HP has everything to start using Murano
17:37:49 <gokrokve_> Also, as we have some time
17:38:05 <gokrokve_> I would like to announce what we have in PoC stage
17:38:23 <gokrokve_> 1) CloudFoundry ServiceBroker API PoC
17:38:24 <ruhe> gokrokve_: oh. i believe sjmc7 has it under his control
17:39:09 <gokrokve_> 2) Multiple Heat Stacks deployment PoC - when application can have multiple Heat Stacks rather then one
17:39:59 <gokrokve_> 3) Multicloud deployments PoC - when Murano can use user credentials to authenticate rather then token only. It will help application to deploy DR topology on different datacenters or even clouds
17:40:07 <serg_melikyan> gokrokve_: I thought that number two we support out of the box, or you are talking about just some example that can be shared?
17:40:29 <ruhe> #topic open discussion
17:40:30 <gokrokve_> serg_melikyan: #2 is possible to support but not out of the box
17:40:50 <gokrokve_> right now stack is created in environment by default
17:41:00 <gokrokve_> and it bound tightly to it
17:41:09 <ruhe> gokrokve_: you run ahead of topics. please let me do my bureaucracy :)
17:41:10 <gokrokve_> So to do multiple stacks is hard
17:41:26 <gokrokve_> ruhe: sure
17:41:45 <ruhe> we're ok now
17:41:51 <gokrokve_> So I need volunteers to do these PoC
17:42:02 <gokrokve_> #1 is almost done to something demoable
17:42:33 <gokrokve_> #2 - some discussions with Stan and some initial implementations, but we need to rewrite instance class and the way we do networking
17:42:57 <gokrokve_> #3 is not even designed, but really important and requested by customers
17:43:33 <gokrokve_> I hope we will not need to assign volunteers.
17:43:57 <ruhe> gokrokve_: i believe we can discuss that internally. that's not an appropriate place
17:44:21 <gokrokve_> Probably guys from other companies what to do this
17:44:27 <gokrokve_> It is not Mirantis specific
17:45:16 <gokrokve_> So lets keep this list of PoC somewhere and anybody can actually work on them
17:45:45 <gokrokve_> As our current policy is to approve BPs with some implementaiton details we can't really work without PoCs
17:45:47 <ruhe> HP folks have a lot on their own at this moment. I'm not sure anyone of newcomers would be able to tackle such complex scenarios
17:46:13 <gokrokve_> ruhe: True, but it does not mean that we need to keep this internal
17:46:31 <ruhe> gokrokve_: yeah. it's always good to have a list of future features and prioritise it taking multiple inputs into account
17:46:35 <gokrokve_> I want to make sure that averybody understands where we are going
17:47:11 <ruhe> sure
17:47:24 <ruhe> anything else to discuss today?
17:47:40 <gokrokve_> Nope, not from my side
17:47:52 <gokrokve_> Let me go from the stage :-)
17:48:11 <ruhe> ok
17:49:43 <ruhe> just an update from me - migration to oslo.db and other incubated oslo projects is going well. i don't want to leave murano with deprecated unsupport code from oslo-incubator while the rest of community is migrating to those new libs
17:49:56 <ruhe> *unsupported
17:50:38 <katyafervent2> i want to ask about blueprint
17:50:45 <ruhe> sure
17:51:47 <katyafervent2> ruhe could you provide a link please)
17:52:02 <katyafervent2> i cant copy
17:52:04 <ruhe> katyafervent2: https://blueprints.launchpad.net/murano/+spec/dynamic-ui-specify-no-explicit-name-field this one?
17:52:18 <katyafervent2> yes
17:52:33 <katyafervent2> did we finish with discussion?
17:52:41 <ruhe> katyafervent2: i don't think so
17:52:48 <katyafervent2> or should we continue to discuss
17:53:23 <katyafervent2> so when should we continue?
17:53:23 <ruhe> i don't see +1/+2 comments. from those who participated in the discussion
17:54:04 <ruhe> we had a debate about this, but didn't reach a consensus
17:54:06 <katyafervent2> everyone who is argeed on this blueprint please leave +2 comments
17:54:44 <ruhe> katyafervent2: you have half of the team in the same office with you :)
17:54:55 <ruhe> and the second half is always in IRC
17:55:55 <katyafervent2> ok, so i need to get positive comments
17:56:35 <ruhe> yes, that's our policy now. we need generall agreement on the blueprint before it gets an approval
17:57:10 <ruhe> katyafervent2: ping me if you don't get responses. i'll help you to reach out the core team
17:57:18 <ruhe> do we have anything else to discuss today?
17:58:21 <ruhe> ok. thanks everyone
17:58:29 <ruhe> #endmeeting