17:01:40 <ruhe> #startmeeting murano
17:01:41 <openstack> Meeting started Tue Sep  2 17:01:40 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:44 <openstack> The meeting name has been set to 'murano'
17:02:09 <sergmelikyan> o/
17:02:13 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:02:50 <ruhe> we're not going to expect too many people today. some are busy with internal work some are on vacations
17:03:21 <ruhe> but, katyafervent, dteselkin could still be here?
17:03:53 <dteselkin> Hi :)
17:04:09 <katyafervent2> hi
17:04:21 <ruhe> hooray. we have kind of a quorum :)
17:04:43 <ruhe> #topic keystone trusts wrt Juno release shedule
17:04:53 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/auth-for-long-running-requests
17:05:13 <ruhe> Stan did a good work and updated the whiteboard with his findings
17:05:45 <ruhe> there is still a chance we can get this feature working in Juno. But it should be optional
17:05:53 <ruhe> sergmelikyan: is that correct?
17:06:34 <sergmelikyan> ruhe, perfectly
17:06:43 <ruhe> ok
17:07:00 <ruhe> i hope sjmc7 and angus will provide feedback on that too
17:07:28 <ruhe> anything else for this topic?
17:07:40 * ruhe thinks we can set record meeting time today
17:08:01 <ruhe> #topic drop https://blueprints.launchpad.net/murano/+spec/murano-api-exception-handling from juno
17:08:02 <katyafervent2> :)
17:08:59 <ruhe> we still don't gave a general agreement on how it should be done and we didn't have a chance to have a broad discussion on this topic. so i suggest to drop this BP from Juno
17:09:14 <ruhe> any objections?
17:09:26 <katyafervent2> no objections
17:09:54 <ruhe> i hope sergmelikyan doesn't object too
17:10:28 <ruhe> #topic drop https://blueprints.launchpad.net/murano/+spec/dynamic-ui-specify-no-explicit-name-field from juno
17:10:34 <sergmelikyan> ruhe, no objection, we should revise this BP in the next cycle, but some part of the job was made in J
17:10:50 <ruhe> we still don't gave a general agreement on how it should be done and we didn't have a chance to have a broad discussion on this topic. so i suggest to drop this BP from Juno
17:11:06 <ruhe> any objections?
17:11:08 <sergmelikyan> nope
17:12:04 <ruhe> #action ruhe to drop murano-api-exception-handling and dynamic-ui-specify-no-explicit-name-field from juno plans
17:12:15 <ruhe> #topic documentation for juno release
17:12:24 <ruhe> #link https://etherpad.openstack.org/p/murano-docs
17:12:54 <ruhe> sergmelikyan, dteselkin do you have doc items assigned on yourselves?
17:13:18 <ruhe> i'd personally like to help to document building of images with diskimage-builder
17:13:35 <sergmelikyan> ruhe, not yet, but will do
17:13:43 <katyafervent2> ruhe cool!
17:14:07 <ruhe> sergmelikyan, dteselkin: please review this document. it's going to be our plan for the next month
17:14:30 <katyafervent2> sergmelikyan, I picked you to help with api specufication
17:14:51 <katyafervent2> we also need to provide update on actions
17:15:35 <ruhe> yeah, katyafervent2 feel free to assign at least mirantis folks to specific items :)
17:16:10 <ruhe> ok
17:16:41 <ruhe> we're ready to switch to open discussion unless there is a new important topic to discuss right now
17:17:39 <ruhe> #topic open discussion
17:18:24 <btully> i had a question about environment deployments
17:18:54 <ruhe> sure
17:19:01 <btully> when an environment is deployed, should you be able to deploy it again?
17:19:09 <katyafervent2> btully, hi! go ahead
17:19:27 <btully> allow me to elaborate
17:19:49 <katyafervent2> in the ideal case - yes
17:20:05 <btully> currently after an environment is successfully deployed, the status gets set to "Ready to deploy" and the api returns a status of "pending"
17:20:17 <katyafervent2> but currently redeploy is not working
17:20:32 <btully> from a UX standpoint, we never really inform the user that the deployment was successful
17:21:03 <katyafervent2> btully, i have not seen this behaiviour
17:21:43 <katyafervent2> session is opend in your environment and it becomes pending
17:21:54 <btully> https://www.dropbox.com/s/l391le6xvazyeo7/pending-status-components.png?dl=0
17:22:19 <katyafervent2> but it shoud happen only in case of adding new apps ir deleting existing
17:23:02 <btully> it looks like session gets deleted if env is deployed
17:23:50 <btully> just wondering if it would be worth it to have a status of "Deployed" provided it were possible
17:26:11 <katyafervent2> you need to find out why environment has new session
17:26:16 <sjmc7> my 2c before i disappear again :) - it'd be nice to see 'Ready' if there's nothing to do, or 'Ready to deploy' if there is (i.e. an application has been added)
17:26:49 <btully> katyafervent2: it looks like session gets deleted when env is deployed
17:26:55 <ruhe> that seems pretty reasonable from UX standpoint
17:27:00 <btully> then a new one is created which has status pending
17:27:22 <katyafervent2> sjmc7, thats what I have in my environment
17:28:13 <btully> so after you deploy an env, what status do you see?
17:28:35 <katyafervent2> it can ve named deployed if environment state changed after deployment
17:28:45 <katyafervent2> ready
17:28:58 <btully> interesting. ok i will test a few more times
17:29:07 <btully> thanks
17:29:34 <katyafervent2> dont hasitate to ping me via email or irc
17:30:26 <ruhe> muranopl-based packages report status from muranopl. for instance https://github.com/murano-project/murano-app-incubator/blob/master/io.murano.apps.apache.Tomcat/Classes/Tomcat.yaml#L50
17:31:03 <ruhe> sergmelikyan: is there any way to do something similar from heat SC based packages?
17:32:08 <sjmc7> not from within the heat template, no
17:32:26 <sergmelikyan> ruhe, you mean hot packages? I don't think so, cause whole template is sent directly to the Heat. There are no stages in between
17:32:57 <sjmc7> we could send a status indicating that it's being dealt with by heat
17:33:19 <ruhe> yeah, at least that. as a first step
17:34:05 <ruhe> polling stack status shouldn't be a problem either
17:35:58 <ruhe> ok. i think we understand the problem here. sergmelikyan let's discuss this with stan and see how we can fix this
17:36:13 <sergmelikyan> 'k
17:36:58 <ruhe> btully: we'll get back to you with this topic tomorrow (after discussin it with stan)
17:37:17 <ruhe> any other questions?
17:38:55 <ruhe> waiting 2 more minutes before closing the meeting
17:42:50 <ruhe> all right
17:42:53 <ruhe> thanks everyone
17:42:58 <ruhe> and bye bye
17:43:04 <ruhe> #endmeeting