17:01:28 <serg_melikyan> #startmeeting Murano
17:01:29 <openstack> Meeting started Tue Dec 2 17:01:28 2014 UTC and is due to finish in 60 minutes. The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:32 <openstack> The meeting name has been set to 'murano'
17:01:52 <serg_melikyan> Hi o/
17:02:53 <serg_melikyan> Am I alone today? )
17:03:16 <henarmunoz> Hi :-)
17:03:50 <serg_melikyan> Hi Henar! :)
17:04:22 <serg_melikyan> Thank you for joining today :)
17:04:54 <ruhe> o/
17:05:15 <serg_melikyan> #topic Agenda
17:05:40 <serg_melikyan> 1. Action Items Review
17:05:53 <serg_melikyan> 2. TOSCA Support & Pluggable Acrhitecture
17:05:59 <serg_melikyan> 3. Open Discussion
17:06:16 <serg_melikyan> Do anyone want to propose other topics to the Agenda?
17:06:35 <StanLagun> hello everyone. Sorry for being late
17:07:05 <serg_melikyan> Let's start with action items review :)
17:07:38 <serg_melikyan> #topic Action Items Review
17:07:50 <serg_melikyan> #1 StanLagun, re-examine re-deployment feature after #1394104 will be merged
17:07:59 <serg_melikyan> StanLagun: had a chance to do it?
17:08:12 <StanLagun> was it merged?
17:08:49 <StanLagun> yes, it was
17:08:57 <StanLagun> but I haven't tested it since
17:09:19 <serg_melikyan> Ok, let's move to the next week
17:09:38 <serg_melikyan> #action StanLagun, re-examine re-deployment feature after #1394104 will be merged
17:11:11 <serg_melikyan> #2 Serg, review and merge initial commit with template to the murano-specs
17:11:14 <serg_melikyan> Done
17:11:37 <serg_melikyan> StanLagun: btw, regarding the specs, how Versioning spec is going?
17:13:33 <StanLagun> serg_melikyan: wish I could say it is going well :) I almost finished this task but had to switch to urgent bugs
17:14:33 <serg_melikyan> #3 discuss policy guided fulfillment and create all necessary BP
17:15:10 <serg_melikyan> We had very fruitful meeting last week, but I once again failed to file blueprints.
17:15:32 <serg_melikyan> I hope guys not going to hold a big grudge on me :)
17:15:59 <serg_melikyan> #action StanLagun, move Versioning spec to the spec repo
17:16:22 <serg_melikyan> #action serg_melikyan, create all necessary BP for policy guided fulfillment
17:17:32 <serg_melikyan> #topic TOSCA Support & Pluggable Architecture
17:18:37 <serg_melikyan> Guys, let's discuss ideas about how to make additional languages pluggable. For now support for Heat packages are hard-coded, but questions is which level on pluggable we need
17:19:53 <serg_melikyan> StanLagun: had a time to think about that?
17:20:29 <serg_melikyan> I think we don't need actual ability to plug new package types on the fly
17:21:15 <StanLagun> serg_melikyan: it is not hardcoded. But there is no ability to load plugins dynamically which is relatively easy to implement
17:21:21 <serg_melikyan> Rather some API
17:21:29 <serg_melikyan> StanLagun: do we need it?
17:21:52 <StanLagun> I think we do need it
17:22:23 <StanLagun> But we need to refactor package API first
17:23:11 <serg_melikyan> Why? From one point of view it will be a little bit convenient to add them, but it is not a thing that people change so often
17:26:10 <serg_melikyan> Ok :) I think there are not so much people in this chat to discuss this question :) Let's skip it and discuss later.
17:26:41 <serg_melikyan> #info we didn't had much people to discus Pluggable Architecture in scope of new package types
17:26:46 <StanLagun> it allows people to expirement with integration. Or have some integration in "contrib" folder rather than in main code
17:26:55 <serg_melikyan> #topic Open Discussion
17:27:03 <StanLagun> *experiment
17:27:19 <serg_melikyan> StanLagun: you right, agreee. Didn't thought about that aspect
17:27:37 <serg_melikyan> henarmunoz: How is your work with Murano is going? :)
17:28:41 <henarmunoz> just testing and having a look at the code
17:29:16 <StanLagun> hemanthm: did you faced any problems by now?
17:29:28 <StanLagun> henarmunoz: ^^
17:31:04 <henarmunoz> at this moment, MuranoPlException: [keystoneclient.exceptions.EmptyCatalog]: The service catalog is empty.
17:31:32 <henarmunoz> but will continue testing :-)
17:32:09 <serg_melikyan> This is related to the keystone - probably you need to register services in keystone (no idea how you did end-up with empty catalog).
17:32:26 <serg_melikyan> http://docs.openstack.org/developer/keystone/configuringservices.html
17:33:06 <StanLagun> probably we can help
17:33:13 <henarmunoz> thanks
17:34:01 <henarmunoz> last murano version should work with icehouse or just juno vesion?
17:34:01 <serg_melikyan> henarmunoz: btw, team may join us in IRC #murano and we will be happy to help
17:34:47 <henarmunoz> thanks
17:35:29 <serg_melikyan> Actually it should works with both of them, if given that you run murano-dashboard separately from OpenStack one
17:36:17 <serg_melikyan> I mean, you can have OpenStack installed, and Murano running separately but pointing to OpenStack installation.
17:37:41 <henarmunoz> yes, i have murano locally for debugging pointing to an openstack devstack version
17:38:08 <serg_melikyan> this what we do too, our lab is IceHouse and we run latest master locally
17:39:08 <serg_melikyan> If you see keystoneclient.exceptions.EmptyCatalog with devstack, probably problems with devstack?
17:39:23 <serg_melikyan> It should at least have all needed components like nova
17:39:53 <StanLagun> do you have Neutron enabled in devstack?
17:40:12 <serg_melikyan> StanLagun: isn't it enabled by default?
17:40:23 <StanLagun> no. nova-network is default
17:41:34 <henarmunoz> I don't have neutron, just nova-network and the service catalog contains the nova service
17:42:03 <serg_melikyan> That may be a problem, latest Murano 2014.2 works only with neutron
17:42:07 <StanLagun> that may be the problem. Murano requires Neutron. Support for nova-network wasn't merged yet
17:42:20 <serg_melikyan> :D
17:43:05 <henarmunoz> ok, and the failure is when murano tries to create the network, thanks for the hint :-)
17:45:51 <serg_melikyan> btw, StanLagun probably we need to rework support for nova-network with a thought to support attachment to existing networks on case of neutron
17:46:15 <StanLagun> yes
17:46:29 <StanLagun> we need to refactor the whole core library
17:46:54 <StanLagun> I don't think we should merge commit as is
17:47:52 <serg_melikyan> #info we need to rework nova-network commit to support joining to the existing networks in Neutron.
17:48:34 <StanLagun> btw there is no ability to join existing Neutron network yet
17:48:51 <serg_melikyan> That is I am talking about
17:48:59 <StanLagun> not just nova
17:49:20 <serg_melikyan> This feature we also need and it may affect design
17:55:35 <serg_melikyan> If there are no other things to discuss, let's end meeting a little bit earlier
17:55:40 <serg_melikyan> #endmeeting