17:00:59 <sergmelikyan> #startmeeting murano
17:01:00 <openstack> Meeting started Tue Feb 17 17:00:59 2015 UTC and is due to finish in 60 minutes. The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:04 <openstack> The meeting name has been set to 'murano'
17:02:19 <sergmelikyan> Hi folks :)
17:02:21 <katyafervent> Hi guys!
17:03:02 <jolsen> hello all
17:04:42 <katyafervent> Do we have action items from the previous meeting?
17:04:47 <StanLagun> hi
17:04:50 <ativelkov> o/
17:05:04 <RadekPospisil> hi
17:05:47 <sergmelikyan> katyafervent, not really :) We can skip this part of the meeting
17:06:13 <sergmelikyan> #topic Blueprint Discussion
17:06:21 <sergmelikyan> #1 https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload
17:06:34 <sergmelikyan> How package uploading form should be look like? Should we just have drag-and-drop window or keep regular button too?
17:06:51 <sergmelikyan> I would say that I love when you can do both, it is convenient
17:07:01 <katyafervent> Recently we discussed new feature with jolsen
17:07:21 <jolsen> I like the idea of having both options as well
17:07:45 <katyafervent> So I suggest to keep regular button, but provide opportunity to upload multiple files
17:07:58 <ativelkov> +1 on both. That's similar to what people have in modern UIs
17:08:26 <jolsen> Sure. Here is the example I pulled from for the button https://blueimp.github.io/jQuery-File-Upload/angularjs.html
17:08:32 <ruhe> o/
17:08:34 <sergmelikyan> Multiple files?
17:08:38 <katyafervent> It should be done in one blueprint https://blueprints.launchpad.net/murano/+spec/new-button-upload
17:08:53 <katyafervent> yes, several files at once
17:09:15 <katyafervent> Now files are uploaded only after 'next' button is clicked
17:09:18 <sergmelikyan> How we are going to proceed with later steps for each one of them>
17:09:51 <katyafervent> Hmm
17:10:00 <jolsen> The way to upload packages now is clicking select file button, choose 1 file, next > go back do the same, etc. etc.
17:10:07 <katyafervent> Should we add a separate button for that?
17:10:17 <jolsen> Eliminiating the back and forth would be great
17:10:51 <ativelkov> Why don't we have ability to select multiple files?
17:11:23 <jolsen> ativelkov, is that referring to the capability currently?
17:11:29 <sergmelikyan> jolsen, we need to select category for the each package + edit tags, privacy settings and so on
17:11:36 <katyafervent> That;s how it was implemented, so I think everyone agreed that we need this feature
17:11:44 <sergmelikyan> jolsen, how it is going to look like?
17:12:12 <jolsen> BP 1 - https://blueprints.launchpad.net/murano/+spec/new-button-upload
17:12:16 <katyafervent> sergmelikyan, let's provide ideas and pick the best one
17:12:57 <jolsen> BP2 https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload
17:13:19 <jolsen> the first BP is a really rough mockup I whipped up in a few min
17:14:16 <jolsen> But I think within the upload modal there should be the ability to select and/or add a category for the package and create tags
17:14:38 <katyafervent> I suggest to add ability to edit parameters that would be common for all the packages
17:15:03 <kzaitsev> I humbly think, that uploading multiple files introduces difficult UI/logic choices. What if one of the files is invalid — should the whole batch be considered invalid or should we just ignore the file?
17:15:09 <katyafervent> so categories and tags will be common for a group of packages that will be uploaded at once
17:15:23 <sergmelikyan> I agree that having ability to drag-n-drop instead selecting files is really nice improvement, having ability to upload multiple applications makes it just awesome. But we need to think more about implementation
17:15:44 <jolsen> I agree sergmelikyan
17:16:38 <jolsen> If one package fails, it shouldnt stop the rest of the upload. Give an error message specific to that package
17:16:46 <katyafervent> jolsen, don't you mind, that we create an action item for you? :)
17:17:05 <jolsen> and what would that be? :)
17:17:26 <katyafervent> could you prepare some kind of specification with implementation details
17:17:54 <jolsen> Sure, I can take ownership of that
17:18:14 <sergmelikyan> jolsen, we use murano-specs for writing specifications for blueprints, it would be nice if you will have simple spec for this feature drafted-up. I am talking about first bp (about multiple uploads at once)
17:18:17 <ruhe> katyafervent: i believe we need to provide some links and examples of specs to jolsen
17:18:36 <jolsen> that would be great ruhe
17:18:44 <sergmelikyan> Second BP is straightforward enough to implement it without spec
17:19:18 <katyafervent> that contains answers for questions, that we discussed: how to deal with package editing on the next steps after uploading, how to deal with broken files
17:19:57 <ruhe> sergmelikyan: second BP is about drag-n-drop? are you sure it doesn't require some design on both frontend and backend? i.e. i'm not sure if we can skeep spec in this case
17:19:59 <katyafervent> ruhe, jolsen yeah, I provide examples in our #murano channel and try to answer all the questions
17:20:19 <jolsen> not a problem. Thanks ruhe!
17:20:41 <katyafervent> ruhe, backend support will be implemented on the first blueprint, which is a dependency
17:20:56 <ruhe> i see
17:23:18 <kzaitsev> But if we decide to allow "bulk-editing" tags, and other attributes of all the packages you uploaded — one would want to fix and re-upload everything all-together. I just want to note that this kind of UI-decisions usually imply a lot of work around them.
17:24:37 <sergmelikyan> #action jolsen, sreate spec for https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload
17:24:45 <sergmelikyan> #undo
17:24:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9d39190>
17:27:38 <jolsen> where can I find the meeting minutes?
17:28:34 <ruhe> jolsen: http://eavesdrop.openstack.org/meetings/murano/
17:28:50 <jolsen> Thank you
17:29:01 <ruhe> there are also logs for #murano channel http://eavesdrop.openstack.org/irclogs/%23murano/
17:29:06 <sergmelikyan> jolsen, they are published automatically
17:29:20 <jolsen> great
17:29:22 * sergmelikyan checked the blueprints again
17:30:13 <sergmelikyan> jolsen, what do you think about making first BP a way to just enable drag-n-drop (without multiple files, if it makes sense) and second as a full blown multi-application upload?
17:30:39 <jolsen> I would agree with that approach
17:30:56 <jolsen> drag-n-drop seems like the lower hanging fruit
17:31:09 <sergmelikyan> Yeah
17:31:22 <sergmelikyan> then I suggest to implement first BP without spec, and write spec for the second
17:31:34 <jolsen> okay
17:31:50 <katyafervent> For me drag and drop for one file does't make sense
17:31:58 <sergmelikyan> #action jolsen, create spec for https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload
17:32:40 <jolsen> Could the drag-n-drop code be modified to contain a link to select, enabling 1 file to upload?
17:33:27 <sergmelikyan> jolsen, not sure that I got you
17:34:40 <sergmelikyan> can you explain a little bit?
17:34:46 <jolsen> What I mean is in a simpler way is, could the existing upload button still exist in the modal to accommodate single file uploads but also have the drag-n-drop box for multi uploads?
17:35:36 <jolsen> the drag-n-drop would be the only function to be added since the single file upload button already exists
17:35:41 <katyafervent> I suggest the opposite way: implement support for multiple file with existing button
17:35:48 <katyafervent> and then add drag-and-drop
17:36:17 <sergmelikyan> I think anyway we need to have button to add files to multi-upload list (just in case drag-n-drop is not an option, take a look to all google drive upload forms)
17:36:30 <katyafervent> ruhe, what do you think: which way should we pick?
17:36:37 <jolsen> Okay, so it seems there are two schools of though...Some say implement drag-n-drop first, others say multi upload via button first then drag-n-drop
17:36:43 <sergmelikyan> But if we want to support multi-upload already in first BP - we need a spec that would describe behaviour in details
17:37:20 <jolsen> I think multi-upload is a heavier lift than just the drag-n-drop
17:37:23 <ruhe> katyafervent: i don't have any strong opnions on that. i think it should be decided by jolsen, since he's the one who's driving this feature :)
17:37:53 <sergmelikyan> I have concerns about multi-upload, not with a way how to do it (button, drag-n-drop). Multi upload requires clear spec that will describe how we are handling that/
17:38:45 <katyafervent> sergmelikyan, that's what we expecting
17:38:50 <sergmelikyan> How we are handling partial failures, how we are proceeding with category selection and so on
17:39:03 <jolsen> Okay, so I would say we use sergmelikyan's approach. Take care of low hanging fruit of implementing drag-n-drop first then full blown multi select after...if I understand correctly
17:39:58 <sergmelikyan> jolsen, BP 1 https://blueprints.launchpad.net/murano/+spec/new-button-upload, one app upload with drag-n-drop
17:40:20 <sergmelikyan> BP 2 https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload multiple uploads with drag-n-drop
17:41:05 <sergmelikyan> that was my suggestion :)
17:41:54 <katyafervent> +1
17:42:30 <jolsen> So are you saying implement drag and drop for 1 file upload?
17:43:09 <sergmelikyan> that was my proposal, but maybe that does not make any sense
17:44:12 <jolsen> It doesn't. If drag n drop is going to be implemented, it should support multiple uploads. I think the only thing that needs to be figured out is how to handle failed packkages
17:44:13 <katyafervent> if it would be look ok and button will still exist, then why not
17:44:14 <sergmelikyan> Another way is have multiple in a first BP, but that we need spec + answers about how we are handling category selection & other staff for each app
17:44:43 <sergmelikyan> jolsen, and how to select category for each (or all) apps
17:45:14 <jolsen> that's something that would need to be worked out and mocked up
17:45:26 <jolsen> I don't have an answer to that currently
17:46:06 <sergmelikyan> I would like to point out that upload form is 3 step wizard, and we need to figure out what to do with last two steps.
17:46:22 <sergmelikyan> jolsen, sure
17:46:30 <katyafervent> yeah. let's think about it and discuss on the next meeting and on #murano channel during the week
17:46:55 <katyafervent> what's the next topic?
17:47:06 <jolsen> I agree katyafervent
17:47:27 <sergmelikyan> jolsen, thank you!
17:47:30 <sergmelikyan> #topic Open Discussion
17:47:37 <jolsen> :)
17:52:49 <sergmelikyan> Any other topic discus? Or let's get back to the work? :)
17:54:32 <katyafervent> Let's finish. Goodbye!
17:54:41 <ruhe> bye bye. thanks everyone!
17:54:43 <sergmelikyan> #endmeeting