17:00:17 <sergmelikyan> #startmeeting murano
17:00:17 <openstack> Meeting started Tue Feb 24 17:00:17 2015 UTC and is due to finish in 60 minutes. The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:22 <openstack> The meeting name has been set to 'murano'
17:00:33 <sergmelikyan> Hi folks!
17:00:47 <stan_lagun> hi!
17:02:18 <dteselkin_> Hi!
17:04:59 <sergmelikyan> Agenda: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:05:20 <sergmelikyan> Today we don't have anything specific for agenda, let's start as usual with Action Items
17:05:37 <sergmelikyan> #1 jolsen, create spec for https://blueprints.launchpad.net/murano/+spec/package-drag-drop-upload
17:06:25 <sergmelikyan> Looks like jolsen is not here today
17:07:59 <kzaitsev> I'm still a bit new to this — should we discuss bugs/blueprints and/or proposals how to fix/implement them here?
17:08:52 <sergmelikyan> Sure, If you'd like to discuss something you just edit our agenda and add something there prior meeting
17:09:12 <sergmelikyan> We also can discuss questions in Open Discussion topic
17:11:05 <sergmelikyan> I think we can move to Open Discussion and discuss your questions
17:11:11 <sergmelikyan> #topic Open Discussion
17:12:40 <kzaitsev> I think it's worth mentioning, that there are few parts of murano (including error logging) that would most likely fail if we actually implement some i18n =) There are many places where strings are translated to str, which might cause unicode errors. I haven't actually tested it, but my guts tell me there will be quite a few unicode errors =)
17:14:01 <kzaitsev> I'm not sure if it's appropriate to create a single blueprint for that though.
17:14:02 <sergmelikyan> What do you mean by fail?
17:15:16 <kzaitsev> there are some places where strings are enforsed with str(). I guess they would raise UnicodeDecodeError if translated strings would be passed there.
17:16:00 <kzaitsev> I guess the correct thing to do would be — to actually translate everything and run some tests with non-C locale.
17:17:13 <stan_lagun> kzaitsev: I've seen such problems when trying th raise native Python exceptions with non-ascii messages
17:17:30 <stan_lagun> Exception messages were not designed to be localized
17:18:37 <sergmelikyan> stan_lagun, maybe oslo i18n somehow handles that? They provide framework for translation, I doubt that it is so broken
17:19:38 <stan_lagun> the problem is that str(e) is the only correct method of getting exception message and it will fail on non-ascii chars
17:19:43 <sergmelikyan> kzaitsev, and I guess we should eliminate all calls to str
17:19:51 <hmunfru> hi sorry for the delay
17:20:11 <katyafervent2> hi hmunfru !
17:23:41 <kzaitsev> Also! Is gate-murano-integration feeling OK now? It seemed like it had some problems (failing after obviously unrelated code changes)
17:25:30 <sergmelikyan> kzaitsev, yeah, issue was with handling output from newest version of nova-client
17:25:37 <sergmelikyan> should be working already
17:25:44 <sergmelikyan> stan_lagun, so what you are suggesting?
17:27:44 <stan_lagun> sergmelikyan: this needs some research. Personally i don't like the idea of i18n for strings that are not displayed in UI. I also think that language files need to be a part of murano package like resource files attached to .exe
17:28:23 <stan_lagun> thats about applications. Engine itself doesn't generate user-visible strings so nothing to translate
17:28:57 <stan_lagun> but we have to follow openstack good practices despite what I think
17:29:51 <sergmelikyan> stan_lagun, yeah :)
17:29:52 <sergmelikyan> https://wiki.openstack.org/wiki/Translations
17:29:55 <kzaitsev> Is it a good idea — to add translation tests? (Like run all the tests with all the strings translated to smth like "♔")
17:31:14 <stan_lagun> kzaitsev: if we support it it should be tested
17:31:15 <sergmelikyan> kzaitsev, I am not sure about that, we can discuss how to do it properly with oslo i18n team
17:31:47 <sergmelikyan> I mean, I am not sure how to correctly implement that
17:32:04 <kzaitsev> yeah, me to (not sure)
17:32:58 <stan_lagun> sergmelikyan: can we leave it till release U? Or at least until real-life bug-repport or customer request?
17:33:09 <sergmelikyan> stan_lagun, why?
17:33:10 <stan_lagun> Seems like not that important thing for now
17:33:34 <sergmelikyan> It depends, I think that if you started something you need to get done that
17:33:41 <kzaitsev> I agree, that it doesn't seem to be an urgent thing to do. =)
17:33:41 <stan_lagun> and it causes more problems than it solves
17:34:44 <sergmelikyan> I think we should constantly keep our code in accordance with OpenStack guidelines, and maintain it.
17:35:10 <sergmelikyan> And since we started working on translation it should be finished, no point to making only half of the job
17:35:39 <stan_lagun> I doubt if someone uses any OpenStack services with non-C locale in production at all. Don't sure i want to pioneer all the problems
17:35:40 <sergmelikyan> And at some point of time we should work on translation too as whole openstack itself
17:35:50 <kzaitsev> Well then I guess it's worth being put into a blueprint.
17:36:08 <sergmelikyan> kzaitsev, you mean specific BP about testing translation?
17:36:31 <kzaitsev> yes, why not?
17:36:54 <sergmelikyan> stan_lagun, I think you will not be a pioneer, most of the OpenStack project have translation to different languages
17:37:01 <sergmelikyan> kzaitsev, just asking :)
17:37:20 <sergmelikyan> kzaitsev, I think you should try to talk with i18n team
17:38:15 <stan_lagun> sergmelikyan: one thing is to claim it and another thing is to actually use non-English locale. In theory we also support locales as long as they are English locale :)
17:38:20 <sergmelikyan> kzaitsev, Doug Hellmann is one of the top contributors to oslo i18n project
17:39:01 <kzaitsev> Yeah I'll do that! Maybe they have a shortcut for such kind of testing already.
17:39:20 <stan_lagun> And who is going to translate API messages and so on?
17:40:14 <sergmelikyan> stan_lagun, community :)
17:40:32 <sergmelikyan> And I think there is no point to ask you :)
17:41:21 <kzaitsev> stan_lagun: My issue is not about translation. It' is more about the fact that there are a couple of places in the code, that would raise exceptions if translated. It's worth at least to test that our tests would not fail if we would translate everything to something unicode.
17:42:47 <stan_lagun> Once that you have a language files for many languages it will be hard to change anything in API because it also may require changing messages and you cannot do it on your own (suppose that you don't speak all those languages). And we are going to have some serious changes in API. So either we won't have any translations at all or we will wish wi not have them
17:43:19 <stan_lagun> kzaitsev: I get it. But it is not the only problem with i18n
17:43:35 <kzaitsev> Oh I see what you mean
17:44:18 <sergmelikyan> stan_lagun, I think there is a way to handle what do you talking about :) OpenStack is released twice a year :) You can ensure translations between releases.
17:44:19 <stan_lagun> it is hard to make sure all the translations are in sync
17:45:00 <sergmelikyan> stan_lagun, there is no point arguing about that. At least we should make sure that Murano supports translations
17:45:49 <stan_lagun> sergmelikyan: it is extremely hard if you take in account the number of messages that we have and the number of people around that know Chinese, Japanese, Hebrew, Arabic and so on
17:45:50 <sergmelikyan> hmunfru, please take a look at https://review.openstack.org/152643
17:46:57 <kzaitsev> Ok. to sum it up — I'll ask oslo.i18n team if they have an easy way to test that and file a bp to actually test translations (I think actually translating the app is a different topic though)
17:47:01 <sergmelikyan> hmunfru, this should enable support for attaching to the existing networks
17:47:15 <sergmelikyan> kzaitsev, awesome!
17:47:21 <hmunfru_> ok
17:47:49 <sergmelikyan> So you can enable choosing to which network to attach before deployment
17:48:23 <hmunfru_> perfect!
17:57:13 <sergmelikyan> #action kzaitsev, ask oslo.i18n team if they have an easy way to test that and file a bp to actually test translations
17:57:39 <sergmelikyan> Looks like we are running out of time :)
17:57:42 <sergmelikyan> Thank you!
17:57:45 <sergmelikyan> #endmeeting