17:00:06 <serg_melikyan> #startmeeting murano
17:00:06 <openstack> Meeting started Tue Mar  3 17:00:06 2015 UTC and is due to finish in 60 minutes.  The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:10 <openstack> The meeting name has been set to 'murano'
17:00:17 <serg_melikyan> Hi folks!
17:00:50 <kzaitsev_> evening
17:02:00 <serg_melikyan> I hope we are not going to be only ones who attended :)
17:04:04 <katyafervent> Hi!
17:04:08 <ruhe> o/
17:04:31 <serg_melikyan> o/
17:04:39 <henar> hi
17:04:48 <slagun> hi
17:05:22 <freerunner> hi folks
17:06:21 <pashkin> Hello!
17:06:27 <serg_melikyan> Let's get started :)
17:06:39 <serg_melikyan> #topic Action Items
17:07:12 <serg_melikyan> #1 kzaitsev, ask oslo.i18n team if they have an easy way to test that and file a bp to actually test translations
17:07:26 <serg_melikyan> kzaitsev_: had a chance to talk with people from oslo?
17:08:09 <kzaitsev_> Sorry, I hadn't =( I'm intending to do that asap, though.
17:08:44 <serg_melikyan> Let's finish with this i18n story :)
17:09:25 <serg_melikyan> Unfortunately agenda for todays meeting is pretty short, do we have some question that we should add to the agenda?
17:10:11 <serg_melikyan> #topic Open Discussion
17:10:43 <serg_melikyan> henar: how work on Environment Templates is going? I saw that we already merged part of the functionality :)
17:12:10 <henar> yes, and hte creation of an environment from a template is comming..
17:12:22 <henar> so it should be everything completed in some days
17:12:57 <kzaitsev_> I guess everyone is pretty busy preparing for the FF
17:13:12 <serg_melikyan> Excellent, we definitely need to prepare some demo for this feature to publish before the summit
17:13:31 <serg_melikyan> kzaitsev_: yeah, K3 is a last code drop before the release
17:14:00 <serg_melikyan> henar: had a chance to take a look on feature that gives ability to attach application to the existing network?
17:14:14 <serg_melikyan> That I had shared sometimes ago?
17:14:30 <henar> no really...
17:14:35 <henar> I will try to do this week
17:15:16 <serg_melikyan> henar: we tested this feature with OS deployments that have 1 shared network for all tenants, but it should be also helpfull for platform that you guys working on
17:16:56 <henar> ok
17:17:00 <henar> ok
17:17:42 <serg_melikyan> freerunner: Do you have news about CI/CD for Congress & Mistral integration?
17:17:54 <serg_melikyan> I saw most of the patches are merged, but what about CI job?
17:18:04 <serg_melikyan> When we will have that third-party job?
17:20:33 <serg_melikyan> freerunner: ? you are with us?
17:20:45 <freerunner> serg_melikyan: As i know, the job was configured and initial scripts in murano-repo was already prepaired.
17:21:11 <serg_melikyan> Any chance do you know status of the job? Maybe we need to review it?
17:21:46 <freerunner> serg_melikyan: But i haven't any information about status. =( I'll inspect in soon.
17:22:08 <freerunner> *it
17:23:10 <serg_melikyan> I think we need to finish with this third-party CI ASAP, feature freeze is in a weeks away and we need to make sure that merged tests are running and everything is working
17:26:46 <serg_melikyan> freerunner: if you will need my help with that I would be happy to help :)
17:27:41 <freerunner> serg_melikyan: ofc, i'll start working on it tomorrow. =)
17:27:53 <serg_melikyan> ofc? :)
17:28:35 <freerunner> serg_melikyan: 'ofc' is about make sure that merged tests are working =)
17:28:53 * serg_melikyan googled
17:28:54 <serg_melikyan> http://www.urbandictionary.com/define.php?term=ofc
17:29:15 <serg_melikyan> I love urbandictionary :)
17:30:22 <serg_melikyan> I love second description of this term )
17:30:57 <serg_melikyan> slagun: how do you think will we have much troubles with YAQL 1.0?
17:31:26 <serg_melikyan> I hope compatibility layer can help us, but will it be sufficient? Will we be able to use new features?
17:31:33 <serg_melikyan> What is your plan about it?
17:31:52 <slagun> serg_melikyan: troubles - no. But quite some work to migrate (much more than for Mistral for example)
17:32:36 <slagun> compatibility layer is not helping with migration. It is intended to help end user so that it will be possible to have smooth transition
17:33:18 <slagun> going to finish with migration this week. At lease if I won't spend it with k8s
17:33:30 <serg_melikyan> But will it limit features available to the user?
17:33:58 <serg_melikyan> slagun: I hope so :) But I think k8s is not so easy task :(
17:34:10 <serg_melikyan> I didn't expect so much troubles with networking
17:35:25 <serg_melikyan> slagun: what do you think about wrapping all details about networking to some short document that we may share with k8s developers?
17:35:27 <slagun> no :) in fact the immediate visible difference will be hundred on new functions methods and operators become available in MuranoPL. The next hop will be static functions and later extension methods based on new YAQL
17:36:10 <serg_melikyan> I think we should reach out to them - maybe they have some ideas and will help to solve our issues much more easily
17:36:20 <serg_melikyan> slagun: excellent :)
17:36:28 <slagun> serg_melikyan: that is a good idea. Unfortunately the document alone will not help to deliver it in time
17:37:07 <serg_melikyan> Yeah, I get that. But it will help to not repeat to each new person involved our issues and what we are doing.
17:38:16 <serg_melikyan> And we can have some chat with them and discuss our issue - I think they are interested in proper support in OpenStack for k8s and probably there are some solution that maybe done on they side
17:39:08 <serg_melikyan> So what do you think about putting some short document describing how it works (on networking side) with emphasis on issues related on networking in OpenStack?
17:39:12 <serg_melikyan> Really short one
17:43:01 <serg_melikyan> slagun: ping
17:43:48 <serg_melikyan> #action kzaitsev, ask oslo.i18n team if they have an easy way to test that and file a bp to actually test translations
17:44:00 <slagun> serg_melikyan: I'll write a summary of all approaches I see, pros and cons and brief description on how k8s network works
17:44:01 * serg_melikyan just recording AIs
17:44:12 <kzaitsev_> Oh! seems like i18n meeting is being held this week on thursday
17:44:18 <kzaitsev_> I think I'll atend it
17:44:34 <kzaitsev_> seems like a good place to get help =)
17:45:06 <serg_melikyan> slagun: I would start with description how it works - it will already help to spot issues and probable solutions. And they we will work on possible solutions. I think it's better approach
17:45:27 <serg_melikyan> kzaitsev_: sure :) though it may be faster to reach them in they IRC channel
17:45:40 <serg_melikyan> *then will
17:46:41 <serg_melikyan> slagun: Let's start with short description how it works and incompatibilities with OpenStack?
17:47:11 <slagun> I'm going to write an email that explains all of this
17:47:42 <serg_melikyan> slagun: thank you! though I think to have it in etherpad is better - easier to share
17:48:37 <serg_melikyan> #action slagun, write short description how k8s works and incompatibilities with OpenStack
17:52:18 <kzaitsev_> They have "Introduction of translation test project" in their agenda for Thursday.
17:52:24 <kzaitsev_> wonder what that means... =)
17:54:08 <serg_melikyan> kzaitsev_: looks very promising :)
17:54:26 <serg_melikyan> or sounds :)
17:58:45 <serg_melikyan> Thank you for attending todays meeting!
17:58:48 <serg_melikyan> #endmeeting