17:00:28 <serg_melikyan> #startmeeting murano
17:00:29 <openstack> Meeting started Tue Mar 10 17:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:33 <openstack> The meeting name has been set to 'murano'
17:00:38 <serg_melikyan> Hi folks! o/
17:00:43 <henar> hi
17:00:43 <aderyugin> hi!
17:02:14 <kzaitsev> Hi there. I was to contact the i18n guys about an easy way to check for i18n errors
17:03:14 <kzaitsev> I actually attended their meeting. Unfortunatelly there is no easy way. The project i18n-test aims to provide one, but it is in it's infant stage.
17:03:15 <kzaitsev> But
17:03:27 <kzaitsev> Btw. Am I too quick?
17:03:41 <stan_lagun> no :)
17:03:44 <serg_melikyan> kzaitsev: you jumped straight to Action Items? :)
17:04:08 <serg_melikyan> kzaitsev: kinda, but no worries
17:04:15 <kzaitsev> yep I did. =)
17:04:23 <kzaitsev> so back to my "but"
17:05:17 <serg_melikyan> kzaitsev is talking about following AI: kzaitsev, ask oslo.i18n team if they have an easy way to test that and file a bp to actually test translations
17:05:24 <pashkin> Hello!
17:05:41 <kzaitsev> but. I'm not the only one who want's such a way, and there is for a example this https://review.openstack.org/#/c/142239/ commit to horizon, that looks really promising
17:07:18 <kzaitsev> It aims to check for translation problems in horizon. I haven't had enough time to look into it, but it seems like a good start.
17:07:23 <serg_melikyan> kzaitsev: so you are going to explore this tool and see if it is suitable for us?
17:08:35 <kzaitsev> serg_melikyan: yes, it looks exactly like a tool I was looking for.
17:08:52 <serg_melikyan> #action kzaitsev, plans to check tool for testing translation tool introduced in Horizon: https://review.openstack.org/142239 and see if it suitable for us
17:09:52 <serg_melikyan> Next action item is for you, Stan ;)
17:10:02 <kzaitsev> Aaand that's basicly all I have to say about i18n for now. +)
17:10:04 <serg_melikyan> #2 slagun, write short description how k8s works and incompatibilities with OpenStack
17:10:43 <serg_melikyan> Stan, I believe you forgot to publish this e-mail to the mailing list
17:11:10 <kzaitsev> oh just a sec. there're actually two interesting commits, aiming at the i18n task, 2d being https://review.openstack.org/#/c/147262/
17:11:22 <kzaitsev> to oslo.i18n
17:11:33 <stan_lagun> Yes, but it is outdated anyway since we figured out how k8s networking works
17:11:37 <serg_melikyan> I believe we already overcome issue with networking in k8s maybe it will be beneficial to share problen & solution and discuss options about native integration with Magnum folks
17:12:32 <serg_melikyan> kzaitsev: awesome :) Looks very promising, I hope we will add tests soon for i18n
17:13:00 <serg_melikyan> stan_lagun: what do you think?
17:14:09 <stan_lagun> serg_melikyan: I really don't know what to write there. On this stage there is really nothing to discuss. I think better approach would be to publish some release notes on how the final solution works and then to improve it for the next release according to feedback
17:14:32 <stan_lagun> Otherwise it will be hard for people to understand
17:15:21 <serg_melikyan> stan_lagun: we can discuss options for native integration with LBaaS - I believe folks from Magnum will be interested. We may discuss that with them in they channel first to see if there is a topic to discuss
17:16:38 <stan_lagun> Integration with LBaaS is straight forward. What do you want to discuss there? Just give LBaaS member IPs фтв ерфеы ше
17:16:46 <serg_melikyan> stan_lagun: let's do it - I will join to discussion with them
17:16:46 <stan_lagun> *and thats it
17:17:11 <serg_melikyan> stan_lagun: I am talking about when k8s interacts with LBaaS
17:17:18 <serg_melikyan> directly
17:19:16 <serg_melikyan> stan_lagun: ok, I will start and let's see. I am interested in tight native integration between k8s and OpenStack - and how Magnum does k8s deployement
17:19:26 <serg_melikyan> Let's move on
17:19:41 <serg_melikyan> #topic PTL Election
17:20:00 <SergeyLukjanov> hey folks
17:20:12 <SergeyLukjanov> serg_melikyan, asked me to help with ptl elections
17:20:31 <serg_melikyan> Yesterday I proposed to move Murano to openstack namespace, and folks pointed out that we don't have officially elected PTL
17:20:38 <SergeyLukjanov> so, I've been doing it previously for about 5 times and schema is very easy
17:21:00 <SergeyLukjanov> serg_melikyan, yeah, it should be anyway resolved to avoid such things in future
17:21:19 <SergeyLukjanov> so, let me describe the common election process
17:21:20 <serg_melikyan> SergeyLukjanov: thank you for the help :)
17:21:42 <SergeyLukjanov> Elections will be held using CIVS and a Condorcet algorithm
17:21:54 <SergeyLukjanov> it's a Schulze/Beatpath/CSSD variant
17:22:10 <SergeyLukjanov> any tie will be broken using https://wiki.openstack.org/wiki/Governance/TieBreaking
17:22:20 <SergeyLukjanov> the timeline is
17:22:28 <SergeyLukjanov> one week for candidates proposals
17:22:32 <SergeyLukjanov> and one week for voting
17:23:31 <SergeyLukjanov> in order to be an eligible candidate (and be allowed to vote) in a PTL election, you need to have contributed an accepted patch to one of the murano projects during the last yea
17:23:33 <SergeyLukjanov> r
17:23:50 <SergeyLukjanov> hm, sounds like the only question is
17:24:06 <SergeyLukjanov> what's the PTL timeframe we'll be electing for
17:24:12 <kzaitsev> one more week for voting? so it's 2 weeks total, right?
17:24:28 <SergeyLukjanov> kzaitsev, yup, if there will be more than one candidate
17:24:34 <SergeyLukjanov> IMO it should be rest of Kilo + Liberty
17:24:41 <serg_melikyan> SergeyLukjanov: I would say until end of the next release?
17:24:54 <serg_melikyan> SergeyLukjanov: =1
17:24:56 <serg_melikyan> +1
17:25:26 <serg_melikyan> SergeyLukjanov: How we are proposing candidates?
17:25:52 <SergeyLukjanov> I will send an email to -dev for opening candidates proposals
17:26:08 <SergeyLukjanov> and candidate should propose himself by sending an email to -dev
17:26:27 <SergeyLukjanov> with specific subject and telling his own story :)
17:27:05 <SergeyLukjanov> any other questions?
17:27:38 <serg_melikyan> SergeyLukjanov: Everything looks pretty clear, thank you for the help!
17:27:54 <serg_melikyan> Let's do it :)
17:28:03 <SergeyLukjanov> np, so, I'm disappearing now and will send an email later today
17:28:41 <serg_melikyan> SergeyLukjanov: thank you :)
17:28:59 * serg_melikyan is wondering if ruhe will be interested in one more round of PTL :D
17:29:39 <serg_melikyan> Folks any other things around this topic that we need to discus?
17:30:30 <serg_melikyan> #topic Open Discussion
17:30:43 <serg_melikyan> I would like to discuss topic around diversity
17:31:27 <serg_melikyan> I mean contribution diversity, unfortunately we too focused on features that we want to implement, and less focused on diversity :(
17:31:56 <serg_melikyan> We need to work on our code-review, and increase of review contribution from folks not from Mirantis.
17:32:32 <kzaitsev> I wonder how that could be done.. =)
17:32:55 <serg_melikyan> kzaitsev: moar reviews :)
17:33:05 <serg_melikyan> We need more core-reviewers :)
17:33:34 <serg_melikyan> henar: You have great contribution to Murano in terms of features (and I hope we will finish review of them soon), but we miss code-review contribution that is essential to become core member in Murano
17:33:47 <serg_melikyan> :(
17:34:12 <henar> yes. you are right. in fact, we are not in a better position for revision, since we know how openstack and murano code works
17:35:03 <kzaitsev> Ok then, so lets' review more =) and try to attract other people to review more =)
17:35:57 <serg_melikyan> henar: I am sure that you folks know a lot about Murano and OpenStack, and we would really appreciate more involvement in Reviews, that would be one of the last missing part to become core member in Murani
17:36:05 <serg_melikyan> *Murano
17:37:30 <henar> sure
17:39:04 <serg_melikyan> http://stackalytics.com/?project_type=all&module=murano&metric=marks - this a great tool to measure involvement to the project and usually following page http://stackalytics.com/report/contribution/murano/30 is used for measuring impact of contributor to reviews
17:42:24 <serg_melikyan> Any other topics to discuss for today?
17:43:10 <freerunner> serg_melikyan: I'm think we can discuss a job with Congress/Mistral integration
17:43:36 <serg_melikyan> freerunner: yeah, last week we spent a lot of time fixing this job
17:43:47 <serg_melikyan> freerunner: we anywhere near to make it work?
17:45:24 <freerunner> serg_melikyan: So, the job now not fixed yet. Me and Filip spent a lot of time to try to find a workaround. So, the last problem is global variables in project-config
17:45:53 <serg_melikyan> Which global variables?
17:46:15 <freerunner> serg_melikyan: Global variables which enablec Congress policies
17:46:59 <freerunner> serg_melikyan: we have code that exports this variable, but this code works incorrectly
17:47:13 <serg_melikyan> ?
17:47:29 <serg_melikyan> You mean patchset fixing True -> true?
17:47:37 <serg_melikyan> Or we have another issue?
17:48:33 <freerunner> serg_melikyan: It seems that this patch don't fixes job
17:49:21 <serg_melikyan> Did you found root cause?
17:50:08 <freerunner> serg_melikyan: Not yet. =(
17:50:46 <serg_melikyan> Job is not voting yet - so it not breaks our gate, we have time to work on this issue
17:51:51 <freerunner> serg_melikyan: So, we can set this variable as True by default in our devstack/lib, but i'm think that this is bad workaround.
17:53:49 <serg_melikyan> freerunner: agree, I don't like this workaround
17:54:00 <serg_melikyan> let's spend some more time working on this
17:55:14 <freerunner> serg_melikyan: I hope that Serg Lukjanov can help us with this job.
17:56:48 <serg_melikyan> I think we are missing something trivial
17:57:46 <serg_melikyan> Thank you, folks!
17:57:54 <serg_melikyan> #endmeeting murano