17:00:15 <serg_melikyan> #startmeeting murano
17:00:15 <openstack> Meeting started Tue Mar 24 17:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:19 <openstack> The meeting name has been set to 'murano'
17:00:35 <serg_melikyan> Hi folks! o/
17:00:52 <slagun> o/
17:00:55 <RadekPospisil> hi
17:01:37 <serg_melikyan> Hi RadekPospisil \o/
17:01:43 <aderyugin> hi
17:02:00 <katyafervent> hi
17:02:35 <freerunner> o/
17:02:47 <serg_melikyan> Agenda for todays meeting may be found here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:05:00 <serg_melikyan> #topic Action Items Review
17:05:08 <serg_melikyan> We have only one AI for today
17:05:11 <serg_melikyan> #sergmelikyan, send e-mail describing roadmap planning procedure
17:05:44 <serg_melikyan> And I shamelessly failed this AI :( I will send e-mail tomorrow, we need to start planning for the next cycle
17:05:49 <serg_melikyan> #action sergmelikyan, send e-mail describing roadmap planning procedure
17:06:18 <serg_melikyan> RadekPospisil: do you guys had a chance to start thinking about next steps in Policy Guided Fullfilment?
17:09:08 <serg_melikyan> #topic Bug-Scrub Day
17:09:35 <serg_melikyan> Folks, I propose to have bug-scrub day at this Friday
17:10:35 <serg_melikyan> #startvote Should we have bug-scrub day on this Friday? Yes, No, Other
17:10:36 <openstack> Begin voting on: Should we have bug-scrub day on this Friday? Valid vote options are Yes, No, Other.
17:10:37 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:10:38 <katyafervent> serg_melikyan, sounds good to me. At what time
17:10:46 <katyafervent> Yes
17:10:53 <serg_melikyan> #vote Yes
17:10:54 <katyafervent> #vote Yes
17:10:59 <freerunner> #vote Yes
17:11:02 <aderyugin> #vote Yes
17:11:04 <kzaitsev_> #vote Yes
17:11:07 <RadekPospisil> #vote Yes
17:11:08 <serg_melikyan> katyafervent: it is 24h event to span across the globe
17:11:40 <katyafervent> so out #murano channel will be the main place to communicate, right?
17:11:45 <katyafervent> *our
17:11:45 <henar> #vote Yes. Can you provide more information about it?
17:11:46 <RadekPospisil> what's the rules for bug-scrub day ?
17:11:46 <openstack> henar: Yes. Can you provide more information about it? is not a valid option. Valid options are Yes, No, Other.
17:11:46 <serg_melikyan> correct
17:12:02 <henar> #vote Yes
17:12:09 <henar> can you provide more information about it?
17:13:06 <serg_melikyan> Core-reviewers are going through bugs and clean them up from invalids and so on, and assign to the next milestone (kilo-rc1), then anyone can ask to assign particular bug to him
17:13:30 <slagun> #vote yes
17:13:55 <serg_melikyan> And whole team is focused on fixing bugs, and helping in fixing bugs to each other. Whole day is about bugs
17:14:26 <serg_melikyan> #endvote
17:14:26 <openstack> Voted on "Should we have bug-scrub day on this Friday?" Results are
17:14:27 <openstack> Yes (8): kzaitsev_, katyafervent, henar, serg_melikyan, slagun, freerunner, RadekPospisil, aderyugin
17:14:30 <RadekPospisil> I assume that bug reportes have to be online to help core reviewers providing more data about defects?
17:15:01 <serg_melikyan> Yes, https://bugs.launchpad.net/murano
17:15:13 <kzaitsev_> Should we actively search for more bugs before Friday? =)
17:15:14 <serg_melikyan> Aaa you mean reportees
17:15:21 <serg_melikyan> yeah, it would be helpful
17:15:36 <RadekPospisil> ok
17:15:40 <serg_melikyan> kzaitsev_: we should do it each day before release :D
17:16:23 <RadekPospisil> the irc room is #murano ?
17:16:37 <serg_melikyan> RadekPospisil: Yes
17:18:10 <serg_melikyan> We have pretty big list of bugs, and pretty short review queue - we did great job reviewing changes. Now we can focus on QA part, and finishing feature in FFE
17:19:09 <serg_melikyan> I propose to move to the next topic, any other questions about Bug-Scrub Day? I will announce it tomorrow
17:20:06 <serg_melikyan> #topic Feature Freeze Exception
17:20:24 <serg_melikyan> Let's discuss status of each feature that is marked as FFE
17:20:56 <serg_melikyan> We have three features:
17:20:59 <serg_melikyan> 1. Support for configuration languages (puppet, chef)
17:21:28 <serg_melikyan> henar: can you update status about this feature?
17:21:48 <henar> we are in the process of revision and working towards comments
17:22:03 <henar> the functionality is done. I am working towards comments
17:22:25 <henar> and also I should add some QA tests (end-to-end test) fro puppet and chef
17:23:20 <serg_melikyan> henar: excellent, thank you
17:23:41 <serg_melikyan> 2. Migrate to YAQL
17:23:41 <freerunner> henar: Henar, please, add me to reviewers of your commits. I'll help u with it.
17:23:52 <serg_melikyan> slagun:
17:24:10 <henar> thanks
17:24:11 <serg_melikyan> slagun: can you update us about this feature
17:24:15 <serg_melikyan> ?
17:24:24 * serg_melikyan is sloppy today
17:24:42 <kzaitsev_> freerunner, You should say your name in gerrit, cause it differs from freerunner =)
17:24:49 <slagun> slagun: haven't done anything on this feature since last meeting but I hope it will be finished by the next one
17:25:00 <slagun> serg_melikyan: ^^^
17:27:55 <freerunner> henar: My gerrit name is vryzhenkin. So, u can also add me by e-mail: vryzhenkin@mirantis.com
17:28:12 <henar> ok
17:29:07 <serg_melikyan> 3. Murano Versioning
17:30:38 <serg_melikyan> slagun: I think this BP is also on you?
17:30:50 <slagun> serg_melikyan: sure. After YAQL
17:33:13 <serg_melikyan> :(
17:34:28 <serg_melikyan> Looks like we are pretty behind with versioning :(
17:34:36 <serg_melikyan> #topic Open Discussion
17:35:27 <serg_melikyan> Any particular topic to discuss for today?
17:36:00 <serg_melikyan> I have a few good news to share:
17:36:06 <kzaitsev_> how's our proposal to governance going? =)
17:36:22 <serg_melikyan> Exact topic that I would like to share )
17:36:32 <serg_melikyan> 1) https://review.openstack.org/162745 moving steady :) We have 3 +1 already
17:37:31 <kzaitsev_> Yay! =)
17:37:33 <serg_melikyan> 2) https://launchpad.net/python-muranoclient - tomorrow we are going to release new python-muranoclient
17:37:52 <serg_melikyan> We fixed number of bugs and many new features
17:38:32 <serg_melikyan> kzaitsev_: I believe most of your repository blueprint will be released with this version, right?
17:39:18 <kzaitsev_> Correct. 90% of the functionality is inside the client
17:39:46 <kzaitsev_> other 10 is horizon UI
17:40:08 <serg_melikyan> Cool :)
17:40:39 <serg_melikyan> freerunner: btw, I remembered valuable hint for you - you can add all murano repos to the watching list in the settings on review.openstack.org
17:40:59 <serg_melikyan> After that you will be able to see every commit there on My -> Watched Changes page
17:41:17 <serg_melikyan> It really saves time, and you can browse all submitted changes
17:41:27 <serg_melikyan> No need to adding you to the reviewers specifically
17:42:32 <freerunner> serg_melikyan: I'm think it will be useful. ;) Thanks.
17:44:36 <serg_melikyan> I think Canada was not so good choice to held OpenStack Summit :(
17:44:57 <slagun> why&
17:45:00 <slagun> ?
17:45:21 * serg_melikyan was notified that he will receive his visa after 1.5 month after application
17:46:19 <serg_melikyan> It's crazy, many people not sure that they will attend OpenStack Summit almost until the last weeks before the Summit.
17:46:47 <serg_melikyan> But I am not sure about visa rules in Canada regarding other countries
17:47:00 <serg_melikyan> RadekPospisil: Do you need visa to attend Summit?
17:47:12 <slagun> I believe most of the people are from USA and Canada is relatively near for them
17:47:26 <slagun> and they don't need visa
17:47:27 <RadekPospisil> AFAIK CZ is visa-free with Canada
17:48:29 <serg_melikyan> RadekPospisil: I envy you guys :) I was filling my applications yesterday - it's really detailed, almost like I am moving to Canada instead of 5 days visit
17:48:52 <RadekPospisil> serg_melikyan: :-)
17:49:30 <serg_melikyan> They even requested my marriage certificate (my wife is not going with me though) :D
17:59:48 <serg_melikyan> Thank you, folks!
17:59:51 <serg_melikyan> #endmeeting