17:00:28 <sergmelikyan> #startmeeting murano
17:00:28 <openstack> Minutes:        http://eavesdrop.openstack.org/meetings/containers/2015/containers.2015-04-14-16.01.html
17:00:29 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/containers/2015/containers.2015-04-14-16.01.txt
17:00:30 <openstack> Log:            http://eavesdrop.openstack.org/meetings/containers/2015/containers.2015-04-14-16.01.log.html
17:00:31 <openstack> Meeting started Tue Apr 14 17:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:34 <thomasem> o/
17:00:35 <openstack> The meeting name has been set to 'murano'
17:00:44 <sergmelikyan> o/
17:01:13 <katyafervent> o/
17:01:18 <slagun> o/
17:01:22 <Fang_fenghua_> o/
17:01:27 <ddovbii> Hi
17:01:49 <FilipBlaha> hi
17:02:10 <aderyugin> hi^^
17:02:38 <sergmelikyan> Meeting Minutes from previous meeting: http://eavesdrop.openstack.org/meetings/murano/2015/murano.2015-04-07-17.00.html
17:02:58 <sergmelikyan> #topic Action Items Review
17:03:05 <sergmelikyan> We have two not assigned action items from previous meeting :(
17:03:15 <sergmelikyan> #1 schedule discussion for https://blueprints.launchpad.net/murano/+spec/abstract-env-template
17:03:31 <sergmelikyan> I didn't schedule a meeting due to high load related to RC :(
17:03:46 <sergmelikyan> We still have open critical issues that we are working on fixing :(
17:03:58 <sergmelikyan> We are going to return to this topic a little bit later
17:04:03 <henar> ok
17:04:07 <kzaitsev> Let's schedule it after RC than?
17:04:30 <sergmelikyan> kzaitsev, agree
17:04:58 <sergmelikyan> #action sergmelikyan, schedule discussion for https://blueprints.launchpad.net/murano/+spec/abstract-env-template after Kilo RC1
17:05:10 <sergmelikyan> #2 propose new structure for murano-apps
17:05:46 <sergmelikyan> ddovbii, thank you for updating our murano-apps: https://github.com/stackforge/murano-apps
17:06:16 <ddovbii> :)
17:07:03 <sergmelikyan> this is all for action items review :)
17:07:11 <sergmelikyan> #topic Release Status
17:07:24 <sergmelikyan> https://launchpad.net/murano/+milestone/kilo-rc1
17:08:13 <sergmelikyan> We have pretty good number of fixed issue, but we also have 7 Critical issues either in Confirmed or In Progress state
17:09:00 <sergmelikyan> I would like to walk through Confirmed and Assigned issues
17:09:13 <katyafervent> 7 :(
17:09:44 <sergmelikyan> Issues that are in progress have fixes on review, and we should focus on reviewing them ASAP as well as addressing comments
17:10:04 <sergmelikyan> slagun, https://bugs.launchpad.net/bugs/1443725
17:10:05 <openstack> Launchpad bug 1443725 in murano "[murano-apps] Deployment of multiple apps fails if apps have the same ports" [Critical,Confirmed] - Assigned to Stan Lagun (slagun)
17:10:11 <sergmelikyan> any update on this one?
17:10:36 <slagun> not yet
17:10:47 <slagun> Hopefully will fix later today
17:11:12 <sergmelikyan> do we have understanding on how you are going to address this issue?
17:12:41 <slagun> everything looks right in simulation mode. Need to try deploy it. It is either I mixed up container port and host port somewhere or somebody is already listening on that port for real (in stock image)
17:14:23 <sergmelikyan> Do I understand correctly, that in both Kubernetes and Docker we should be able to have same application twice?
17:14:41 <sergmelikyan> btw, we don't have reflected in the bug that it relates to particular apps
17:15:48 <slagun> sergmelikyan: we do have: 1. Upload applications which have some the same ports (Glassfish, Jenkins) to Murano
17:18:32 <sergmelikyan> slagun, thx for update, let's hope to have a fix today
17:18:51 <slagun> In Docker you can have 2 instances of the same app. Not on Pod
17:18:58 <sergmelikyan> katyafervent, https://bugs.launchpad.net/bugs/1441569
17:18:59 <openstack> Launchpad bug 1441569 in murano "Same app is listed twice in the catalog" [Critical,Confirmed] - Assigned to Ekaterina Chernova (efedorova)
17:19:05 <slagun> (sorry, missed first question)
17:21:10 <katyafervent> We agreed to mark public apps with corresponding label
17:22:21 <katyafervent> such as 'shared' and add to known issues, that if shared app has the same fqn with one of own packages  - shared will not be deploy
17:23:35 <sergmelikyan> katyafervent, thank you
17:23:38 <sergmelikyan> #topic Open Discussion
17:24:14 <sergmelikyan> FilipBlaha, sorry I blocked patch with lint until Liberty will be open, it will be once we will release RC1
17:24:51 <FilipBlaha> serg: ok, I understand
17:28:18 <kzaitsev> we have a nice idea for app repository, yet I'm not sure if we'll manage to squeeze it in the release =/ igor suggested that we could store a json/yaml file somewhere on the server with a list of packages on that server
17:28:57 <kzaitsev> The file would be non-authoritative
17:29:33 <kzaitsev> And it would allow to build an autocompletion for dashboard package import field
17:30:02 <kzaitsev> yet I guess it would count as improvement, and with RC behind the corner — we'll have to postpone the idea
17:30:52 <sergmelikyan> kzaitsev, but it is an awesome improvement, should really improve package-import feature
17:31:01 <sergmelikyan> would it be also supported in CLI?
17:31:04 <kzaitsev> sergmelikyan — what would you say about that?
17:31:15 <sergmelikyan> I mean would be it is possible to support in CLI?
17:31:20 <kzaitsev> well. CLI is a different beast
17:32:11 <kzaitsev> I see how we could implement a package-server-list or smth to get a list of packages on murano-repo-url
17:32:24 <kzaitsev> and later use it for bash-completion script
17:32:41 <kzaitsev> but that wouldn't be possible before we have a really nice bash-completion =)
17:33:31 <sergmelikyan> heh :) we already have some changes in master regarding this :)
17:34:00 <kzaitsev> I'm planning to play with it during liberty, to allow say mutano package-delete <tab> list id's of packages. But as of now — bash completion script is rather dump for that kind of thing
17:34:40 <kzaitsev> What I'm asking is — shall we delay the idea until liberty?
17:35:13 <sergmelikyan> I really like bash-completion feature, when you develop Murano you are usually use python-muranoclient pretty rarely, so I was not really missing this so much. But lately I was playing with client and got tired of typing all the staff manually
17:35:44 <sergmelikyan> kzaitsev, I think so, anyway once RC will be out of the doors, master will be open for Liberty
17:36:50 <FilipBlaha> awesome idea, current importing of packages is not very comfortable it will be improvement
17:38:30 <sergmelikyan> Any other questions that we want to discuss today or let's finish early and get back to working on RC?
17:39:58 <sergmelikyan> Thank you, folks!
17:40:04 <sergmelikyan> #endmeeting