17:00:53 <sergmelikyan> #startmeeting Murano
17:00:53 <openstack> Meeting started Tue May 12 17:00:53 2015 UTC and is due to finish in 60 minutes. The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:56 <openstack> The meeting name has been set to 'murano'
17:01:09 <sergmelikyan> Hi folks :)
17:01:11 <sergmelikyan> o/
17:01:20 * sergmelikyan feeling tension before the summit
17:01:30 <henar> hi
17:01:47 <ddovbii__> hi
17:02:26 <FilipBlaha> hi
17:04:43 <sergmelikyan> I left same agenda as for previous meeting, because Summit is on the next week, and I feel we have yet things to discuss.
17:05:18 <sergmelikyan> As proven on previous meeting summit discussions may take whole meeting, so if you have topics to discuss please propose, and we will discuss them first.
17:05:50 <kzaitsev> I have 1n concern, that I wanted to leave untill open discussion =)
17:05:59 <ruhe> i just wanted to give heads up on what i've been doing with CLI tests for muranoclient
17:06:22 <sergmelikyan> kzaitsev, naughty boy :)
17:06:33 <sergmelikyan> #topic CLI Tests for Murano
17:06:37 <ruhe> all the CLI tests are going to be moved under python-muranoclient repo and will run as a separate job
17:07:12 <ruhe> running them will be easy: deploy your openstack, source openrc, run 'tox -e functional'
17:07:16 <sergmelikyan> ruhe, previously we were running them against each commit to murano repo to ensure that they are working with change in API (if any), will it be possible?
17:07:23 <ruhe> s/openstack/devstack
17:07:59 <ruhe> sergmelikyan: yes, it's possible. let's get them working on muranoclient and then enable for commit to murano
17:08:41 <sergmelikyan> excellent :) I remember times when API was in active development and client was always behind :)
17:08:57 <sergmelikyan> ruhe, thank you for jumping on and fixing them!
17:09:14 <sergmelikyan> They broke after we updated requirements to tempest_lib?
17:09:29 <ruhe> actually there were 3 problems :)
17:09:40 <ruhe> 1. tempest_lib changed API for CLI tests
17:09:50 <ruhe> 2. devstack no longer installs nose (which we rely on)
17:10:02 <ruhe> my patches migrate tests from nose to testr
17:10:22 <ruhe> 3. in stable/kilo we had incorrect version in setup.cfg
17:10:32 <sergmelikyan> for tempest_lib?
17:10:46 * sergmelikyan updated requirements right before release :(
17:10:54 <ruhe> no, this one https://github.com/openstack/murano/blob/master/setup.cfg#L18
17:11:06 <ruhe> requirements are ok
17:11:49 <sergmelikyan> Ah...
17:11:49 <ruhe> somehow we managed to have incorrect version in murano-dashboard. AFAIK kzaitsev is working on that
17:12:51 <ruhe> i do not recall myself doing this patch, so i blame evil ghosts
17:12:58 <kzaitsev> Yep. I guess my commits to s/kilo would only pass after commit in murano is merged?
17:13:23 <ruhe> kzaitsev: correct. we need this one to land first https://review.openstack.org/#/c/182279/
17:14:11 <sergmelikyan> I see "# FIXME: see how it's done in saharaclient" is it going to be fixed in the next commit?
17:14:33 <kzaitsev> Oh. I can actually depend them on it, So that the tests should pass at the very least
17:14:45 <ruhe> sergmelikyan: we'll have to backport my patches to muranoclient
17:15:01 <ruhe> to get rid of that "FIXME"
17:15:38 <ruhe> one lesson i learned from all this
17:16:07 <sergmelikyan> ruhe, I think we need to backport them despite stable/kilo is now supported release and we usually only critical fixes porting there
17:16:17 <ruhe> we should pay closer attention to what's going on in mailing list. Joe Gordon provided excellent instructions to move CLI tests to clients on Feb 13: http://lists.openstack.org/pipermail/openstack-dev/2015-February/056916.html
17:16:29 <sergmelikyan> I vote for perfectly working CI on stable/* branches
17:16:39 <sergmelikyan> :(
17:16:46 <ruhe> sergmelikyan: we will *have to* backport this changes
17:16:47 <sergmelikyan> I've missed his e-mail...
17:17:35 <sergmelikyan> I need to configure filter on tempest related e-mails - we heavily depend on devstack & tempest, and any change in tempest may break CI
17:17:45 <sergmelikyan> ruhe, thank you!
17:18:00 <ruhe> well, sometimes we ignore those message because murano was in stackforge, but even if you're in stackforge and not "integrated" it's better to keep up with community
17:18:29 <sergmelikyan> It's not usually ignorance, but the storm of e-mails each day...
17:19:08 <ruhe> yes, that too
17:19:43 <sergmelikyan> Any other topics to discuss?
17:19:49 <ruhe> i think we covered this topic enough
17:19:52 <kzaitsev> So. With almous every core developer attending summit (except for katyafervent I suppose?) I would like to ask you guys to look at review.openstack.org every once in a while =)) Otherwise reviews would pile up =)))
17:20:17 <ruhe> kzaitsev: absolutely agree
17:21:08 <sergmelikyan> +1
17:21:54 <sergmelikyan> #topic Design Summit
17:22:32 <sergmelikyan> I've updated our schedule with links to etherpads, please take a look: libertydesignsummit.sched.org/type/design+summit/Murano
17:23:31 <sergmelikyan> We have pretty open schedule for Contributors Meet-up for now, but I think it will be quickly populated with items
17:23:54 <sergmelikyan> Anything that you folks feel we should discuss there?
17:25:41 <sergmelikyan> StanLagun, hi :)
17:25:59 <StanLagun> sergmelikyan, hi!. Sorry fir being late
17:26:19 <sergmelikyan> I have an idea to have a virtual mini-summit after the actual Liberty summit for contributors that are not able to joins us in the Vancouver
17:26:48 <StanLagun> +many
17:26:54 <sergmelikyan> I heard nice feedback about them from Glance team, that had that thing not so long ago
17:27:16 <henar> +1
17:28:13 <sergmelikyan> I will start preparation right after the Vancouver, I think it should be somewhere in beginning of June, we can't delay to long
17:28:39 <sergmelikyan> 1-3 days, depending on number of topics that we would have to discuss
17:29:56 <sergmelikyan> StanLagun, since you here, can you take a look at https://etherpad.openstack.org/p/murano-liberty-work-session-2 ?
17:30:11 <sergmelikyan> What do you think we should also include there?
17:30:14 <StanLagun> I'll be on vocation after Vancouver till 5th of June
17:30:37 <ruhe> StanLagun: ha! we'll design everything without you! ;)
17:30:42 <sergmelikyan> #info Stan is going to be on vacation till 5th of June
17:31:18 <sergmelikyan> #info mini-design summit will be held in the beginning of the June
17:31:39 <StanLagun> sergmelikyan, where?
17:31:50 <sergmelikyan> StanLagun, you mean which tool?
17:32:31 <StanLagun> sergmelikyan, I thought it is going to be IRL
17:33:29 <StanLagun> I think we can add agent authentication to the https://etherpad.openstack.org/p/murano-liberty-work-session-2
17:33:31 <sergmelikyan> StanLagun, most probably no - it's hard to gather people from around the globe in the same place, and if people missed summit in Vancouver, most probably they will not be able to attend mini design Summit
17:34:13 <StanLagun> I remember we had plans to hold it in Poland
17:34:21 <sergmelikyan> StanLagun, do you think we should mix to topics? Each session is 40m, I'm afraid that we will not have time to cover both of them
17:34:31 <sergmelikyan> *s/to/two
17:35:07 <sergmelikyan> StanLagun, let's include agent authentication here: https://etherpad.openstack.org/p/murano-liberty-contributors-meetup
17:35:45 <StanLagun> sergmelikyan, I thing that agent is more important topic and might be more interesting for audience as it is a good topic for collaboration and cross-project activity
17:37:08 <sergmelikyan> StanLagun, do you think we should swap work-session #2 with discussion about agent authentication?
17:37:39 <StanLagun> sergmelikyan, I'd say it is a good idea
17:38:18 <StanLagun> we can vote
17:38:55 <ruhe> fwiw i don't strong preferences about order of sessions
17:39:26 <sergmelikyan> Discussions on work-session are limited by time, and may have up to 50 participats
17:39:50 <sergmelikyan> contributors meetup will be limited by 10 people at max
17:40:31 <StanLagun> btw may I add problem #3 to the murano-liberty-work-session-1 ?
17:40:35 <sergmelikyan> So topic that require more input from audience is preferred choice for discussing on work session
17:40:52 <sergmelikyan> StanLagun, sure, if it's related to the topic of the session
17:41:33 <sergmelikyan> StanLagun, do you feel that we will implement agent authentication in Liberty and it's need to be discussed?
17:42:07 <StanLagun> sergmelikyan, I'd say this is the first thing we need to implement. This is a must
17:42:17 <sergmelikyan> I feel that it will be more interesting topics for work-session, but I am not sure that it will not be wasted if we are not going to work on agent authentication
17:42:53 <StanLagun> there is ongoing discussing on this in ML
17:42:55 <sergmelikyan> #startvote Should we discuss agent authentication on the work-session #2? Yes, No
17:42:55 <openstack> Begin voting on: Should we discuss agent authentication on the work-session #2? Valid vote options are Yes, No.
17:42:56 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:43:13 <StanLagun> #vote yes
17:43:36 <freerunner> #vote yes
17:44:21 <aderyugin> #vote yes
17:44:34 <DmytroDovbii> #vote yes
17:45:14 <sergmelikyan> #vote yes
17:45:17 <sergmelikyan> #endvote
17:45:18 <openstack> Voted on "Should we discuss agent authentication on the work-session #2?" Results are
17:45:19 <openstack> Yes (5): freerunner, aderyugin, StanLagun, DmytroDovbii, sergmelikyan
17:45:50 <sergmelikyan> StanLagun, can you update etherpad accordingly, and move previous topic to contributors meetup?
17:46:45 <StanLagun> sergmelikyan, I'll do it
17:47:06 <sergmelikyan> #action StanLagun update etherpad for work-session #2
17:47:56 <sergmelikyan> StanLagun, I will send them to ML once you will update etherpad
17:48:09 <sergmelikyan> Moving to Open Discussion?
17:49:15 <sergmelikyan> #topic Open Discussion
17:50:08 <sergmelikyan> We will not have a meeting on the next week due to OpenStack Summit :) I will update our agenda for the next meeting :)
17:50:44 <ruhe> on a related note "Bayern Munich vs Barcelona" starts in less than an hour, so i'd prefer to close the meeting as early as possible :)
17:51:33 <StanLagun> ruhe, you need a hour to prepare? :)
17:52:57 <sergmelikyan> StanLagun, beer and other stuff need to be bought?
17:53:08 <sergmelikyan> #endmeeting