17:01:21 <serg_melikyan> #startmeeting murano
17:01:22 <openstack> Meeting started Tue Jun  2 17:01:21 2015 UTC and is due to finish in 60 minutes.  The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:26 <openstack> The meeting name has been set to 'murano'
17:01:30 <serg_melikyan> o/
17:01:42 <serg_melikyan> Hi folks, today is awesome day :)
17:01:54 <serg_melikyan> We have 2 new core reviewers in our team :)
17:01:56 <kzaitsev> gday =)
17:02:05 <serg_melikyan> kzaitsev - congrats!
17:02:12 <DmytroDovbii> o/
17:02:24 <katyafervent2> 0/
17:02:42 <kzaitsev> yay!
17:03:23 <ativelkov> o/
17:03:36 <ativelkov> sorry for being l8 guys
17:04:29 <henar> hi
17:05:35 <kzaitsev> I'm going to quote Uncle Ben: With great power comes great responsibility =)
17:06:17 <aderyugin> hi!
17:06:21 <FilipBlaha> hi
17:06:25 <serg_melikyan> FilipBlaha: My congrats!!
17:06:45 <FilipBlaha> Thanks:)
17:07:21 <serg_melikyan> Let's get started :) and proceed with my minute of shame :)
17:07:33 <serg_melikyan> #topic Action Items Review
17:08:05 <serg_melikyan> http://eavesdrop.openstack.org/meetings/murano/2015/murano.2015-05-26-17.02.html - meeting minutes from previous meeting
17:08:32 <serg_melikyan> #1 sergmelikyan create a doodle to select date for overview meeting
17:08:58 <serg_melikyan> Was not able to do that :(
17:09:07 <serg_melikyan> I promise tomorrow we will be voting :)
17:09:14 <serg_melikyan> #action sergmelikyan create a doodle to select date for overview meeting
17:10:21 <serg_melikyan> #topic Roadmap for Liberty
17:10:37 <serg_melikyan> Folks, we still don't have a clear roadmap on our wiki
17:10:45 <serg_melikyan> https://wiki.openstack.org/wiki/Murano/Roadmap
17:11:27 <serg_melikyan> We already have several BPs that we agreed (at least initially) to work on during the liberty cycle, let's gather them in one etherpad and assign to the milestone
17:11:31 <serg_melikyan> any thoughts?
17:11:35 <katyafervent2> and do we have clear roadmap in general?
17:12:40 <serg_melikyan> katyafervent2: it OpenStack :) Starting from liberty was decided that we don't need to assign BPs to milestone, but I still think that it is usefull
17:13:45 * serg_melikyan searching for the e-mail with announcement
17:14:28 <serg_melikyan> http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg53892.html
17:14:45 <serg_melikyan> ^ Liberty release management and tracking
17:15:21 <katyafervent2> so huge :)
17:15:50 <serg_melikyan> Read only TL;DR: section )
17:17:04 <serg_melikyan> So what about creating etherpad and putting there BPs? No objections?
17:17:59 <katyafervent2> No
17:18:07 <henar> no
17:18:39 <ativelkov> To discuss - may be. Then we need to move them to wiki
17:18:44 <serg_melikyan> #link https://etherpad.openstack.org/p/murano-liberty-etherpads
17:19:05 <serg_melikyan> #info we will gather BPs in etherpad and move them to Wiki
17:19:10 <serg_melikyan> ativelkov: sure, that is idea
17:19:52 <serg_melikyan> #link https://etherpad.openstack.org/p/murano-liberty-bps
17:19:56 <serg_melikyan> Correct link ^
17:20:34 <kzaitsev> Does it mean, that any BP, that we want to implement in liberty should go to the etherpad?
17:21:21 <serg_melikyan> kzaitsev: may be not all of them, but we need to start with biggest ones to form our Roadmap
17:22:40 <kzaitsev> got it. Actually... The fact that we have to add BP's for Liberty in an etherpad kind of means, that launchpads ui fails =((
17:23:31 <serg_melikyan> kzaitsev: not exactly - only drivers may add them to launchpad, but not only drivers propose bps
17:23:41 <kzaitsev> nevertheless will do. =) I've got a couple of smaller ideas, that are yet to be filed as BPs.
17:23:41 <ativelkov> launchpad ui has been failing for a long time
17:24:19 <ativelkov> but the etherpad is just a quick starting point
17:24:39 <ativelkov> we will not rely on it for the whole cycle: it's just a document for the next meeting
17:25:02 <serg_melikyan> ativelkov: you read my mind :) Scary :P
17:25:13 <kzaitsev> serg_melikyan: that's exactly my point. There's no convinient way to filter BPs. =) Not ranting anymore =)
17:28:06 <ativelkov> kzaitsev: there are a bunch of scripts which may be used for various kinds of batch operations in LP
17:28:12 <serg_melikyan> #topic Open Discussion
17:28:31 <serg_melikyan> Any topics to discuss for today?
17:29:18 <serg_melikyan> FilipBlaha: We discussed number of topics on the summit - do you plan to convert them to BPs on launchpad?
17:29:20 <ativelkov> wanted to gather some requirest on what do people want from the next generation of package repo
17:30:05 <serg_melikyan> FilipBlaha: https://etherpad.openstack.org/p/murano-liberty-contributors-meetup <- I mean these
17:30:27 <kzaitsev> oh! I have a question. How about we drop py26 and start supporting py34? I've written a letter today to murano, but since everyone's here..
17:30:29 <serg_melikyan> ativelkov: I think it's better to start mailing thread about that
17:30:49 <FilipBlaha> serg: Radek is working on that but I am no sure right know. I will discuss it with him tomorrow
17:30:58 <serg_melikyan> kzaitsev: nope :) We should not drop py26, and I am all for py3 job
17:32:14 <kzaitsev> Why not drop py26? only python-muranoclient uses it right now, not even agent is guaranteed to be py26 compatitable.
17:32:42 <serg_melikyan> kzaitsev: did you read e-mails from me and Alex?
17:32:52 <kzaitsev> oh. sry. will do.
17:34:22 <kzaitsev> Ok. Got it. Client is going to be py26 compatitable, and i'll look into py34 some time soon
17:34:56 <ativelkov> kzaitsev: the general idea is that "normal" openstack services are supposed to live in "normal" environments, which are usually up-to-date etc
17:35:18 <ativelkov> Agent is supposed to run in VM, which means that we have even better control over its env
17:36:17 <ativelkov> but clients are going to be used in ANY envs, including the legacy ones
17:36:56 <kzaitsev> ativelkov, yeah, now I see the difference, thanx!
17:37:39 <ativelkov> BTW, there is an issue in yaql1.0 under py26
17:38:04 <ativelkov> it fails couple of tests on its built-in functions
17:40:23 <kzaitsev> and I had some issues with yaql 0.2 when launching murano under py34 today. =) This is going to be a rather fun feature to implement I guess =)
17:40:57 <serg_melikyan> kzaitsev: we need to upgrade python-muranoclient to newer versoion of YAQL
17:43:22 <katyafervent2> and release client again?)
17:43:56 <serg_melikyan> why not?
17:44:29 <katyafervent2> just asking
17:45:18 <kzaitsev> "release early, release often" =)
17:50:15 <serg_melikyan> Looks like we exhausted topics for today :)
17:50:19 <serg_melikyan> #endmeeting