17:01:04 <kzaitsev_mb> #startmeeting murano
17:01:05 <openstack> Meeting started Tue Jul  7 17:01:04 2015 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:06 <Nikolay_St> o?
17:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:10 <openstack> The meeting name has been set to 'murano'
17:01:11 <Nikolay_St> o/
17:01:15 <ruhe> o/
17:01:17 <kzaitsev_mb> hi all
17:01:20 <StanLagun> o/
17:01:26 <freerunner> o/
17:01:30 <khivin> hi)
17:02:33 <kzaitsev_mb> I'd like to start with the elephant in the room, and say, that we currently have some problems with dsvm job. freerunner and I are looking into it, but we would appreciate any help from you guys =)
17:02:44 <FilipBlaha> hi
17:03:03 <aderyugin> hi!
17:03:20 <kzaitsev_mb> We skiped our prev meeting, cause we had no agenda and no action items
17:03:30 <kzaitsev_mb> so there's no point in reviewing that
17:03:55 <kzaitsev_mb> But I've added a couple of items, I'd like to discuss to todays meeting agenda
17:03:56 <Nikolay_St> :d
17:04:15 <kzaitsev_mb> #topic Spec review process
17:05:42 <kzaitsev_mb> 1) I'd like to ask everyone to review specs more. Some of us tend to dismiss a patchset if it has -1 from someone.
17:05:53 <kzaitsev_mb> I believe that should not be the case for spec reviews
17:06:22 <Nikolay_St> agreed here
17:07:09 <Nikolay_St> specs has many points to discuss always, so -1 from someone couldn't be a real marker of something bad
17:08:48 <kzaitsev_mb> I'd like to remind, that L-2 is around the corner, and I believe we have only merged a spec or two =)
17:09:13 <kzaitsev_mb> Really hope, that we'll improve the situation soon
17:09:42 <mgershen> will it help if I split my spec to 2 specs? :)
17:09:53 <Nikolay_St> which one mgershen?
17:10:05 <mgershen> https://review.openstack.org/#/c/198559/
17:10:23 <kzaitsev_mb> Which brings me to the second point about specs — shouldn't we introduce something like a spec-freeze? A date, after which no specs would be merged?
17:11:56 <mgershen> I am considering splitting it anyway, since i would like to start working on what is agreed on
17:12:25 <kzaitsev_mb> nova has it (and it actually happened last week I think). The reasoning is that reviewing specs takes a lot of time, and having a deadline would encourage people to work on specs faster and possibly review them more.
17:12:28 <Nikolay_St> mgershen: I think this spec shouldn't be split to 2. it looks consistent
17:12:36 <Nikolay_St> kzaitsev_mb: I agree with you here.
17:13:04 <StanLagun> I think splitting in 2 is a good idea
17:13:33 <Nikolay_St> kzaitsev_mb: but we have a some kind of rule set for this freeze
17:14:15 <kzaitsev_mb> I'm not really sure, that we should agree on such a measure, when our PTL is on a vacation, though +)))
17:14:52 <Nikolay_St> :D
17:15:20 <Nikolay_St> we can just collect views
17:15:30 <kzaitsev_mb> I generally like the idea to have a spec-freeze at l-2 (and later at m-2 and so on).
17:15:34 <Nikolay_St> without an official poll
17:16:14 <kzaitsev_mb> Let's discuss it in ML then
17:16:45 <Nikolay_St> sure
17:17:01 <kzaitsev_mb> #action kzaitsev start spec-freeze discussion in ML
17:17:54 <kzaitsev_mb> #topic dropping db downgrades
17:18:09 <kzaitsev_mb> Next topic then
17:19:14 <kzaitsev_mb> I've been looking through bugs for l-2 and stumbled upon this one https://bugs.launchpad.net/murano/+bug/1399151
17:19:14 <openstack> Launchpad bug 1399151 in murano "Error during execution of database downgrade" [Medium,Confirmed]
17:19:50 <kzaitsev_mb> Recently some of the OS projects have dropped db downgrades completely, AFAIK
17:20:04 <kzaitsev_mb> nova and glance, to name the few (I might be wrong though)
17:20:07 <Nikolay_St> kzaitsev_mb: neutron for example
17:20:24 <Nikolay_St> and I think sahara
17:20:51 <kzaitsev_mb> Nikolay_St: so it looks like a trend =)
17:21:10 <Nikolay_St> kzaitsev_mb: yeap, it's one of the latest community practices
17:21:16 <FilipBlaha> + for dropping
17:21:16 <Nikolay_St> and we should follow
17:21:26 <FilipBlaha> +1
17:21:39 <StanLagun> +1
17:21:51 <Nikolay_St> +1
17:21:59 <mgershen> +1
17:22:16 <freerunner> +1 as well
17:22:20 <kzaitsev_mb> I wanted to start a vote, but looks like everyone agrees anyway =)
17:22:56 <Nikolay_St> for sure
17:23:08 <freerunner> kzaitsev_mb: so, for official, u can start vote =)
17:23:47 <kzaitsev_mb> freerunner: I think I'll just add agreed hash-tag to save us some time =)
17:24:34 <kzaitsev_mb> #agreed we decided to drop support for migration downgrades
17:25:05 <kzaitsev_mb> We should update our docs accordingly, I guess then =)
17:26:04 <kzaitsev_mb> and the last topic for today, then
17:26:14 <kzaitsev_mb> #topic nightly builds
17:27:12 <kzaitsev_mb> I'm not sure if it is possible, or even a good idea, but it seems, like a nice idea to check our stable branches from time to time?
17:28:04 <kzaitsev_mb> The idea came from some discussion in horizon (it was rejected there though, but the purpose was different there)
17:28:34 <StanLagun> we had this idea for a long time
17:29:22 <kzaitsev_mb> The idea is to have a nightly build of every stable branch of every of our projects. This should help us detect gate blocks sooner, since stable branches are not updated that often.
17:30:46 <kzaitsev_mb> StanLagun freerunner aderyugin is it even possible with current jenkins infrastructure?
17:30:49 <kzaitsev_mb> Even though I like the idea, I haven't seen anything like that in any project =(
17:32:18 <freerunner> kzaitsev_mb: You mean dsvm jobs, yep?
17:33:12 <kzaitsev_mb> freerunner: something like that. The easiest and dirtiest way to do this would be to push a commit for review, but I dislike this approach for obvious reasons )
17:34:40 <kzaitsev_mb> So I suppose no one really does it, right?
17:35:26 <freerunner> kzaitsev_mb: I think nope.
17:36:43 <kzaitsev_mb> this means we can be first =) but also means that it would probably be a lot of work to setup such a system nicely =(
17:39:18 <kzaitsev_mb> Does anyone want to volunteer to investigate how we can do such a thing? =)
17:39:24 <kzaitsev_mb> I guess no one =)
17:39:25 <kzaitsev_mb> ok I'll do it then
17:40:15 <kzaitsev_mb> #action kzaitsev look for a way to run periodic nightly builds of stable branches
17:40:41 <kzaitsev_mb> I'll try to contact infra guys, we can't be the first team to want a thing like that =)
17:41:04 <kzaitsev_mb> ok, so we're out of topics, moving to open discussion
17:41:11 <kzaitsev_mb> #topic Open Discussion
17:43:05 <kzaitsev_mb> A thing I've noted about previous guys meeting (containers) — is that they have permanent links to their agendas. And they link them during meetings. I'll try to adopt that approach during our next meeting =)
17:43:58 <mgershen> sounds cool :)
17:44:15 <kzaitsev_mb> Hm, I remember that we wanted to make some mid-cycle virtual meetup.
17:45:28 <kzaitsev_mb> Is the idea dead? I belive Serg was the one driving it though.
17:46:20 <freerunner> kzaitsev_mb: I've think we can discuss this, when Serg goes back from vacation =)
17:46:31 <freerunner> *I think
17:47:07 <kzaitsev_mb> freerunner: yep. sounds good
17:50:08 <kzaitsev_mb> looks like we can finish a bit early
17:50:34 <Nikolay_St> looks like my client was kicked off from channel :(
17:50:39 <freerunner> kzaitsev_mb: One more sec =)
17:51:11 <freerunner> kzaitsev_mb: I have one idea for next meeting. We can discuss a better versioning of muranoclient.
17:52:10 <kzaitsev_mb> freerunner: let's add it tour next meeting agenda then.
17:52:27 <kzaitsev_mb> I'll update it accordingly.
17:52:46 <kzaitsev_mb> #idea (by freerunner) discuss a better versioning of muranoclient
17:53:04 <freerunner> kzaitsev_mb: Cool =)
17:53:54 <kzaitsev_mb> freerunner: it would be nice if you would prepare some write up beforehand, so that everyone could read it, though =) an etherpad would be awesome.
17:54:19 <kzaitsev_mb> *short writeup =)
17:54:32 <freerunner> kzaitsev_mb: Sure ;)
17:57:07 <kzaitsev_mb> ok, before time runs out. I'd like to remind everyone (even non-core developers) to review https://review.openstack.org/#/q/status:open+project:openstack/murano-specs,n,z some specs, and do so even if there is a -1 from someone there.
17:59:40 <kzaitsev_mb> let's end the meeting =) I believe it was rather productive =)
18:00:05 <kzaitsev_mb> #endmeeting