17:01:52 <kzaitsev_mb> #startmeeting murano
17:01:53 <openstack> Meeting started Tue Jul 21 17:01:52 2015 UTC and is due to finish in 60 minutes. The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:57 <openstack> The meeting name has been set to 'murano'
17:02:14 <kzaitsev_mb> hi all, murano time
17:02:19 <katyafervent> Hi
17:02:26 <noa-koffman> Hi
17:03:02 <Nikolay_St> hi
17:03:37 <sergmelikyan> o/
17:03:42 <sergmelikyan> Hi noa-koffman!
17:03:46 <mgershen> Hi
17:03:47 <sergmelikyan> Happy to see you here :)
17:03:55 <sergmelikyan> mgershen: o/
17:03:57 <FilipBlaha> Hi
17:03:58 <noa-koffman> Hi, happy to be here :)
17:04:03 <mgershen> :D
17:04:06 <Nikolay_St> :D
17:04:07 <sergmelikyan> FilipBlaha: o/
17:04:10 <kzaitsev_mb> Agenda for todays meeting: #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda/Archive/2015-07-21/
17:04:14 <ativelkov> o/
17:04:47 <kzaitsev_mb> so we can start with action items review. There was only one — I had to update the yaql BP, to offload some work from slagun
17:05:01 <kzaitsev_mb> I didn't, but katyafervent did the work anyway =)
17:05:02 <freerunner> o/
17:05:11 <kzaitsev_mb> thank you katyafervent for that! =)
17:05:15 <katyafervent> :)
17:05:42 <kzaitsev_mb> #topic Migrating to yaql 1.0 status.
17:06:02 <kzaitsev_mb> So slagun is unable to attend, but I chatted with him and can give a status update
17:07:00 <kzaitsev_mb> 1) the dsl is ported 2) yaql itself was improved by slagun. What's left is to port yaql functions of the engine (not dsl)
17:07:11 <kzaitsev_mb> slagun promises to finish it by tomorrow =)
17:07:44 <kzaitsev_mb> the WIP commits are #link https://review.openstack.org/#/c/204099/
17:08:01 <kzaitsev_mb> and #link https://review.openstack.org/#/c/204103/
17:08:34 <kzaitsev_mb> So let's hope that we'll see murano working on yaql 1.0 by the end of the week =)
17:08:57 <sergmelikyan> kzaitsev_mb: we need to coordinate with Mistral team on that
17:09:12 <sergmelikyan> We should switch to 1.0 together
17:09:20 <kzaitsev_mb> sergmelikyan: that's a good point!
17:09:30 <katyafervent> https://review.openstack.org/#/q/status:open+branch:master+topic:bp/migrate-to-yaql-vnext,n,z
17:10:00 <katyafervent> Stan, please set corresponding topic to be able to see all commits
17:10:47 <katyafervent> We will release new version of yaql and update all the patches
17:10:59 <katyafervent> so it's too early to merge them
17:12:12 <kzaitsev_mb> sorry, got disconnected
17:12:32 <kzaitsev_mb> #action slagun coordinate yaql1.0 release with mistral guys
17:12:41 <kzaitsev_mb> lets leave it like this, then
17:13:09 <kzaitsev_mb> #topic Assign CrossProjectLiason status for Oslo (and possibly Release management)
17:13:38 <kzaitsev_mb> so the next topic is about CPLs
17:14:04 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons for those who do not know who CPLs are
17:14:40 <kzaitsev_mb> sergmelikyan, are you willing to share Oslo and Release duties with someone, right?
17:15:07 <sergmelikyan> kzaitsev_mb: will be happy to :)
17:15:57 <kzaitsev_mb> I think I can take oslo, since I visit Oslo for horizon anyway, but that would make me have 3 CPL titles, whoch is a bit too much +)
17:16:47 <kzaitsev_mb> katyafervent: can you maybe take doc CPL from me? =)
17:16:57 <sergmelikyan> kzaitsev_mb: it takes too much of your time?
17:17:11 <kzaitsev_mb> not really, just the bus factor )
17:17:13 <katyafervent> I don't know what I need to do
17:18:14 <kzaitsev_mb> katyafervent: https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation here's short info. you do not to do much, just be the person, that passes important news from doc team to murano and vice versa
17:19:20 <katyafervent> ok
17:19:22 <kzaitsev_mb> sergmelikyan: and the release.. I'm not really sure about that one.
17:19:38 <sergmelikyan> kzaitsev_mb: I will keep this one for now
17:20:47 <kzaitsev_mb> ok, so if no objections katyafervent takes documentation CPL from me. I take oslo CPL from sergmelikyan. and sergmelikyan keeps release CPL.
17:21:36 <Nikolay_St> kzaitsev_mb: no objections :)
17:21:37 <kzaitsev_mb> #agreed katyafervent is the new doc CPL, kzaitsev_mb is the new oslo CPL, sergmelikyan is still the release CPL
17:22:05 <kzaitsev_mb> I'll update the wiki, then =)
17:22:46 <kzaitsev_mb> Let's move to the openstack-murano question then
17:22:53 <kzaitsev_mb> #topic Voting: should we move to openstack-murano?
17:23:20 <katyafervent> recently I wrote an email about that
17:23:31 <kzaitsev_mb> #startvote should we move to #openstack-murano? Yes, No, Abstain
17:23:31 <openstack> Begin voting on: should we move to #openstack-murano? Valid vote options are Yes, No, Abstain.
17:23:32 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:23:36 <sergmelikyan> ativelkov: summarized my thoughts around that, that's why I don't support this idea at all
17:23:41 <sergmelikyan> No
17:23:46 <sergmelikyan> #vote No
17:23:48 <katyafervent> most of openstack project have openstack suffix.
17:24:01 <freerunner> #vote Yes
17:24:03 <kzaitsev_mb> #vote Abstain
17:24:09 <katyafervent> Is that just heat has not that suffix?
17:24:37 <ativelkov> #vote No
17:24:38 <FilipBlaha> #vote Abstain
17:24:40 <katyafervent> There are a lot of resources where we providing our irc channel as #murano
17:24:41 <mgershen> #vote Abstain
17:24:48 <kzaitsev_mb> katyafervent: there is a wiki page with all IRC channels
17:24:59 <noa-koffman> #vote Abstain
17:25:05 <sergmelikyan> ativelkov: your vote?
17:25:12 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/IRC
17:25:15 <freerunner> I'm not see real significant reasons to stay in #murano
17:25:16 <ativelkov> sergmelikyan: I did
17:25:21 <ativelkov> #vote No
17:25:23 <ativelkov> see above)
17:25:33 <sergmelikyan> A really lot of resources, that's why I very negative about that
17:25:36 <sergmelikyan> *I am
17:25:47 <Nikolay_St> congres, heat and nova-docker
17:25:50 <katyafervent> #vote No
17:25:56 <Nikolay_St> and also magneto-db
17:26:00 <Nikolay_St> #vote Abstain
17:27:05 <ruhe> #vote Yes
17:28:01 <kzaitsev_mb> on the one hand this make our channel a bit more consistent, but on the other would likely cause confusion and some trouble short and mid-term
17:30:07 <sergmelikyan> Heat is perfectly fine with they channel :)
17:30:12 <katyafervent> we loosing our time with vote "Abstain". there are should be just two options
17:30:16 <freerunner> katyafervent: I'm really surprised that you vote 'No' in this voting. ;)
17:30:17 <sergmelikyan> I don't see why we need to change ours
17:30:31 <sergmelikyan> Let's finish the vote
17:30:44 <kzaitsev_mb> #endvote
17:30:45 <openstack> Voted on "should we move to #openstack-murano?" Results are
17:30:46 <openstack> Yes (2): freerunner, ruhe
17:30:47 <openstack> Abstain (5): noa-koffman, FilipBlaha, kzaitsev_mb, mgershen, Nikolay_St
17:30:48 <openstack> No (3): katyafervent, ativelkov, sergmelikyan
17:31:38 <katyafervent> I could affect the result)
17:31:43 <kzaitsev_mb> katyafervent: well, if we didn't have abstain, people could just ignore the vote to do so =)
17:31:53 <katyafervent> I just imagine what we need to change
17:32:06 <katyafervent> all docs together with readme's
17:32:13 <kzaitsev_mb> so it's decided. We're staying in #murano
17:32:33 <kzaitsev_mb> katyafervent: lot's of work, really =)
17:32:42 <kzaitsev_mb> #topic Logging refactoring and the spec for it.
17:32:48 <kzaitsev_mb> our last topic for today
17:32:57 <kzaitsev_mb> Nikolay_St: can you pls elaborate?
17:33:04 <Nikolay_St> kzaitsev_mb: yeap
17:33:52 <Nikolay_St> so, a few weeks ago when I just join the team I suggest an idea to write a loggin spec for murano like this one: https://github.com/openstack/openstack-specs/blob/master/specs/log-guidelines.rst
17:34:29 <Nikolay_St> It's a complex spec with general statements
17:34:48 <Nikolay_St> and here is the one I've adopted to sahara project: http://specs.openstack.org/openstack/sahara-specs/specs/kilo/sahara-log-guidelines.html
17:35:11 <Nikolay_St> but few week ago we use murano.common.log
17:35:41 <Nikolay_St> and now we merged oslo_log into murano ana I also provide a patch with oslo_log to murano-dasboard
17:36:11 <Nikolay_St> so, as for me it's time to work on spec with more specific log levels descriptions and rules
17:36:31 <Nikolay_St> I plan to do it myself
17:36:33 <kzaitsev_mb> #link https://github.com/openstack/openstack-specs/blob/master/specs/log-guidelines.rst
17:37:10 <Nikolay_St> what do you think do we need this spec?
17:37:26 <Nikolay_St> #link http://specs.openstack.org/openstack/sahara-specs/specs/kilo/sahara-log-guidelines.html
17:37:28 <sergmelikyan> We need this spect, but it's sure not a top priority thing
17:38:07 <Nikolay_St> sergmelikyan: I rememer about amount of bugs
17:38:13 <kzaitsev_mb> agree with sergmelikyan on that one. Would be really nice to have a guideline, but we're not desperate to have one =)
17:38:16 <Nikolay_St> I'll do it in 'background'
17:38:41 <kzaitsev_mb> Nikolay_St: looks like a nice idea overall to me.
17:38:48 <katyafervent> +1
17:40:04 <Nikolay_St> so, we can mark it as agreed, right?
17:40:07 <kzaitsev_mb> #action Nikolay_St create a draft of the log guideline spec.
17:40:30 <Nikolay_St> nice
17:40:32 <kzaitsev_mb> Nikolay_St: yep, I think there are no objections to that one =)
17:40:48 <kzaitsev_mb> so If you have time to work on it — it would be really nice.
17:40:58 <kzaitsev_mb> ok, then
17:41:03 <kzaitsev_mb> #topic Open Discussion
17:41:21 <kzaitsev_mb> Anything you have to discuss about murano in general?
17:41:46 <kzaitsev_mb> Oh! I think we have an announcement: python-muranoclient was released
17:42:10 <kzaitsev_mb> python-muranoclient 0.6.2 to be specific with abandon feature support
17:42:14 <noa-koffman> I opened a bug today https://bugs.launchpad.net/murano/+bug/1476543, and wanted to see if there is an agreement about this issue
17:42:15 <openstack> Launchpad bug 1476543 in murano "catalog/packages/<package_id>/ui does not return json" [Undecided,New] - Assigned to Lin Yang (lin-a-yang)
17:42:16 <uvirtbot> Launchpad bug 1476543 in murano "catalog/packages/<package_id>/ui does not return json" [Undecided,New]
17:42:17 <uvirtbot> Launchpad bug 1476543 in murano "catalog/packages/<package_id>/ui does not return json" [Undecided,New] https://launchpad.net/bugs/1476543
17:42:54 <kzaitsev_mb> btw, sergmelikyan shouldn't we write about these to openstack-announce@lists.openstack.org ?
17:43:20 <Nikolay_St> noa-koffman: right, I think it looks like bug
17:43:36 <sergmelikyan> noa-koffman: definitely a bug
17:43:58 <sergmelikyan> confirmed
17:44:04 <noa-koffman> ok thanks
17:44:13 <sergmelikyan> kzaitsev_mb: usually small releases are not announced
17:44:19 <kzaitsev_mb> I think you can even say triaged ;)
17:44:46 <noa-koffman> I also opened a bug regarding the version of murano endpoint in keystone, https://bugs.launchpad.net/murano/+bug/1476716
17:44:47 <openstack> Launchpad bug 1476716 in murano "murano is registerd in keystone without API version" [Undecided,New]
17:44:48 <uvirtbot> Launchpad bug 1476716 in murano "murano is registerd in keystone without API version" [Undecided,New]
17:44:49 <uvirtbot> Launchpad bug 1476716 in murano "murano is registerd in keystone without API version" [Undecided,New] https://launchpad.net/bugs/1476716
17:44:59 <noa-koffman> that we discussed about last week
17:45:29 <kzaitsev_mb> sergmelikyan: well there was recently a letter about glance_store 0.7.0..0.7.1 being released.
17:45:31 <sergmelikyan> Yep, thank you for that!
17:45:59 <sergmelikyan> kzaitsev_mb: well, than I would appreciate if you would send e-mail there
17:46:22 <sergmelikyan> Nikolay_St: can you take a look at the both of them?
17:47:20 <Nikolay_St> sergmelikyan: you're talking about bugs?
17:47:27 <sergmelikyan> yep
17:47:32 <kzaitsev_mb> ok I'll take a look at the list and send a letter there. I think we can start using that mailing list a bit more =)
17:48:22 <kzaitsev_mb> sergmelikyan: Lin Yang is working on one of those, we should try to catch the guy and ask him/her to visit our meetings sometime
17:48:23 <Nikolay_St> sergmelikyan: one of them is already assigned to Lin Yang
17:48:30 <Nikolay_St> but I'll take another one
17:48:49 <kzaitsev_mb> he seems to do some good job fixing some of our smaller bugs =)
17:49:00 <noa-koffman> Nikolay_St: ok great thanks
17:53:52 <sergmelikyan> Any other open questions? Or we can finish slightly earlier?
17:55:11 <kzaitsev_mb> I think we can. was witing for -5 mins
17:55:25 <kzaitsev_mb> ok, folks. Thanks everyone for attending!
17:55:30 <Nikolay_St> bye
17:55:32 <katyafervent> Bye
17:55:34 <noa-koffman> bye
17:55:39 <kzaitsev_mb> See you next week or in #murano
17:55:40 <FilipBlaha> bye
17:55:43 <kzaitsev_mb> #endmeeting