17:00:16 <sergmelikyan> #startmeeting murano
17:00:17 <openstack> Meeting started Tue Aug  4 17:00:16 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:21 <openstack> The meeting name has been set to 'murano'
17:00:22 <kzaitsev_mb> ok =)
17:00:32 <sergmelikyan> Hi folks o/
17:00:52 <kzaitsev_mb> today's agenda is available at #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda/Archive/2015-08-04/
17:00:57 <xiangxinyong> hi everyone!
17:01:05 <Nikolay_St> \o/
17:02:02 <kzaitsev_mb> sergmelikyan: is ativelkov coming, btw
17:02:11 <FilipBlaha> Hi
17:02:39 <sergmelikyan> kzaitsev_mb: I am not sure :) He is in Israel...
17:03:00 <kzaitsev_mb> ok, thought you're in touch. seems like no then
17:03:06 <freerunner> o/
17:03:27 <sergmelikyan> #topic Action Items Review
17:03:46 <sergmelikyan> kzaitsev_mb: I am it touch with him but not like each minute :)
17:04:38 <sergmelikyan> kzaitsev_mb: #1kzaitsev_mb as soon as yaql and muranopl is ready — write an email to encourage murano team and murano users to test new yaql
17:04:56 <sergmelikyan> kzaitsev_mb: I think all commits are on review but not yet merged
17:05:09 <kzaitsev_mb> yep, just today =)
17:05:28 <sergmelikyan> We have a lots of people interested in YAQL, I guess we can send e-mail encouraging people to take a look before merge
17:06:12 <kzaitsev_mb> #link https://review.openstack.org/#/c/208679/ the yaql commit, that according to stan is like rc1 (or is it 2?)
17:06:49 <kzaitsev_mb> and a #link https://review.openstack.org/#/c/204099/ engine, ported to yaql 1.0
17:07:12 <kzaitsev_mb> I'll reschedule the AI
17:08:16 <kzaitsev_mb> #action kzaitsev_mb write an email to encourage murano team and murano users to test new yaql
17:08:33 <sergmelikyan> kzaitsev_mb: why?
17:09:06 <kzaitsev_mb> what why? cause I have not written the email yet. cause the commits were only ready today. =)
17:09:12 <sergmelikyan> We can send e-mail anyway as I already send, or you think we should send 2 e-mails?
17:09:18 <kzaitsev_mb> oh
17:09:20 <kzaitsev_mb> #undo
17:09:22 <kzaitsev_mb> ok
17:09:34 <sergmelikyan> */send/said
17:09:42 <kzaitsev_mb> said or send?
17:09:51 <kzaitsev_mb> that makes a looot of difference
17:10:00 <sergmelikyan> said )
17:10:04 <Nikolay_St> :)
17:10:07 <kzaitsev_mb> so I have to send an email
17:10:18 <kzaitsev_mb> let's add a AI for it, won't we?
17:10:32 <sergmelikyan> kzaitsev_mb: sure :)
17:10:40 <kzaitsev_mb> #action kzaitsev_mb write an email to encourage murano team and murano users to test new yaql
17:10:44 <sergmelikyan> I thought you've decided to postpone it
17:11:06 <sergmelikyan> #topic Migrating to YAQL 1.0
17:11:10 <kzaitsev_mb> well if everything is nearly ready — we can move the discussion to ML
17:11:39 <sergmelikyan> I guess we had update from kzaitsev_mb, but my be Stan have something to add
17:11:50 <kzaitsev_mb> i've just pinged Stan and he's en route somewhere, promised to be here later
17:11:51 <sergmelikyan> but I guess he is not here
17:12:02 <sergmelikyan> kzaitsev_mb: thx
17:13:04 <sergmelikyan> We also can skip topic about artifact repo because Alex is also not attendence todays
17:13:11 <kzaitsev_mb> ativelkov: is not here either, so the 2d topic yeah =(
17:13:29 <sergmelikyan> #topic Stable jobs
17:13:35 <sergmelikyan> kzaitsev_mb: :)
17:14:47 <kzaitsev_mb> so yeah. my patch to infra has been merged
17:15:12 <kzaitsev_mb> and we now have stable jobs running periodically
17:15:41 <kzaitsev_mb> they run everyday (AFAIR the config)
17:15:54 <kzaitsev_mb> if they fail — they write a letter to #link http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-stable-maint
17:16:32 <sergmelikyan> I've already subscribed ;)
17:16:38 <kzaitsev_mb> so if you're interested in monitoring and helping out with stable branches — subscribe to the list.
17:17:00 <Daviey> \o/
17:17:16 <kzaitsev_mb> Would probably require some filters, since all stuff write there (horizon, nova, etc.)
17:18:09 <kzaitsev_mb> I'll also write a letter to ML 'bout the jobs, so that folks, who're missing today would also know =)
17:18:37 <sergmelikyan> Daviey: o/
17:18:55 <kzaitsev_mb> that's all I really had to say about stable jobs =)
17:19:07 <sergmelikyan> #action kzaitsev_mb write e-mail about stable jobs
17:19:38 <kzaitsev_mb> slagun: hi! =)
17:19:42 <sergmelikyan> #topic Open Discussion
17:19:47 <slagun> hi!
17:19:58 <slagun> sorry for being late
17:20:51 <sergmelikyan> slagun: looks like kzaitsev_mb covered question about YAQL migration, anything to add?
17:20:52 <kzaitsev_mb> sergmelikyan: slagun maybe we'll switch to YAQL before Open Discussion? =)
17:21:01 <sergmelikyan> I hope we will finish migration during this week
17:22:19 <slagun> new engine should be fully functional at the moment
17:22:45 <slagun> It passes all unit tests and I managed to deploy complex k8s topology with it
17:24:00 <slagun> though I need to fix pep8
17:24:06 <sergmelikyan> slagun: I really liked unit-tests coverage
17:24:12 <sergmelikyan> on the commits with yaql
17:24:22 <kzaitsev_mb> so our next steps: would be release new yaql, notify mistral guys, test new engine, release yaql 1.0, merge all the things. Right? =)
17:24:47 <sergmelikyan> yup
17:25:27 <slagun> yes. My suggestion to release yaql rc2 as soon as all yaql commits got merged and test with rc2. If there won't be any yaql issues then rc2 will became the release. Otherwise there will be rc3
17:26:45 <kzaitsev_mb> Nice. So we have to ping sergmelikyan and ativelkov to review yaql patches, cause I guess the're the ones with +2 on that repo )
17:26:55 <sergmelikyan> I've already did that btw
17:27:15 <slagun> Its a chain of 6 commits :)
17:27:48 <slagun> And I already have some code that is going to find its way into yaql 1.1
17:28:00 <kzaitsev_mb> oh boy =)
17:28:34 <kzaitsev_mb> ok, so on an unrelated note: #link https://review.openstack.org/#/c/208145/ this is the last commit, that would make our new js linting job green.
17:28:51 <kzaitsev_mb> thanks a lot to xiangxinyong for doing most of linting work =)
17:29:19 <xiangxinyong> kzaitsev_mb:you are welcome
17:29:52 <kzaitsev_mb> I have a question though — should we make it voting after we merge this one?
17:30:16 <Nikolay_St> kzaitsev_mb: if it works good - why not?
17:31:15 <kzaitsev_mb> well, yeah guess a broken js job would result in a -1 from other reviewers anyway
17:31:57 <kzaitsev_mb> so, I guess I'll make a commit, that makes it voting as soon as the patch lands =)
17:32:23 <kzaitsev_mb> Nikolay_St: you wanted to say smth about the logs, right?
17:32:39 <Nikolay_St> kzaitsev_mb: yeah, thanks for the notice
17:33:06 <Nikolay_St> guys, as you may know we merged a logging spec for murano last week
17:33:27 <Nikolay_St> #link http://murano-specs.readthedocs.org/en/latest/specs/liberty/murano-log-guildelines.html
17:33:54 <Nikolay_St> please try to follow it in the new commits and update patches on review close to it
17:34:23 <kzaitsev_mb> agree on that one )
17:34:23 <Nikolay_St> I work on the existing code and will try to commit changes in 1-2 days
17:35:11 <Nikolay_St> also, in the near future we might need to update it as soon as TRACE level is introduced in the newest oslo.log version
17:36:15 <slagun> I'm going to use trace for new engine method invocation logging as soon as https://review.openstack.org/#/c/208702/ gets merged
17:36:16 <Nikolay_St> so, that's all from my side. thx for attention) if you have any question about log you reach me on #murano :)
17:36:31 <Nikolay_St> slagun: nice
17:37:22 <Nikolay_St> I need to take a look at the major OpenStack logging spec to be sure how we should use trace in murano
17:37:29 <Nikolay_St> have no time yet :(
17:38:46 <kzaitsev_mb> Nikolay_St: requirements are already updated by the bot ) so we'll have 1.8 log library really soon )
17:40:16 <Nikolay_St> kzaitsev_mb: I know) I just need some time to update the spec. I'll do it on Thursday, I suppose. after next log wg meeting
17:42:59 <xiangxinyong> I have a question. Do we have mid cycle meeting?
17:43:29 <Nikolay_St> sergmelikyan: ^^
17:43:34 <Nikolay_St> kzaitsev_mb: ^^
17:43:52 <sergmelikyan> xiangxinyong: no, this time we don't have midcycle summit but we can orginize call if needed
17:44:24 <sergmelikyan> if you have topic to discuss, we can schedule video-conference call
17:44:43 <xiangxinyong> sergmelikyan: understood. Thanks
17:45:24 <kzaitsev_mb> should we wrap up? =)
17:47:39 <sergmelikyan> looks like so :)
17:47:50 <sergmelikyan> Any other topics to discuss folks?
17:48:20 <Nikolay_St> nope
17:48:23 <sergmelikyan> #endmeeting