17:01:09 <Nikolay_St> #startmeeting murano
17:01:10 <openstack> Meeting started Tue Sep  1 17:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is Nikolay_St. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:13 <openstack> The meeting name has been set to 'murano'
17:01:26 <Nikolay_St> o/
17:01:28 <xiangxinyong> hello
17:01:35 <mgershen> o/
17:01:35 <stan_lagun> o/
17:01:57 <_ddovbii> hi
17:02:24 <Nikolay_St> #topic Action items review
17:02:29 <freerunner> Hey!
17:02:58 <Nikolay_St> well
17:03:22 <Nikolay_St> it look like we don't have any action items since previous meeting
17:04:27 <Nikolay_St> so, if we really don't have any I think we can move forward
17:04:41 <Nikolay_St> any objections??
17:05:19 <kzaitsev_mb> \o/
17:05:24 <Nikolay_St> kzaitsev_mb: hey!
17:05:45 <kzaitsev_mb> a bit late for rollcall, aint I? =)
17:06:45 <ativelkov> hi folks
17:06:49 <ativelkov> sorry for being late
17:07:03 <Nikolay_St> #topic Artifact (glance v3) transition status update (ativelkov)
17:07:09 <Nikolay_St> ativelkov: please
17:07:13 <ativelkov> OK
17:07:27 <ativelkov> So, the inetegration itself is 99% complete
17:07:48 <ativelkov> Right now I am verifying the remaining 1% )
17:08:06 <Nikolay_St> ativelkov: ok
17:08:21 <Nikolay_St> so nothing to worry about?
17:08:25 <ativelkov> There are a number of bugs in Glance which are fixed but await the patches to land
17:09:01 <ativelkov> And two patches in Glance Client in the same state (on review) which we will copy from glanceclient to muranoclient
17:09:21 <ativelkov> The list of this patches is here:
17:09:23 <ativelkov> #link http://etherpad.openstack.org/p/fastTrackPatches
17:09:44 <ativelkov> I expect submitting the patches to murano today or tomorrow
17:10:36 <Nikolay_St> ok, good to know. guys, please keep an eye at review and review patches when they will appear
17:11:10 <Nikolay_St> ativelkov: anything else?
17:11:13 <kzaitsev_mb> Are we going to have artifacts ON or OFF by default?
17:11:23 <kzaitsev_mb> in stable/liberty I mean
17:11:32 <ativelkov> kzaitsev_mb: I'd prefer them to be off
17:11:39 <ativelkov> as this is experimental feature
17:11:57 <ativelkov> In glance we have v3 api disabled by default in L
17:12:02 <kzaitsev_mb> agree on that one
17:12:16 <Nikolay_St> +1
17:12:32 <ativelkov> stan_lagun: any comments on this?
17:13:24 <stan_lagun> comments on Glance?
17:13:34 <Nikolay_St> stan_lagun: about artifacts usage
17:13:43 <ativelkov> on glance being off by default. Will that be an issue for versioning?
17:14:00 <stan_lagun> I'd prefer that client will discover GLARE availability by default
17:14:05 <stan_lagun> so on/off/auto
17:14:10 <stan_lagun> and auto=default
17:14:29 <ativelkov> That may be tricky
17:14:56 <stan_lagun> you can call some v3 API and fallback on error code
17:15:13 <ativelkov> As this requires to 1) discover glance in service catalog, 2) call / on glance and check which versions of Glance API are available
17:15:20 <stan_lagun> or analyze keystone endpoints
17:15:32 <ativelkov> Such logic usually should not be part of client
17:15:52 <stan_lagun> why not?
17:17:09 <stan_lagun> you may do it on engine side if you'd like and if client can be configured to use GLARE by the caller
17:17:21 <ativelkov> yes
17:17:30 <ativelkov> I'll try doing that if I have time
17:19:13 <Nikolay_St> so, we agree to enable 'version discovery mechanism' for artifacts usage?
17:19:32 <ativelkov> Well, I cannot commit on doing this in L
17:19:38 <ativelkov> I'll try if we can
17:19:56 <ativelkov> But the time is really tight and I'd prefer not to add any new features
17:20:02 <Nikolay_St> ok
17:20:18 <ativelkov> FF is just several days ahead
17:20:30 <stan_lagun> So its either auto or off by default
17:20:41 <ativelkov> yup
17:21:40 <Nikolay_St> #agreed artifacts usage auto/off by default.
17:22:15 <Nikolay_St> #topic Feature Freeze is September 3
17:22:32 <Nikolay_St> kzaitsev_mb: I know that you added this topic
17:22:44 <kzaitsev_mb> yep
17:22:54 <kzaitsev_mb> well Just wanted everyone to know =)
17:22:59 <Nikolay_St> :D
17:23:01 <Nikolay_St> ok
17:23:02 <kzaitsev_mb> apparently not many people came =)
17:23:13 <kzaitsev_mb> #info Feature Freeze is September 3
17:23:15 <kzaitsev_mb> haha
17:23:23 <ativelkov> kzaitsev_mb: what's the scope of FF
17:23:24 <ativelkov> ?
17:23:39 <ativelkov> in my understanding it is only murano / murano-dashboard repos
17:23:48 <Nikolay_St> well, as a quick reminder we have stan_lagun patches about versioning on review
17:24:08 <ativelkov> while murano-apps and python-muranoclient are on different release schedule, is that correct?
17:24:27 <kzaitsev_mb> huh, want about client? )
17:24:29 <Nikolay_St> here is the chain starts #link https://review.openstack.org/#/c/214163/
17:25:01 <Nikolay_St> also, we have my 2 patches with CF service broker.
17:25:04 <kzaitsev_mb> wall I'd think, that apps have completely different schedule. they do not even have stable branches unless we would decide to make one
17:25:15 <kzaitsev_mb> which is... a nice idea in my understanding
17:25:27 <Nikolay_St> the chain starts #link https://review.openstack.org/#/c/196820/
17:25:45 <kzaitsev_mb> new apps are guaranteed to work on master and having a stable/liberty for apps seems good enough
17:25:57 <Nikolay_St> kzaitsev_mb: it's a good idea
17:26:13 <Nikolay_St> kzaitsev_mb: we can discuss it in ML I guess
17:26:40 <kzaitsev_mb> yep. We need Serg to answer those questions (I mean app and client FF scope)
17:26:44 <kzaitsev_mb> anyway
17:27:05 <Nikolay_St> kzaitsev_mb: yeap
17:27:23 <Nikolay_St> do we have any other features on review?
17:27:46 <stan_lagun> Apps should not be tied to Murano releases by any means other than those introduced by versioning
17:29:15 <stan_lagun> You don't need to guarantee that apps works on Liberty or any other release. As long as you have fixed your requirements to released versions of MuranoPL and core library etc they must work forever
17:30:00 <stan_lagun> And as soon as core library become a plugin we may release it in the middle of the cycle
17:31:01 <kzaitsev_mb> stan_lagun: so I have stable/kilo murano and want to use some apps. But all the apps on murano-apps use new UI FormatVersion
17:31:16 <Nikolay_St> guys
17:31:18 <kzaitsev_mb> so I get 500 when I try to add them to env
17:31:26 <Nikolay_St> I guess that it's not this topic
17:31:39 <kzaitsev_mb> Nikolay_St: I think you can safely change it to OpenDiscussion ;)
17:31:47 <Nikolay_St> so, if we don't have any other to talk about ff we should move forward
17:31:51 <Nikolay_St> kzaitsev_mb: yeah
17:32:00 <Nikolay_St> #topic OpenDiscussion
17:32:14 <stan_lagun> kzaitsev_mb: you are wrong
17:32:34 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda/Archive/2015-09-01/ todays agenda
17:32:45 <stan_lagun> as part of versioning there will be not just latest version of the app but all versions simultaneously
17:32:58 <kzaitsev_mb> huh
17:33:09 <stan_lagun> so if you are using older version of something just grab older version of the app
17:33:10 <kzaitsev_mb> well if that is solved — then yep, I'm ok
17:33:18 <kzaitsev_mb> stan_lagun: where from
17:33:36 <stan_lagun> murano-apps
17:33:45 <kzaitsev_mb> stan_lagun: would we publish new versions of apps as different folders?
17:33:49 <stan_lagun> yes
17:33:58 <kzaitsev_mb> ok, sonds fine to me
17:34:10 <stan_lagun> otherwise you need to have a separate repo for each app
17:34:46 <kzaitsev_mb> if that's though of as part of versioning initiative — great. =)
17:35:42 <kzaitsev_mb> so just for the record
17:36:05 <kzaitsev_mb> We have our gates blocked by django 1.8 =(
17:36:18 <kzaitsev_mb> I hoped we had that under controll, but we hadn't
17:36:39 <Nikolay_St> kzaitsev_mb: any suggestion about how we can fix it?
17:36:43 <kzaitsev_mb> so dashboard job is blocked untill https://review.openstack.org/#/c/219222/ lands
17:37:23 <kzaitsev_mb> #link s joined #openstack-meeting-alt
17:37:30 <kzaitsev_mb> #link https://review.openstack.org/#/c/219222/
17:37:45 <katyafervent2> but not for murano repo
17:38:13 <kzaitsev_mb> Nikolay_St: we have to add formtools to requirements. If the guys in infra would not agree on that we would have to grab the code I guess
17:38:18 <kzaitsev_mb> but I do not like that idea
17:38:25 <katyafervent2> jenkins is passed!
17:38:40 <kzaitsev_mb> katyafervent2: yep after a couple of rechecks it's finally green =)
17:38:57 <freerunner> kzaitsev_mb: I think, in this patch not needed to update upper-constraints.
17:39:05 <kzaitsev_mb> can you maybe ping some infra guys — you mentioned you know who to ask )
17:39:10 <kzaitsev_mb> freerunner: you're wrong
17:39:19 <kzaitsev_mb> if you would not update the job would fail
17:39:24 <freerunner> kzaitsev_mb: It will be updated automatically by bot.
17:39:32 <kzaitsev_mb> they have a job, that checks upper constraints on commit
17:39:39 <katyafervent2> thats not infra team
17:39:40 <kzaitsev_mb> freerunner: yeah, but not for new libraries
17:40:01 <kzaitsev_mb> freerunner: remember the time we added yaql
17:40:07 <katyafervent2> we need to go to openstack dev
17:40:41 <freerunner> kzaitsev_mb: I remember this time ;)
17:41:56 <freerunner> kzaitsev_mb: katyafervent2: I've added requirements cores to this patch. Let's wait.
17:42:49 <kzaitsev_mb> also just for the note — we have a commit on review, (that's blocked by this obviously =)), that adds preliminary angular support for murano-dashboard
17:43:17 <kzaitsev_mb> #link https://review.openstack.org/#/c/218515/
17:44:01 <kzaitsev_mb> It adds REST api to dashboard, that we later should be able to expand, when angularising the dashboard
17:47:10 <katyafervent2> Here is the link https://review.openstack.org/#/c/219222/
17:47:36 <katyafervent2> Please, take a look. You can help us unblock our gate before feature freeze!
17:47:51 <katyafervent2> wrong channel)
17:48:00 <Nikolay_St> katyafervent2: ok)
17:50:11 <katyafervent2> Do we have topic to discuss?
17:51:24 <Nikolay_St> katyafervent2: I don't think so
17:51:32 <Nikolay_St> any questions guys?
17:51:44 <xiangxinyong> Can i add some app into murano-app after sep.3?
17:52:20 <Nikolay_St> xiangxinyong: as far as we don't have FF for it - yes
17:52:24 <Nikolay_St> kzaitsev_mb: ^^
17:52:39 <xiangxinyong> OK
17:52:51 <katyafervent2> Yes, murano-apps and pythonclient are not followed main scheduler and have separate releases
17:53:17 <xiangxinyong> understood
17:53:18 <katyafervent2> Ok, see you later, guys!
17:54:10 <Nikolay_St> well
17:54:18 <Nikolay_St> any other questions?
17:57:07 <Nikolay_St> I guess no questions to discuss
17:57:13 <Nikolay_St> so, see you all guys!
17:57:19 <Nikolay_St> #endmeeting