17:00:20 <sergmelikyan> #startmeeting murano
17:00:22 <openstack> Meeting started Tue Nov 24 17:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <openstack> The meeting name has been set to 'murano'
17:00:37 <sergmelikyan> Hi team!
17:00:39 <freerunner> heeey ;)
17:00:59 <Nikolay_St> hi
17:01:20 <slagun> hi
17:01:28 <kzaitsev_ip_> hi, will get to my laptop in a few moments
17:01:41 <kzaitsev_ip_> I mean 0/
17:03:05 <Nikolay_St> kzaitsev_ip_: :D
17:06:43 <sergmelikyan> #topic Action Items
17:06:55 <sergmelikyan> ask kzaitsev_ws about "BP for maintaining visiblity of dependencies"
17:06:58 <sergmelikyan> #1
17:07:04 <sergmelikyan> kzaitsev_ip_: ? )
17:08:04 <kzaitsev_mb> ola, I'm back with my usual name )
17:08:51 <sergmelikyan> you have so many of them :)
17:09:12 <kzaitsev_mb> yep, sorry ) I still get notified for every mention
17:09:15 <kzaitsev_mb> so the BP
17:09:53 <kzaitsev_mb> we have 2: #link https://blueprints.launchpad.net/murano/+spec/better-control-over-image-downloads
17:10:06 <kzaitsev_mb> and #link https://blueprints.launchpad.net/murano/+spec/better-package-dependency-ui
17:11:25 <sergmelikyan> I think first one is superseded by second one
17:11:37 <kzaitsev_mb> they do not directly address the issue, but cover it as part of the themselves. I believe, that as soon as we implement those — image visibility controll would come naturlly
17:11:46 <kzaitsev_mb> well, probably you're right
17:12:47 <kzaitsev_mb> shall you mark it as superceded, then?
17:14:17 <sergmelikyan> I am interested in what other folks think :)
17:14:21 <sergmelikyan> regarding this
17:16:11 <kzaitsev_mb> https://hools.files.wordpress.com/2007/06/pooh_think.gif
17:16:25 <kzaitsev_mb> =)
17:19:41 <sergmelikyan> slagun: ^
17:19:42 <sergmelikyan> :)
17:20:03 <kzaitsev_mb> shall we put an AI for everyone to think on that? =)
17:20:05 <sergmelikyan> sometimes I think that only kzaitsev_mb and me are actually attending this meeting
17:20:14 <sergmelikyan> we did that last week actually
17:20:17 <ddovbii> I'm ok with idea to leave both of them
17:20:52 <slagun> I'd prefer to have 1 BP. But 2 is also okay
17:21:57 <kzaitsev_mb> well, sergmelikyan you and I — we just type real fast =))
17:22:22 <sergmelikyan> kzaitsev_mb: let's merge them with one BP covering all aspects regarding handling dependencies during import?
17:22:49 <katyafervent2> both, we can combine later if needed
17:24:35 <sergmelikyan> kzaitsev_mb: ?
17:25:10 <kzaitsev_mb> sergmelikyan: yeah, sure.
17:25:24 <freerunner> I think that we shouldn't merge these bps to one. At least, because client can work without dashboard, and dashboard without client can't. But, this is IMHO.
17:25:41 <kzaitsev_mb> #action merge dependency blueprints (kzaitsev)
17:26:01 <kzaitsev_mb> freerunner: both of them actually affect both dashboard and client
17:27:06 <slagun> it is easier to track and understand when there is a single BP. There may be many commits with partial BP implementation though
17:27:09 <kzaitsev_mb> freerunner: so it makes perfect sence to just rethink them as one, since they both solve the same problem more or less.
17:27:24 <kzaitsev_mb> yep, agree on that.
17:27:37 <kzaitsev_mb> shall we move to our agenda? =)
17:28:07 <sergmelikyan> yep
17:28:32 <sergmelikyan> #startvote Do we enable building docs for rtd on Murano CI? Yes, No
17:28:33 <openstack> Begin voting on: Do we enable building docs for rtd on Murano CI? Valid vote options are Yes, No.
17:28:35 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:28:37 <sergmelikyan> #vote Yes
17:29:37 <kzaitsev_mb> I'm all in, if that is possible, although I believe, that we should use d.o.o for an official link to documentation
17:29:45 <kzaitsev_mb> #vote Yes
17:30:06 <kzaitsev_mb> that being said — googling murano docs still brings up rtfd
17:30:08 <katyafervent2> #vote yes
17:30:50 <slagun> #vote yes
17:30:51 <ddovbii> #vote Yes
17:31:40 <freerunner> I think, sergmelikyan missing 'need to' verb in voting ;)
17:31:54 <kzaitsev_mb> this vote is from last meeting, right?
17:31:58 <katyafervent2> kzaitsev_mb, thats the main reason of support rtd
17:32:03 <Nikolay_St> #vote yes
17:32:09 <Nikolay_St> kzaitsev_mb: right
17:32:15 <freerunner> But, I'm agree. We need to create this job.
17:32:20 <freerunner> #vote yes
17:32:42 <sergmelikyan> kzaitsev_mb: last week we aded action item to have vote on this one
17:33:03 <sergmelikyan> #endvote
17:33:04 <openstack> Voted on "Do we enable building docs for rtd on Murano CI?" Results are
17:33:05 <openstack> Yes (7): ddovbii, Nikolay_St, slagun, freerunner, katyafervent2, sergmelikyan, kzaitsev_mb
17:33:14 <kzaitsev_mb> ok, cool =) seems, like everyone was in on that )
17:33:21 <sergmelikyan> freerunner: will you proceed with this?
17:34:22 <freerunner> sergmelikyan: Sure. Also, I will ask aderyugin for help with it.
17:34:28 <sergmelikyan> #action freerunner add job to Murano CI for building docs for ReadTheDocs
17:36:54 <sergmelikyan> #topic Change application_catalog to application-catalog
17:37:50 <kzaitsev_mb> I'm not entirelly sure of implications this might have.
17:37:58 <freerunner> Huh. I'm ok with this change, but we need to fix all mentions of application_catalog for all projects, which using this type.
17:38:14 <kzaitsev_mb> why do we have to change it, does anyone understand? the bug is not very helpfull
17:38:29 <sergmelikyan> I guess we need to just make sure that there are no other mentions in other projects or if there are - fix them
17:39:05 <sergmelikyan> there are more details here https://bugs.launchpad.net/sahara/+bug/1356053
17:39:05 <openstack> Launchpad bug 1356053 in devstack "Doesn't properly get keystone endpoint when Keystone is configured to use templated catalog" [Undecided,In progress] - Assigned to Sergey Reshetnyak (sreshetniak)
17:39:28 <kzaitsev_mb> what is the correct one and why is it correct?
17:39:55 <kzaitsev_mb> sergmelikyan: like I said — the bug doesn't state why it is wrong
17:40:07 <sergmelikyan> it's not wrong
17:40:11 <slagun> I'd vote to investigate if its possible to fix the route cause why dashes are not accepted
17:40:41 <slagun> *root cause*
17:41:00 <sergmelikyan> "Keystone seems to be converting underscores to dashes here: https://github.com/openstack/keystone/blob/master/keystone/catalog/backends/templated.py#L47"
17:41:10 <sergmelikyan> I like application-catalog more to be honest :)
17:41:31 <slagun> +1
17:41:53 <katyafervent2> i agree on changes
17:41:56 <kzaitsev_mb> I wonder if this would break existing setups during upgrade?
17:41:59 <sergmelikyan> So I would change that, and if there issues with application_catalog one - perfect chance to fix that
17:42:24 <kzaitsev_mb> And I wonder where is the man, that added this to agenda...
17:42:25 <sergmelikyan> kzaitsev_mb: it depends on how upgrade is done
17:42:42 <kzaitsev_mb> sergmelikyan: so there might be problems, right?
17:42:42 <sergmelikyan> I guess we can talk with folks who did this change for Sahara
17:42:53 <kzaitsev_mb> this means, that we should at least not it in the docs
17:42:58 <sergmelikyan> sure
17:42:59 <kzaitsev_mb> or in release notes ))
17:43:03 <sergmelikyan> sure
17:43:18 <freerunner> So, in this case, I prefer to set -2 for this patch https://review.openstack.org/#/c/243421/3 , before all jobs wasn't fixed. Just noticing, that we have congress integration and rally scripts. Also, we need to fix 'service_broker' naming.
17:43:40 <katyafervent2> all jobs pass except rally
17:44:21 <freerunner> katyafervent2: Congress job doesn't green here.
17:46:00 <sergmelikyan> I guess we can just wait until everything will be green, it's not right to set -2 without clearly stating what is missing in the patch
17:46:24 <sergmelikyan> by the way do we need to update devstack libs?
17:46:32 <kzaitsev_mb> sergmelikyan: I believe docs about upgrade are missing
17:46:56 <kzaitsev_mb> and I would most certainly request a release note on that.
17:46:59 <sergmelikyan> kzaitsev_mb: can you take AI to help LI with taking care about every aspect of this change?
17:47:14 <sergmelikyan> I would really happy if we would carry out that change
17:47:19 <sergmelikyan> *would be
17:47:56 <kzaitsev_mb> k, no problem
17:48:17 <freerunner> sergmelikyan: Libs should be removed soon, after Murano CI updating.
17:48:32 <kzaitsev_mb> #action take good care of bug 1514692
17:48:32 <openstack> bug 1514692 in python-muranoclient "Murano does not get keystone endpoint when Keystone is configured to use templated catalog" [High,In progress] https://launchpad.net/bugs/1514692 - Assigned to Ekaterina Chernova (efedorova)
17:48:46 <sergmelikyan> #action kzaitsev_mb help Li Yingjun with bug #1514692
17:48:56 <sergmelikyan> :)
17:49:37 <sergmelikyan> #topic Using reno for RElease NOtes (kzaitsev)
17:49:43 <kzaitsev_mb> yay, finally =)
17:50:08 <kzaitsev_mb> So I wanted to bring attention to my letter here #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/080364.html
17:50:34 <kzaitsev_mb> I believe it summs up everything pretty nicely.
17:50:55 <kzaitsev_mb> And we even have our first release not merged )
17:51:01 <kzaitsev_mb> #link http://docs.openstack.org/releasenotes/murano/unreleased.html
17:52:06 <kzaitsev_mb> so let's please start using the tool. If you have any problems with it, or anything is not clear — ping me, or better answer the mail, so that everyone would benefit from discussion )
17:55:59 <sergmelikyan> kzaitsev_mb: sure ) I really like this tool, we need to add release-notes tag usage in launchpad
17:56:25 <kzaitsev_mb> sergmelikyan: I believe we do not
17:56:33 <sergmelikyan> why?
17:56:46 <kzaitsev_mb> reno was designed to stop using launchpad for release notes
17:57:02 <kzaitsev_mb> or does the tag do exactly that? =)
17:57:50 <sergmelikyan> I think tag should be set by bug supervisor, and commit addressing bug should contain release notes (created by RENO).
17:58:11 <kzaitsev_mb> oh. got what you mean
17:58:30 <kzaitsev_mb> well, if you look at template — it has ore than just features and fixes
17:59:04 <kzaitsev_mb> even minor changes might benefit from a release note. But having too many might clutter the document
17:59:15 <kzaitsev_mb> So I suggest, that we would use common sense =))
17:59:38 <sergmelikyan> kzaitsev_mb: sure
17:59:54 * sergmelikyan says sure too many times today
18:00:05 <sergmelikyan> Thanks folks!
18:00:06 <sergmelikyan> #endmeeting