17:00:55 <sergmelikyan> #startmeeting murano
17:00:56 <openstack> Meeting started Tue Jan 12 17:00:55 2016 UTC and is due to finish in 60 minutes. The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:59 <openstack> The meeting name has been set to 'murano'
17:01:10 <sergmelikyan> o/
17:01:45 <slagun> o/
17:02:01 <kzaitsev_ip_> o/
17:02:28 <tlashchova_> o/
17:03:32 <sergmelikyan> We have following agenda for today: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:03:34 <kzaitsev_ip_> will get to normal client in 2 minutes
17:03:58 <sergmelikyan> Please add to this agenda anything that you would like to discuss today, we have few minutes while we are on roll call
17:04:42 <ativelkov> o/
17:06:58 <kzaitsev_mb> here I am =)
17:09:11 <sergmelikyan> #topic Action Items Review
17:09:23 <kzaitsev_mb> did we have any? =)
17:09:28 <sergmelikyan> http://eavesdrop.openstack.org/meetings/murano/2015/murano.2015-12-22-17.00.html <- meeting minutes from the last meeting
17:09:53 <sergmelikyan> last meeting was so long time ago...
17:10:05 <kzaitsev_mb> oh right
17:10:07 <sergmelikyan> #1 ativelkov to summarize the plugin usage questions in etherpad
17:10:36 <ativelkov> ouch
17:10:42 <ativelkov> didn't do that, sorry
17:11:12 <sergmelikyan> #action ativelkov to summarize the plugin usage questions in etherpad
17:11:23 <sergmelikyan> ativelkov: holidays :) no worries )
17:11:31 <sergmelikyan> #2 release client, stable/liberty updates
17:11:33 <kzaitsev_mb> ativelkov: which plugin is it btw?
17:11:45 <ativelkov> kzaitsev_mb: that's not about a particular plugin
17:11:55 <kzaitsev_mb> #2 done — 1.0.2 murano and dashboard, 0.7.2 client have been released
17:12:27 <ativelkov> That's a general question where should plugins be in terms of pbr packages - should the plugins which we ship with murano be in the same setup.cfg or should they have their own ones
17:12:50 <kzaitsev_mb> I've also sent corresponding mails before NY to openstack-announce =)
17:14:08 <kzaitsev_mb> ativelkov: oh, now I remember =)
17:16:25 <Nikolay_St> hey
17:16:30 <Nikolay_St> finally I'm here
17:17:05 <katyafervent2> I'm here too :)
17:18:23 <kzaitsev_mb> (=
17:18:39 <Nikolay_St> kzaitsev_mb: =)
17:18:50 <Nikolay_St> traffic jam in the undeground :D
17:18:58 <Nikolay_St> really BIG problem
17:20:33 <sergmelikyan> wow... traffic jam in subway? )
17:20:51 <sergmelikyan> #topic Abandoning milestones?
17:21:03 <katyafervent2> will we have bug triage day for everyone who is interested
17:21:16 <sergmelikyan> katyafervent2: mmm?
17:21:19 <kzaitsev_mb> katyafervent2: ?
17:21:36 <kzaitsev_mb> ok. so both my topics today are going to be short
17:21:41 <sergmelikyan> katyafervent2: I mean was this question? and how it's relates to the topic of dicsussion?
17:21:57 <katyafervent2> before mitaka-2 release
17:22:07 <katyafervent2> horizon has it today :)
17:22:12 <kzaitsev_mb> a while ago I started this discussion
17:22:15 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/083113.html
17:22:22 <kzaitsev_mb> didn't get much response =)
17:22:28 <kzaitsev_mb> Would like to re-start it
17:22:39 <kzaitsev_mb> the letter basicaly summs everything up
17:23:03 <kzaitsev_mb> I've come to think that abandoning milestones is a good idea, and abandoning bps is a bad one
17:23:04 <katyafervent2> sorry, I typed before you changed the topic, let's discuss it later
17:23:27 <kzaitsev_mb> katyafervent2: what makes you think we have such a day? I haven't seen any announcements.
17:24:07 <katyafervent2> kzaitsev_mb, it was a question. sorry
17:24:08 <kzaitsev_mb> I mean. if you want to have one — we should at least write a letter to ML or smth
17:24:14 <kzaitsev_mb> oh I see
17:24:30 <kzaitsev_mb> ok.
17:24:31 <kzaitsev_mb> so
17:24:52 <sergmelikyan> I still don't see a reason have one, and think that they are total waste of time :)
17:25:08 <kzaitsev_mb> pls find some time and think about my proposal regarding milestones and bps =)
17:25:24 <katyafervent2> regarding abandoning milestones
17:25:38 <sergmelikyan> kzaitsev_mb: Yeah... I missed fact that we can have different versions in different projects
17:26:10 <kzaitsev_mb> sergmelikyan: that's basically what we have now with murano-agent
17:26:33 <katyafervent2> I suggest to postpone it a little bit and continue to set milestones for now
17:26:35 <kzaitsev_mb> the new scheme for stable branches allows us to have 1.0.1 murano-agent and 1.0.2 murano-dashboard for example
17:26:43 <kzaitsev_mb> katyafervent2: why?
17:26:52 <kzaitsev_mb> I mean
17:26:56 <slagun> the only good thing about milestones is that by looking at LP ticket for commit you always know in which release the feature was introduced
17:27:26 <slagun> I'd make milestones be just "mitaka" rather than m1 etc
17:27:31 <kzaitsev_mb> if you have any good points — pls respond the letter =)
17:28:07 <kzaitsev_mb> slagun: that's a good point actually. although wouldn't series cover it?
17:28:14 <katyafervent2> until handling with new versions become understandable to everyone. I think it is still a transition period :)
17:28:57 <katyafervent2> and for that period I support Stans suggestion
17:29:06 <slagun> kzaitsev_mb: agree. Either series or milestones. There should be only one :)
17:31:17 <sergmelikyan> kzaitsev_mb: can we move to the next topic?
17:31:45 <kzaitsev_mb> sure =) I just hope, that those of you who have some opinion on the topic would find some time to answer the email )
17:31:51 <sergmelikyan> #topic Do we need any release model changes?
17:33:27 <kzaitsev_mb> ok, so this is also gonna be a short one
17:33:43 <kzaitsev_mb> and it's kind of related to the previous
17:34:06 <kzaitsev_mb> Thierry wrote a letter recently about release model freeze around m-2
17:34:15 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-dev/2016-January/083726.html
17:34:18 <kzaitsev_mb> so
17:34:43 <kzaitsev_mb> if we would like to change a release-model of any of our project we should act in the following two weeks
17:35:34 <kzaitsev_mb> we currently have
17:35:36 <slagun> kzaitsev_mb: let's vote on next community meeting
17:35:57 <sergmelikyan> kzaitsev_ip_: do you think that we need change?
17:36:04 <katyafervent2> I think this change is required for all official projects right ?
17:36:15 <kzaitsev_mb> #link https://github.com/openstack/governance/blob/561c848b481ad6008b0d484d5f609930f2e11a7d/reference/projects.yaml#L1979-L2023
17:37:19 <kzaitsev_mb> we might want to switch our cycle-with-milestones to cycle-with-intermediary
17:37:31 <sergmelikyan> katyafervent2: I guess no, we don't have to change anything
17:37:45 <kzaitsev_mb> and we might want to move murano-apps to release:independent
17:37:46 <sergmelikyan> kzaitsev_ip_: what is the benefit of doing that in our case?
17:37:56 <sergmelikyan> >and we might want to move murano-apps to release:independent
17:38:24 <sergmelikyan> I think we should continue releasing murano-apps tied to murano releases
17:38:55 <kzaitsev_mb> I actually think murano-apps might even be release:none, but have
17:39:05 <kzaitsev_mb> release:has-stable-branches
17:39:32 <Nikolay_St> agree with kzaitsev_mb here
17:39:35 <kzaitsev_mb> this would be more appropriate representation of how we handle murano-apps
17:40:04 <kzaitsev_mb> that would mean we don't actually deliver a tarball or smth, but still have stable-branches, that are supported for respective murano releases
17:40:08 <sergmelikyan> kzaitsev_ip_: disagree
17:40:18 <slagun> +1
17:41:32 <sergmelikyan> kzaitsev_ip_: release:cycle-with-milestones does not relate to delivery method
17:41:45 <sergmelikyan> and we usually build zip archive with all apps
17:42:15 <kzaitsev_mb> #link http://governance.openstack.org/reference/tags/release_cycle-with-milestones.html
17:42:21 <kzaitsev_mb> well who needs that zip?
17:42:30 <kzaitsev_mb> I mean does anyone ever use it?
17:42:33 <sergmelikyan> whole murano-apps is a single entity, which contains several applications versioned toghether... we discussed this previously, but I guess we need to summarize that in e-mail and continue to discuss if needed
17:42:54 <sergmelikyan> kzaitsev_ip_: guess, how many people downloaded tarballs with murano?
17:43:01 <sergmelikyan> 1-2 in months?
17:43:16 <sergmelikyan> question is not what you attach to the launchpad page
17:43:28 <katyafervent2> I agree with Kirill, I haven't ever use Mirantis-apps tarball
17:44:09 <sergmelikyan> release:cycle-with-milestones does not say anything regarding how you deliver staff
17:44:15 <sergmelikyan> it says how do you release that
17:44:36 <kzaitsev_mb> sergmelikyan: "The “release:cycle-with-milestones” tag describes which projects follow the first option: a single release at the end of the cycle"
17:44:43 <sergmelikyan> and I think that we should continue releasing murano-apps in a same way as before - alongside with Murano
17:45:00 <sergmelikyan> kzaitsev_ip_: yep, and?
17:45:57 <slagun> sergmelikyan: thats what stable branches mean. Each stable branch corresponds to murano release. But there is no need for either milestones or tarballs for murano-apps
17:46:32 <kzaitsev_mb> ok, maybe we're not really understanding each other or not understanding the release model
17:47:07 <kzaitsev_mb> sergmelikyan: do you want me to ping release team (thierry and dhellman) to clarify on the topic?
17:47:35 <sergmelikyan> slagun: in murano-apps we often use features from Murano right away when they are developed
17:48:12 <slagun> sergmelikyan: so what?
17:48:16 <sergmelikyan> kzaitsev_ip_: I guess we should start from understanding on our side regarding what is actually you want to archive and then see which reelase model suits better
17:48:23 <kzaitsev_mb> sergmelikyan: from what I understand murano-apps do not have a "release"
17:48:50 <sergmelikyan> kzaitsev_ip_: can you share what do you consider a release?
17:49:04 <sergmelikyan> in my opinion tag in GIT is a release
17:49:25 <slagun> stable branches must work on corresponding version of murano. master must work on current muster
17:49:27 <sergmelikyan> so when we cut milestone in murano-apps we are making release
17:49:54 <slagun> we make release by creating stable branches
17:50:08 <sergmelikyan> slagun: not exactly milestone is also release
17:50:15 <sergmelikyan> just beta release
17:50:57 <slagun> I'd preffer each commit to be a beta release. That is continuous delivery
17:51:05 <sergmelikyan> let me take action item to describe my vision regarding versioning of murano-apps, and when we will agree on that - let's talk about changing release model
17:51:26 <Nikolay_St> sergmelikyan: will you write a letter in ML?
17:51:33 <sergmelikyan> Nikolay_St: yes
17:51:36 <kzaitsev_mb> ok, agree on that
17:52:15 <kzaitsev_mb> I'll still reach out to the release-team to see if my idea (has-stable, release:none) even makes sense from their perspective =)
17:52:19 <sergmelikyan> #topic sergmelikyan describe versioning model for murano-apps
17:52:35 <kzaitsev_mb> should be action ;)
17:52:43 <sergmelikyan> kzaitsev_ip_: I would prefer to describe how do we want to version murano-apps first
17:52:50 <sergmelikyan> it's not described anyware
17:53:05 <sergmelikyan> #action sergmelikyan describe versioning model for murano-apps
17:53:05 <kzaitsev_mb> describe versioning model for murano-apps
17:53:13 <sergmelikyan> #topic Open Discussion
17:53:16 <kzaitsev_mb> ok, sure )
17:54:41 <kzaitsev_mb> so a couple of news — dashboard translation commit is stuck until infra guys decide on the new spec for dashboard-like repos
17:55:18 <kzaitsev_mb> 2) rohini has submitted an initial patch with support for osc =) which is awesome, pls give it some time and play with it
17:55:41 <kzaitsev_mb> #link https://review.openstack.org/#/c/266018/
17:55:57 <kzaitsev_mb> I mean the fact that there is such a commit is awesome =)
17:56:15 <kzaitsev_mb> gotta check the awesomness of the commit before saying that it is )
17:57:14 <enthurohini> i will itegrate the commands soon.
17:58:16 <kzaitsev_mb> enthurohini: oh =) cool, didn't notice that you joined )
17:58:28 <enthurohini> kzaitsev_mb, i have implemented single command, should i commit for review or wait untill i complete a group of command?
17:59:02 <kzaitsev_mb> I'd suggest you would add another commit atop the 1st one, that adds a group of commands )
17:59:09 <enthurohini> kzaitsev_mb, i joined but was late. :P
17:59:49 <enthurohini> ok
18:00:04 <Nikolay_St> kzaitsev_mb: enthurohini can you share a link to the review?
18:00:22 <kzaitsev_mb> Nikolay_St: I just did ^^
18:00:31 <Nikolay_St> kzaitsev_mb: my bad
18:00:34 <Nikolay_St> TIME
18:00:43 <kzaitsev_mb> it'll be in meeting notes )
18:00:50 <sergmelikyan> #endmeeting