17:00:01 <Nikolay_St> #startmeeting murano
17:00:01 <openstack> Meeting started Tue Jan 19 17:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is Nikolay_St. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:04 <openstack> The meeting name has been set to 'murano'
17:00:11 <Nikolay_St> hi all
17:00:25 <StanLagun> o/
17:00:27 <enthurohini> hello
17:00:35 <madhuri_> o/
17:00:38 <freerunner> o/
17:00:59 <Nikolay_St> Serg asked me to hold todays meeting
17:01:02 <Nikolay_St> so
17:01:20 <kzaitsev_mb> o/
17:01:41 <Nikolay_St> here is an agenda for today: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:02:03 <ativelkov> o/
17:02:34 <Jeffrey4l> \o/
17:03:01 <Nikolay_St> #topic Action Items Review
17:03:04 <zhurong> o/
17:03:18 <Nikolay_St> so, we have 2 action items from previous meeting
17:03:31 <Nikolay_St> #1. ativelkov   * ativelkov to summarize the plugin usage questions in etherpad
17:03:47 <Nikolay_St> ativelkov: please proceed :)
17:06:30 <ativelkov> sorry, this one is still in progress
17:06:31 <Nikolay_St> ativelkov: are you here?
17:06:37 <Nikolay_St> ativelkov: ok
17:06:58 <Nikolay_St> #action ativelkov to summarize the plugin usage questions in etherpad
17:07:15 <Nikolay_St> the second one is: sergmelikyan describe versioning model for murano-apps
17:07:37 <Nikolay_St> Serg is away. may be somebody else know something? StanLagun kzaitsev_mb ?
17:07:46 <kzaitsev_mb> nope =)
17:08:02 <kzaitsev_mb> this camo out of our discussion about release tags
17:08:20 <kzaitsev_mb> this week is the last to change release tags for OS projects in M
17:08:33 <Nikolay_St> kzaitsev_mb: ok, get it
17:08:37 <kzaitsev_mb> so we're probably will only be able to do it during N
17:08:44 <kzaitsev_mb> so there is no hurry anyway =))
17:08:54 <Nikolay_St> ok
17:09:54 <Nikolay_St> well, I think to store this action somewhere, so I'll file it again until we decide something.
17:10:48 <Nikolay_St> may be we should start discussion in ML? I think it's a good point otherwise we can forget about it
17:13:10 <kzaitsev_mb> I don't know tbh =)
17:13:55 <zhurong> I am sorry, this is the first time i join the meeting, So i don't quite understand about versioning model for murano-apps, can someone give me some help?
17:14:10 <kzaitsev_mb> we've discussed that a couple of times, but still I have problems comprehending how do we want to see our apps being developed and released )
17:14:23 <kzaitsev_mb> zhurong: that's the point )
17:14:45 <kzaitsev_mb> Nikolay_St: let's just add the AI for serg once again shall we? =)
17:14:58 <Nikolay_St> kzaitsev_mb: ok, let's do it
17:15:51 <Nikolay_St> #action sergmelikyan describe versioning model for murano-apps (from 12.01.16)
17:16:00 <Nikolay_St> that's all for action items
17:16:03 <StanLagun> this is better be called release model because we do have versionning for murano apps and it is something very different
17:16:55 <Nikolay_St> StanLagun: good point
17:17:08 <Nikolay_St> how can I cancel the action?
17:17:32 <zhurong> add a new action?
17:18:18 <kzaitsev_mb> #action sergmelikyan describe versioning model for murano-apps
17:18:19 <kzaitsev_mb> done
17:18:21 <kzaitsev_mb> =)
17:18:58 <kzaitsev_mb> Nikolay_St: this tutorial http://wiki.debian.org/MeetBot has some usefull commands ;)
17:19:07 <Nikolay_St> kzaitsev_mb: yeah
17:19:17 <Nikolay_St> probably you can't decline action
17:19:27 <Nikolay_St> let's move forward
17:19:34 <freerunner> kzaitsev_mb: Looks like Serg is not here now. We should notify him about action items, I think ;)
17:19:53 <kzaitsev_mb> I think we had an item on our agenda added by madhuri_
17:20:07 <Nikolay_St> #topic Blueprint
17:20:08 <kzaitsev_mb> freerunner: that's an item from prev meeting. but yep good point
17:20:18 <Nikolay_St> #topic Magnum/Murano Rationalization(madhuri)
17:20:18 <madhuri_> Hi all
17:20:28 <kzaitsev_mb> madhuri_: can you comment? =)
17:20:35 <madhuri_> Yes sure
17:20:51 <madhuri_> This bp is to do magnum/murano rationalization
17:21:05 <madhuri_> Magnum and Murano both deploys kubernetes cluster
17:21:20 <Nikolay_St> #link https://blueprints.launchpad.net/murano/+spec/magnum-murano-rationalization
17:21:24 <madhuri_> So Intel, Rackspace and Mirantis had meeting about it in Tokyo
17:21:34 <madhuri_> And there we came up with this idea
17:21:51 <madhuri_> So I am working on it to write Magnum plugin for Murano
17:22:27 <madhuri_> I have also submitted a patch for it
17:22:31 <kzaitsev_mb> not really sure what you mean by rationalization =)
17:22:53 <madhuri_> Ok let me try to explain
17:23:19 <madhuri_> Both projects have some advantages over other
17:24:08 <madhuri_> So here we are trying to get advantages of both with removing this duplicate implementation
17:24:27 <kzaitsev_mb> i'm not sure if that's a good name for bp, but well
17:24:29 <kzaitsev_mb> ok =)
17:24:54 <StanLagun> madhuri_: Murano doesn't install or use k8s. It is just one of the apps that we have. We may have one more implementation of the same interface (actually we have 2 already) and one more app that installs k8s. We don't need to decide which one is better and leave only one
17:24:56 <madhuri_> Yeah we can decide on it
17:25:26 <kzaitsev_mb> So as far as I understand you want to use magnum from murano, by utilising murano plugins mechanism, right?
17:25:41 <madhuri_> Yes right kzaitsev_mb
17:26:57 <madhuri_> There has been lots of talks about this in previous summit
17:27:07 <kzaitsev_mb> and that would enable users to write apps, that rely on their existing magnum installations and take advantage of the catalog of apps and ease of deployment, murano offers, right?
17:27:46 <madhuri_> Exactly kzaitsev_mb
17:28:01 <madhuri_> A white paper has already been released for it
17:28:08 <madhuri_> #link https://www.mirantis.com/blog/magnum-vs-murano-openstack-container-strategy/
17:28:33 <kzaitsev_mb> madhuri_: you're not explaining why would you do any of that in the bp
17:28:44 <kzaitsev_mb> so it would be great to add some rationale =)
17:29:00 <madhuri_> kzaitsev_mb: I will add this points in detail in bp
17:29:01 <kzaitsev_mb> cause it's not really clear at the 1st glance, I think =)
17:29:05 <madhuri_> Thanks for the input
17:30:15 <madhuri_> Please let me know if anyone have any question or concern with it
17:30:17 <StanLagun> So where is the rationalization?
17:30:47 <kzaitsev_mb> We've hadn't had any contributions to contrib and/or plugins before, so you're the first one here =)
17:31:08 <madhuri_> Murano will be using Magnum to deploy kubernetes cluster and then usin Murano dashboard users can easily deploy pods, rcs on it
17:31:16 <StanLagun> kzaitsev_mb: I forgot about Cloudify plugin
17:31:22 <kzaitsev_mb> since we do not have any policies on what plugins get in and what not — I guess this is going to be a case-by-case thing )
17:31:24 <madhuri_> Does that make sense StanLagun?
17:31:51 <kzaitsev_mb> I had a chat with Serg earlier today and he was overall supportive of the idea =)
17:31:57 <madhuri_> Magnum offers TLS, loadbalancer feature and Murano offers strong UI to users
17:32:41 <StanLagun> madhuri_: again, Murano doesn't use Mangnum or anything else. It is your app that does. You are writing another implementation of KubernetesCluster etc which is good and I very appreciate it. However it is just one more app, not Murano improvement or something
17:33:45 <madhuri_> Ok one more point using Magnum will help Murano support Swarm and Mesos
17:34:21 <madhuri_> As Magnum supports this COEs(Container Orchestration Engine)
17:34:57 <madhuri_> It depends on user which way they want their COEs to be deployed
17:35:41 <StanLagun> Thats good. My point is since it is one more app and it's not going to replace any of existing app or change anything in Murano there is nothing to decide for us here. One more application is always good. One more plugin is even better
17:35:58 <madhuri_> Yes :)
17:37:03 <Nikolay_St> so, I guess that's all for this topic?
17:37:08 <madhuri_> Ok so I would need your help to get this through
17:37:10 <madhuri_> Yes
17:37:17 <madhuri_> And kzaitsev_mb is already doing it.
17:37:25 <madhuri_> Thanks kzaitsev_mb :)
17:37:27 <Nikolay_St> madhuri_: you're always welcome at #murano :)
17:37:37 <Nikolay_St> #topic Open Discussion
17:37:43 <madhuri_> Thank you everyone!
17:37:46 <kzaitsev_mb> madhuri_: feel free to come to #murano and ping us on any problems you encounter =)
17:38:05 <madhuri_> kzaitsev_mb: I always do that :)
17:39:32 <Nikolay_St> guys, any question for Open Discussion?
17:39:55 <StanLagun> madhuri_: my only wish is that your app could be used as an implementation of DockerContainerHost. Thus anyone could use it as a drop-in replacement for current KubernetesPod
17:40:31 <madhuri_> StanLagun: Ok I don't have idea about it now but I will do that
17:42:24 <kzaitsev_mb> StanLagun: madhuri_ that's actually a terrific idea.
17:42:28 <kzaitsev_mb> Nikolay_St: not me =)
17:42:50 <madhuri_> kzaitsev_mb: Thanks
17:44:13 <zhurong> Do any guys submit a topic for Austin Topics about murano?
17:44:44 <Nikolay_St> zhurong: I start the process today
17:45:34 <zhurong> Nikolay_St Come on
17:50:33 <Nikolay_St> zhurong: I'll notify you if the talk will be elected :D
17:50:39 <Nikolay_St> team, anything else?
17:53:31 <zhurong> And should we rotation meeting time? Consider Chinese developers...
17:54:49 <Nikolay_St> zhurong: we can move it even-odd schedule
17:55:14 <Nikolay_St> zhurong: you can start discussion in ML if you want
17:55:48 <Nikolay_St> I can't say that murano weekly meeting is this popular in China, but let's try :)
17:56:06 <zhurong> I get it
17:57:10 <StanLagun> Nikolay_St: it's our chance to get millions of contributors :)
17:57:24 <Nikolay_St> StanLagun: well
17:57:49 <zhurong> Thanks,  StanLagun Nikolay_St
17:58:03 <zhurong> our time is CST 01:57:46
17:58:35 <Nikolay_St> zhurong: this sucks :(
17:58:46 <Nikolay_St> it's hard to attend meeting in that time
17:58:50 <Nikolay_St> I know it :)
17:59:23 <StanLagun> 9PM at Moscow
18:00:45 <Nikolay_St> it's time
18:00:50 <Nikolay_St> #endmeeting